Jump to content
chatdeau

HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

1,494 posts in this topic

Recommended Posts

Thanks, but I still have the same problem. Again it's stuck at "waiting on <...><..> IOProviderClass..." after like 30 seconds the screen changes to this (picture attached)...is that a problem with my graphic card (Nvidia quadro 600) ?

 

and I don't need to patch my dsdt at all?

Have you tried safemode?

Share this post


Link to post
Share on other sites
Advertisement

Thank you Rockey,

These two go in S/L/E or in Kext folder of EFI??

into in S/L/E 

Thanks, but I still have the same problem. Again it's stuck at "waiting on <...><..> IOProviderClass..." after like 30 seconds the screen changes to this (picture attached)...is that a problem with my graphic card (Nvidia quadro 600) ?

 

and I don't need to patch my dsdt at all?

Definitely you need patched dsdt

62b4fb14df0190253c2df33f519ee660.png

 

 

for Z620 clover  10.12 folder

Share this post


Link to post
Share on other sites

into in S/L/E 

Definitely you need patched dsdt

62b4fb14df0190253c2df33f519ee660.png

 

 

for Z620 clover  10.12 folder

ok I have all of these...my FakeSMC.kext is the most recent one from rehabman including cpusensor gpusensor,....

 

after my first install, istats didn't show any temperature or fan speed. so I got weird feeling, since the fans didn't spin faster while using prime95 torture test. so right now im trying to reinstall everything. 

When the istats shows 0,0°C, it means that system dosen't know, when to speed up the fans right?

 

also I think, a correctly patched dsdt could solve everything right? but using maciASL confuses me, because I don't know which patches I need. I included RehabMan's repository but I really don't understand which of all patches I need. all tutorials I found where specific for some parts, but no one explained, how to choose the right one and how to find out which I need

Share this post


Link to post
Share on other sites

ok I have all of these...my FakeSMC.kext is the most recent one from rehabman including cpusensor gpusensor,....

 

after my first install, istats didn't show any temperature or fan speed. so I got weird feeling, since the fans didn't spin faster while using prime95 torture test. so right now im trying to reinstall everything. 

When the istats shows 0,0°C, it means that system dosen't know, when to speed up the fans right?

 

also I think, a correctly patched dsdt could solve everything right? but using maciASL confuses me, because I don't know which patches I need. I included RehabMan's repository but I really don't understand which of all patches I need. all tutorials I found where specific for some parts, but no one explained, how to choose the right one and how to find out which I need

here is a patched dsdt from z420 you can use as reference

Archive.zip

Share this post


Link to post
Share on other sites

Guys, I am starting to lose my mind.

 

I bought an SSD drive so decided to install El Capitan from fresh on my Z800, as I am having issues with my gfx card on Sierra

 

I have the following kexts in the 10.11 folder:

jChJ5Jv.png

 

I also have the following flags enabled: -v -dart=0 -rootless=0 kext-dev-mode=1

 

and have Nvidia set to VESA mode.

 

Unfortunately I am getting the following kernel panic when I try to boot into the el Cap usb disk:

 

738Np8Dl.jpg

 

What seems to be causing this? I had no issues the first time I installed Sierra on this machine. Or is El Capitan not compatible?

Share this post


Link to post
Share on other sites

Guys, I am starting to lose my mind.

 

I bought an SSD drive so decided to install El Capitan from fresh on my Z800, as I am having issues with my gfx card on Sierra

 

I have the following kexts in the 10.11 folder:

jChJ5Jv.png

 

I also have the following flags enabled: -v -dart=0 -rootless=0 kext-dev-mode=1

 

and have Nvidia set to VESA mode.

 

Unfortunately I am getting the following kernel panic when I try to boot into the el Cap usb disk:

 

738Np8Dl.jpg

 

What seems to be causing this? I had no issues the first time I installed Sierra on this machine. Or is El Capitan not compatible?

Have you tried booting the install USB in safemode.?

Share this post


Link to post
Share on other sites

Hello, everybody.

Help me to properly configure my workstation. Want to use Mac OX Sierra or Yosemite.

 

I have successfully installed and started OS X, I'm install Clover to /EFI/CLOVER partition,

but I do not understand what kext, patch i must do.

Someone can help me.

What kext i must to put in /EFI/CLOVER/kext/10.12/ ?

What in /S/L/E/ ?

What i must to delete from /S/L/E/

I'm dont understant what dsdt must to use and  where they should locate.

And my video don't work properly. "About this mac" write video 3 mb, and resolutin is bad.

May be somebody can create archive, with kext, dsdt, ssdt and other... and write where i must to put or install them. Which need to delete or patch.

 

My spec:

HP z420

Processor Intel Xeon E5-1603 @ 2.80GHz (LGA2011)

MB C600/X79, Intel Sandy Bridge-EP

RAM 8 GB ( 4x2GB ECC UDDR3 )

Video AMD FirePro V3900  (1 GB)

SSD Kingston 120 GB

Sound Realtek ALC262

Raid controller LSI Adapter, SAS2 2308 Mustang

 

boot osX by defalut config.plist with arg: -v npci=0x2000

 

PS : sorry for my English.

Share this post


Link to post
Share on other sites

Hi GreenBunny

 

Finally I reach El Capitan starting and installing from USB to Harddisk, I have an HP620 an old 2012/13 workstation, I'm not an expert but following this guide (  http://www.insanelymac.com/forum/topic/314799-guide-z820-el-capitan-the-great-guide-sucess/)I reach the goal.

 

I'm in the middle of fixing process and I have a similar configuration like your computer. Try to read with attention the guide it function! (or maybe for me)

 

P.S. Where you can from?

Share this post


Link to post
Share on other sites

Hi Rockey,

 

Right, so correct me if I'm wrong.

 

r7QP1FY.jpg

 

The upper ports (yellow box) are the standard SATA ports which connect to the hot plug bays?

 

And the bottom set of ports (blue box) are the SAS controller ones which won't work in OSX??

 

They all work in OS-X . All the ports work in OS-X . Just don't disable the SAS controller in bios.

There is no need to disable the SAS controller in bios.

I have my DVD, Blu-ray, and 2.5" SSD's connected to the Top black Sata ports.

I have my drive bays storage hard-drives connected to my SAS controller.

I am not using raid however. I did not configure raid. However I could have if I wanted to.

All the Sata ports work with OS-X Sierra. 

You can switch the Sata cables around to your liking.

Guys, I am starting to lose my mind.

 

I bought an SSD drive so decided to install El Capitan from fresh on my Z800, as I am having issues with my gfx card on Sierra

 

I have the following kexts in the 10.11 folder:

jChJ5Jv.png

 

I also have the following flags enabled: -v -dart=0 -rootless=0 kext-dev-mode=1

 

and have Nvidia set to VESA mode.

 

Unfortunately I am getting the following kernel panic when I try to boot into the el Cap usb disk:

 

738Np8Dl.jpg

 

What seems to be causing this? I had no issues the first time I installed Sierra on this machine. Or is El Capitan not compatible?

 

 

Guys, I am starting to lose my mind.

 

I bought an SSD drive so decided to install El Capitan from fresh on my Z800, as I am having issues with my gfx card on Sierra

 

I have the following kexts in the 10.11 folder:

jChJ5Jv.png

 

I also have the following flags enabled: -v -dart=0 -rootless=0 kext-dev-mode=1

 

and have Nvidia set to VESA mode.

 

Unfortunately I am getting the following kernel panic when I try to boot into the el Cap usb disk:

 

738Np8Dl.jpg

 

What seems to be causing this? I had no issues the first time I installed Sierra on this machine. Or is El Capitan not compatible?

Download my USB Install config and files I used for install below. Should work for HP z800, z600, z400. See Link

https://www.dropbox...._Files.zip?dl=0

 

See my post:

http://www.insanelymac.com/forum/topic/307064-hp-z400z600z800-workstations-os-x-1010x1011x-installation/?p=2335626

Hi guys, I was thinking if my problems (audio and firewire in os x el capitan) were in kexts of EFI folder and S/L/E folder, instead of DSDT.

 

I have this kexts in EFI/Clover/kexts folder:

 

- AHCIPortInjector_v1.0.0_Micky1979.kext

- AHCIPortInjector.kext

- AppleACPIPlatform.kext

- ApplePCIIDE.kext

- ATAPortInjector.kext

- Disabler.kext

- FakeSMC.ketx

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx

- LegacyAppleAHCIPortIntelICHx.ketx

- NullCPUPowerManagement.kext

- realtekALC.kext

- USB_Series8_Injector.kext

- USB_Series9_Injector.kext

- VoodooPS2Controller.kext

 

 

I have installed or replaced this kexts in S/L/E:

 

- AHCIPortInjector_v100_Micky1979.kext

- AppleHDA.kext

- AppleHPET.kext

- CodecCommander.kext

- FakeSMC.kext

- GenericUSBXHCI.kext

- HDMIAudio.ketx

- LegacyAppleAHCIPortIntelICHx.ketx

- lspcidrv.ketx

- NullCPUPowerManagement.kext

- RtWlanU.kext

- RtWlanU1827.kext

- VoodooHDA_v2.87.kext

- VoodooTSCSync.kext

 

I got all of them of one attached file in this post.

 

What do you think?

What kexts do you think I can delete?

Download my USB Install config and files I used for install below. Should work for HP z800, z600, z400. See Link

https://www.dropbox...._Files.zip?dl=0

 

See my post:

http://www.insanelym...tion/?p=2335626

Hi guys,

 

First off.....MAJOR thanks for this thread and installation guides! AMAZING!

 

That being said I have managed to install Sierra onto my Z800, the issue I am having is I can only boot into Sierra via my Clover USB, If I attempt to boot from my OSX HDD I get the following error "boot0af: error"

 

Any chance someone could guide me through fixing this? Would be hugely grateful!

 

Cheers,

Jon.

 

Current config:

-----------------------------------------------------------------------------------------------------------------------------------------

HP Z800

CPU: 2 x 6 Core X5670 Xeon 2.97ghz

RAM: 24gb

GPU: EVGA GTX 980 4gb

 

HDD:

240gb OCZ SSD (Windows 10 OS)

1TB SSD (Windows Data Folder)

1TB WD BLUE (MAC OS - SIERRA)

250gb Seagate Barracuda (MAC Data Folder)

Download my USB Install config and files I used for install below. Should work for HP z800, z600, z400. See Link

https://www.dropbox...._Files.zip?dl=0

 

See my post:

http://www.insanelym...tion/?p=2335626

 

You do not seem to have one of these.         It seems you are in the wrong thread.

  HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

 

Yes, That is an HP z800 motherboard.

Good Evening Rockey, and everyone. I hope I can get some help with what is turning out to be a very arduous weeklong endeavor of trying to get Sierra to even install on my Z800. I have so far managed to get the BIOS settings to be exactly as Rockey has them, and have the USB bootable with clover and necessary kexts. The problem is that I end up getting a "(com.apple.appkit.xpc.sandboxServiceRunner) <Warning>: the JoinExistingSession key is only available to application services" error. 

 

I have gotten my clover, kexts, DSDT, as well as the config.plist from a guide that is on here for the z800. I was wondering if there was something on there that is stopping it from going any further. I am adding them below for anyone to check and get back to me. I have spent many many hours trying to get this to install, but no luck. Any help will be appreciated

 

System Specs if anyone is curious

2x X5670

256GB micron SSD(connected to regular SATA ports and not SAS ports)

48GB 1333 DDR3 ECC Ram (4GB x12)

Firepro V5900 graphics card

Download my USB Install config and files I used for install below. Should work for HP z800, z600, z400. See Link

https://www.dropbox...._Files.zip?dl=0

 

See my post:

http://www.insanelym...tion/?p=2335626

Hi Rockey,

 

Right, so correct me if I'm wrong.

 

r7QP1FY.jpg

 

The upper ports (yellow box) are the standard SATA ports which connect to the hot plug bays?

 

And the bottom set of ports (blue box) are the SAS controller ones which won't work in OSX??

In bios make these changes:

 

Security > System Security

 

-               Data Execution Prevention = Enable

-               Virtualization (VTx) = Enable

-               Virtualization (VT-d2) = Enable

-               AES Instruction = Enable

 

Security > Device Security (Everything to “Device Available” except these)

 

-               Serial port = Hidden

-               Internal USB = Enable

-               SAS Controller = Enable

-               Legacy Diskette = Hidden

-               Embedded Security = Enable

 

                           NIC wake on lan = Hidden/Disable

 

 

I have connected my boot drives to the Sata controller.

I have connected my Storage drives( hard drive caddies ) to the SAS controller

 

Check you Sata cables and make sure they are connected to the correct controller.

You can switch the sata cables around on the motherboard to fix this.

Share this post


Link to post
Share on other sites

Thanks very much for posting this, ZorroZZ.  My Z800 with 3.60 BIOS and EVGA GTX770 is doing pretty well with El Capitan after following this guide.

 

Only one real hitch so far - as soon as I send the box to sleep, it wakes up after two or three seconds.  OSX Console says this is due to UHC1, UHC5.  I've disabled all "Wake on LAN/USB" settings in the BIOS but this persists.  Is there a further DSDT patch I need to apply?

 

Just making a belated note that when I got around to unplugging a USB KVM from the Z800 to test, it would finally stay asleep properly.  I thought I tried this before unsuccessfully with El Kap (it might work there too), but it does work with Sierra.  I think the KVM was sending some USB signal every few seconds which was making the Z800 wake up a few seconds each time after it was sent to sleep.

 

Cheers again for all the great help on here.

Share this post


Link to post
Share on other sites

Just making a belated note that when I got around to unplugging a USB KVM from the Z800 to test, it would finally stay asleep properly.  I thought I tried this before unsuccessfully with El Kap (it might work there too), but it does work with Sierra.  I think the KVM was sending some USB signal every few seconds which was making the Z800 wake up a few seconds each time after it was sent to sleep.

 

Cheers again for all the great help on here.

Sleep/wake should work Vanilla. No need to add powermanagement.kexts or any other kexts.

Just make sure you have "wake on lan activity" disabled in network settings and disable "wake on lan" in bios NIC settings.

Hi guys, I was thinking if my problems (audio and firewire in os x el capitan) were in kexts of EFI folder and S/L/E folder, instead of DSDT.

 

I have this kexts in EFI/Clover/kexts folder:

 

- AHCIPortInjector_v1.0.0_Micky1979.kext

- AHCIPortInjector.kext

- AppleACPIPlatform.kext

- ApplePCIIDE.kext

- ATAPortInjector.kext

- Disabler.kext

- FakeSMC.ketx

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx

- LegacyAppleAHCIPortIntelICHx.ketx

- NullCPUPowerManagement.kext

- realtekALC.kext

- USB_Series8_Injector.kext

- USB_Series9_Injector.kext

- VoodooPS2Controller.kext

 

 

I have installed or replaced this kexts in S/L/E:

 

- AHCIPortInjector_v100_Micky1979.kext

- AppleHDA.kext

- AppleHPET.kext

- CodecCommander.kext

- FakeSMC.kext

- GenericUSBXHCI.kext

- HDMIAudio.ketx

- LegacyAppleAHCIPortIntelICHx.ketx

- lspcidrv.ketx

- NullCPUPowerManagement.kext

- RtWlanU.kext

- RtWlanU1827.kext

- VoodooHDA_v2.87.kext

- VoodooTSCSync.kext

 

I got all of them of one attached file in this post.

 

What do you think?

What kexts do you think I can delete?

 

 

You don't need most of those kexts

I used these

 

I have this kexts in EFI/Clover/kexts folder:

 

 

AHCIPortInjector.kext

FakeSMC.ketx

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx

 

 

 

I have installed or replaced this kexts in S/L/E:

 

 

AHCIPortInjector.kext

FakeSMC.ketx

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx

 

You only need  "VoodooTSCSync.kext" in the USB installer. /EFI/Clove/Kexts

Share this post


Link to post
Share on other sites

This is my first post on InsanelyMac after 6 years of hibernation, where a lot of things happened and changed. I'm glad to be back again and see how the "new kids on the block" rule the matter!

 

 

RESPECT!

 

 

My HW Specs:

 

 HP Z800 Workstation  BIOS V.3.60

2 x Intel® Xeon® processor X5650 2.66 GHz, 12MB cache 1333 MHz memory, 6-Core

*   24GB DDR3 RAM     *     GFX: Nvidia QUADRO 6000.   *

Windows 10 on RAID0 LSILogic RAID SAS 1068E Controller (3 x 420GB SAS HD)

Backup SAS HD 1TB on LSILogic RAID SAS 1068E Controller

Windows 10 on RAID0 Intel RST ICH10 Controller (3 x 120GB SSD)

Sierra on Kingston 120GB SSDNow  on SATA port 1

 

USB 3.1 IcyBox PCI-e Controller

 

Following instructions from here I have installed Sierra 10.12.5 on my Z800 successfully.

 

I didn't´t touch my DSDT jet, because I won't first to learn and understand what I am doing.

 

At the moment I have Problem with USB and Audio. The 2 middle USB ports from 6 on the Back do not working. For the Sound I am using at the moment combination of three Kexts:

AppleALC.kext & Lily.kext, which MacPeet patched for me, but only with the CodecCommander.kext installed in S/L/E i can hear the Sound!

 

I have patched 15 USB ports Limit in the Clover, but did´n have success.

 

At the moment I am using this Kexts in EFI/Kexts/10.12:

AHCIPortInjector.kext

AppleALC.kext

FakeSMC.kext

IOAHCIBlockStorageInjector_v1.0.0_Micky1979.kext

Lilu.kext

NullCPUPowerManagement_v1.0.0d2_tgwbd.kext

 

Any Advices?

Share this post


Link to post
Share on other sites

 Hi quattrofx thanks for the comments im gonna attached my patched dsdt and a acpi 3.0a PDF file there are lots of information how to creat dsdt patch 

 

Hi Rockey12!

THX for your replay and BIG THX for all of Hard WORK you are doing here! THX goes also to Chris and all the HacMac Family! RESPECT!  :thumbsup_anim:

 

Following your work I was able to pre- and post install fast everything successfully, except of some USB glitches witch I explained in this Forum:

https://www.root86.com/topic/8508-os-x-sierra-10125-on-hp-z800-clover/?p=96873

and here:

https://www.root86.com/topic/8506-z600-usb-probleme/?p=96996

 

How did you solve your USB & PM? I just won't to know the right way, because I was away for 6 years and a lot of things changed, but I am willing to learn.... It is just easy to take your DSDT and work with it, without understanding how, but not for me.... :-)

There are some more questions on this Topic witch I have posted (it is in German language, you understand it, or?). Should I post it here in English as well?

 

Best Regards

QFX

Share this post


Link to post
Share on other sites

thanks again it doesn't matter English or german the important thing is to make some progress don't hesitate to ask any question 

Share this post


Link to post
Share on other sites

Ok.

 

How did you solve your USB & PM? Should I create my own DSDT or can I use the Clover to do this? If I use DSDT, what stuff should I disable im Clover? I don't won't that DSDT comes into conflict with Clover.

 

THX & BR

QFX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks (Laptop: Thinkpad T61 / Nvidia NVS 140m, Laptop: Dell Latitude E6410 / Nvidia G3100m, Desktop: Gigabyte G31 / GeForce 9600, Desktop: Biostar TH55HD / Sapphire Pulse RX580) are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (No solution yet - work-around is to use Firefox) Safari has problems loading insanelymac web pages after sleep / wake.  Work-around: use Firefox or reboot.  I have seen reports in forums where Safari issues are experienced after sleep / wake on a real Mac.  Not sure if the problems are related.  I suspect that it might be related to streaming video on InsanelyMac pages (since I haven't observed the issue on "static" pages). (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A  
      Clover Configuration: To be provided
       
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.4.02 Clover (UEFI) r5118 Lilu.kext 1.4.4 WhateverGreen.kext 1.3.9 AppleALC.kext 1.4.9 IntelMausiEthernet 2.5.0  
      Credits To be provided
       
       




      EliteDesk800 G4 Mini - Rev 0.5.zip

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
        Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://tinyurl.com/rkqmpd9
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data>AQAAAA==</data> <key>AAPL,ig-platform-id</key> <data>CQClPg==</data> <key>device-id</key> <data>pT4AAA==</data> <key>disable-external-gpu</key> <data>AQAAAA==</data> <key>enable-hdmi20</key> <data>AQAAAA==</data> <key>framebuffer-con1-busid</key> <data>AQAAAA==</data> <key>framebuffer-con1-enable</key> <data>AQAAAA==</data> <key>framebuffer-con1-type</key> <data>AAgAAA==</data> <key>framebuffer-con2-enable</key> <data>AQAAAA==</data> <key>framebuffer-con2-index</key> <data>/////w==</data> <key>framebuffer-fbmem</key> <data>AACQAA==</data> <key>framebuffer-patch-enable</key> <data>AQAAAA==</data> <key>framebuffer-portcount</key> <data>AgAAAA==</data> <key>framebuffer-stolenmem</key> <data>AAAwAQ==</data> <key>framebuffer-unifiedmem</key> <data>AAAAgA==</data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By josebv98
      So, ive trying to install various versions of macOSs to an old hp laptop.
      Specs: intel i7 3610qm, 8gb ram, nvidia 650m, intel HD4000
      model: hp dv6
       
      3 ago i did managed to install Niresh yosemite, even bought the right wifi adapter so i could use it on campus, but even then, i had to set cpus=1
       
      Now, ive tried several guides, tried internet vanilla install guide (which ive done successfully in 2 devices), opencore guide, opencore laptop guide
       
      Im currently having some financial problems, so i want sell my macbook to pay student loans, i really want to daily drive this laptop in mac os, but i cant get to boot the installer.
       
      Anyone here have a similiar laptop? so i could borrow the efi folder, just to get it to install, then ill change stuff
       
×