Jump to content
chatdeau

HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

1,493 posts in this topic

Recommended Posts

Hi Rockey,

 

Right, so correct me if I'm wrong.

 

r7QP1FY.jpg

 

The upper ports (yellow box) are the standard SATA ports which connect to the hot plug bays?

 

And the bottom set of ports (blue box) are the SAS controller ones which won't work in OSX??

You do not seem to have one of these.         It seems you are in the wrong thread.

  HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

Share this post


Link to post
Share on other sites
Advertisement

 Hi themadsalvi

 can you upload your Clover EFI folder

waqy==== can you be more specific what exactly is wrong with bay

I have attached my clover folder as a zip. Thank you for the help

 

edit: I have removed the appleHDA from the clover folder because it made no difference when it came to the sound working or not.

CLOVER.zip

Share this post


Link to post
Share on other sites

 

You do not seem to have one of these.         It seems you are in the wrong thread.

  HP Z400/Z600/Z800 Workstations OS X 10.10.x/10.11.x Installation

 

One of what?

 

this is inside my z800

 

 

WCCDpA1.jpg

 

 

 

Share this post


Link to post
Share on other sites

SASMegaRAID.kext    

this is  the  only  kext  but doesn't support Fusion MPT family of controllers


I have attached my clover folder as a zip. Thank you for the help

 

edit: I have removed the appleHDA from the clover folder because it made no difference when it came to the sound working or not.

so this time please do not add all the kexts to clover folder

add or install to the system library extension

 

open the Easy kext utility app and drop all the kexts on it that,s all  ======i have attached new config.plist 

post-555472-0-57556700-1491660231_thumb.jpg

Archive 2.zip

Share this post


Link to post
Share on other sites

One of what?

 

this is inside my z800

 

 

WCCDpA1.jpg

 

 

 

So this is another computer?      

 ASUS Rampage Extreme II

Intel Core i7 965 3.2 GHz

24GB DDR3 RAM

MSI Radeon HD 7970 3GB

Iiyama E2407HDS

Share this post


Link to post
Share on other sites

So this is another computer?      

 ASUS Rampage Extreme II

Intel Core i7 965 3.2 GHz

24GB DDR3 RAM

MSI Radeon HD 7970 3GB

Iiyama E2407HDS

That's my main Hackintosh.

 

The Z800 is another one I am building

Share this post


Link to post
Share on other sites

That's my main Hackintosh.

 

The Z800 is another one I am building

 

That's my main Hackintosh.

 

The Z800 is another one I am building

Now I get it!

Share this post


Link to post
Share on other sites

I have to say I still having cmos reset in my Z600

I am tired of fight but if anyone knows anything I would try

This is the screen on I try to reboot with F1 and config bios reboot and work without problem, sleep works fine

 

IMG_0004.jpg

Share this post


Link to post
Share on other sites

I have to say I still having cmos reset in my Z600

I am tired of fight but if anyone knows anything I would try

This is the screen on I try to reboot with F1 and config bios reboot and work without problem, sleep works fine

 

IMG_0004.jpg

Read post #921. I had the same problem and this fixed it.                http://www.insanelymac.com/forum/topic/307064-hp-z400z600z800-workstations-os-x-1010x1011x-installation/page-47

Share this post


Link to post
Share on other sites

I patched AICPM like say that page and I remove NullCPUPowerManagement from kext folder in EFI partition.

After reboot I have an spontaneous reboot seconds after desktop is active, the CMOS was reset again

I put back NullCPUPowerManagement in the folder and now system is stable, don't know if going to reset CMOS when shut it down

 

Share this post


Link to post
Share on other sites

 

I patched AICPM like say that page and I remove NullCPUPowerManagement from kext folder in EFI partition.

After reboot I have an spontaneous reboot seconds after desktop is active, the CMOS was reset again

I put back NullCPUPowerManagement in the folder and now system is stable, don't know if going to reset CMOS when shut it down

 

 

Where was your  appleintelcpupowermanagement.kext ? mine is in S/L/E

Share this post


Link to post
Share on other sites

like mine

S/L/E

I tried to patch it again and modified date do not change don't know if it changed the first time

 

This is the terminal commands a answer

 

Z600Mac-Pro:~ jaime2$ cd ~/Downloads/AICPMPatch

Z600Mac-Pro:AICPMPatch jaime2$ perl AICPMPatch.pl /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement

 

/System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement

 

arch: x86_64

 

/System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement: Permission denied

Z600Mac-Pro:AICPMPatch jaime2$ sudo perl AICPMPatch.pl /System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement --patch

Password:

 

/System/Library/Extensions/AppleIntelCPUPowerManagement.kext/Contents/MacOS/AppleIntelCPUPowerManagement

 

arch: x86_64

 

wrmsr found: 0

wrmsr ignored: 0

Z600Mac-Pro:AICPMPatch jaime2$

Share this post


Link to post
Share on other sites

Give these 2 kexts a go AppleIntelCPUPowerManagement.kext already patched both of the kexts are from Sierra 10.12.4

 

AppleIntelCPUPowerManagement.kext

AppleIntelCPUPowerManagementClient.kext

 

 

enable VT-x and VT-d in bios

Archive.zip

Share this post


Link to post
Share on other sites

Hi guys, I was thinking if my problems (audio and firewire in os x el capitan) were in kexts of EFI folder and S/L/E folder, instead of DSDT.

 

I have this kexts in EFI/Clover/kexts folder:

 

- AHCIPortInjector_v1.0.0_Micky1979.kext

- AHCIPortInjector.kext

- AppleACPIPlatform.kext

- ApplePCIIDE.kext

- ATAPortInjector.kext

- Disabler.kext

- FakeSMC.ketx

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx

- LegacyAppleAHCIPortIntelICHx.ketx

- NullCPUPowerManagement.kext

- realtekALC.kext

- USB_Series8_Injector.kext

- USB_Series9_Injector.kext

- VoodooPS2Controller.kext

 

 

I have installed or replaced this kexts in S/L/E:

 

- AHCIPortInjector_v100_Micky1979.kext

- AppleHDA.kext

- AppleHPET.kext

- CodecCommander.kext

- FakeSMC.kext

- GenericUSBXHCI.kext

- HDMIAudio.ketx

- LegacyAppleAHCIPortIntelICHx.ketx

- lspcidrv.ketx

- NullCPUPowerManagement.kext

- RtWlanU.kext

- RtWlanU1827.kext

- VoodooHDA_v2.87.kext

- VoodooTSCSync.kext

 

I got all of them of one attached file in this post.

 

What do you think?

What kexts do you think I can delete?

Share this post


Link to post
Share on other sites

Do you see any of the kext which is related to the FireWire Device all you need is a working DSDT patch for FireWire

 

- AHCIPortInjector_v1.0.0_Micky1979.kext  use only one this or 

- AHCIPortInjector.kext === this 

- AppleACPIPlatform.kext

- ApplePCIIDE.kext========?

- ATAPortInjector.kext=========?

- Disabler.kext=========?

- FakeSMC.ketx   must 

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx === this or 

- LegacyAppleAHCIPortIntelICHx.ketx ====or this

- NullCPUPowerManagement.kext========== yes if the  AppleIntelcpupowermanagement.kext is not patched 

- realtekALC.kext =======?

- USB_Series8_Injector.kext ===== no

- USB_Series9_Injector.kext ===== no

- VoodooPS2Controller.kext ==== no

 

 

 

 

- AHCIPortInjector_v100_Micky1979.kext

- AppleHDA.kext =============================== yes if want 

- AppleHPET.kext  ===================== no why 

- CodecCommander.kext ==================================  yes with the combination of AppleHDA

- FakeSMC.kext =========================== yes must 

- GenericUSBXHCI.kext ================================ yes for workin USB port 

- HDMIAudio.ketx =================== yes  

- LegacyAppleAHCIPortIntelICHx.ketx ================?

- lspcidrv.ketx  ==================================   ?

- NullCPUPowerManagement.kext

- RtWlanU.kext=================== no

- RtWlanU1827.kext ================== no

- VoodooHDA_v2.87.kext ===================== yes 

- VoodooTSCSync.kext ============================= yes

Share this post


Link to post
Share on other sites

Hi guys,

 

First off.....MAJOR thanks for this thread and installation guides! AMAZING!

 

That being said I have managed to install Sierra onto my Z800, the issue I am having is I can only boot into Sierra via my Clover USB, If I attempt to boot from my OSX HDD I get the following error "boot0af: error"

 

Any chance someone could guide me through fixing this? Would be hugely grateful!

 

Cheers,

Jon.

 

Current config:

-----------------------------------------------------------------------------------------------------------------------------------------

HP Z800

CPU: 2 x 6 Core X5670 Xeon 2.97ghz

RAM: 24gb

GPU: EVGA GTX 980 4gb

 

HDD:

240gb OCZ SSD (Windows 10 OS)

1TB SSD (Windows Data Folder)

1TB WD BLUE (MAC OS - SIERRA)

250gb Seagate Barracuda (MAC Data Folder)

Share this post


Link to post
Share on other sites

Hi guys,

 

First off.....MAJOR thanks for this thread and installation guides! AMAZING!

 

That being said I have managed to install Sierra onto my Z800, the issue I am having is I can only boot into Sierra via my Clover USB, If I attempt to boot from my OSX HDD I get the following error "boot0af: error"

 

Any chance someone could guide me through fixing this? Would be hugely grateful!

 

Cheers,

Jon.

 

Current config:

-----------------------------------------------------------------------------------------------------------------------------------------

HP Z800

CPU: 2 x 6 Core X5670 Xeon 2.97ghz

RAM: 24gb

GPU: EVGA GTX 980 4gb

 

HDD:

240gb OCZ SSD (Windows 10 OS)

1TB SSD (Windows Data Folder)

1TB WD BLUE (MAC OS - SIERRA)

250gb Seagate Barracuda (MAC Data Folder)

http://www.insanelymac.com/forum/topic/301255-how-to-fix-the-boot0af-error-using-clover/

 

 

or Download the Installer from this link install it and replace only 2 files in clover folder

 

http://www.insanelymac.com/forum/topic/307064-hp-z400z600z800-workstations-os-x-1010x1011x-installation/?p=2363202

 

https://drive.google.com/file/d/0B661P9Kp9bPAdmR1TTJUMmxmcDA/view  

Share this post


Link to post
Share on other sites

Do you see any of the kext which is related to the FireWire Device all you need is a working DSDT patch for FireWire

 

- AHCIPortInjector_v1.0.0_Micky1979.kext  use only one this or 

- AHCIPortInjector.kext === this 

- AppleACPIPlatform.kext

- ApplePCIIDE.kext========?

- ATAPortInjector.kext=========?

- Disabler.kext=========?

- FakeSMC.ketx   must 

- IOAHCIBlockStorageInjector_v1.0.0_Micky1979.ketx === this or 

- LegacyAppleAHCIPortIntelICHx.ketx ====or this

- NullCPUPowerManagement.kext========== yes if the  AppleIntelcpupowermanagement.kext is not patched 

- realtekALC.kext =======?

- USB_Series8_Injector.kext ===== no

- USB_Series9_Injector.kext ===== no

- VoodooPS2Controller.kext ==== no

 

 

 

 

- AHCIPortInjector_v100_Micky1979.kext

- AppleHDA.kext =============================== yes if want 

- AppleHPET.kext  ===================== no why 

- CodecCommander.kext ==================================  yes with the combination of AppleHDA

- FakeSMC.kext =========================== yes must 

- GenericUSBXHCI.kext ================================ yes for workin USB port 

- HDMIAudio.ketx =================== yes  

- LegacyAppleAHCIPortIntelICHx.ketx ================?

- lspcidrv.ketx  ==================================   ?

- NullCPUPowerManagement.kext

- RtWlanU.kext=================== no

- RtWlanU1827.kext ================== no

- VoodooHDA_v2.87.kext ===================== yes 

- VoodooTSCSync.kext ============================= yes

 

Thank you Rockey, I've done a good cleaning. RtWlan kexts are for WIFI.

 

This is my current DSDT, I don't know what more I can do:

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Hey there,

 

I just got a used z620 and im trying to figure out, where I can get all the write .kext and how to patch my DSDT. 

Attached are my .kext as well as all other files I put onto my USB drive.

 

In general I used #####, with injected nVidia (which is responsible for nv_disable=1 bootflag) Other then that I used npci=0x3000. and of course verbose mode.

 

write now, clover freezes at "Waiting on <dict ID....." (see picture)

 

I think it has something to do with the files I provided. Where can I find the right .kext files and which do you know any repositories which include most or all of my specs?

 

SPEC's

HP Z620 Workstation

Mainboard: HP 158A

Chipset: Intel C602 (Patsburg-A)

CPU: 2x Intel Xeon E5-2670

Graphic: nVidia Quadro 600

 

EDIT1: first of all...how do I know which .kext I need in general...=)

files.zip

post-2055165-0-22184800-1491985586_thumb.jpg

Share this post


Link to post
Share on other sites

Clover arbitrary device injection

 

I've test the same, but when I restart, clover starts the system, the apple logo appears, but the system restarts automatically.

 

Have I use arbitrary inject with every pci card?

config.plist.zip

Share this post


Link to post
Share on other sites

Give these 2 kexts a go AppleIntelCPUPowerManagement.kext already patched both of the kexts are from Sierra 10.12.4

 

AppleIntelCPUPowerManagement.kext

AppleIntelCPUPowerManagementClient.kext

 

 

enable VT-x and VT-d in bios

Thank you Rockey,

These two go in S/L/E or in Kext folder of EFI??

Share this post


Link to post
Share on other sites

use this config.plist  =========baertig 

 

 

Thanks, but I still have the same problem. Again it's stuck at "waiting on <...><..> IOProviderClass..." after like 30 seconds the screen changes to this (picture attached)...is that a problem with my graphic card (Nvidia quadro 600) ?

 

and I don't need to patch my dsdt at all?

post-2055165-0-24242000-1492083169_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
      -Donations with PicPay 
      @danielnmaldonado
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
      DSDT.Gigabyte Z490-UD.zip
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--























       









       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
    • By tonyx86
      This guide is a work in progress and will be updated as I refine the installation.
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
       
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec SMBIOS MacModel MacMini 8,1 Unsupported M.2 PCIe x1 2230 Intel Wi-Fi (currently disabled in BIOS).  I may replace this with Brcm, but am using only Ethernet (IntelMausi) for now.  
      Installation Steps: To be provided
      See attached EFI and /L/E kexts in EliteDesk.zip archive See installation methodology here See references here  
      What is not working
      Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card).  
      What is not tested
      USB c 3.1 port Microphone port  
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions
      (Solved. Problem resolves itself after a few boot cycles) After applying the Catalina 10.15.5.02 supplemental update, Catalina booted to a single display.  After a few boot cycles, multi-display operation was restored to normal. (Solved and included in the attached EliteDesk.zip archive) Unable to upgrade from 10.15.4 to 10.15.5 when using IntelMausiEthernet.kext.  Solution is to switch to IntelMausi.kext (Rev 1.0.2 here). (Solved and included in the attached EliteDesk.zip archive) Some USB devices were not recognized. My SSDT-UIAC.aml was incomplete and did not specify all required USB port types (missing SSxx ports). The attached EliteDesk.zip archive includes this fix. (Reported this as a possible Clover issue - no solution yet) Clover boot loader may default to Recovery volume after a normal shutdown.  Work-around is to select your normal macOS volume.  This may only happen when Clover is configured to boot LastBootedVolume and may be "fixable" by explicitly setting a boot volume (haven't tested this). (No longer observed) At least one display blanks (sleeps) when plugging / unplugging USB device (observed in front USB 3.1 ports).  Display wakes immediately on keyboard and mouse activity, so this is a minor issue but may be indicative of another issue. (Solved - this is a BIOS setting and requires no macOS changes) Safari has problems loading insanelymac web pages after sleep / wake.  I suspect that the problem is with the embedded video on the pages.  Also observed video problem in AppStore after sleep/wake.  Console: VideoDecodersUnavailable.  Solution is to enable Intel ME in BIOS. (Solved and included in the attached EliteDesk.zip archive) Display does not fully wake after resuming from sleep (needs an extra mouse or keyboard stimulus to fully wake).  Solution is to change boot arg darkwake=0 to darkwake=2.  Other values of darkwake may work as well, but this is the first I tried and it worked. (Solved and included in the attached EliteDesk.zip archive) -disablegfxfirmware boot arg is not required with WEG.  I inadvertently left this boot arg after I encountered an endless gfx firmware update boot loop while working on my FB patching.  This boot arg is no longer necessary after completing FB patching with WEG. (Solved and included in the attached EliteDesk.zip archive): Sometimes, CMOS time is lost on shutdown or restart.  Solution is to enable Clover's Apple RTC fix in config.plist. (Solved and included in the attached EliteDesk.zip archive) headphone jack doesn't work.  Solution is to change HDEF layout-id to 28. (Solved and included in the attached EliteDesk.zip archive) System freezes on wake from sleep because of a kernel panic related to hda-gfx (my system does not have HDMI and my DP->DVI adapters do not drive monitor speakers).  Solution is to add No-hda-gfx property to HDEF as described here.  This property is recognized as a Lilu flag and prevents loading hda-gfx. (Solved and included in the attached EliteDesk.zip archive) Device (PMCR) is not defined.  Solution is a SSDT that "injects" the missing device. (Solved and included in the attached archive) eficheck is loaded (not sure why this is bad, but may be a privacy issue - see here). Solution is to add updated EFICheckDisabler kext that include Q370 chipset.  See here.  
      BIOS Version / Configuration: To be provided
      Version: 02.11.01 Rev.A Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers AudioDxe DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching: To be provided
       
      Current Versions
      Catalina 10.15.5.02 Clover (UEFI) r5118 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
       







      EliteDesk800 G4 Mini - Rev 0.8.zip
    • By Fantome1S
      Finaly Success to boot on Sierra 10.12.6 (16G29) with Touchscreen working theres still things to fix but everything is almost working. During the Corvid StayAtHome Period I was able and have time to make this laptop boot on MacOS after a lot of attemps before going back to job. It was the hardest laptop hackintosh install attemp i've done so far and Sierra OS is the only that works. I tried El Capitan and Mojave and its never boot so I not even tested Catalina. I searched on the web and theres no install guide for this specific laptop or no Success install post on this laptop its look like a not very well supported laptop by hackintosh. Maybe some of you can help me correct the things that still not work. Audio work but with voodo (low sound and low quality) I want to make it work with AppleALC to get better quality sound. Thanks in advance
       
      Things that work:
       
      -Touchscreen
      -Trackpad (not the gesture for now) - Backlight Keyboard
      -EthernetPort and Wireless (with a wifi dongle. I will change to a broadcom wifi mini-pci chip)
      -Brightness Controls with FN key
      -Audio Voodoo ''low sound'' (will tried to change to AppleALC or AppleHDA fix method) 
      -USB 3.0
       
      Things that not work or need to be fixed:
       
      -Weird double long booting screen-first loading bar on the right. after real loading bar is visible ?
      -Audio (Voodoo) work but with low volume sound- still not success to make work AppleALC.kext method
      -SENSORS -CPU-HDD Temperatures, BATTERY LEVEL, ETC…
      - Sleep (Disabled): USB ports not works after wake from sleep
      -Trackpad Gestures
       
      Hardware:
       
      CPU: Intel Core i7-3687U, 2100 MHz
      GPU: Intel HD Graphics 4000
      RAM: 12 GB (4GB soldered + 8 GB Samsung DDR3 1600)
      Motherboard/Laptop model: Intel Panther Point QM77, Intel Ivy Bridge - (HP Revolve 810 G1)
      Audio Codec: IDT 92HD91BXX @ Intel Panther Point PCH - High Definition Audio Controller
      Ethernet Card: Intel(R) 82579LM Gigabit Network Connection
      Wifi/BT Card: Intel(R) Centrino(R) Advanced-N 6235
      HP hs2350 HSPA+ MobileBroadband Network Adapter
    • By mavifree
      Sir 
       
      I am new in Hackintosh and i try to make my hp laptop a hackintosh but am not able to boot in Installation menu i don't know why please help as am new in hackintosh world so i really need your help if some can. I really be very thankful to you. Please Help me.
       
      installation stuck at (Please go to https://panic.apple.com to report this panic)
       
      MY Laptop Specs :
       
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      And here is the screenshot attachment and my EFI folder:
       


      Clover.rar
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      https://tinyurl.com/rkqmpd9
       
      --OpenCore Folder--
      https://tinyurl.com/y75hqg7z
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
×