Jump to content
Sign in to follow this  
Followers 0
jmeg

Updating OS X on a VM

1 post in this topic

Recommended Posts

Hello all.

 

I am new to these forums and Hackintoshes in general. I successfully installed OS X Snow Leopard using an official Snow Leopard install DVD I own and some other booting tools. I suppose I don't have an official Hackintosh in the sense that I run OS X from as a guest machine. If it helps, I use Oracle's VirtualBox. The VM runs perfectly fine. I used a combined update to update from the first version of Snow Leopard (available on the install disk) to the last/latest version of Snow Leopard.

 

So, with that being said, is it possible to update the operating system while my guest is running without having to change things around? I'd ideally like to be running OS X Yosemite. The Yosemite OS update is available from the App Store for free right now, but I'm a little hesitant to run it at the moment. I was reading somewhere that you should only update your Hackintosh with combined updates from Apple. Any truth to this? I sincerely apologize for my ignorance. As you can tell, I'm still learning. Any help would be greatly appreciated. Thanks! :)

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   -DSDT My DSDT DSDT.GA H97M-DS3P MaLd0n.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -HDEF -RTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF -HDMI





      -FakeSMC
      https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek -Audio https://github.com/vit9696/AppleALC -LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By coreycusick
      I have an old P4 machine and I want to install OS X Tiger on it, is this possible in 2019, I can't find any torrents for jas 10.4.8
    • By Jordan Davis
      I'm a software developer, and have been getting into a lot of photo/video-ography. So I'm looking for advice from the community to help me build bad ass video editing comp so I don't waste my life in front of the screen waiting on rendering times.
       
      So I've watched this video --  https://www.youtube.com/watch?v=SY_h_W5I0Jo&t=497s
      Looks like in terms of video editing using software like PR and AE, the amount of CPU cores seems to be the greatest factor and the amount of GPU cores coming in 2nd?  
      Build: (keep in mind I want to run OSX)
      CPU - So I'm looking at getting the new Intel i9? (because the amount of cores) GPU - some high core Radeon GPU? (because I think all apple stuff works with Radeon) FAN - cooler master, idk is this a reliable brand?  idk what  else open for suggestions  
       
    • By Luk3_90
      Buongiorno a tutti,
       
      La scorsa settimana ho aggiornato High Sierra a Mojave seguendo le rispettive guide per l' aggiornamento dei Kext all' interno della partizione EFI. Tutte le periferiche funzionano correttamente audio compreso ( di solito non parte al primo riavvio ), tranne la Vram della scheda grafica integrata in firma ( 7 MB riconosciuti). Premesso che:
      - Ho aggiornato Lilu e aggiunto WhateverGreen nella cartella EFI/Clovers/Kexts/10.14 & EFI/Clovers/Kexts/Other
      - Ho rimosso IntelGraphicsFixup & Shiki
      - Ho rimosso Inject Intel con il relativo platform Id della scheda video ( era necessaria per High Sierra)
      - Con Clover configurator ho aggiunto sotto Device -> Proprieties  platform id, device id, Framebuffer-unifedmem ecc. ecc. ( Vedere config.plist in allegato)
      Al boot mi esce il messaggio [IGPU] Failed to initialize graphics firmware e si blocca la schermata. Qualora dovessi mettere un FakeId o semplicemente fare da clover Inject Intel + Platform Id: 0x00001912 ( se metto il Platform giusto 0x19120000 mi da sempre il solito errore), il sistema ovviamente parte senza problemi ma con 7MB di VRam.
       
      Mi è sfuggito qualcosa?
       
      Grazie in anticipo
      config.plist
×