Jump to content
fantomas1

Nvidia Web Driver updates for El Capitan (UPDATE 07/11/2018)

724 posts in this topic

Recommended Posts

The WebDrivers are pinned to a single macOS build number.
Until there is an official update you can replace Info.plist below this path with the attached version:

/System/Library/Extensions/NVDAStartupWeb.kext/Contents

This invalidates the signature of the WebDriver but will work as long as loading unsigned kexts is allowed.

Before booting with the patched WebDriver rebuilding the kernel cache is required.

The WebDrivers should be functional again now.

NVDAStartupWeb_2017_004_plist.zip

Share this post


Link to post
Share on other sites
Advertisement

Hello

 

We've had one mac update automatically and had to apply the latest web driver 346.03.15f10 on 15G17023. The issue now is that we can't use GPU rendering via Cinema 4D and Octane as it constantly crashes. Is there any way to rollback to 15G1611? 

 

I've tried to install the earlier web driver 346.03.15f09 but that didn't end well!

 

I've tried to install several versions of cuda and all still crash octane.

 

Any ideas would be great please as don't really want to reinstall el captain and all of the apps (I should have made a time machine backup).

Share this post


Link to post
Share on other sites

Hello

 

We've had one mac update automatically and had to apply the latest web driver 346.03.15f10 on 15G17023. The issue now is that we can't use GPU rendering via Cinema 4D and Octane as it constantly crashes. Is there any way to rollback to 15G1611? 

 

I've tried to install the earlier web driver 346.03.15f09 but that didn't end well!

 

I've tried to install several versions of cuda and all still crash octane.

 

Any ideas would be great please as don't really want to reinstall el captain and all of the apps (I should have made a time machine backup).

 

If you have a Time Machine backup you can rollback, otherwise I dont know

Share this post


Link to post
Share on other sites

346.03.15f10 works also fine with 10.11.6 (15G18013) - Security Update Developer Beta 2017-005.

(Mini late 2009, dunno why I keep on installing these...)

The driver may work fine, but NVIDIA's installer doesn't work for 15g18013. Does anyone know of a fix or manual installation procedure?

 

I updated from 10.11.3 to 10.11.6, updated the web drivers, and everything still worked fine *until* the security update (which brought me to 15G18013). Now I can only boot the OSX driver (i.e. nv_disable=1). I've tried patching the info.plist via Xcode with the later build number, but that didn't work, either. Thanks!

 

Update: I extracted the new bundles and kexts with Pacifist, loaded with Kext Wizard, rebuilt cache, replaced the info.plist file with the one above, and then with one modified for 15G18013 but still not working 100%. At least now, with nv_disable, f10 is showing up and the performance is okay-ish. Enough to keep tinkering... but will probably just clean install Sierra after all!

Share this post


Link to post
Share on other sites

Thanks BreBo. Installation fails for me. I have an Nvidia GTX 460. Was working before the secuirty update. Same situation as

piplup

Share this post


Link to post
Share on other sites

A working driver for build 15G21007 please

I re-installed El Capitan yesterday and updated it and found that I didn't have an installable set of web drivers for my GT 240 so hacked the f13 to get it to install. On reboot I find the driver is "not compatible" so I hacked the f14 version likewise replacing the build number in the installer,,,, SAME Result! No updates available either....

I am not sure when the latest security patch for El Capitan was released but if HIgh SIerra history is anything to go by a working Web driver is usually available within 24 hours of the patch

If anyone has anm update on this or a workaround please share

Screen Shot 2018-05-04 at 9.41.44 PM.png

Edited by Squidderlee

Share this post


Link to post
Share on other sites
On 5/5/2018 at 5:50 AM, Squidderlee said:

A working driver for build 15G21007 please

I re-installed El Capitan yesterday and updated it and found that I didn't have an installable set of web drivers for my GT 240 so hacked the f13 to get it to install. On reboot I find the driver is "not compatible" so I hacked the f14 version likewise replacing the build number in the installer,,,, SAME Result! No updates available either....

I am not sure when the latest security patch for El Capitan was released but if HIgh SIerra history is anything to go by a working Web driver is usually available within 24 hours of the patch

If anyone has anm update on this or a workaround please share

 

What SWU channel you're using? I'm on dev channel and no 15G21007 yet.

Share this post


Link to post
Share on other sites
On 5/6/2018 at 2:27 AM, DMCrimson said:

 

What SWU channel you're using? I'm on dev channel and no 15G21007 yet.

I solved it. It was an update from one of the Public Betas that Scuppered my build!... I hadn't realised but the image I was using was still set to receive beta updates and somehow it managed to add a pre-release update to a post GM release 

the Solution was to copy over the image again and disable beta updates before updating!

As Bowie Said... "Hunky Dory" now!

Share this post


Link to post
Share on other sites

Hey guys, I have a MacPro running El Capitan 10.11.6 with a MSI NVIDIA GTX 970.

Can you please help with an updated WebDriver?

Thanks a lot

10BaseT

 

WebDriver 346.03.15f14

Mac OS X version 10.11.6 (15G21013) is not supported with this package. Please see NVIDIA’s website for further driver information.

Edited by 10BaseT

Share this post


Link to post
Share on other sites
On 6/2/2018 at 12:36 AM, 10BaseT said:

Mac OS X version 10.11.6 (15G21013) is not supported with this package. Please see NVIDIA’s website for further driver information.

Need this too. After performing a security update everything went wrong.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for maintaining this thread. I noticed my web driver panel (OS X 10.11.6 El Capitan) still doesn't show the Nvidia Web Driver - 346.03.15f16 update.. even if I click Check Now. Is this just my Mac Pro that is acting weird? Shouldn't it just automatically update like always? (using a GT730 in a Mac Pro 3,1)

Share this post


Link to post
Share on other sites

Update: Apparently, the driver wil only update after system update. After system update the system won't boot.. Therefore, I can't even log in remotely. (Worked around it by temporarily using an old GT 8800)

 

Is there a more elegant way to do this, like still being able to log in remotely?

Share this post


Link to post
Share on other sites

Hi guys, I have a iMac (27-inch, Mid 2011) running El Capitan 10.11.6 with a NVIDIA GTX 765M 2048 MB.
I've downloaded every single Web Driver for 10.11.6 but it didn't work:
Mac OS X version 10.11.6 (15G21013) is not supported with this package. Please see NVIDIA’s website for further driver information.

 

This versions I've downloaded:

Screen Shot 2018-09-24 at 14.16.56.png

 

Even the versions is complete the same:

163774942_ScreenShot2018-09-24at14_21_48.thumb.png.549a45b5877c761ea05926549bd6d26a.png

 

Edited by denised

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f16 --> build 16G2016 (thanks to Cyberdevs) New!
      Nvidia Web Driver - 378.05.05.25f15 --> build 16G1918 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f14 --> build 16G1917 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider)
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
    • By fantomas1
      Hi InsanelyMacaliens    
       
      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS High Sierra.
       
      10.13.6
      Nvidia Web Driver - 387.10.10.10.40.128 --> build 17G7024 (thanks to flowrider) New!
      Nvidia Web Driver - 387.10.10.10.40.127 --> build 17G6030 (thanks to Extreme™) 
      Nvidia Web Driver - 387.10.10.10.40.124 --> build 17G6030 (thanks to flowrider) 
      Nvidia Web Driver - 387.10.10.10.40.123 --> build 17G6029 (thanks to Badruzeus) 
      Nvidia Web Driver - 387.10.10.10.40.122 --> build 17G5019 (thanks to TimeLord04) 
      Nvidia Web Driver - 387.10.10.10.40.118 --> build 17G5019 (thanks to ReddestDream)
      Nvidia Web Driver - 387.10.10.10.40.113 --> build 17G4015 (thanks to flowrider)
      Nvidia Web Driver - 387.10.10.10.40.108 --> build 17G3025 (check here)
      Nvidia Web Driver - 387.10.10.15.15.108 --> build 17G2307 (thanks to marcozardi)
      Nvidia Web Driver - 387.10.10.10.40.105 --> build 17G65 (thanks to sl0wtarget)
       
      10.13.5
      Nvidia Web Driver - 387.10.10.10.35.106 --> build 17F77 (check here)
       
      10.13.4
      Nvidia Web Driver - 387.10.10.10.30.107 --> build 17E202 (check here)
      Nvidia Web Driver - 387.10.10.10.30.106 --> build 17E199 (thanks to BreBo)
      Nvidia Web Driver - 387.10.10.10.30.103 --> build 17E199 (thanks to ricoc90)
       
       
      10.13.3
      Nvidia Web Driver - 387.10.10.10.25.161 --> build 17D102 (thanks to Cyberdevs)
      Nvidia Web Driver - 387.10.10.10.25.160 --> build 17D2102 (thanks to Cyberdevs)
      Nvidia Web Driver - 387.10.10.10.25.159 --> build 17D2012 (thanks to cyberdevs)
      Nvidia Web Driver - 387.10.10.10.25.158 --> build 17D102 (thanks to cyberdevs)
      Nvidia Web Driver - 387.10.10.10.25.157 --> build 17D2047 (thanks to cyberdevs)
      Nvidia Web Driver - 387.10.10.10.25.156 --> build 17D47 (thanks to darthsian) 
       
       
      10.13.2
      Nvidia Web Driver - 378.10.10.10.25.106 --> build 17C2205 (thanks to KGP-X99)
      Nvidia Web Driver - 378.10.10.10.25.105 --> build 17C2120 (see this post)
      Nvidia Web Driver - 378.10.10.10.25.104 --> build 17C205 (thanks to ReddestDream)
      Nvidia Web Driver - 378.10.10.10.25.103 --> build 17C89 (thanks to Il Francy MacPc) 
      Nvidia Web Driver - 378.10.10.10.25.102 --> build 17C88 (thanks to piiggggg)
       
       
      10.13.1
      Nvidia Web Driver - 378.10.10.10.20.109 --> build 17B1003 (see this post)
      Nvidia Web Driver - 378.10.10.10.20.108 --> build 17B1002 (thanks to BreBo)
      Nvidia Web Driver -378.10.10.10.20.107 --> build 17B48 (thanks to piiggggg) 
       
       
      10.13.0
      Nvidia Web Driver - 378.10.10.10.15.121 --> build 17A405 (thanks to Asgorath)
      Nvidia Web Driver - 378.10.10.10.15.120 --> build 17A405 (thanks to phi777)
      Nvidia Web Driver - 378.10.10.10.15.117 --> build 17A405 (thanks to phi777)
      Nvidia Web Driver - 378.10.10.10.15.114 --> build 17A365 (thanks to Asgorath).
    • By kromakey
      Hello ,
       
      Just changed my CPU to a E5450 to be able to Run Mojave , but now I can not run not even EL Capitan    (it was working well with CORE2DUO)
       
      I already flashed a modified bios to be able to recognise the CPU.
       
      here some print screens from Verbose :
       
      https://photos.app.goo.gl/kqWauSu5GZ9Kogxh7
       
      https://photos.app.goo.gl/F6kL5YbiFBqLcGyz6
       
       
      AZUS P5K PRO  - CPU E5450 - NVIDIA 9600GT - 5G RAM 
       
       
      ANY HELP is APPRECIATED
       
      Thanks/Obrigado
       
      Kromakey 
       
       
       
       
    • By fusion71au
      Clover r4914 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4914 for VMware.zip". Mount Clover-v2.4k-4914-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×