Jump to content
Sign in to follow this  
Followers 0
uPaymeiFixit

Clover takes 20 seconds. Is this slow?

5 posts in this topic

Recommended Posts

From the time Clover starts loading (after b1f: init 5) to the time the boot selection screen shows, about 20 seconds passes. 

 

I followed the suggestion of another post and unplugged all of my USB devices and everything went much faster. (about 4 seconds vs 20) I plugged in one device at a time and recorded the time to find the culprit. Here is the result:

// Added USB Device         Time 1 Time 2 (seconds)
Keyboard                    4.200   4.202
+Arduino                    4.416   4.390
+Mouse                      4.316   4.169
+Tartarus                   4.740   4.463
+Monitor (Hub)              4.587   4.738
+Monitor (Hub) -> Webcam    4.919   4.934
+Bluetooth Dongle           7.280   7.270
+Wireless Xbox Controller   7.357   7.186
+External Hard Drive        19.219  18.781

The Bluetooth Dongle and the External Hard Drive seem to be slowing it down the most. Is there anything I can do about this? 

 

Clover is on version 2.3k build 2015-05-29 19:32:05

I'm running Yosemite (10.10.3)

BIOS is up to date (F11)

It may be important to note that my motherboard does not support UEFI.

 

Links:

Clover config.plist: http://pastebin.com/wxUDDxhn

Clover bdmesg: http://pastebin.com/FZDetHZ4

Hardware: http://pcpartpicker.com/p/xsDgyc

Reddit Thread: http://www.reddit.com/r/hackintosh/comments/38hzh7/clover_takes_20_seconds_is_this_slow/

Share this post


Link to post
Share on other sites
Advertisement

@uPaymeiFixit,

 

On my legacy BIOS desktop (GAP55aUD3/Intel i5 750/AMD HD 5770), I found installing Clover with the BiosBlockIO option greatly reduced the time taken to reach the Clover Main Menu:

 

post-846696-0-70754200-1403501286_thumb.

 

You can also compile Clover yourself with CloverGrowerPro and use the "-D DISABLE_USB_SUPPORT" option to disable scanning for USB devices except the keyboard during boot - see @Maniac10's guide here (in Spanish - use google translate :)).  The "Activate Only SATA0 Patch by default" option will allow Clover to scan for only the hard disk attached to the first SATA port.

 

Good Luck!

Share this post


Link to post
Share on other sites

Hello and Welcome to InsanelyMac Forum!

 

Read this: Post#47 How to speedup Clover boot

And this: Clover Wiki/Boot

 

I have read through these two documents and I'm down to about 7 seconds! So thank you very much for that. I have some questions though. 

 

 
Reason #1
Debug is set to false in my config.plist
 
Reason #2
I set Scan -> Entries / Legacy / Tool to false, and there were no bootable devices shown, so I reverted it.
 
It's my understanding that I have all of my custom entries disabled (Because the key is #Custom instead of Custom). Is this correct?
 
At the moment I do not have any NTFS drives connected, so I assume disabling NTFS.efi will not help. Is this correct?
 
Reason #3
/EFI/CLOVER/drivers64/ contains 
FSInject-64.efi
HFSPlus-64.efi
and drivers64UEFI contains
FSInject-64.efi
HFSPlus-64.efi
OsxFatBinaryDrv-64.efi
 
Can any of these be removed safely? Is this too many? Should I be worrying about my drivers32 folder?
 
Reason #4
TextOnly=True, so I will assume this can be disregarded.
 
Reason #5 
Mouse -> Enabled=false
 
Reason #6
I have added HFSPlus-64.efi to my /EFI/CLOVER/drivers64*/ folders. This helped a lot. I'm down to about 8 seconds. 
 
 
 
Legacy
I'm not sure if I should change this or not.
 
DefaultVolume
I will assume this will not speed up the boot process. Correct?
 
DefaultLoader
Will this potentially speed up clover?
 
Fast
I would like to use this, but I need to be able to select what I am booting into. How can I tell clover to only search for Sata0 drivers?

@uPaymeiFixit,

 

On my legacy BIOS desktop (GAP55aUD3/Intel i5 750/AMD HD 5770), I found installing Clover with the BiosBlockIO option greatly reduced the time taken to reach the Clover Main Menu:

 

post-846696-0-70754200-1403501286_thumb.

 

You can also compile Clover yourself with CloverGrowerPro and use the "-D DISABLE_USB_SUPPORT"  option to disable scanning for USB devices during boot - see @Maniac10's guide here (in Spanish - use google translate :)).

 

Good Luck!

 

Thank you so much. Installing Clover with the BiosBlockIO option got me down to 3 seconds. I know in most cases this isn't considered fast, but for now it's enough for me for now. 

 

Just out of curiosity, would compiling Clover to disable scanning for USB devices disable my keyboard, and therefore prevent me from selecting an alternative boot device? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Specs:
      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz
    • By TimothyF
      My steps so far:
      Set up Catalina install USB exactly according to Plain Vanilla guide. Disconnect my Windows drive in PC, so that only the empty Hard Drive is connected to Motherboard. Boot to USB, select Install Catalina option. BIOS set to UEFI, Safe mode Off. Always get stuck at the same IOconsoleUsers: GIOScreenLockState point. Tried -radvesa, -radoff, nv-disable=0 boot options (separately), and disabling BIOS virtualization (vt-d) -> NO luck. This from the top search result https://www.reddit.com/r/hackintosh/comments/b5a6ry/ioconsoleusersgioscreenlockstate_3_blackscreen/  
      Screen pics attached. Here are the last couple of lines that could be important:
      GTrace synchronization point 4
      Unsupported CPU
      Unsupported PCH
      Adding ADGP mode validate property
      hmm.. mismatch sizes 3100 vs 20
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOconsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
       
      Please give me some ideas what else might work. Thank you.


       
       
      Other details of Clover and Desktop PC below:
       
      Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: config.plist ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)  
    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By STLVNUB
      Script file to clone Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By TimothyF
      My PROBLEM: I followed the Plain Vanilla guide (https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/) to a T in creating the OS X Catalina installer USB. I'm totally new to Hackintosh, and just want an Apple environment to Time Machine migrate my files and system from my ageing MacBook Pro. When I start to use the USB on the target PC (Dell Inspiron 3847 desktop), I ONLY see the Microsoft (which is the original OS, and on a SEPARATE Hard drive from where I want to install Mac OS), ZERO option for installing the OSX Catalina! Please SEE PICTURE link: https://imgur.com/a/FnLB2Q9   I'm a beginner, but I tried to google my problem. The answers were either incomplete, hard for me to understand and put into action, or were outdated and applied to older OSXs. I appreciate any help in diagnosing and solving this problem!   Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: see attached ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)   ------------------------------------ Attached:
      Screenshot of Clover installer not showing the Mac OSX option
      config.plist of my installer USB
      Clover_Install_Log.txt (not sure if this is relevant)   THANK YOU VERY MUCH!     config.plist
      Clover_Install_Log.txt
×