Jump to content
naquaada

Searching ZFS for Clover

16 posts in this topic

Recommended Posts

Advertisement

Thanks for your very quick response :D

 

Actually it doesn't detect my Solaris partition, but perhaps because there's no bootloader on it. Solaris uses GRUB2, but it is EXTREMELY difficult to handle... I have to use a static IP with two DNS servers and never got it to work... Of course there's no inbuilt function for it...

Share this post


Link to post
Share on other sites

Depending on the version of zfs on the Solaris install if it uses the compatible version before they took it closed source you should be able to access the data sets with the zfs on mac installed to your hack. You really need to get a boot loader installed into the slice containing the / of your Solaris install then Clover should just be able to boot by choosing that partition in the Clover boot display screen. More than likely need to have installed the Solaris as an uefi install as that is what I needed to do for my Linux install to work with Clover.

 

https://openzfsonosx.org/

Share this post


Link to post
Share on other sites

Clover already contains sources for ZFS.

Clover/GrubFS/src/ZFS.inf

Someone has to compile it.

Clover.dsc:

  # FS from grub
!ifndef NO_GRUB_DRIVERS
  Clover/GrubFS/src/EXFAT.inf
  Clover/GrubFS/src/HFSPLUS.inf
  Clover/GrubFS/src/ISO9660.inf
  Clover/GrubFS/src/NTFS.inf
  Clover/GrubFS/src/UDF.inf
  #Clover/GrubFS/src/UFS.inf
  #Clover/GrubFS/src/UFS2.inf
  #Clover/GrubFS/src/XFS.inf
!endif

Share this post


Link to post
Share on other sites

What's the status on this now?

ZFS is awesome on the Mac now.

( https://openzfsonosx.org )

Booting on ZFS without much trouble would be kick-ass.

They are actually implementing some functionality for booting but I don't think it's very mature yet.

Perhaps Clover could be a good tool for this even on Apple hardware.

 

I found this interesting but I don't know if it's relevant to booting Mac OS.

https://wiki.freebsd.org/RootOnZFS

 

Edit: Sorry for necromancing but I find it very interesting and would like to find more info/solutions.

Share this post


Link to post
Share on other sites

What's the status on this now?

 

Someone have to correct compilation for GrubZFS included in Clover sources.

It is not hard but nobody need it.

Share this post


Link to post
Share on other sites

I had enough bit rot or silent data corruption of whatever sorts to realise that ZFS can be worth a LOT.
Take into account the amazing features like redundancy simple and simple change of drives, snapshots, rollback, etc, etc.
I have GREAT experiences with it and I have data that value so it´s been amazing for me.

I think I will bring this with clover and grub drivers to the attention of the OpenZFSonOSX developers..
(They are working on implementation of ZFS Boot but I think its a bit tricky when Apple is not.


As you might guess, I'm not a developer.

If anyone could provide easy to follow instructions for building these drivers from grub2 (will they work seamlessly in Clover?)...
or simply build them from current source, that would be enormously appreciated.

Share this post


Link to post
Share on other sites
Posted (edited)

 

Hi. I have a problem that I think is related to Clover.
 
I have a Z370N motherboard with 4 SATA ports. I have a PCI-E card with 2 SATA ports. They are all populated with 8TB disks in a mirrored ZFS array.

Boot drive is NVMe and I am using the latest Clover installer (4910) and Mojave 10.14.4

Upon booting after a CMOS reset/BIOS update, the disks appear in MacOS Mojave as expected. Upon subsequent reboots, the 4 ports on the motherboard do not register the disks. Sometimes, the disks randomly appear after a reboot.

Upon testing with APFS SATA disks, there is no such problem. This appears to be a problem limited to recognising ZFS disks on the motherboard SATA ports. The PCI-E attached disks are unaffected. 
 
It seems to be an issue with Clover because upon startup after a CMOS reset, Clover takes a while to scan disks and does not recognise my "LastBootedVolume" - upon subsequent boots, there is no lengthy scan it boots right up.

Has anyone experienced this? Any thoughts on a fix?

 

Edited by kuruu

Share this post


Link to post
Share on other sites

Don't forget to download and install grub_zfs.efi driver into /EFI/CLOVER/drivers64UEFI folder.

Share this post


Link to post
Share on other sites
13 hours ago, Slice said:

Don't forget to download and install grub_zfs.efi driver into /EFI/CLOVER/drivers64UEFI folder.

Google does not reveal any reference to a grub_zfs.efi - is this an April fools joke?

Share this post


Link to post
Share on other sites
32 minutes ago, apianti said:

 

https://efi.akeo.ie/downloads/efifs-latest/x64/

 

Anyway, is there any special fs*.efi for clover or we could also use it from (for example) rEFInd build, etc? Thanks.

Share this post


Link to post
Share on other sites
10 hours ago, Badruzeus said:

 

https://efi.akeo.ie/downloads/efifs-latest/x64/

 

Anyway, is there any special fs*.efi for clover or we could also use it from (for example) rEFInd build, etc? Thanks.

 

Yeah, file system drivers should work for any UEFI firmware. If they work when using clover, then they will work anytime.

 

9 hours ago, kuruu said:

Brilliant! That seems to have sorted me out.

 

Oh, so you were doing something with solaris or freebsd?

 

4 hours ago, Download-Fritz said:

 

Let me second that real quick, utter rubbish, please stop spreading FUD. The kext data to link, i.e. the executable and the Info.plist, are put in a buffer that resides in the booter's Device Tree memory, then it is picked up by the kernel from there and linked into the kernel space, as any kext is. The mechanism used to inject kexts now is literally the Apple mechanism to boot without kextcache several versions ago.

 

Yeah, someone who can research and not just take nonsense at face value.... lol, those idiots.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×