Jump to content
Austere.J

[GUIDE] Intel HD Graphics 5500 on OS X Yosemite 10.10.3

49 posts in this topic

Recommended Posts

Advertisement

So the problem is the memory size. But this is aesthetic thing not a problem.

 

You can watch videos in YouTube, and open some Apps, in OS X?

Share this post


Link to post
Share on other sites

:w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:  :w00t:

 

I think I got it.  Set the Bios DVM to 64Meg, even though Windows states 160Meg

 

It's a almost perfect build. Just some of the little extras like keyboard function keys , keyboard light and battery meter a little odd and crazy.  I would say this car checks out fine. :thumbsup_anim:            

Share this post


Link to post
Share on other sites

I don't know why you need to hard work making IHD5500 full QE/CI Support :D

I used Asus A455LF-WX016D and work perfectly. Just enter bios and set DVMT to 64MB and it works.
Sleep, Restart, shutdown, full QE/CI just MIC PROBLEM with Conexant CX20752.

I know i am lucky because there is option to change DVMT at my BIOS  :hysterical:  :hysterical:  :hysterical:

Share this post


Link to post
Share on other sites

I don't know why you need to hard work making IHD5500 full QE/CI Support :D

 

I used Asus A455LF-WX016D and work perfectly. Just enter bios and set DVMT to 64MB and it works.

Sleep, Restart, shutdown, full QE/CI just MIC PROBLEM with Conexant CX20752.

 

I know i am lucky because there is option to change DVMT at my BIOS  :hysterical:  :hysterical:  :hysterical:

 

 

Can you explain how?

Share this post


Link to post
Share on other sites

What should i explain?? I just make USB installer El Capitan with CreateInstallMedia method, use latest clover, set DVMT at BIOS = 64MB. Then boot.

Oh i almost forgot, i set ig-platform-id = 0x16260006.

Working :
- Full QE/CI

- HDMI Out
- Audio HDMI

- VGA Output but not correct resolution

- Sleep, restart, shutdown

- Good Power Management

You can see this screenshots

post-1311960-0-43688200-1450046358_thumb.png

post-1311960-0-39955300-1450046370_thumb.png

post-1311960-0-52588600-1450046379_thumb.png

Share this post


Link to post
Share on other sites

What should i explain?? I just make USB installer El Capitan with CreateInstallMedia method, use latest clover, set DVMT at BIOS = 64MB. Then boot.

 

Oh i almost forgot, i set ig-platform-id = 0x16260006.

 

Working :

- Full QE/CI

- HDMI Out

- Audio HDMI

- VGA Output but not correct resolution

- Sleep, restart, shutdown

- Good Power Management

You can see this screenshots

 

 

You can pass the guide used?It has intel hd 5500?

Share this post


Link to post
Share on other sites

Yes,, you can see device id of my graphics card. See at screenshot it's "0x16168086". It's Intel HD Graphics 5500. I just edited model name to Intel HD 6100 with DSDT :D

I can 'go config.plist/// dsdt?

Share this post


Link to post
Share on other sites

What should i explain?? I just make USB installer El Capitan with CreateInstallMedia method, use latest clover, set DVMT at BIOS = 64MB. Then boot.

 

Oh i almost forgot, i set ig-platform-id = 0x16260006.

 

Working :

- Full QE/CI

- HDMI Out

- Audio HDMI

- VGA Output but not correct resolution

- Sleep, restart, shutdown

- Good Power Management

You can see this screenshots

 

how did you set DVMT at BIOS = 64MB?

Share this post


Link to post
Share on other sites

It's literally in the first post...

i have hp ac158nl i have the possibility to change dvmt to 64mb in my bios, i have i3 5005u  and 5500hd

i have succesfully installed osx and clover i have edit the id grafics in clver configurator and set it: 0x16160001 but it doesnt se graphic 

can you help me ? the bad thing is that i can change dvmt  to 64mb but i havent graphic  :wallbash:

Share this post


Link to post
Share on other sites

i have hp ac158nl i have the possibility to change dvmt to 64mb in my bios, i have i3 5005u  and 5500hd

i have succesfully installed osx and clover i have edit the id grafics in clver configurator and set it: 0x16160001 but it doesnt se graphic 

can you help me ? the bad thing is that i can change dvmt  to 64mb but i havent graphic  :wallbash:

 

Try 0x16160006.

Share this post


Link to post
Share on other sites

Hi everyone,  I am back again.  I have actually succeeded in a Hackintosh on a Asus 303 LNB model.  For this model, I have managed to work on it till almost everything is working, multi-tap, brightness controls, audio controls and I have even managed to DSDT an error free DSDT with battery patch with MACIASL.

 

I am trying to help someone with an almost exact model.  Asus 303L.  In fact, what I can conclude from the specs , it is the exact same machine, same graphics, same Nvidia chip.  Except that it comes with a small 32GB internal flash and a normal 750 GB HDD instead of SSD.

 

The bootable USB booted up fine,  no errors, no hiccups and I can proceed with everything that I am all too familiar with, since I have re-done my own Hackintosh a gazillion number of times while I am trying to get all the kexts and features in place.

 

Everything worked without a glitch.  However, the system hanged with the attached error.

 

To make matters much more amazing.  I can use the thumb drive as the bootable boot loader to boot up the HDD Mac OS and it will work fine.  Say for instance, if I were to install Wi-Fi , it will work as long as I use the thumb drive as the bootloader to select the laptop's HDD.

 

But If I use the clover on its own, it will hang.  And the best part of it all, is that to determine what could be the cause.  I only added FakeSMC.kext which is a mandatory kext and restarted to check if it will boot.  Nope.. It hangs.  With just one FakeSMC.kext

 

And to top it off , if I simply wait it out, as it would only load like one quarter of the apple logo and hangs there, the whole laptop, actually goes to sleep .   :shock:   But I am not able to actually wake it up anyways.  How is that even possible when the Mac OS is not even half loaded.

 

I cannot even boot in safe mode, cpus=1 and I tried quite a handful of flags, but nope.  

 

I can pop in the thumb drive and it will load perfectly fine.

 

What I cannot understand is that how can a laptop, load a thumb drive without issues, but yet fails to load on its own?

 

A few additional things to note is that, the laptop does not seem be successful in loading the HD 5500 hex config 16160002 even though I have checked to ensure that it is correct.

 

But the laptop is HD5500.  I can bet my last dollar on it.   Any ideas on this error as attached?

 

Thanks in advance.

 


Attach file as it seemed to have failed to attach in the previous post

post-678532-0-31625400-1451998856_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Special one,

 

Thanks for the reply.  SLE stands for?  == 

 

I did some guess searching, and I am guessing that you are implying that instead of throwing it directly into Clover = EFI, I will put them into System => Library => Extensions for the system to pick them up later only after the whole system has booted up.

 

Hmmm... Ok, is there actually any explanation for there to be a difference by doing SLE?  Since if a Mac is not compatible with a piece of kext somehow, it should crash as well even if I am to put it in SLE.

 

Its a pity, I don't have the opportunity to try anymore.  The guy's laptop died the very next day and he sent it in for warranty repairs.  Guess he will be sticking to Windows for quite a while.  

 

But it will be good to know for the future.

 

Side track a little .  I get like 4 hours out of this hackintosh that I built.  Not that I timed it, I have managed to get a working battery notification at the top right which tracks the number of hours left.  I can control the brightness and so I won't waste the battery.

 

I find it a little warm when I use it.  Feels exactly the same if I am using it in Windows with high performance settings.  Any power management kext that is recommended that can actually control the Intel i 5500 CPU?  Because in Windows, I can get 8 hours or more out of it.

 

Thanks in advance again..~

Share this post


Link to post
Share on other sites

Hi all, 

 

Just to update.  Finalised build.  I used the 6.0.1330 FakeSMC Kext dated 22 January 2014 7:53 am

 

https://sourceforge.net/projects/hwsensors/files/ 

 

After which, simply let the Mac go to sleep once.  Then wake it up and it will never hang or crash anymore.  Runs a lot cooler as well.  A notebook cooler is still highly recommended.  

 

As for Internal Wi-Fi for this model Asus 303LN .  It is a work in progress  here.

 

https://github.com/ammulder/AppleIntelWiFiMVM

 

This model looks like a good one to Hackintosh.  Some forums say El-Captain will solve the random crash and freeze for good.  Well.... time for a break before the El-Captain experiment.   :D

 

post-678532-0-18189900-1461479214_thumb.jpg

post-678532-0-78326600-1461479233_thumb.png

Share this post


Link to post
Share on other sites

LOL  8 hours.. Bamm ..  I got this... :lol:

 

I guess the solution is to install all the kext first and leave clover last.  After rebooting, check if you have installed everything like sound and Wi-Fi.  

 

Install Clover last and reboot.

 

After which, whatever that, you only insert those kexts that are not loaded or working, into the clover EFI and not the entire chunk of kexts that you need. 

post-678532-0-38918600-1462084686_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ltooz_audis
      I got the perfect working macBook Air 7,2 working with Mojave - Everything is working - I do mean even the SD card reader - audio - backlight controlled with keyboards... I'll write up the full tutorial and video how to soon. Love the Mojave, High Sierra was nothing compared to this.
      Cheers,
      Louis
       
       
       
    • By Andres ZeroCross
      A. Notebook Specifications
      Name : Asus A455LF-WX159D
      Processor : Intel Core i3 5005U
      IGPU : Intel HD Graphics 5500
      Discrette GPU : Nvidia GT930M
      RAM : 8GB PC12800/1600Mhz
      Wifi Card : Atheros AR9565
      Bios Version : 300
      Audio Codec : Conexant
      Storage : Samsung SSD 850 Evo 500GB
      Boot Mode : UEFI with CSM Disabled
       
      B. How To Install 
       
      I am not good for make a tutorial, so i upload my CLOVER folder (zipped), just use it (overwrite your USB Installer's Clover Folder) Set SATA Controller to AHCI at BIOS Make sure your BIOS version is "300" Set DVMT to 64MB XHC set to "Smart AUTO" C. Make a USB Installer with CreateInstallMedia method, install Clover Bootloader R4423 or above, then delete Clover Folder inside it and replace with mine
      =======
      SPECIAL NOTE
      D. Normally for broadwell IGPU (IHD 5500), you only need to Inject Intel and set ig-platform-id=0x16160002 or 0x16260006. But some notebook will face RANDOM KERNEL PANIC or STUCK at IGPU log (hang) when you inject ig-platform-id. This is not DVMT Pre-Allocation Problem. I found the solution  Just set FakeIGFX to 0x16268086, Tick Inject Intel and set ig-platform-id as 0x16260006 or 0x16160002. Now you will get QE/CI  For me, i set those values at SSDT-1.aml (check my attachment file)
      ======

      Whats Working??
      - QE/Ci
      - Audio OUT and Mic
      - Wifi Card
      - LAN Ethernet
      - Battery Indicator
      - Fn + Brightness Button
      - Touchpad
      - Sleep, Restart and Shutdown
      - All USB Port (High Speed and Super Speed)
      - Battery Indicator
      - Etc
       
      Thanks
       
      My Clover Folder's Link : https://drive.google.com/open?id=1qzvT155DZ1r8cI0ceBW4OjWAEMUu491-







    • By Mohamed Mohsen Elnahla
      Hi 
      I tried to install OSx El capitain before and my intel was working perfectly but now i erased it and installed macOS sierra 
      I tried all guides and removed the OS and reinstalled it a lot and tried to upgrade the os to 10.12.6 but every time i face the same thing i have my Intel Graphics HD 5500 with 1536 MB but it doesn't work at all i still have glitching and i have gray lock screen and it is like i don't have graphics (this problem happened only with sierra 10.12.3 and 10.12.6 but not with el capitain 10.11.3)

      So i have uploaded some photos and a file of my laptop information and clover information and some photos of kexts which i used
      my laptop specifics :
      HP Pavilion 15 p218ne
      Ram: 6 GB
      Processor : Intel I5-5200U
      Graphics :
      - Intel HD Graphics 5500
      - Nvidia Geforce 840M
      (my Laptop specifics)

      Clover settings

      MacBook Pro.spx
      (My kexts) (they were working perfectly on el capitain and the AppleintelBDHWGraphicsF.....  is the one which made my intel 1536MB but still not working)

       
    • By ltooz_audis
      After i finished updating macOS High Sierra on HP x360 15-u011dx Haswell HD4400 i7-4510u, I started to update my daughter Dell Inspiron 7352 Broadwell HD5500 i7-5500u. It was a little harder but it works quite nicely. The new Clover is Buggy with the cache that cause "Error loading Kernel Cache..." that I had to re-install the OS. Kernel Panic all the time until I got the config.plist and kexts correctly. Now it's a perfect little 13" MacBook Air7,2. If you have anything thing with a "u" at the end of the CPU, don't use macbook pro, it doesn't do you any good.
      I'll have full tutorial soon.
       


      Make sure to have en0 built-in without Ethernet Built-in

       
      Cheers,
      Louis
    • By ltooz_audis
      I just got a Dell Inspiron 7352 Broadwell i7-5500u HD5500 and made it into a perfect MacBook Air7,2 with everything working. I installed Yosemite, El Capitan and macOS Sierra. Here is how I did it. For those who have no mac to create an 8GB installer, watch the videos.
       
      1. To boot the installer use ig-platform-id 16160006, when everything is done boot with 16260006 for full QE/CI.
      2. Use Rehabman config.plist file and edit some.
      3. Make sure to use all the newest and greatest kexts from Rehabman for perfect running system, especially with macOS Sierra.
      4.Patch ALC255 using AppleALC.kext will get HDMI and all audio ports detection perfectly.
      5. For more information on this laptop.
       
      Choose the MacBook Air 7,2 with SMBIOS MBA71 will run faster with macOS Sierra then SMBIOS MBA72.


       
      -El Capitan on Dell Inspiron 7352 Broadwell i7-5500u

       
      -Create Clover boot partition using BootDiskUtility.

       
      -Extract HFS from macOS Sierra using 7zip command line.

       
      -Create macOS Sierra USB Installer with Clover 3974

       
      -Install macOS Sierra and El Capitan on external usb drive before restore it to the internal hard drive.

       
      -Post macOS Sierra Installation.

       
      -Patch AppleHDA on Realtek ALC255.

       
      -Patch DSDT & SSDT
      The best patches to get this laptop to sleep/wake/audio/HDMI are (we don't need to patch all):
      * Null Ethernet - set a real Mac Address - use the one for the original wifi that will be replaced.

       
      * Rename _DSM to _XDSM.
       

       
      * Audio Layout id = 13 = 0x0D.
       

       
      * Pnlf_Haswell_Broadwell.
       

       
      * Fix WAK Arg0 V2.
       

       
      * Fix IRQ.
       

       
      * Fix SMBUS.
       

       
      * Fix USB3_PRW 0x6D.
       

       
      * Rename B0D3 to HDAU both DSDT and SSDT.
       

       

       

       

       

       
      * Patch _Q1D and _Q1C for backlight keyboard.
       

       

       
      -Install El Capitan 10.11.6 to Internal Hard Drive and Clover UEFI.

       
      -Install Fuse to write to NTFS Windows Partition.
       
      -Replace DW1560 Dual band Wifi and Bluetooth 4.0 BCM94352Z.

       
      Cheers,
       
      Louis
×