Jump to content
Sign in to follow this  
Followers 0
Anass Bnou Malik

Ecran noir sur pc portable

8 posts in this topic

Recommended Posts

Bonjour tout le monde :

 

J'ai un petit problème avec mon hackintosh , j'ai reussi à installer yosemite sur mon pavillon dv6 2143sf avec les flags GraphicsEnabler=Yes & IGPEnabler=Yes ,le problème survient au moment du lancement de yosemite

je mets les mêmes Flags , je tombe sur un écran gris avec le curseur de la souris (puis ce ne fait rien , j'ai du laisser une 20ène de minutes mais ça n'a rien fait )

Si je ne mets rien comme flag (aprés avoir changé le kernel (lapic kernel ))  , je tombe sur un écran noir : j'ai essayé de faire pas mal de chose mais c'est ca soit bloque , soit écran noir

 

Du coup je peux démarrer en désactivant les pilotes de la carte graphique avec Nv_disable=1.

 

ma carte graphique est une nvidia g105m de 512 mo , yosemite 10.10.2 installé

Je me demande si il faut que j'installe les kext ou j'ai juste besoin d'utiliser un dsdt correct .

Share this post


Link to post
Share on other sites
Advertisement

salut ABM   :)

 

si ma mémoire est bonne, le proc de ton pc portable a une carte graphique intégrée (Intel GMA HD je crois, pas sûr) et le switch entre celle-ci et celle dédiée (NVIDIA) n'est pas pris en charge par le système d'exploitation d'Apple (ils ont leur propre système de switch), donc c'est pour cela que tu te trouves avec un écran noir.

 

et la solution était justement le boot flag nv_disable=1 ce qui a eu pour effet de "désactiver" les kexts (drivers) nvidia chargés lors du boot.

 

:)

Share this post


Link to post
Share on other sites

Je ne pense pas avoir le switch sur le mien , il me semble juste avoir le gforce g105m , le nv_disable désactive les kext de nvidia , mais en contre partie , je n'ai pas de carte graphique qui fonctionne (image saccadés , limite résolution à 1024*768 , VRAM 3mo = pas de pilote de carte graphique installé ...)

Share this post


Link to post
Share on other sites

chez hp, pour ton modele, ils proposent bien le pilote pour l'intel HD. donc apriori oui il est bien équipé du switch.

comme c'est bien un intel HD de 1ere génération, il me semble bien que osx les supporte moyennant un peu de bidouille.

Share this post


Link to post
Share on other sites

Sur le mien j'ai un chipset PM55 , contrairement au HM55 qui possède une intel HD graphics , le mien possède juste la nvidia g105m , bref je n'ai jamais eu de switch sur ce pc.

 

Le problème c'est que j'ai toujours un écran noir sans mettre nv_disable = 1 et je ne sais pas d'ou vient le problème , j'ai essayé de patché mon dsdt pour faire marcher la carte graphique mais ca n'a pas marché , des idées ?

Share this post


Link to post
Share on other sites

Moi j'en étais sur , finalement il suffisait d'installer un smbios différent pour pouvoir installer les pilotes alternatives de nvidia correspondant au bon build de mon système et de démarrer avec les arguments suivants ( aprés avoir appliqué le lapic patch ) :

nvda_drv=1 GraphicsEnabler=Yes IGPEnabler=Yes

 

J'ai installé le voodooHDA avec soundflower pour pouvoir avoir du son mais des fois il se coupe et je suis obligé de redemarrer, je ne sais pas d'ou peut venir le problème ...

et il me reste juste un problème de brightness et de batterie à résoudre et tout deviendrai fonctionnel sur mon pc , je pense que tous ces problèmes ne peuvent se résoudre qu'en patchant le DSDT ?

 

Et comment je pourrais connaitre le model de mon chipset son , je sais que c'est un IDT mais je ne connais pas le model ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×