Jump to content
ZoroLives

Mavericks to Yosemite Problem

8 posts in this topic

Recommended Posts

Hi folks, I am upgrading Mavericks to Yosemite. Ref thread: http://www.insanelymac.com/forum/topic/300976-cant-get-it-stable/. to see how I got Mavericks up and running - I had some challenges. I have been reviewing that thread to see if there are answers there for me (again).

I have been mostly stable with Mavericks for about 6 months (still no DVD player recognized and restart problems) and I decided it was time to move to Yosemite. Cloned my Mavericks drive and started following directions to upgrade cloned drive to Yosemite. Unfortunately, the Clover I first tried made some global changes and now my main Mavericks drive isn’t booting properly anymore. Thank goodness I still have this 10.6.8 drive to go back to. The Mavericks drive will still boot but it takes about twice as long to do any sort of file launching, and it has no internet anymore. That means I can boot into Mavericks and use any suggested tools, but not chat this way in the mean time.

So far the suggested Yosemite upgrade thread is not working. Ref: http://www.insanelymac.com/forum/topic/298521-easy-yosemite-1010-final-usb-installer-updated-10162014/.

Problem I have now is a familiar one, I have run too many installers at my target disk and I still don’t know what I am doing. This is my fault. I have some rather serious disfunction in my thinking from an old head injury - working through it now (finally) but that is another story. Bottom line is I have a hard time following this process and it helps when I understand what is supposed to go where. I will probably never join the ranks of the experts here and yet I am indebted to them and their hard work and kind and generous support of others here.

I wish I knew what should, and should not go where. For example, if I have a voodoo driver, what should I not have that is conflicting, etc.? Maverick now: takes much longer than it used to to boot and to respond after a click to launch an app, wont launch some apps it used to launch (gets a, this app closed unexpectedly - retry - cancel-etc dialogue), shows WIFI in the WIFI software but shows red dot in the system network (and as before, says no DVD player installed even for a DVD file transferred from my laptop - it isn’t the actual player its just not recognized).

The main issue is that my formerly stable Maverick drive is now unstable. So following upgrade to Yosemite from Mavericks instructions may fail because I am missing a part of the instructions or because I am applying it to a screwed up Mavericks install. What has clover left that is conflicting with running Chameleon, etc? (and vice verse). All in all it seems that step one is to stabilize Mavericks again. Of course I would be delighted to just get Yosemite working.

Thanks again for any help with this.

ZoroLives

 

PS: At the posting of this I am recloning (CCC) my (mostly) working Mavericks drive to my future Yosemite drive. THis will erase my errors and confusion from using Chamelion and Clover to boot it properly. My goal is to avoid working on what is already working, test the copy to make sure I know how to get it working and stable, and then do the same thing on my main (Mavericks) drive. OGT (On Going Thanks).

 

Update: My Main Mavericks drive has an Extras folder and an EFI folder. Is it supposed to have both? However I did this, I am thinking this is why it is now taking so darned long to boot and lauch apps? The Extras folder contains org.chameleon.Boot.plist and several KEXTs. The EFI folder contains a bunch of Clover stuff. I have had more past experience with camilion than Clover, however the vanilla install tutorial for Mavericks to Yosemite now says the moderator has moved on to the Clover project and recommends the same. So, I remain confused.

 

UPDATE: Deleted the EFI folder that had the Clover boot stuff in it, booted OK. Veeeerrry slow but assume this is rebuilding cache. Cant get it working with WIFI. WIFI used to work fine on this system. WHatever I did, knocked out the KEXT my system was using. Getting this stable is critical to getting a clone upgraded to Yosemite. My WIFI software (HAwkins) shows I am getting a signal and conencted on that level. But the system network shows no internet connection. REnewed LEase but that did nothing to fix. I will continue to review the previous thread (show link top of this post) for earlier suggestions to make sure the correct network driver is still where it is supposed to be - or, could I have inadvertantly instelled a conflicting network driver that I need to remove? That is my main question, how can I tell what I am supposed to have and not have wiht my build? Still throwing too much garbage at it, hoping something sticks. Would love to learn more about the pieces I am installing, why, why not (conflicts). OGT.

 

UPDATE: Phase 1: Maveriskcs back online and stable is resolved. Reset my kernal chache and paired my extensions a bit. Also deleted the EFI folder with the Clover "stuff".

 

Now any help in getting to Yosemite would be greatly appreciated. OGT.

Share this post


Link to post
Share on other sites
Advertisement

If mavericks isn't running great for you, couldn't you get another HDD and try a fresh install.  Sorry, I'm of no real help- thats what I ended up doing though

Share this post


Link to post
Share on other sites

Probably not. I tried that in the past. All I get is more drives that may or may not work. What I am trying to do is find out what is working and what should be working. I have to educate myself in order to do that and, that is harder than It sounds.

 

All I need now with Mavericks is to get sound working again. It would be nice to get evorboot working and DVD to be recognized - very nice, but, that is a PITA I can live with - till I have time to focus on It again. My goal is to A - Get mavericks working for my everyday use (done but for sound) and B -  upgrade It to Yosemite.

 

Sound worked great but when I put in a demo of an app called "Digital Power Station" by Bongiovi, the sound quality never really recovered after I uninstalled It. I uninstaled the app but It left a driver I cannot get rid of. The Bongijovi web site says I should have a KEXT called "DPSReflector.KEXT". But, I don't have one in my S/L/E folder. My sound system preferences output has one file listed, the DPSReflector. It does nothing and should not still be there as there is no DPSReflector KEXT.

 

I used to have several output options related to my board and case, green rear out was what I used. But none of those output lines are still there so, no sound.

 

I have used Kext Utility to install the following sound related kext's:

 

Extra: HDAEnabler1.kext, AppleHDA.kext

 

S/L/E: RealtekRTL8111.kext, RealtekRTL81xx.kext, VoodooPS2Controller.kext, Legacy889HDA.kext, ALC885_889a.kext.

 

I still have no sound and no sound output options, Nada, zip, bupkiss.

 

Currently re-cloning my extra drive. I will try again to move It to Yosemite. Last time I tried, I ended up with a drive that would not boot.

 

UPDATE: Hooray. Sound is working again. I threw evry bit of sound I could find in Vietnam tool. VoodooMonitor kext caused panics, removed It and now, It works. I still have that pernicious DPSReflector in my sound panael. Wish I could pull It out by the roots as It doesnt belong there.

 

Will re-clone again and start Yosemite upgrade attempt again.

 

 

IMPORTANT UPDATE: THIS THREAD: *************

 

I got into this upgrade mess, now restored, by following this thread: http://www.insanelymac.com/forum/topic/298521-easy-yosemite-1010-final-usb-installer-updated-10162014/. It walked me through building a USB drive using Clover. I am more comfortable with Chameleon but not against Clover, I just get confused easily when I don't understand all the options. Clover seems to insist I use EFI where Chameleon does not. I am asked to choose drivers and options for my board but I can't even tell if I need EFI or not.

My mom had great stories from being born in Indonesia to missionary parents. She said that in rural areas, woman used to throw a stick of butter against a statue of the Buddha in order to see if they were going to be pregnant or not. If It stuck, It was pregnancy for sure, if not, no pregnancy. That's what I feel like with this hackintosh sometimes. I feel like I keep throwing butter at the screen and seeing what sticks.

I remember in the early builds of Yosemite that people were saying that Clover was the only way to get Yosemite working. Is that still true? Was It ever true? I can't even tell what they keep referencing as DP2/DP1 on that thread?

My goal is to move to Yosemite and have that boot stable. Can I do that and keep with Chameleon, or is this (link referenced) method really a good way to go? And, if I do this and still have my old files set up from Chameleon, how do I avoid the mess I just slogged through?

 

I apreciate the help. OGT

Share this post


Link to post
Share on other sites

I use clover, but AFAIK chameleon should work fine- after all, why would there be a way of creating an installer usb with cameleob if you couldn't boot from it.

 

The 1tb SSHD in my sig is running good 10.10 with clover; it does boot0 if you try cameleon, but even that is fixable.

 

Is yor dvd drive pata or sata?

Share this post


Link to post
Share on other sites

To get familiar with Clover install it to a USB flash drive. (I assume that all the necessary kexts are installed in S/L/E on the Mavericks drive) Format the USB drive using Apple GUID then run the clover installer and install the boot loader to the USB. Then use the USB drive to boot into your Maverick install (hit F12 at startup to access the BIOS boot menu and select the USB drive from the list of harddisks).

 

When installing Clover to the USB you will not use anything UEFI and do not install to the EFI partition. You can choose whatever Theme you like and can experiment with the other options to see what they do. Once you have Clover installed to the USB drive, select the USB as boot source. When the computer is booting from Clover you can select the OS to boot into from the Clover boot page.  You do not have to change anything on the Mavericks install to boot from Clover on the USB drive (chameleon will be ignored).

 

If you are using Clover version 2953 or later you do not need to do anything special to update Maverick to Yosemite. Simply place the Yosemite installer in the Applications folder, double click the installer and let it run. The installer will run for a minute or so and the computer will reboot. When the computer reboots into the Clover boot screen, use the arrow keys to select "boot OS X Install from (your HD name)". The installer with run and when the computer reboots (your HD) will not contain Yosemite.

 

Obviously, you want to use a clone of your Mavericks install for this process.

 

Edit: if you use VoodooHDA kext for audio remove it from S/L/E before installing Yosemite. AppleHDA (which will be installed with Yosemite) and voodooHDA do not play together (Panic will ensue).  After install remove AppleHDA kext and reinstall voodooHDA.

Share this post


Link to post
Share on other sites

 

When installing Clover to the USB you will not use anything UEFI and do not install to the EFI partition.

The Clover I am using is "Clover EFI v2.3k r3185". Is there more than one version? Should I be using a differnt version?

 

 

Is yor dvd drive pata or sata?

I forget. It hasnt worked for a long time. Some bug in my insstallation that I never fixed. Oh, here It is, SATA

LG 22X DVD±R DVD Burner with LightScribe Black SATA Model GH22LS30

 

UPDATED: Thursday Mar 5th, 2015 8:59 AM: Backed up fresh copy of main disk to target for Yosemite disk "Yosemite".

Main disk has WIFI and recognizes same in system network prefs, clone would not. Has worked in the past, not sure why It is missing now? After this backup will test again

 

Booted to Cloned disk and removed Voodoo as instructed. Tried running Yosemite installer stock from applications folder of target drive. Rebooted when asked (still have not fixed the reboot issue so had to force reboot). On reboot used standard (for me) Chamilion and then selected Yosemite drive. I was hopign this would continue the installation but, went for a while then a KP. Tried this again verbose, same deal. Got distracted by a visitor so didnt make note of the exact panic message.

Share this post


Link to post
Share on other sites

I hope this thread is still read? Thanks in advance for any help.
I had to get back to other work to be done, revisiting this thread after almost a month. I still cannot get this install to work. If anyone is still listening on this thread, may I Please revisit my recent progress? Apple releasing Photos was my “line in the sand”. I now really need to get to Yosemite.

 

Here are my specs:

MY HACKINTOSH COMPONENTS:
Board:       GA-P55A-UD4P
Socket:      LGA1156
Chipset:     Intel® P55 Express Chipset
Audio:       Realtek ALC889 codec
LAN:         2 x RTL8111E chips (10/100/1000 Mbit)
Graphics:    EVGA GeForce 9800 GTX+ 512 MB
Memory:      3 x 2 GB (6),  DDR3, 1333 MHz, Corsair
OSX:         Mavericks
REF:         http://www.gigabyte.us/products/product-page.aspx?pid=3435#sp

Advice from another thread (no, not that hated squished/rotten tomato one).  :-)
ADVICE: Format USB to GUID partition table and install Legacy method Clover!!!

INSTALLATION METHOD FOR USB INSTALLER:
sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction

ADVICE: Run Clover like this:

CLOVER SELECTIONS:
Install Clover in the ESP
Install boot0af in MBR
CloverEFI 64-bits BiosBlockIO
Drivers64UEFI: EmuVariableUefi-64
Drivers64UEFI: OsxAptioFixDrv-64


ADVICE: Add This:

Clover/ and change your congig.plist with this -  config.plist.zip   1.08KB   0 downloads
and on drivers64UEFI delete VBox and copy this file -  HFSPlus.efi.zip   14.82KB   0 downloads

All the Kexts in Mavericks, tried copying to the USB 10.10 folder:

AHCI_3rdParty_SATA.kext
ALC889a.kext
AppleACPIPlatform.kext
AppleACPIPS2Nub.kext
AppleHDA.kext
ApplePS2Controller.kext
AppleRTC.kext
EvOreboot.kext
FakeSMC.kext
GenericUSBXHCI.kext
HDAEnabler1.kext
IONetworkingFamily.kext
IOUSBFamily.kext
IOUSBMassStorageClass.kext
JMicron36xSATA.kext
NullCPUPowerManagement.kext

Result, No boot to that drive

These are the minimum KEXTS which seem necessary to at least start booting in the USB Install in Clover:

AppleACPIPS2Nub.kext
ApplePS2Controller.kext
FakeSMC.kext
NullCPUPowerManagement.kext

 What Happens: No matter how I get there, and I have tried running the Yosemite installer and rebooting to Clover, rebooting to the installing drive, booting from Clover and choosing install from target drive = I ALWAYS, get the same result.

I get a long boot up, about ⅓ distance of the little line. I am posting a screenshot of the last screen in Verbose before It turns GUI.

It does turn GUI, but It only shows a light grey screen and the colored spinning ball. After approximately five minutes, the screen turns off.

That’s It. I cannot get past this. The person who was helping me thought that “You no check InjectNVidia.” but said no more on this. I posted the HEX string and the code that EFI studio puts out on my card (see top this post for specs) but he did not say more on this. I don't see a place to do this?

Also, if It matters, I currently have a DSDT file but I don't know if I have to have to use one or not?

Thanks

post-328514-0-54291300-1428850807_thumb.png

Share this post


Link to post
Share on other sites

Major Update, Success!!!! I found that booting from my old working main Mavericks drive which had Chameleon finally worked. Or at least, It got me past the installer. Now I was able to boot from the Clover screen to finish the installation.

I decided to erase my target volume and just start over installing Yosemite fresh on my target drive. Then I chose option to transfer files form old drive.

 

Now I am applying updates.

 

I see now why this has been so long and frustrating for me. I can boot to the same USB 3 times doing exactly the same thing. First boot, FAIL, 2nd boot FAIL, 3rd boot PASS. It's as bad as an old girlfriend, It just wasn't in the right mood the first time I asked ... ;-)

 

I still have orange drive icons and I haven't yet tested Its restarting ability. The DVD drive is still unrecognized - but WiFi and sound work. OK, I still have the problem with the sound being reset every time I reboot ... But at least and at long last I am now running Yosemite.

 

Thanks very much for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×