Jump to content
XTuga

[Success] Asus Maximus VII HERO + GTX 580

12 posts in this topic

Recommended Posts

My System is:

MB: Asus ROG Maximus VII HERO (BIOS 2304) [VT-d: disabled; SATA: AHCI mode; SecureBoot: OtherOS]

CPU: Intel i5 4670K
Storage: Samsung SSD EVO 256Gb (Mac OSX) + OCZ SSD 128Gb (Windows 8.1) + Other storage HD's in NTFS
GPU: MSI 580GTX Lightning 1536MB PCIE
RAM: 8GB G-Skill DDR3-2400
Wireless: Apple iMac WF-AC360 Desktop PCI-1X BCM94360CD
Monitors: ASUS (2K) DVI + HP w2207h (1440p) HDMI

 

 

1. Create a bootable USB Flash Drive

  • Format the USB Fash Drive in GUID and name it "Install"
     
  • Insure the OS X Yosemite.app is in your Application folder
     
  • In terminal run the following script
    sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction
    
  • Now install Clover_v2k_r3185 (or newer) to the Install USB
     
  • Follow this options:

    yUu128k.gif

     
  •  Run Clover Configurator [check in the Inject Nvidia if you have a GTX 580 like me]
     
  • Copy FakeSMC kexts to /EFI/Clover/kexts/10.10 
     
  • Reboot PC and select to start with the USB Flash Drive in UEFI mode
     
  • In Clover menu, select the USB Flash Drive

 

 

 

2. Make the Yosemite installation on the HDD
After get to the installation menu:

  • Format in GUID the HDD where you wanna put the Mac OSX Yosemite
     
  • Make the normal steps of the installation

 

 

 

3. Pos-Install
�  Make HDD bootable
 
     1. Copy the content from the EFI partition on the USB to the EFI partition in the HDD that you have your Mac OS X [you can run Clover Configurator to mount the partitions]

 

 

 

3.1 Fixes

�  Fixing Audio
Install HDAEnabler7 + AppleHDA-269.25-ALC1150 from Mirone post: AppleHDA For Yosemite - DP's
 
�  Fixing Ethernet
Running Hackintosh Vietnam Tool and install kext AppleIntel1000e

 

�  Fixing random reboots (GTX 580)

Random reboots are happening, situation is being analysed to find the cause [Need to put my BIOS running by Intel GPU even if it will use the GTX 580 when get to the Mac OSX desktop.

If you really wanna use the PCIE on BIOS, you need to install Nvidia Web Drivers. Keep using the Apple Nvidia drivers, but for some reason the drivers from Nvidia will eliminate the reboots.
 

�  Notes GTX 580

Even if I put my BIOS to use the CPU-GPU to avoid the reboots, the problem is that even if I have connection to both monitors and they are connected to the DVi ports of the GTX 580, the true is that the fish test I only get 15fps when if I tell my BIOS to run from the PCI-E it run at 60fps.

 

 

What is/not working?

Graphics - Worked OOB

WiFi - Worked OOB

USB - Worked OOB

USB 3.0 - Worked OOB

SATA - Worked OOB

App Store - Worked OOB

Sleep/Shutdown/Reboot/Wake Worked OOB

Network - Patch

Sound - Patch

 

 

 

Benchmarks Windows

Geekbench: 3592 / 11770

Unigine Heaven Benchmark 4.0 Dx11: 51.4/1295/28.6/91.6

Unigine Heaven Benchmark 4.0 OpenGL: 45.1/1135/10.2/83.0

Fish GL: 400 fish / 60fps (http://www.fishgl.com)

 

GPUTest 0.7.0:

  • FurMark - 2058 points (FPS: 34)
    GiMark- 2383 points (FPS: 39)
    PixMark JuliaFP64 - 2151 points (FPS: 35)
    PixMark Piano- 292 points (FPS: 4)

 

Benchmarks Mac OSX 10.10.2

 

Fish GL: (http://www.fishgl.com)

BIOS GPU "AUTO" - 400 fish / 15fps 

BIOS GPU "CPU" - 400 fish / 15fps 

BIOS GPU "CPI-E" - 400 fish / 60fps 

 

GPUTest 0.7.0:

  • FurMark - 2053 points (FPS: 34)
  • GiMark- 2435 points (FPS: 40)
  • PixMark JuliaFP64 - 2151 points (FPS: 35)
  • PixMark Piano- 293 points (FPS: 4)

BruceX (ProRes422): 52s

 

nMV8hm6l.png

 

 

T8CiaGn.png

Share this post


Link to post
Share on other sites
Advertisement

 

Il Francy MacPc, don't update to BIOS 2601 it breaks AHCI driver. 
 
Ru1Sous4, the Asus Maximus VII Hero never had a BIOS version 2304.

 

It doesn't break the AHCI driver either, I'm using BIOS version 2601 right now and it works fine.

 

 

Nice write up. I used yours and some other sources to get my similar setup running. Setup is in signature. Figure I'd share some info in case others need help. To get Yosemite running flawless on my rig I had to do a bit more. Honestly don't have the balls to try El Capitain anytime soon, lol. This setup is sweet as hell right now.

 

Due to having GTX 970 and being a lazy ass that didn't want to take it out and put it back in, I had to install/boot using nv_disable=1, after installation and initial boot, then download web drivers and cuda drivers for nvidia, the graphics was painful during this process, but after installing then boot with nvda_drv=1, fantastic. (Note: Cinebench 167 fps in Windows vs 111 fps in OSX.)

 

HDMI Audio with NVIDIA cards - I followed andrejkw's guide to enable it.

 

iMessage working with this guide here -> Enable iMessage. (Note: I do NOT have a credit card on file with Apple and it works.)

 

Not that I don't trust Vietnam tool, but prefer to get the source to add to my own kext collection and install myself.

AppleIntelE1000e.kext.zip

 

Edit: I have recently moved from AppleIntelE1000e to IntelMausiEthernet. I'm sticking to it since it is newer developed and is being maintained. Here is the link and kext.

IntelMausiEthernet.kext.zip

 

Enable Trim via Clover for 10.10.3 and below

(1) In Clover Configurator, go to Kernel and Kext Patches add a new row

(2) in name put "IOAHCIBlockStorage"

(3) in find hex put "004150504C452053534400"

(4) in replace hex put "0000000000000000000000"

(5) in comment you can write what you want

(6) in InfoPlistPatch leave it as is (unchecked)

(7) Save and reboot

 

Edit: Trim on 10.10.4 can be done via terminal and no longer needs to be patched by Clover.

sudo trimforce enable

Edit: On 10.10.4 my audio would not wake from sleep. I used Mirone's new patched kext for AC1150 for 10.10.4. This was easily fixed with CodecCommander as discussed in his post. I inject with Clover as I do with all my kexts.

CodecCommander.kext.zip

 

Using MacPro5,1

 

My config.plist for install USB is on post #10. Obviously recreate your SMBIOS after installation.

 

Good luck guys!

Share this post


Link to post
Share on other sites

Nice write up. I used yours and some other sources to get my similar setup running. Setup is in signature. Figure I'd share some info incase others need help. To get Yosemite running flawless on my rig I had to do a bit more. Honestly don't have the balls to try El Capitain anytime soon, lol. This setup is sweet as hell right now.

Thanks for sharing, sure will be useful for someone :)

Share this post


Link to post
Share on other sites

Tried doing everything exactly as stated, but ended up with this error:

 

8CmMgEL.jpg

 

 

Any idea why?

Share this post


Link to post
Share on other sites

Not sure of all your boot arguments, try my config file in your clover boot. attachicon.gifconfig.plist.zip unzip it into efi/clover/

It always gets me booted into the installer or my operating system.

Thanks so much! This helped.

 

I've been able to install it, and boot into it on the drive I want it on.

Share this post


Link to post
Share on other sites

So I updated to 10.10.4 everything is working as normal. Clover no longer needs to patch for TRIM to work. You can simply enable it through terminal.

Terminal: sudo trimforce enable

The only problem I encountered was the audio would not wake from sleep. Mirone has updated his kexts for 10.10.4 but still no audio when waking. I am still currently discussing with him if there is a possible fix without using a extra kext but that conversation is probably over already as I have fixed the issue.

 

There were two possible fixes in his post. I went with the first one which was using Codec Commander from Dolnor. A bit a of work to compile the kext with xcode and change some settings but it was easy enough. For those who are updating with this motherboard and using the build in ALC1150 here is the CodecCommander.kext I created from Dolnor's work.

CodecCommander.kext.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Reel
      All work except camera
      You need SwitchResX that the screen does not freeze
         


    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JRevenge
      Ciao ragazzi,
      alla fine sono riuscito a risolvere il problema che riscontravo qualche mese fa, dopo l'ottima EFI sistemata da @gengik84 e l'ho risolto rimuovendo dart=0 che creava kernel panic e problemi quando la batteria scendeva sotto ad un livello di batteria basso. Adesso il sistema non crea più problemi di kernel panic, ma volevo chiedervi se allo stato attuale secondo voi c'è qualcos'altro da ottimizzare.
       
      Vi allego la EFI.
       
      Grazie anticipatamente.
      CLOVER.zip
    • By TheAngryYeti
      So after a gazillion tries with High Sierra, i gave up and decided to try Mojave. I had nothing to lose, afterall.
       
      I started from scratch. I reformatted my thumb drive. Made it bootable from the Mojave [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Booted with it. Selected my language. It installed a little bit. Rebooted. I Booted from the SSD. Installed a bit more. Rebooted. I Booted from the SSD again and it finished the installation.
       
      I went through the basic setup and got to the desktop. I ran [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and selected my options and "built" it.
       
      Thinking i was a-ok, i decided to reboot, just to make sure all was well.
       
      After about 1min, i lose display.
       
      I thought i had messed something up in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], so i decided to go back to my mac mini, redo the thumb drive all over again.
       
      I go to boot from the thumb drive and when i get to the language selection screen, i lose all USB usage, so i cant even get in to wipe the SSD and start over. So, Mojave is still on the SSD, but i cant get to it because i lose display.
       
      Im attaching a screenshot of Verbose mode right before i lose display.
       
      I would greatly appreciate any help to get back into it or at least help getting it re-installed!!
       
      -Sin

    • By TheAngryYeti
      First, my build:
       
      Asus ROG Strix H370-I mobo
      i5 8400 cpu
      32gb ddr 4 2133
      1tb samsung evo 860 ssd
       
      Ive finally gotten to the point where the installation of HS loads to the language selection screen, but then i lose all usage of every USB port.
       
      Im at a loss of what to do from here.
       
      According to others, i have the proper files in the kexts/other folder as well as the drivers64UEFI folder.
       
      Does anyone have any suggestions as to what i can do? Im getting kinda desperate as ive been at it for a week now and this is as far as ive gotten.
       
      -Sin
       
       
×