Jump to content
Sign in to follow this  
Followers 0
redneck

Dell 5420

8 posts in this topic

Recommended Posts

I restored Yosemite 10.10.3 to my 5420 HD in a USB box with another mac PC. Got it to boot from USB box with Chameleon 2588. no boot with 2578 . Boots only with -F.

after a few uses touch pad quit working. now only USB mouse and keyboard. no WiFi or sound . sound beeped on first start. Any help will be nice. no  HDMI.

need HDMI for my 4K monitor/TV.

 

Share this post


Link to post
Share on other sites
Advertisement

Seems you're using a rather awkward method to install 10.10.3 to your laptop. Why don't you make a fresh vanilla installation instead of, if I understood correctly, cloning the Yosemite build of another PC? That's bound to require some tuning thereafter, at least a serious cache rebuild!

Share this post


Link to post
Share on other sites

Thanks Herve!

would be nice but don't have a bootloader that works. I'm not a smart  Mac guy. Just like to play.  

I got clover to boot once. restore was the easy way for yosemite 10.10.3. 

I had to boot with -s -v to get graphics. after permissions repair it works. -  sound and wifi.

hope to learn more  >74 yr old man.

Share this post


Link to post
Share on other sites

Cloning is never a smart way for hackintosh. I think no one even pro can help you with these problems. Try to make a fresh vanilla installation for your own laptop, remember to read carefully and ask for supports for anything u dont understand.

Good hack!

Share this post


Link to post
Share on other sites

after many crashes and giving up trying many different ways to install on Dell 5420 , I installed Maverick on another mac 2.5 HD, then then installed HD in Laptop dell 5420. I got a blue screen. I used HDMI to connect to my Vizio 50' UHD TV. Works !!!!!  1920x1080. I would like to get Laptop screen working. Retired so this is play time for me. I see no reason to install Sierra.

Any help would be great.   installed with USB Maverick installer.  

Share this post


Link to post
Share on other sites

Ok everything working now after switching to IMac 10.1 smbios. except track pad. HDMI is gone.

Stuck at boot until I used UseKernelCache=no GraphicsEnabler=yes.

 

USB clean install did not work !! Blank screen no HDMI > as an after thought i didn't use the boot flags.

Share this post


Link to post
Share on other sites

A Latitude E5420 should use MacBookPro8,1 or MBP8,2 SMBIOS profile, not an iMac's. MBP8,x are SandyBridge laptops with HD3000, iMac10,1 are C2D based desktops with Nvidia /ATI graphics...

 

For HDMI output, you need to patch the SNB FrameBuffer kexts. All details here. HDMI patching for your HD3000-based E5420 should be the same as for the E6x20 series.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gregow
      So, I'm at my wits end here hoping some clever Mac-wizards can help me find a solution. Apologies for a long post, but let me start at the beginning.
       
      I could not find a suitable forum as this pertains to both install and post-install. Anyhow...
       
      A while ago I decided to make a fresh install of Sierra. I had been running it for quite a while, through several updates, and figured it would be nice to start fresh. 
       
      I've done this many times in the past, with the same installation media, with the same procedure and on the same hardware. 
       
      Got everything installed OK. Did the post-install with Rampagedev's X99.dmg, installed the latest version of Clover. Aaand, I can't boot from the EFI on my SSD. It only works. when booting from the USB-stick. From the SSD I only get to:
       
       
       
       
      After that the computer just hangs or reboots.
       
      I've tried with OsxAptioFixDrv, OsxAptioFix2Drx and OsxAptioFixDrv-free2000. Same thing, except OsxAptioFixDrv actually gives a memmap error.
      Tried updating BIOS to the latest version with no difference. I have also replaced my old GTX 970 with a 1080 Ti.
       
      I tried copying the EFI from the USB-stick to the EFI on the SSD. Same thing - it just won't boot. Except once or twice, running very unstable.
       
      Booting from the USB is no walk in the park either. It fails frequently, though later in the process (at seemingly random stages). Sometimes it fails to load the webdriers, other times it freezes at the login screen. Network connection is sometimes barely usable and Safari is very unresponsive.
       
      Kind of odd for a machine that's been running well for a long time and an installation procedure I've relied upon many times.
       
      Trying to re-install Sierra works equally bad. 
       
      Now I get tons on "Sandbox violation" errors. Even if the installer starts is usually unusable. Like, can't use disk utility or actually start the installation. I just get the spinning wheel.
       
      I've checked the BIOS, disabling CSM and secure boot as well as VT-D. Makes no difference. Reverted back to optimized defaults. Same thing.
       
      Something is clearly messed up, and for the life of me I can't figure out what.
       
      And for the record, I'm running Windows without any issues. Hardware is stress-tested and memory seems to be running fine. 
       
      Do you have any idea what could be causing this? Maybe you have some clever suggestion that I haven't tried yet?
       
      I have the following hardware:
       
      Asus X99-A
      I7 5820K
      Asus STRIX 1080 TI OC
      16 Gb (4ch) Corsair Vengance LPX
    • By garnerlogan65
      I've been trying to figure this out for a few days now, without any success. A couple days ago now, I noticed that my system had rebooted and my Clover entry said that it was trying to boot macOS from a hibernated state, which didn't work. Ultimately however, I got it to boot once I selected "Cancel hibernate wake," but once I did this, the graphics driver would not load, requiring me to reinstall the driver, and having to boot with both NvidiaWeb and nvda_drv=1, it seemed like it was finally back to normal. But it just kept freezing after a while, no matter what, it freezes after I login every time, until I restart it, only for it to do so again. I've tried wiping the drive and reinstalling the OS, along with the GPU driver, but it still freezes every single time after I log in to the system, I have no idea why it is or how to fix it. Other people seem to have no clue either. The fact that it is persisting after a reinstall is concerning.
       
      It was working completely fine before a few days ago. I'm lost. I'm looking for any suggestions as to how I can solve this. Are there any logs I should grab that could shed more light on the situation?
       
      EDIT 1: System seems fine when Nvidia web driver isn't loaded. Removed nvda_drv=1 from clover boot flags, NvidiaWeb variable is not working for some reason. Currently no hardware acceleration. Also fails to load driver with just nvda_drv flag.
       
      EDIT 2: Fixed GPU acceleration by re-running Clover installer, and selecting "Install all RC scripts on target volume." Now to see if it still freezes on me. Using just nvda_drv=1 flag.
       
      Edit 3: Still seems to freeze, just not as quickly. All signs point to an Nvidia web driver issue, but I'm not sure how to fix it.
       
      Edit 4: Have been using it for a significant amount of time without freezing, at this point, I'm assuming the window server has been intermittently dying, if it happens again, I'll attempt to remotely kill it via ssh and see if that fixes it.
       
      Edit 5: Tried restarting WindowServer. System UI is still frozen but ssh access is present. 
       
      Edit 6: Fixed the issue by completely wiping the drive including the EFI partition, and configuring it slightly different, reinstalled everything. Haven't had a single issue since. Last reinstallation attempt was done via recovery partition, re-making the installation USB and using that seemed to have an impact.
    • By artis
      hello, 
      I ran into an issue with my built on an Asus x99 deluxe (last firmware) and a 5930k cpu.
      if I enable only the 6 physical cores (clover bootflag cpus=6 out of 12) the machine runs stable and no issue whatsoever.
      as soon as I turn all the cores I experience random crashes and restart.
      has anyone any suggestions on this topic.
      thank you in advance
       
×