Jump to content
katabathos

HD4000 on 6 series no QE

5 posts in this topic

Recommended Posts

Post

 

Hello there, having a bit of difficulty getting HD4000 graphics to work fully. Current situation:

 

About This Mac reports: Intel HD Graphics 4000 1024 MB

Screen resolution is good - all seems to be working fine.

Sleep / wake appears alright. Sound good. Mouse is not laggy - all seems fairly responsive except accelerated graphics=none.

 

No QE - opaque menu bar etc

No video such as bbc iplayer - black screen. Youtube works but is not being driven by card - uses lots of processor.

 

Asus P8H61-I (6 series sandy bridge desktop)

i3 3225 (7 series ivy desktop)

4gb RAM

 

Yosemite 10.10

Vanilla install following these guides:

 

http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/

http://www.insanelymac.com/forum/topic/280756-guide-the-all-in-one-guide-to-vanilla-os-x-including-chameleon-dsdt-for-beginners-updated-for-yosemite/

 

Chameleon 2.3svn r 2578

 

I’ve tried various combinations of bootflags:

 

GraphicsEnabler=yes / =no

IGPEnabler=yes / no

IntelCapriFB=0 through to IntelCapriFB=11 - kernel panics every so often; nothing better than chameleon’s default.

-f

 

and loads of other things!

 

kextstat reveals intelHD4000 is loading.

 

also tried KemalAlkin’s patched AppleIntelFramebufferCapri.kext and AppleIntelSNBGraphicsFB.kext to see if that helps - no!

https://www.hackintosh.zone/get-files/get/127-intel-hd-3000-hd-4000-driver-for-mavericks-109/

 

no SSDT or DSDT

__________________________________________

 

Any suggestions on how to get HD4000 working properly? I’ve been doing a lot of reading around on this forum, but no luck so far.

 

chameleon plist, kextstat output, and screenshots attached for more detail.

 

cheers

 

 

_________________

Chameleon plist:

<key>Graphics Mode</key>
<string>"1920x1080x32"</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>/System/Library/Kernels/mach_kernel</string>
<key>Kernel Flags</key>
<string>-v</string>
<key>SMBIOS</key>
<string>/Extra/SMBios.plist</string>
<key>Timeout</key>
<string>5</string>
 
________________
SMBIOS
 
Pretending to be mac mini 6,2
 
post-1206958-0-85367800-1424808050_thumb.png
post-1206958-0-79802300-1424808057.png
 

Share this post


Link to post
Share on other sites
Advertisement

Solved: use DSDT for series 7 / HD4000 on series six motherboard. Thanks to microsoftFTW who patched my DSDT for me.

Use DSDT plus injection - e.g. with chameleon, the following worked for me:

 

<key>Graphics Mode</key>
<string>"1920x1080x32"</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>IntelCapriFB</key>
<string>10</string>

 

 

 

Full acceleration - QE and all. Good work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By asdfjklsemicolon
      I have successfully set up my HP Pavilion 15-p051us as a hackintosh with Sierra 10.12.5. I have an AMD A10-5745M APU with Radeon 8610G Graphics. The OS boots and is usable, however there is no graphics acceleration which makes icons in finder and notification bar look strange and launchpad is really slow.  
       
      How can I enable QE/CI acceleration on my APU?
    • By Halcyon220
      Hey guys,
       
      So I made a thread a while ago about my problem with Safari Flickering, etc. A user suggested to enable QE/CI, which sounds like that what I might need to do..the problem is, I don't know what to do or where to start
       
      I have an Intel HD 4000 Graphics, i3 processor..That's the only relevant information, really.
       
       
       
      Original thread: http://www.insanelymac.com/forum/topic/308883-intel-hd-4000-safari-flickering-and-other-graphical-bugs-troubleshooting/
       
      I have no idea how to 'inject' kexts.
       
      I'm a complete noob to this but loving Hackintosh a lot so far. Thanks guys.
    • By ACDindia
      Hey guys!
       
      I have been struggling with this weird issue since last 15-20 days..!
       
      Now I think I have narrowed down the error..
       
      My system:
       
      Dell Inspiron 7720 Laptop
      Intel 3rd Gen Core i7 3630QM
      Intel HM77 7 series chipset
      Intel HD4000 + nVidia GT650M DDR5 2 GB optimus (Never works, I know) 
      Using Clover UEFI Bootloader on UEFI system
      I have a DSDT for my laptop. But have tried with and without it too.
       
      What happens:
      The Intel HD4000 works with QE/QC for a couple of times after fresh install. Then suddenly it stops working, although it is detected as usual. AGPM Capri and HD4000 kexts are loaded still I get no QE/QC... AGPM says "Unknown Platform"... I used a LegacyAGPM.kext to get around with that.   Now when the QE/QC is broken, I reboot the computer and in Clover deselect "GeneratePStates" and "GenerateCStates".... QE/QC is back!!! Again after couple of reboots, it is broken!!! Now again i select "GeneratePStates" and "GenerateCStates", QE/QC starts working for few reboots!   What is my problem??? Please help!! Anyone????
    • By DKMN
      Hi All, 
       
      I've been struggling for a while trying to get any throttling of my Xeon E5-2620 (v1 thus Sandy Bridge). 
       
      Using Asus P9X79WS, 10.9.2 (13C64, the release version), and RampageDev's clean SSDT-based installation with updated FakeSMC. 
       
      Using PikeRAlpha's ssdtPRgen script (newest revisions), with various settings. Pike kindly added the v1 definitions for me, but I'd been hand-jamming them before. Tried without and with explicitly forcing SB cpu (-c 0) and xcpm (-w). 

      Nothing I do budges the speed from 20x. Nothing lower unless I use NullCPU (then it naturally throttles between 12x and 20x). No turbo no matter what I do (yes, I specified -turbo 2500 with ssdtPRgen). 
      1. Has anyone got this chip (or very similar) to work? Esp. with the new PM methodology in Mavericks? 
       
      2. Any general hints in troubleshooting? I've re-done the installation and script gen fairly carefully, but I can't help but feel I'm missing something. Perhaps SB has just fallen into a gap in support and everyone is working only on the IB models as they're more focused on enthusiast home use (I do understand why, just that my use case is different and I bought back when V1 was out). 

      Thanks much for any tips!
      David
       
      PS. Here is my SSDT-1 as of today: SSDT-1 as of 20140315
    • By kdogsky
      Hello Community! I currently have a Zotac 550 Ti installed on a ASRock Extreme4 P67. I have been unable to get graphics acceleration with the following: changing id in NVDAGF100Hal.kext, adding DSDT for motherboard, adding Geoforce.kext, patching GeForceGLDriver.bundle, and using ##### Femni Patches. None of these have worked at all and create no difference. In OSX I cant change the resolution too.
       
      Is their any other method I can use to fix these problems?
×