Jump to content

Clover Change Explanations

157 posts in this topic

Recommended Posts


Rev 3208 by Apianti

Fix enable secure boot, should work now.

Rev 3210-3214

Implemented Proportional font width.

It must be set in every theme.plist

	<string>Main metallic looking theme</string>

It will be better if CharWidth will be even value to avoid dirty.

The best if CharWidth = FontWidth - 2



Fixed width

Screen Shot 2015-05-29 at 10.06.49.png


Screen Shot 2015-05-29 at 14.47.28.png


Share this post

Link to post
Share on other sites

Rev 3222

load specific ROM for nvidia cards, ©ErmaC


Implemented a possibility to load ROM with name specific to subvendor_id

It allows to keep a database of different ROMs in one place.

For example



Rev 3222 - 3224.

Implemented NvidiaGeneric names. Idea by ErmaC.


If this true then generic name for Videocard will be used. For example instead of

Gigabyte Geforce 7300LE 

I see

NVIDIA Geforce 7300LE



Rev 3224

Implemented NvidiaSingle

If you have two cards Nvidia and wants to inject only first one :rofl:   then you can set this parameter.


Share this post

Link to post
Share on other sites

Rev 3250


New runtime variables needed for El Capitan and Yosemite.


Bit definitions are follow

For CsrActiveConfig

/* Rootless configuration flags */
#define CSR_ALLOW_UNTRUSTED_KEXTS     (1 << 0)
#define CSR_ALLOW_UNRESTRICTED_FS     (1 << 1)
#define CSR_ALLOW_TASK_FOR_PID        (1 << 2)
#define CSR_ALLOW_KERNEL_DEBUGGER     (1 << 3)
#define CSR_ALLOW_APPLE_INTERNAL      (1 << 4)
#define CSR_ALLOW_DESTRUCTIVE_DTRACE	(1 << 5) /* name deprecated */

                          CSR_ALLOW_UNRESTRICTED_FS | \
                          CSR_ALLOW_TASK_FOR_PID | \
                          CSR_ALLOW_KERNEL_DEBUGGER | \
                          CSR_ALLOW_APPLE_INTERNAL | \
                          CSR_ALLOW_UNRESTRICTED_DTRACE | \

For example bit 0 (value 0x01) allows to use unsigned kexts from /Library/Extensions folder.


For BooterConfig there are flags

/* Bitfields for boot_args->flags */
#define kBootArgsFlagRebootOnPanic    (1 << 0)
#define kBootArgsFlagHiDPI            (1 << 1)
#define kBootArgsFlagBlack            (1 << 2)
#define kBootArgsFlagCSRActiveConfig	(1 << 3)
#define kBootArgsFlagCSRPendingConfig	(1 << 4)
#define kBootArgsFlagCSRBoot          (1 << 5)
#define kBootArgsFlagBlackBg          (1 << 6)
#define kBootArgsFlagLoginUI          (1 << 7)

This flags is analyzed by boot.efi not by kernel and present in boot_args that read by kernel.

Yosemite kernel has follow usage of this flag

csr_get_active_config(csr_config_t *config)
	boot_args *args = (boot_args *)PE_state.bootArgs;
	if (args->flags & kBootArgsFlagCSRActiveConfig) {
		*config = args->csrActiveConfig & CSR_VALID_FLAGS;
	} else {
		/* XXX: change to 0 when <rdar://problem/16239698> is in the build */

	return 0;

Setting the bit 0x20 is equivalent to kernel flag "rootless=0" (Yosemite kernel)

	boot_args *args = (boot_args *)PE_state.bootArgs;
	if (args->flags & kBootArgsFlagCSRBoot) {
		/* special booter; allow everything */
		csr_allow_all = 1;

	int rootless_boot_arg;
	if (PE_parse_boot_argn("rootless", &rootless_boot_arg, sizeof(rootless_boot_arg))) {
		/* XXX: set csr_allow_all to boot arg value for now
		 * (to be removed by <rdar://problem/16239861>) */
		csr_allow_all = !rootless_boot_arg;
		/* if rootless=1, do not allow everything when CSR_ALLOW_APPLE_INTERNAL is set */
		csr_allow_internal &= !rootless_boot_arg;

There is still the question what is changed in El Capitan as we have no the sources.

Share this post

Link to post
Share on other sites

Rev 3262

I wish to propose new way to inject device properties.

For backward compatibility old way is still working.


New way advanced user will be able to make different injection for two graphics cards even if they are similar. It is not possible for rev

As well there is a possibility to inject properties for non-standard device (TVTuner?).


Detailed instructions will be in Clover Instructions thread ASAP.

Screen Shot 2015-08-24 at 15.42.14.png

Share this post

Link to post
Share on other sites

Rev 3264

Compatibility with new EDK2 18475 (and more?).

New compiled legacy boot tested on G41M-ES2H motherboard.


Rev 3265

Add slot name into System Profiler for HDMI device on AMD or Nvidia videocards to avoid PCI device error...

Share this post

Link to post
Share on other sites

Rev 3266

A task: Mavericks and ElCapitan use different framebuffers so ATIConnectorData must be different.

As well FakeCPUID needed for Mavericks is not needed for ElCapitan.

Users must have an ability to load different config.plist for different systems.

Moreover I may propose different configs for similar systems on different volumes.

Or just two entries with different configs without manual switch settings.

That is.

Now we can write name of config into Custom Entry (without .plist extensions!). Tested on Lion computer.

Screen Shot 2015-09-16 at 14.38.50.png

a line Settings=special mean a file special.plist which is the same as config.plist but with other values.

GUI looks like this


First entry has SubEntries with a possibility to return to common setting from common config.plist.



Choosing common or special setting I can boot same system with two different settings.

In my demo this is different VideoCard names. NvidiaGeneric=true/false


In this demo I used file special.plist.

It may be ElCapitan.plist or config-666.plist or any other to your taste.


One note, this plist should not contain sections Boot and GUI.

Share this post

Link to post
Share on other sites

Rev 3269.


I have to make one backward incompatibility with previous versions.

If you had KernelAndKextPatches section inside Custom entries then now you you follow instructions for rev 3266 and move these patches to separate config.

Else it will not work and you will have only common patches.


So KernelAndKextPatches section is in config.plist as main section and not in subsection.


It is needed as I debugged a crash in it.

PS. It also means nobody used it before ;)

Share this post

Link to post
Share on other sites

By default, when Clover scans your partitions for loaders, each volume found is checked for Linux installations. This check takes a short time, but becomes more noticeable with the more volumes you have. And using a theme with larger icons, for example BGM256, takes even longer.


Commit #3325 adds the option for you to disable the scan for Linux installations if you know you don’t have any.


To disable the scan, you can now add Linux=false to the GUI->Scan section of your config.plist.

Legacy booting now loads the GUI 2 seconds faster for me.

Share this post

Link to post
Share on other sites

Up to revision 3306 there was internationalizations.


Rev 3309

Workaround for core count calculations.


Rev 3314

Added file boot1f32 to ISO. It was not here before!


Rev 3319

As I successfully created Clang-3.8 from llvm sources I made changes to have a possibility to compile Clover by this new compiler.

Also synchronisation with recent EDK2.


Rev 3321

Add an item into Clover menu for instant set *-platform-id  which used as ig-platform-id or snb-platform-id.


Rev 3325

Speedup boot by disabling linux scan


Rev 3326

implement Function Disable


For those who knows what is it. RCBA 3418.


Rev 3327

check disabled patches, by cecekpawon

If you have many patches in config.plist then you can Enable/Disable then by one click


Rev 3328

Same for DSDT patches


Rev 3329

add switch for string injection by cecekpawon


It is added in Clover menu for easy on/off


Rev 3330

Don't dump useless OperationRegions


Rev 3333

Added support for other Intel CPU.


Rev 3334-3336

new GetBiosRegions by Rehabman


This resolves some bugs with FixRegion DSDT patch.


Rev 3338

Compatibility with recent EDK2, because of changes in Autogen.py build tool.


Rev 3348

OsxAptioFixDrv: Align the stack to a 16-byte rather than a 8-byte boundary

patch by Download-Fritz

Assuming resolved some bugs.


Rev 3350

Turbo can be disabled


It can be useful for mobile computers at hot weather.



Rev 3356

Introduce calculation for ARTFrequency used in ElCapitan and present on Skylake computers.


Rev ...-3358

I found many bugs with core count calculation and only in this revision I corrected a reason for this.

It is very old bug, at least 4 years, introduced I didn't remember where and whom.

CPUID_4 can't be used for core count calculations.


Rev 3359-3362

Resolve a  SMBIOS patching bug when OEM reused same strings.


Rev 3363

I have Clover sources on volume MacHD while work in volume ElCapitan.

This patch permit me to compile Clover from other volume.


Rev 3365-3368

Introduce new SMBIOS table type 133 to inject "platform-feature" property into registry. Used by ElCapitan.


This is integer value that should be same as in real Macs.


Rev 3369

Compatibility with Xeon E5 v4

Rev 3372

Don't create empty _DSM method if NoDefault properties set.

patch by cecekpawon


Rev 3374

A possibility to not inject ARTFrequency introduced by rev 3356 if calculated value is not good somehow


Share this post

Link to post
Share on other sites

Rev 3471


After an investigation of va_args, here's what I found


  • The difference between __builtin_va_args and __builtin_ms_va_args is that __builtin_va_args passes va_list by reference (i.e. pointer) from caller to callee when va_list is used as a function parameter.  __builtin_ms_va_args passes va_list by value (which is similar to making an implicit va_copy before passing it.)
  • The C standard allows passing va_list by either value or reference.
  • When va_list is passed by reference, calls to va_arg inside the callee change the caller's va_list.
  • The reason __builtin_va_args was failing with clang builds is due to an error in DevicePathToText.c which passes va_list twice as a parameter without va_copy.
  • I corrected this error, along with other errors in use of va_list I found.
  • As a result, it is now possible to use __builtin_va_args with clang.
  • There is a 2nd issue, which is that __builtin_ms_va_args is intended to allow ms_abi functions to pass their va_list as a parameter when calling sysv_abi functions.  This is not an issue with clang, because clang build uses ms_abi on all functions.  In gcc build, functions declared as EFIAPI are ms_abi - all others are sysv_abi.  So in gcc build, it is necessary to use __builtin_ms_va_args.
  • I set things up so clang build uses __builtin_ms_va_args for Windows64 builds on newer versions known to support these keywords.  On all other clang builds, __builtin_va_args is used.

It is now possible to build Clover with -xcode5 using versions of Xcode prior to 7.3 - as long as DevicePathToText.c is patched from Patches_for_EDK2.


Additionally, the problem of GetEfiBootDeviceFromNvram hanging was fixed in rev 3466.  In rev 3470 I added some validation checks to prevent hanging if invalid device paths are stored in nvram.

Share this post

Link to post
Share on other sites

Rev 3474 by cecekpawon

Print information line about building Clover options.


Rev 3476 

C1E fix for AMD CPU. Noted by Bronya, implemented in OpenSolaris.


Several next commits devoted to good compilation with XCODE5 toolchain.


Rev 3487 and 3514

Support for DDR4 by Joe van Tunen


Rev 3499 and 3518

Fill SMBIOS tables entries with data from MacPro3,1 if not defined by user in the case the model is not known for Clover.


Rev 3505

Link Time Optimization can be disabled for xcode5 toolset by a compile-time flag  --no-lto.

It can be needed for older Xcode versions older then 7.3.

It doesn't affect gcc compilation.

Rev 3519 by cecekpawon


Share this post

Link to post
Share on other sites

*** Rev 3327


Added example








Rev 3372

Originally NoDefaultProperties is to create (which still unknown purposes until now) an empty _DSM on each device injected from Clover. From now, we remove em all & switch this function to "SKIP injecting some default extra/additional properties" by Clover. For example, if user have NoDefaultProperties to TRUE & inject NVIDIA to TRUE, then Clover will SKIP inserting extra "connector-type" into registry. However, you still able to do this by hand with "AddProperties" entries like below:








Rev 3399

BootDisplay: To fix ugly 2nd stage boot or even black screen before login screen, we add new "BootDisplay" (a shorthand for "@x,AAPL,boot-display") property into config (value range: 0 - [totalports-1]). For years people did this job via D/SSDT / EFI Strings injections (Apple style), but no more. Before, Clover only set this properties to port 0 by default, which may lead problem if your currently active port (connected to display) other than port 0.

VideoPorts: We have now full (NVIDIA, ATI to follow) functionality to parse & set its properties dynamically from amount of display ports by user defined.

Able to inject Intel/Integrated-GPU even its not set to primary in BIOS by using blank FB (find more here).








Rev 3456

Introduced on 2012 (but seems improperly documented) to set multiple cards fixed properties. Adjust some keys + add more values like: "LoadVBios" & "VideoPorts" for each card (NVIDIA, ATI to follow).




      <string>Quadro FX 380</string>
      <string>YOUR_SECOND_CARD_SUB_ID(if necessary)</string>
      <string>ATI Radeon HD6670</string>




Rev 3490

More adjustment to batch script (wrote by @apianti, please follow this WIKI for min requirements) to compile Clover under Windows. Tested with VS2012, VS2013 & VS2015 with some additional features:




 /--------------------- [ WINDOWS BATCH SCRIPT FOR BUILDING ] ---------------------\

          .d8888b.  888      .d88888b.  888     888 8888888888 8888888b.
         d88P  Y88b 888     d88P   Y88b 888     888 888        888   Y88b
         888    Y88 888     888     888 888     888 888        888    888
         888        888     888     888 Y88b   d88P 8888888    888   d88P
         888        888     888     888  Y88b d88P  8888888    8888888P
         888    d88 888     888     888   Y88o88P   888        888 T88b
         Y88b   88P 888     Y88b. .d88P    Y888P    888        888  T88b
          Y888888P  88888888 Y8888888P      Y8P     8888888888 888   T88ba

 \------------------------------ [ Under rev: 3525 ] ------------------------------/

--usage : print this message and exit
--version : print build version and exit
-h, --help : print build help and exit

-n, --threadnumber <THREADNUMBER> : build with multi-threaded [default CPUs + 1]
-t, --tagname <TOOLCHAIN> : force to use a specific toolchain
-a, --arch <TARGETARCH> : overrides target.txt's TARGET_ARCH definition
-p, --platform <PLATFORMFILE> : build the platform specified by the DSC argument
-d, --define=<MACRO>, ex: -D ENABLE_SECURE_BOOT
-b, --buildtarget <BUILDTARGET> : using the BUILDTARGET to build the platform, or:
                        --debug : set DEBUG buildtarget
                      --release : set RELEASE buildtarget

--vbios-patch-cloverefi : activate vbios patch in CloverEFI
--only-sata0 : activate only SATA0 patch
--std-ebda : ebda offset dont shift to 0x88000
--genpage : dynamically generate page table under ebda
--no-usb : disable USB support
--mc : build in 64-bit [boot7] using BiosBlockIO (compatible with MCP chipset)

--cygwin : set CYGWIN dir (def: c:\cygwin)
--nasmprefix : set NASM bin dir (def: c:\cygwin\bin)
--pythonhome : set PYTHON dir (def: c:\Python27)
--pythonfreezer : set PYTHON Freeze dir (def: c:\Python27\Scripts)
--nobootsector : skip create Bootsector (need Cygwin)
--updtools : udate basetools binaries from repo
--updedk : update EDK source from repo
--updclover : update CLOVER source from repo
--edk2setup : using Edk2Setup.bat instead of edksetup.bat
--edk2rebuild : soft compile basetools binaries
--edk2forcerebuild : hard compile basetools binaries
--edk2reconfig : recover target.txt, tools_def.txt and build_rule.txt from template




Rev 3519

Dynamically to en/disable SSDTs (under ACPI\patched folder) injections via GUI menu (under "Tables dropping ->") / config.plist







Share this post

Link to post
Share on other sites

Rev 3536


Added F1 - Help text in the bottom left corner of GUI. Adjust within theme.plist


Added "System Variables" GUI sub menu. Contain: "BooterConfig" & "CsrActiveConfig".
Set "ExposeSysVariables" to TRUE in Config:SystemParameters to expose more. Current: "MLB", "ROM", "CustomUUID" & "InjectSystemID".


Share this post

Link to post
Share on other sites

Rev 3537


Do you like proportional fonts? Depends on...

Vertical menu looks better with constant width fonts.

Other text with proportional.

So I made questionable change that options menu will switch font to constant width with char width set in Theme.plist.

While Help, About and Boot information will be proportional or no depends on Theme.plist. In this case char width doesn't matter.


Share this post

Link to post
Share on other sites

Rev 3549


A task: I wanted to create USB stick with Windows UEFI installation. It is proposed to use on legacy PC BIOS-based so the stick is bootable by Clover.

So I took usual stick 4Gb OEM formatted to FAT32 one partition and install Clover 3543 on it. Full success! The stick is bootable and can start OSX on HDD.

There is a big problem to copy Windows distribution on it because it contains a folder BOOT/ while the stick contains file BOOT which is Clover itself. They can't live together.


The solution is to rename BOOT -> BOOT5 and replace boot sector boot1f32 by the new one boot1f5 which is the same but booting BOOT5 by default.

Installation instructions are old


Suppose your USB stick is disk3


sudo -s

dd if=/dev/rdisk3s1 count=1 bs=512 of=/tmp/origbs

cp boot1f5 /tmp/newbs
dd if=/tmp/origbs of=/tmp/newbs skip=3 seek=3 bs=1 count=87 conv=notrunc
dd of=/dev/rdisk3s1 count=1 bs=512 if=/tmp/newbs

Share this post

Link to post
Share on other sites

Rev 3561 - first Sierra compatible revision


Rev 3577

Legacy boot improvements.


Legacy boot is a process to boot OSes through 16bit instructions in real mode like it did old PC BIOS-based computer before Clover, before UEFI.

It was needed to boot Windows XP or Windows 7-32bit, old Linux or modern systems if the drive formatted to MBR Partition Table.

But Clover is already 32/64bit program working in EFI environment in protected mode. It can't get back to real mode. To do this we made a trick with loading PBR boot sector and start it in real mode.

It's a pity it is not always work because devices like SATA controller occur in undefined state. :(


There was three methods for Legacy boot before "LegacyBiosDefault", "PBRtest", "PBR" set by config.plist


"LegacyBiosDefault" assumed UEFI BIOS with CSM module capable to do LegacyBoot.

"PBR" is the most commonly used method for legacy Clover. I have one computer with PATA drive working with this method.

"PBRtest" is somehow different. May be someone will be happy with it.


Now I propose one more method "PBRsata". It is the same as "PBR" but making a SATA reset before boot. AFAIK the SATA controller is a main reason why legacy boot is not working.

Hope someone will be happy.


PS. The version is released.

Share this post

Link to post
Share on other sites

Rev 3580
make kext patches to be OS dependent, by Micky1979


Author's post  #880 

and further discussions.



Rev 3586

Bootcamp style for Clover menu

implemented by Needy

initial post   #485  

Rev 3600

Theme list scroll support


screenshot4.png screenshot5.png




Share this post

Link to post
Share on other sites

Rev 3603

Delayed preboot.log.


Before if we press F2 we immediately save preboot.log. It occured before many patches applied.

Since 3603 press F2 just remember that the log will be saved and this will occur at the OS started. Much more lines will be visible. Some lines we never saw starting Windows as full boot.log is not accessible in this operating system.


How it looks now

5:229  0:010  GUI ready
6:242  1:013  UpdateScroll on 0
9:525  3:282  ParseBootOption: invalid boot variable
9:525  0:000  BootOption of the entry is empty
9:525  0:000  StartLoader() start
9:525  0:000  Finally: Bus=200832kHz CPU=2400MHz
9:525  0:000  Loading bootmgfw.efi  status=Success
9:751  0:225  Closing events for Windows
9:751  0:000  OtherOS: Found Acpi 2.0 RSDP 0xCFB13000
9:751  0:000  RSDT at CFEE3040
9:751  0:000  XSDT at 0
9:751  0:000  FADT pointer = CFEE30C0
9:751  0:000  Removed efi-boot-device-data variable: Success
9:751  0:000  Closing log

Share this post

Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dgsga
      Can I propose a new subforum be created for the new OpenCorePkg OpenCore front end being created by vit9696 and others, it is a fantastic piece of work:
      Even at version 0.1 it runs my Mojave 10.14.4 setup very nearly flawlessly. It consists of a 10KB bootstrap BootX64.efi and a 200KB OpenCore.efi OS loader. All configuration is done using a very well documented config.plist 
    • By kingoffright
      Dear all,
      I have a external harddisk about 500GB, I installed the clover into it and the harddisk is GPT format, below is the 3 partitions details:
      FS01: EFI - disk0s1 - fat32
      FS02: install mac  image - disk0s2 -  hfs+
      FS03: install windows 10 - disk0s3 - fat32
      I can use this external harddisk to install Mac without issue, I use below steps to install windows 10
      enter the FS03:
      cd to efi/boot/ and excuete bootx64.efi
      after pop up the windows install screen, i click next and it shows error 'A media driver your computer needs is missing...' and the installation can not go any further.
      Firstly I use ultraiso to write the windows 10 image to a flash disk and no issue to start install window 10 so the image is working fine. Since I dont know how to write
      a wiindow installation image into harddisk partition, I used winrar extra all the files into disk0s3, am I missing some steps or actually clover not support to install windows
      by partitions, apprecating any helps.
    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15.1
      This post will no longer updated, go for the osxlatitude link for further updates
      Original and updated link:
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      On Catalina the System folder is read-only, so you need to remount in rw to modify System/Library. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      2019.11.03: Enabled SIP caused a lots of issues so now it's disabled -> updated bootpack
      2019.11.02: Updated to 10.15.1 -> no problem when/after installing
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By Cwtf
      I just made a clean install of High Sierra on a 1TB crucial ssd. Installed clover Clover_v2.5k_r5070 into the EFI of this ssd, but when I tried to make it my default boot drive, the clover screen wouldn't come up, and left a black screen.
      I tried using the Olarilia usb drive and clover did the same thing.  The only way I can currently boot is to use my old drive with clover v2.4k_4945 then select  my new drive from the clover menu.   
      Do I need to install v2.4k on my new drive or is there a way I can get v2.5k working?
      I have a GA-x79-ud5 motherboard, AMD  rx580 graphics card and use a Sony 4k tv as my monitor.
    • By kylon
      Cloud Clover Editor is an open source application that allows you to manage the configuration of various Hackintosh Bootloaders.

      Open Cloud Clover Editor
      Cloud Clover Editor Wiki
      Cloud Clover Editor Sources
      Supports Clover EFI, Ozmosis, Chameleon, OpenCore GUI and Text Editor Mode CCE Bank Mobile friendly and more...  
      Officially supported browsers
      Chrome 42+ Microsoft Edge 14+ Firefox 39+ Safari 10+ Opera 29+ Opera Mobile 12+ Chrome for Android 75+ Firefox for Android 67+  
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor  (Discontinued) crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support  
      Please let me know if i forgot you!