Jump to content
Sign in to follow this  
Followers 0
imarios

HP G7000 laptop, fan not working properly

1 post in this topic

Recommended Posts

I have an HP G7000 laptop running Lion 10.7.5 .

My fan is not working properly. It's in stand-by until the laptop gets really hot, then it start very loud for about 30-40 seconds or less. When I start the laptop, in Bios settings, it works smooth. At the Apple boot logo it stops.

 

I had deleted the NullCPUPowerManagement kext.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By pepitillo
      Hello there, don't know if this is the right place to ask this, but has anyone managed to get fan readings in GT 710 with GPUSensors??
       
      I got the 2Gb version, and I had to trick with source code of HWSensors to be recognized (The model is actually GT 710B as listed by PCI id)
       
      At the time of writing I can get memory and core frequencies , gpu core voltage and temperature. It would be awesome to read and control fan, because it is stuck on 33% speed (afraid of playing games haha).
       
      Maybe it is something related with pci id recognition in GPIO.
       
      Thanks in advance.
    • By FALLOFMAN
      So I bought a corsair af120, I plugged it in, started windows 10, things were working fine, I realized I have to exchange this fan so I unplugged it, tried to boot sierra but on the apple logo screen and load bar ,it gets halfway until it powers off (not restarts) my pc. I booted in verbose mode and took photos. (sierra was loading fine before this)
       
      Also another problem I have is, sierra wont boot (just stays hung on the apple logo) unless I hit space in clover and chose (load with selected kexts) screenshot for that as well
       
      http://imgur.com/a/hBGsz
       
      http://imgur.com/a/hBGsz
       
      http://imgur.com/a/CIwBS
       
      System specs
      motherboard: asus p8z 77v lx
      cpu: i5 3570k
      ram: corsair vengeance 8gigs
      gpu: nvidia gtx 1060 (although im using intel onboard graphics for sierra)
    • By haidongdo94
      Hi. I'm new to the forum so if there is anything wrong with my post, please let me know.
       
      So, I'm using Asus N56VZ with Yosemite. After patching my DSDT for wifi and brightness issue, my fan goes crazy, and run fast and noisy all the time.
       
      My DSDT.aml is attached. Please help.
       
      Thank you. 
       
       
      DSDT.aml.zip
    • By twarh
      Hi all.
      I just got into the Hackintosh scene a couple of weeks ago, and got 2 Hackintosh builds up and running from doing a lot of reading on tonymacx86, Reddit/r/Hackintosh,OSXLatitude, InsanelyMac…
      I got a Desktop configured, which was relatively easy compared to getting OSX running on my ThinkPad E320.

      What’s working so far

      I got almost every little frigging thing working on the ThinkPad E320 (minus the Wifi, which is a very typical Laptop woe I’ve found. I’ve resorted to a nano USB wifi adapter while a Broadcom chip ships).
       
      CPU GPU Webcam Intel HDA Keyboard/Trackpad Ethernet USB Wi Fi Bluetooth Internal Display, HDMI out, VGA out
      So what’s wrong?

      The only problem is that the laptop overheats. 
      I do not know what exactly is wrong, but I think the fans are simply not spinning fast enough. I used to run Linux and Windows on this very laptop before, and the fans would spin up significantly every time the processor load would increase.
      After I Hackintoshed it, the fans can barely be heard even when the CPU temp goes up to 80-90 degrees celsius! And even though my CPU is detected (with 25 P-States) the battery life is really really bad. I get roughly 2 hours on a full 100% charge on a 6 Cell Battery.
      I tried patching my DSDT and a little bit, but mostly it’s the same from another DSDT I found for my motherboard and model - its the Intel HM65 Chipset. The DSDT worked well, and I had to make a slight tweak for getting the Intel HDA. I used Piker-Alpha’s ssdtgen script to create the SSDTs for my machine and everything boots up and gets detected like I said.


      What I’ve tried so far / more information for diagnosis

      1. Underclocking with SSDT/DSDT - Fail

      I’ve tried solving the overheating/battery life issues by forcing an under clock. I entered lower values into Piker’s script to do this (the script generates SSDTs without any errors when I put in lower Base Frequency and Turbo Frequency and TDP values) but the SSDTs cause the infamous error-
      P-Step Stepper Error 18 at step 35 Error. I think the newer SSDTS should work, but I think my DSDT is referencing the old SSDT with 25 P-States or something like that, and that’s causing the P-Step error on boot (this is just my hypothesis, I’m entirely unsure). I have included my working DSDT and SSDT in the post here so the community can have a look and help patch these files to underclock my processor to 1.8 Ghz with 2.2 Turbo (think that would be easier on the overheating/battery drain).

      2. Underclocking with Clover - Fail again

      My second approach to under clock was to edit the CloverCPU configuration portion. I entered lower Frequency and Bus Speed and 0x00FA Latency values (according to Clover Wiki that Latency is best for Notebooks). But I saw no difference, and this experimentation failed as well.


      Some other weird things

      Looking at HWSensors app and Intel Power Gadget I can see the CPU stepping working (variation in the frequency curve) but I definitely don’t see 25 steppings (as the chart’s jumps are not that granular) which Piker’s script outputs for my current (working, stock clocked, linked in post) SSDTs. DPCI Manager shows around 6 P-States in fact. 

      AppleIntelCPUPowerManangementInfo.kext by Rehabmanshows around 25 P-States, but then again the kext only outputs those messages during boot. Could it be that during boot 25 P-States are detected initially and as the kernel loads it’s lost for some conflict? 

      HWSensors also does not have a Fan control portion either (are my fans not being detected at all?). So I can’t manually control my Fans either.
       
      Please help. I would ideally like my CPU under clocked and my fans working properly. This is the only step left for my beloved HackBook. Could the USB wifi adapter be screwing things up? The laptop goes into sleep, deep sleep and wakes up fine. I spent a lot of time getting it to this far, just need help with the power management/fan control portion, so please help if possible.

      I’m attaching some files so that maybe you guys could take a look and help diagnose the issue -
      [1] My Clover Config 
      [2] DSDT/SSDT 
      [3] IOReg 
      [4] AppleIntelCPUPowerManagementInfo.kext output (I installed the kext and it only shows the output in the boot log :/ ) 
      [5] KextStat dump

      Laptop Detailed Specs
      LENOVO ThinkPad Edge E320 
      Model - 1298CTO 
      Mobo - Intel Express HM65 Chipset 
      CPU - Core i5 2520M (Sandy) (2.5 Ghz to 3.2 Turbo) 
      GPU - Intel HD 3000 (650 Mhz can go upto 1.3 Ghz [not sure]) 
      RAM - 2x 4 GB Corsair SO-DIMM 1333MHz 
      Storage - SanDisk 128GB SSD
      Any help at all will be greatly appreciated.

      Thank you.
    • By soumaxetuirk
      Hello,I am trying to Fix my DSDT so that HWMoniter can read my FAN Speed of laptop (HP_DV6_6164tx).And trying to control the fan speed as its always staying in lowest speed no matter what the temperature is.
      This is my thermal zone from DSDT.
      Scope (_TZ) { ThermalZone (THRM) { Name (REGN, "Processor Thermal Zone") Name (FMAX, 0x15E0) Name (FMIN, 0x07D0) Method (FRSP, 0, NotSerialized) { If (\_SB.PCI0.LPCB.EC.ECOK) { Return (Multiply (\_SB.PCI0.LPCB.EC.FAT, 0xFF)) } Return (FMAX) } Method (FSSP, 1, NotSerialized) { If (\_SB.PCI0.LPCB.EC.ECOK) { Store (And (LNot (Arg0), One), \_SB.PCI0.LPCB.EC.FST) } } Method (_TMP, 0, Serialized) { If (\_SB.PCI0.LPCB.EC.ECOK) { Store (\_SB.PCI0.LPCB.EC.CPT0, Local0) And (HOTW, One, HOTW) If (LEqual (HOTW, Zero)) { If (LGreaterEqual (Local0, \_SB.PCI0.LPCB.EC.HOT)) { Store (One, HOTW) } } Return (Add (Multiply (Local0, 0x0A), 0x0AAC)) } Else { Return (0x0C3C) } } Method (_CRT, 0, Serialized) { Store (\_SB.PCI0.LPCB.EC.CRT, Local0) Return (Add (0x0AAC, Multiply (Local0, 0x0A))) } Method (_HOT, 0, NotSerialized) { Store (\_SB.PCI0.LPCB.EC.HOT, Local0) Return (Add (0x0AAC, Multiply (Local0, 0x0A))) } Method (_SCP, 1, Serialized) { Store (Zero, \_SB.PCI0.LPCB.EC.PAE) } } } I followed some guides from Rehabman,and ended of with this
      Device (SMCD) { Name (_HID, "MONITOR") Method (FAN0, 0, NotSerialized) { Store (^^^LPCB.EC.HOT, Local0) Store (^^^LPCB.EC.CRT, Local1) And (Local0, 0xFFFF, Local0) And (Local1, 0xFFFF, Local1) If (LNotEqual (Local0, Zero)) { If (LEqual (Local0, 0xFFFF)) { Store (Zero, Local0) } Else { Store (0x0100, Local2) Multiply (Local0, Local2, Local3) Add (Local1, Local3, Local4) Divide (0x03938700, Local4, Local5, Local6) Store (Local6, Local0) } } Else { Store (Zero, Local0) } Return (Local0) } } Still nothing... any help would be appreciated . Thank you
×