Jump to content
CatzRuleZWorld

How to install Yosemite (Mac OS X 10.10) on a Pentium G3258 (Or other unsupported CPU)

13 posts in this topic

Recommended Posts

How to install Mac OS X 10.10 Yosemite on an Intel Pentium G3258

(Should work for other OSs and CPUs)

 

 

 

I received a message asking me to make a video on how to install Yosemite on a G3258 but I decided to just make a post about it. Most of the magic is just faking the CPUID with the Clover boot loader.

 

Although I have only tried this method with a G3258 and Yosemite, I don't know of any reason why it wouldn't work to use this for another unsupported processor or another OS like Mountain Lion.

 

For mine I just followed this guide by ###### on his forum site with the small exception of adding the fake CPUID in the config.plist.

 

In step 2:20 I used the standard config.plist to start out with.

 

Here is the section on the Clover wiki with the list of CPUIDs that you can use.

I used the CPUID "0x00010676"; it works for me. If it doesn't work for you, go ahead and find another one that looks like it will from that list.

 

As it shows on the wiki, add the CPUID tag to the "KernelsAndKextPatches" section of the config.plist so it reads something like this

<key>KernelAndKextPatches</key>
<dict>
    <key>FakeCPUID</key>
    <string>0x010676</string>
</dict>

Also make sure to add the -v tag for verbose boot in the boot argument section of the config.plist so you can search for a solution to whatever problems keep you from being able to boot.

 

After the installation is finished and you are installing Clover on the hard drive that you have Yosemite installed to (step 4:6) add the same CPUID you used for the USB drive or just take that whole config.plist and use it for the new installation.

 

This can be confusing to some especially if you've never heard of some of the terms used in hackintoshing but just try to stumble though it because you probably will not be able to learn everything you need to know before you start. Feel free to ask any questions here and myself or one of the other nice people on this forum will probably be able to help you. Also please let me know if I should add or edit anything to this (I really don't know much about hackintoshing).


I just realized the link I posted to the tonymacx86 site might disagree with the forum rules. Can I get a mod to let me know if this is fine? I am not trying to disobey the rules so I will take it down if I need to.
 

Thanks

Edited by Allan
Tonymac Link removed.

Share this post


Link to post
Share on other sites
Advertisement

Did you manage to get the graphics working properly yet? BTW - That CPU id is in the list. It's for a Penryn CPU.

Thanks for catching that, I just edited it...

I got the graphics working one boot but on the next it wasn't working. I haven't messed around with it much more past then.

Share this post


Link to post
Share on other sites

Can you tell me what boot flags and BIOS settings you used??

I recently got this chip and I'm extremely frustrated with trying to get OSX installed.

Thanks!!

Share this post


Link to post
Share on other sites

Hey I made a similar guide but with speedstep working.

http://www.insanelymac.com/forum/topic/303755-how-to-intel-pentium-haswell-works-with-speedstep-yosemite-1010-and-mavericks-109/


To prevent that some moderator delete your topic, you'd advise you remove all references and links of tonymacx86.

Share this post


Link to post
Share on other sites

Greetings! I know this thread is (exactly) a month old, as of this post, but I just want to mention that I have a (so far) fully-working install of OS X 10.10.2 Yosemite with Clover v2.3k R3156 running on a Haswell Pentium G3220 with the following components:

 

  • MSi H81M-E33 Logic Board
  • EVGA NVIDIA GeForce 210 512MB
  • 1TB SATA III HDD
    • 500GB OS X & Windows partitions
  • 4GB DDR3 PC3-10600 1333MHz RAM

 

I followed the "How to Install OS X Yosemite Using Clover" guide first, from *you know who* (Google search the title, first link), and used the FakeCPUID: 0x0306A0, which was found in the very beginning of the guide posted above me. That ID is from an Ivy Bridge Core i5, so it will say this in the System Information.

 

This board, along with the E35 & E35 V2 variants (which I worked with hackintoshing before this model) needed a flashed BIOS, so I download the latest BIOS for the respective logic board model from MSi's website, and flashed it with PMPatch in Windows. Also, any brand GeForce 210 with any amount/type of RAM should have OOB functionality, like the one in this unit.

 

I will try to post more information later on. Might even create my own guide. :)

Share this post


Link to post
Share on other sites

Greetings! I know this thread is (exactly) a month old, as of this post, but I just want to mention that I have a (so far) fully-working install of OS X 10.10.2 Yosemite with Clover v2.3k R3156 running on a Haswell Pentium G3220 with the following components:

 

  • MSi H81M-E33 Logic Board
  • EVGA NVIDIA GeForce 210 512MB
  • 1TB SATA III HDD
    • 500GB OS X & Windows partitions
  • 4GB DDR3 PC3-10600 1333MHz RAM

 

I followed the "How to Install OS X Yosemite Using Clover" guide first, from *you know who* (Google search the title, first link), and used the FakeCPUID: 0x0306A0, which was found in the very beginning of the guide posted above me. That ID is from an Ivy Bridge Core i5, so it will say this in the System Information.

 

This board, along with the E35 & E35 V2 variants (which I worked with hackintoshing before this model) needed a flashed BIOS, so I download the latest BIOS for the respective logic board model from MSi's website, and flashed it with PMPatch in Windows. Also, any brand GeForce 210 with any amount/type of RAM should have OOB functionality, like the one in this unit.

 

I will try to post more information later on. Might even create my own guide. :)

 

Thanks for the update Sawtooth! I've been silently lurking on some of these G3258 posts here and on other sites, readying to do a low cost build with a few new and recycled parts. It's great to see more people with successful builds on Haswell Pentiums using this information! A guide would be excellent. I'll try to do one too one I dive into my build...

Share this post


Link to post
Share on other sites

Greetings! I know this thread is (exactly) a month old, as of this post, but I just want to mention that I have a (so far) fully-working install of OS X 10.10.2 Yosemite with Clover v2.3k R3156 running on a Haswell Pentium G3220 with the following components:

 

  • MSi H81M-E33 Logic Board
  • EVGA NVIDIA GeForce 210 512MB
  • 1TB SATA III HDD
    • 500GB OS X & Windows partitions
  • 4GB DDR3 PC3-10600 1333MHz RAM

 

I followed the "How to Install OS X Yosemite Using Clover" guide first, from *you know who* (Google search the title, first link), and used the FakeCPUID: 0x0306A0, which was found in the very beginning of the guide posted above me. That ID is from an Ivy Bridge Core i5, so it will say this in the System Information.

 

This board, along with the E35 & E35 V2 variants (which I worked with hackintoshing before this model) needed a flashed BIOS, so I download the latest BIOS for the respective logic board model from MSi's website, and flashed it with PMPatch in Windows. Also, any brand GeForce 210 with any amount/type of RAM should have OOB functionality, like the one in this unit.

 

I will try to post more information later on. Might even create my own guide. :)

 

I just got the same board for 40$ on ebay :) I'll try it too.

 

Got it to work just fine, it even boots on the on board graphic card (no HW acceleration)

 

Specs: Intel G3258 4.5GHz 1.27v | MSI H81M-E33 | Crucial Ballistix 8GB | Rosewill Case | EVGA 430 Watt | EVGA 9800 GT | Samsung 830 256GB | Win 7/Mac OSX 10.10.1 | Clover UEFI

 

Added a 9800GT for acceleration. Played 4K videos just fine on Safari (pretty surprised, couldn't do that on windows) Audio and Lan works, Audio was a bit tricky. Using UFEI boot

Share this post


Link to post
Share on other sites

Thanks for the update Sawtooth! I've been silently lurking on some of these G3258 posts here and on other sites, readying to do a low cost build with a few new and recycled parts. It's great to see more people with successful builds on Haswell Pentiums using this information! A guide would be excellent. I'll try to do one too one I dive into my build...

 

yup pick up a G3258 for 49$ at micro center ><!

Share this post


Link to post
Share on other sites

This is really new CPU and board.

CPU model = 0x3D  - Haswell-U5

Host = 0x1604

Graphics card = 0x1606, 1616, 161E - Iris Graphics

 

EDITED: Committed to Clover 3166.

Share this post


Link to post
Share on other sites

Greetings! I know this thread is (exactly) a month old, as of this post, but I just want to mention that I have a (so far) fully-working install of OS X 10.10.2 Yosemite with Clover v2.3k R3156 running on a Haswell Pentium G3220 with the following components:

 

  • MSi H81M-E33 Logic Board
  • EVGA NVIDIA GeForce 210 512MB
  • 1TB SATA III HDD
    • 500GB OS X & Windows partitions
  • 4GB DDR3 PC3-10600 1333MHz RAM

 

I followed the "How to Install OS X Yosemite Using Clover" guide first, from *you know who* (Google search the title, first link), and used the FakeCPUID: 0x0306A0, which was found in the very beginning of the guide posted above me. That ID is from an Ivy Bridge Core i5, so it will say this in the System Information.

 

This board, along with the E35 & E35 V2 variants (which I worked with hackintoshing before this model) needed a flashed BIOS, so I download the latest BIOS for the respective logic board model from MSi's website, and flashed it with PMPatch in Windows. Also, any brand GeForce 210 with any amount/type of RAM should have OOB functionality, like the one in this unit.

 

I will try to post more information later on. Might even create my own guide. :)

 

tons of thanks

 

will try today on my intel g3220 + asrock h81m-dgs rev 2.0 with flashed bios.

 

LE: for me its still a no go. with -v stuck at "missing bluetooth" thing. still searching, still trying.

Share this post


Link to post
Share on other sites

Hey Everyone, 

Just wanted to say thanks for all of the tips and tricks in this thread. Just built my second Hackintosh, and my first ever Clover installation. It was a little bit of a learning curve compared to Chameleon, but everything is running flawlessly.

Intel G3258 
Gigabyte GA-H81M-DS2V
EVGA GeForce GT640 2GB
Corsair Vengeance 8GB (2x4) 1600MHz
Corsair CX430 PSU
Cooler Master N200 Case 

Running Yosemite 10.10.2 with MacMini 6,2 System Definition from the config.plist provided earlier. SpeedStep, Audio, and Graphics all working flawlessly. Very pleased with the results smile_osx.png

Share this post


Link to post
Share on other sites

I just realized the link I posted to the tonymacx86 site might disagree with the forum rules. Can I get a mod to let me know if this is fine? I am not trying to disobey the rules so I will take it down if I need to.

 

Thanks

 

 

Hello @CatzRuleZWorld.

 

I removed the tonymac link ok? We have a lot of guides teaching how to install OS X with Clover.

 

And thanks for the Guide  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×