Jump to content
Andy Vandijck

macosxbootloader (Hackintosh version).

37 posts in this topic

Recommended Posts

I created a hackintosh specific version of the MacOSX bootloader.

I tested it so far under legacy Clover.

 

Project page including more downloads:

https://github.com/andyvand/macosxbootloader

 

Built result hack specific is attached.

Test please, I need feedback as this is a new version.

Might need some more fixing here and there.

 

When testing please note the following in the report:

- Legacy boot / UEFI boot

- 32 / 64 bit Clover use

- Result

 

This one is Yosemite optimized and should work (support for hackintosh in initial stage)

EDIT: New version.

Added strict warning, enable all warnings flag and set warnings as errors flags, fixed some issues, implemented -f support and finally made sure everything was built optimized.

Also reimplemented driver loading (now works optimal and fast).

EDIT2: Added Clover build tools version.

boot.efi.zip

boot.clovertools.efi.zip

Share this post


Link to post
Share on other sites
Advertisement

Sorry Andy copy this file on usr/standalone/i386 folder or...?

I'm on UEFI Clover install.

This goes into /System/Library/CoreServices/boot.efi

First do sudo chflags nouchg /System/Library/CoreServices/boot.efi

Make sure to test on USB stick first...

Share this post


Link to post
Share on other sites

Does not work for me on Yosemite!!! :(

Any report to give?

Share this post


Link to post
Share on other sites

After reboot my PC blocked on boot.

attachicon.gif2014-12-09 17.37.29.jpg

 

Now see where is the problem.

Thanks!!!

Try using legacy Clover boot.

Aptio reloc doesn't work yet (needs fix).

EDIT: Also note - this boot.efi is universal (32 + 64 bit arch).

You can also test 32-bit legacy Clover to boot into 64-bit kernel (works).

Share this post


Link to post
Share on other sites

KP unable to find driver for this platform with Clover legacy for me.

Damn... do you have a patched DSDT in /EFI/CLOVER/ACPI/Patched?

If not, put one there...

Just to check...

Share this post


Link to post
Share on other sites

Extremely fast boot after last update (If I can get the hackintosh specific bug fixed that doesn't enable ACPI platform init).

The new version has -f support (ignore kernel cache).

You might want to try this too...

EDIT: By the way - when I get home I'll add auto installer packages.... (need my dev certificates for signing these).

EDIT2: On the Github page you also find the regular built version (this can be used for real MacPro or so with only EFI32 to run Yosemite) with latest optimizations and strict flags and stuff and code modifications it should work real fast on such a machine...

Share this post


Link to post
Share on other sites

Anyone with an Ozmozis flashed mobo willing to test and report?

Would like to see reports there (as it's kind of weird that is doesn't load ACPI, should work as it does so on real Macs...)

Let me know please :D

Share this post


Link to post
Share on other sites

Hi Andy unfortunately with boot.clovertools.efi get blank boot with uefi n legacy (intel machine)

And Apple version?

I allready noted some time ago that the combined 32+64 bit UEFI files only work when built from MS sources or Apple's..

You could easily rebuild though...

make CLOVERTOOLS=1

for 64 bit or

make CLOVERTOOLS=1 ARCH=i386

for 32 bit.

And don't combine them into and UEFI combined, I noticed it does not work...

Stay tuned currently updating project.

Post more on Github soon.

Share this post


Link to post
Share on other sites

Hi Andy.

 

I send you a PM.

EDIT: you just reply in the meantime.

 


 

I'm going to move this topic in the bootloader section.

EDIT2: topic moved, and a temp link from previous source section as been given.

 

ErmaC

Share this post


Link to post
Share on other sites

BTW: Don't try any VM (VMWare, Virtualbox / Paralles) because don't work yet...

When I get that working: I'll post here ;)


Tested auto-installer,

Work insanely great.

It is integrated for build within main Makefile of Github sources too.

It execututes an universal  build and then packages it.

- make newinstaller (make flat style package).

- make legacy-installer (make Tiger style package.

Greetz

Andy

I added the packages and also the script.

It works great and makes booster (2 scripts and one Makefile ;))

Share this post


Link to post
Share on other sites

Hey Andy, I know I already asked this but this has piqued my curiosity. I know the macpro1,1 requires a 32-bit bootloader but I don't really understand what this is for as far as hackintoshes go. Would I benefit from this on my 2600k build? It still needs another boot loader like clover or chameleon right? Sorry if it's a dumb question...

Share this post


Link to post
Share on other sites

Hi Andy,

 

I have clover install on legacy mode (bios mode)

How can I install your version ?

just copy the "boot.efi" file in "/System/Library/CoreServices/boot.efi" and then reboot using clover ?

 

regards,

Barnum

Share this post


Link to post
Share on other sites

I noticed that you use ARCHCFLAGS -target x86_64-pc-win32-macho for the 64-bit version of boot.efi but there is no target set for the 32-bit variants. What about using i386-pc-win32-macho?

It doesn't work, try it...

I tested and noticed it didn't want to use it.

Share this post


Link to post
Share on other sites

It doesn't work, try it...

I tested and noticed it didn't want to use it.

Oops. That should have read: x86-pc-win32-macho

 

Anyway. I guess that you will still get the backend triplet error. I know that x86-pc-darwin-macho compiles, but that is probably also wrong. You better ask on the EDKII mailing list what to use for 32-bit EFI applications. I would have asked it myself, but I can't (work related limitation). Or file a clang bug report perhaps (since x86_64-pc-win32-macho works)?

Share this post


Link to post
Share on other sites

Oops. That should have read: x86-pc-win32-macho

 

Anyway. I guess that you will still get the backend triplet error. I know that x86-pc-darwin-macho compiles, but that is probably also wrong. You better ask on the EDKII mailing list what to use for 32-bit EFI applications. I would have asked it myself, but I can't (work related limitation). Or file a clang bug report perhaps (since x86_64-pc-win32-macho works)?

Tried all of those...

Found nothing with stock clang for 32 bit win target...

So I implemented it the way it is now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By JamesMaloney
      Salve a tutti,
      ho provato diverse volte ad installare macOS sul mio laptop ma sempre senza successo, non riesco mai ad arrivare nemmeno all'installer!
      Ho tentato ormai diverse configurazioni/driver ma non capisco mai da cosa siano derivanti gli errori o i blocchi che mi trovo davanti e sto quindi cercando aiuto per capire come procedere 
      Nello specifico il config che sto provando ad utilizzare non mi trova per niente la partizione con l'installer, mentre un altro vecchio (presente sempre nella cartella di clover allegata con estensione .orig) si inchioda subito dopo la scelta della partizione di avvio.
      Qualcuno mi sa dare una mano su come superare ciò?
      Grazie in anticipo,
       
      Giacomo
       
       
      P.S. Le mie specifiche sono:
       
      - Modello ASUS N552VW-FI202T
      - Schermo 3840x2160
      - CPU Intel Core i7-6700HQ
      - RAM 16GB ddr4 2400mHz
      - Intel HD Graphics 530 + nVidia 960m 4GB (anche funzionasse solo la Intel sarebbe perfetto)
      - SSD 256GB
      - HDD 1TB
      CLOVER.zip
    • By BuXb
      SleepOnLowBattery (“SOLB”)
      by BugsB, based on a script by Toggi3 * + more code snippets from the www
       
      For those of us whose HackBook (or even real MacBook) doesn't automatically and properly go into power saving mode on very low battery but just powers down coldly, crashing macOS: “SOLB”, a small and RAM/ CPU wise very low footprint AppleScript based utility that checks the battery level every 2 minutes, running via daemon in the background.
       
      You can choose between two versions, either with or without sound. Both display a notification in the top right of your screen.
       
      Between ≤10 and >8% battery charge:

       
      Between ≤8 and >5% battery charge:

       
      On ≤ 5% battery charge you will see a 10 seconds countdown dialog box in 1 second intervals:

       

       
      which you can cancel, or have your your *ac*Book be sent to sleep when down to 0.
       
      The version with sound uses the pleasant macOS US female voice Allison. If the lady is not installed, you can download "her" via System Preferences, Accessibility, Speech (pane tab should get opened by the install script), click onto the two arrows to the right of System Voice, Customize, English (Unites States) -- Female, activate Allison, OK (macOS downloads voices to /System/Library/Speech/Voices - Allison consumes 120 MB).
       
      If you want to see/ see and listen first, disconnect your Mac from its power supply and double click the “run Demo” file in either folder, with or without sound.
       
      The launcher is installed per user, so one user can use the script with and another user the script without sound.
       
      Run your desired install.command, with or without sound. The script should be active right away without restart.
       
      Regarding the sound version, you can also:
      - download any other English voice of your liking and edit the name inside the script at the very top
      - download any language voice and translate the text inside the script
      Edit with Apple Script Editor, save, install, reboot.
       
      Tested working in macOS High Sierra 10.13.6, Mojave 10.14.6 and Catalina 10.15.1.
      Please feedback if this utility also works for you.
       
      If you have ideas, experience bugs, etc., please contribute as precise, succinct, productive and friendly as possible. In case of a bug, always include your version of macOS for me or others to try and help. Thank you.
       
      ENJOY
       
      VERSION HISTORY:
      2019-11-15 v. 1.1
          •    BUG FIX: changed all occurrences of ExternalChargeCapable to ExternalConnected in all Apple Script .scpt files (SleepOnLowBattery.scpt, SleepOnLowBatterySound.scpt, demo.scpt) to restore functionality
          •    IMPROVEMENT: made queries of MaxCapacity and CurrentCapacity more compatible to work with hopefully any system
          •    NEW: added Catalina compatibility to install scripts; verified Mojave compatibility
          •    NEW: Sound script uses voice Allison if installed, otherwise automatically defaults back to another English standard voice (Daniel, Alex or Fred)
       
      2018-11-10 v.1.0
          •    initial version
       
      IDEAS TO IMPLEMENT IN FUTURE RELEASES:
      Have the sound version install script check if Allison is installed, and if not, offer to download and install it. Purely cosmetic: find a way to have the display notification in the top right of the screen not display the Script Editor icon but the one of the utility without turning the utility into an app but by maintaining a script to keep the load footprint low. This is currently neither possible with an Apple Script nor with an Apple Script Bundle file, only with the script compiled into an app. One possibility might be a Perl approach, if someone volunteers. ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      * Thanks to Toggi3 for the base script:
      https://hints.macworld.com/article.php?story=20110219013713667
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      THE CODE (of the version with sound):
      install.command:
       
      LaunchAgent SleepOnLowBatterySound.plist:
       
      Script SleepOnLowBatterySound.scpt:
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
       
      SleepOnLowBattery (SOLB) by BugsB v.1.1 (2019-11-15).zip
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.1
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Current EFI 
      Updated 30/10/2019
      AudioGods Z390 Pro EFI VEGA Navi Radeon VII F11 DSDT.zip - Use with Bios revision F11 Only (30/10/2019 Catalina 10.15.1 Vega, Navi, Radeon VII DSDT Installed) SMBios MacPro1,1
      AudioGods Z390 PRO EFI RX F11 DSDT.zip - Use with Bios revision F11 Only (30/10/2019 Catalina 10.15.1 RX5XX DSDT Installed) SMBios MacPro1,1

      iMac19,1 EFI (can be problematic for some users)

       
      PLEASE NOTE - Please flash your motherboard bios to revision F11 to use my current EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
      Latest Gigabyte Z390 PRO BIOS (F11)
      mb_bios_z390-aorus-pro_f11.zip
       
       
      CFG Unlock (MSR) F11 BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's & Older EFI’s (A big thanks to @MaLd0n for compiling these DSDT's)

       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F11)
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • Boot -> Windows 8/10 Features -> Other OS
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Disabled
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Disabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Enabled
      • Settings -> IO Ports -> USB Configuration ->  XHCI Hand-off -> Enabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
       
      • Save & Exit → Save & Exit Setup 
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       

       

       

       

       
       
       
       
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×