Jump to content
claure

USB 3.0 problema spegnimento.

25 posts in this topic

Recommended Posts

Buongiorno,dopo aver installato il kext per usb3,il pc ci mette circa 30 secondi per spegnersi,ho provato i kext evoreboot e OpenHaltRestar ma non è cambiato niente.Grazie a chi può darmi una mano.

Share this post


Link to post
Share on other sites
Advertisement

Si,lo faccio sempre perché installo i kext con kext wizar.

A me è capitato più volte che Kext Wizard non li riparasse e ho preso l'abitudine di farlo da utility disco. 

Share this post


Link to post
Share on other sites

A me è capitato più volte che Kext Wizard non li riparasse e ho preso l'abitudine di farlo da utility disco. 

 

Riparato i permessi anche da utility disco ma non è cambiato niente.

Share this post


Link to post
Share on other sites

Se il kext è corretto, potrebbe essere una impostazione bios ad essere errata.

Dal bios non penso perché me lo fa solo con questo kest.

 

Per caso usi Yosemite?

Perche se usi quel kext su yosemite non va...

Prova a togliero e vedrai che si risolve il problema

Mentre su maverics va alla grande

Si uso yosemite e quando cancello il kext GenerichUSBXHCI il pc si spegne in pochissimi secondi.

Share this post


Link to post
Share on other sites

Dal bios non penso perché me lo fa solo con questo kest.

 

Si uso yosemite e quando cancello il kext GenerichUSBXHCI il pc si spegne in pochissimi secondi.

Beh se le porte funzionano hai risolto il problema

Share this post


Link to post
Share on other sites

Se cancello quel kext l'usb 3.0 non funziona  :)

Anche a me si spegne lentamente probabilmente per lo stesso motivo, ma sono obbligato ad usare il kext per far funzionare le USB ASMedia, perchè non ci riesco con il DSDT. Forse per te il DSDT potrebbe essere la soluzione. Puoi anche a provare questi flag, da soli o combinati, dovresti fare qualche prova, anche se solitamente servono per eliminare problemi legati al riavvio e altri.

-gux_no_idle  e/o  -gux_defer_usb2   e/o  -gux_no_sleep

Se usi clover li puoi abilitare nella sezione boot. A me serve solo primo per esempio.

Share this post


Link to post
Share on other sites

Quindi tu risolvi il riavvio lento o spegnimento ..mettendo quel flag ?

E usi anche il kext generic?

Veramente intendevo il contrario, nel senso che anche io ho lo spegnimento lento con genericusb, mentre è più veloce con la patch del DSDT, con la quale però non mi funzionano le porte USB3.0 ASMedia, per cui sono costretto ad usare il kext. Il flag mi serve perchè funzioni l'Hot Plug, altrimenti mi riconosce quello che c'è collegato solo se conneso prima dell'avvio. Con Mavericks la dovevo usare assieme a -gux_defer_usb2.

Però mi hai fatto venire in mente che adesso sono passato da Chameleon a Clover e forse potrei riuscire ad abilitare il tutto tramite oppurtune impostazioni nel config.

Si dirmi invece se i flag che ho menzionato sono relativi solo al genericusb?

Share this post


Link to post
Share on other sites

Ho provato quei flag impostandoli direttamente nel config pero non è cambiato niente,per il DSDT dove posso trovare la patch,grazie.

Share this post


Link to post
Share on other sites

Ho provato quei flag impostandoli direttamente nel config pero non è cambiato niente,per il DSDT dove posso trovare la patch,grazie.

Prova a postare il tuo DSDT pulito. C'è un pò da lavorare perchè PJALM non ha più aggiornato le sue patch. Altrimenti Registrati sul sito Pjalm.com e vedi anche tu cosa trovi.

Share this post


Link to post
Share on other sites

Intanto grazie per la disponibilità,il DSDT originale l'ho postato qui             #390             ,perché quello che ho adesso  l'ha corretto  il bon Fabio,vede se riesci a fare qualcosa con calma pero e prendi tutto il tuo tempo,grazie.

Ecco il DSDT con le patch per la H81M. Però prima di provarlo, se non hai un backup avviabile, vedi se riesci a fare il boot con DSDT=Null, in modo che puoi ripristinare quello funzionante. Naturalmente devi contestualmente togliere il genericusb perchè lui avrebbe la precedenza. In ogni caso se non si risolve con questo DSDT, prova ad aggiungere di nuovo il generic e vedi se cambia qualcosa.

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Flicka...quello che ti posso dire....e quel kext per Yosemite non va ancora....

In effetti se lo usi...ti funzionano le Asmedia...ma hai un riavvio lento e altrettanto lo spegnimento...io per il momento sto aspettando sviluppi seri su questo problema...

 

PS: Quelle flag che intendi tu...mai provate...e nel Wiki non li vedo menzionate...mi linki ?

Share this post


Link to post
Share on other sites

Flicka...quello che ti posso dire....e quel kext per Yosemite non va ancora....

In effetti se lo usi...ti funzionano le Asmedia...ma hai un riavvio lento e altrettanto lo spegnimento...io per il momento sto aspettando sviluppi seri su questo problema...

 

PS: Quelle flag che intendi tu...mai provate...e nel Wiki non li vedo menzionate...mi linki ?

Questo è il link alla repo di Zenith:

http://sourceforge.net/projects/genericusbxhci/files/

vedi la release note. Ti allego uno screen di Clover dove le vedi nella sezione arguments.

A me funziona bene, USB Intel 2.0 3.0 e ASMedia 3.0.

Da risolvere eventualmente lo spegnimento un pò lento.

Senza il flag -gux_no_idle i supporti di memoria vengono visti solo se collegati prima dell'accensione. Ma è un problema soprattutto alla mia ASRock

post-342261-0-47159800-1418409496_thumb.png

Share this post


Link to post
Share on other sites

Ma hai problemi di sleep ?

A me lo sleep funziona. Diciamo che alle volte ci mette qualche secondo a ricollegare il bluetooth, ma niente di che.

Share this post


Link to post
Share on other sites

Ecco il DSDT con le patch per la H81M. Però prima di provarlo, se non hai un backup avviabile, vedi se riesci a fare il boot con DSDT=Null, in modo che puoi ripristinare quello funzionante. Naturalmente devi contestualmente togliere il genericusb perchè lui avrebbe la precedenza. In ogni caso se non si risolve con questo DSDT, prova ad aggiungere di nuovo il generic e vedi se cambia qualcosa.

Ciao,ho provato il DSDT ma mi da un kernel panic.

 
307rdx0.jpg
 
 
2n9erm9.jpg

Share this post


Link to post
Share on other sites

 

Ciao,ho provato il DSDT ma mi da un kernel panic.

 
307rdx0.jpg
 
 
2n9erm9.jpg
Qui ci vuole qualcuno più avezzo di me su questi errori. In tutti i casi il DSDT non va.

Share this post


Link to post
Share on other sites

Va bene,grazie per la tua disponibilità,rimetto il vecchio DSDT con il kext genericusb in attesa di nuovi sviluppi,buona serata.

Buona serata anche a te.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×