Jump to content
Jona

[AJUDA PF] XPS 15 L502X, Early 2011

43 posts in this topic

Recommended Posts

Advertisement
19 hours ago, artur_pt said:

olá

 

posta teu hardware detalhado para tentarmos ajudar

 

o hd tem de estar em modo sata (ahci)

 

bom hack

Quote

 

ProcessorIntel Core i5-2410M


Graphics adapter

NVIDIA GeForce GT 540M - 2048 MB, Core: 672 MHz, Memory: 900 MHz, shader rate: 1344 MHz, DDR3-VRAM, ForceWare 265.94


Memory 8 GB


Display15.6 inch 16:9, 1920 x 1080 pixel, AUO17ED (B156HW01), B+RG LED True-Life, glossy: yes


Mainboard

Intel HM67


SoundcardRealtek ALC665 @ Intel Cougar Point PCH - High Definition Audio Controller

 

SSD 480

HD 1tb

 

 

Já tentei todas as maneiras mas o pendrive com o MacOS sempre dá  "Operation System not Found"

Share this post


Link to post
Share on other sites

olá

 

smbios macbookpro8.1

 

seleciona esse no clover

 

estás a tentar instalar no ssd ? ou no hd ?

 

tenta instalar sierra para começar

 

nos gráficos injecta a intelhd + dual link

 

bom hack

Share this post


Link to post
Share on other sites

Então, o problema é que nem o boot no pendrive eu consigo dar. Estou tentando no SSD. Eu sei que o hardware é compatível aparentemente, o problema é que quando tento bootar o pendrive o clover não inicia e fica mostrando "Operation System not found". Já testei o pendrive em outros computadores e funciona normal.

Share this post


Link to post
Share on other sites
6 minutes ago, Allan said:

Mesmo usando em portas USBs diferentes você ainda tem esse problema?

 

Esse notebook tem duas portas USB 3.0 e uma porta e-SATA+USB. Só consigo acessar o pendrive pela última, nas USB 3.0 nem aparece pra bootar pelo pendrive nas opções de boot. Tentei usar o pendrive em MBR, mas não consegui. Ele não dar o erro de "Operation System not found" mas a tela do clover fica travada em "6_" com o underline piscando.

 

EDIT

 

Consegui acessar o pendrive por outro USB mas o erro permanece. Ou seja, pelos dois USBs que estão funcionando, um 3.0 e outro 2.0, a tela mostra "Operation System not found"

Edited by PetrusDeMelo

Share this post


Link to post
Share on other sites
On 11/17/2014 at 9:35 PM, Jona said:

agora esta dando esse erro.

post-1437593-0-48992200-1416270894_thumb.jpg

 

Eu to tendo exatamente este erro no primeiro boot do USB na tentativa de iniciar a instalação. Não é no boot do SSD/HD após a instalação como aconteceu com algumas pessoas que tem este notebook.

Share this post


Link to post
Share on other sites
2 hours ago, PetrusDeMelo said:

embora aparentemente várias pessoas na internet tenham conseguido fazer hack neste modelo.

De acordo com suas pesquisas, elas são recentes?

Se deu certo com outro user em "x" versão do macOS, então você pode tentar fazer o mesmo.

 

No Olarila, tem as imagens do OS X desde o Snow. Dai se você quiser instalar uma versão anterior até chegar na que deseja poderá atualizar o sistema. Em vez de instalar do zero.

Pode ficar zuado, mas....

Share this post


Link to post
Share on other sites

Gente, eu consegui dar boot na instalação instalando o Enoch Chameleon ao invés do Clover. Essa é uma abordagem possível? Entretanto estou com kernel panic no load da instalação. A questão é que eu já tenho muita experiência com o Clover, mas nenhuma com o Chameleon. Podem me dar novas direções?

 

 

1.jpeg

Share this post


Link to post
Share on other sites

Eis o que eu já descobri:

 

- O problema apresentado "Operation System not found" não é exclusivo da instalação do macOS, e sim de qualquer instalação que utilize um pendrive em formato GPT (acontece com Windows e Linux também) neste notebook. Quando está em MBR, o USB inicia normalmente. Acontece que em MBR o meu Clover está dando pau na inicialização.

 

Com essas novas informações, me sugerem novas ideias?

Edited by PetrusDeMelo

Share this post


Link to post
Share on other sites

Pessoal, 

 

Desculpem está comentando pela terceira vez seguida. Não sei o que se caracteriza como flood aqui. Quero compartilhar meus avanços pra caso alguém passe pela mesma situação que eu.

 

Consegui uma BIOS modificada que liberou as funções UEFI da placa mãe, e agora consegui iniciar o Clover normalmente. Estou tentando instalar o High Sierra do Olarila.

 

Segue link das bios modificadas (por sua conta em risco). Comigo funcionou perfeitamente.

 

http://forum.notebookreview.com/threads/l502x-modded-bioses-download-gpu-voltages-and-more.635536/

Share this post


Link to post
Share on other sites

Feedback final:

 

Consegui instalar o High Sierra. Com vídeo, bluetoth, ethernet e áudio funcionando. Não pegou WiFI por que a placa não é compatível. Indiquei ao cliente a troca da placa por uma que funcionasse.

 

Se alguém precisar de alguma ajuda com este modelo, pode solicitar! :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By TimothyF
      My steps so far:
      Set up Catalina install USB exactly according to Plain Vanilla guide. Disconnect my Windows drive in PC, so that only the empty Hard Drive is connected to Motherboard. Boot to USB, select Install Catalina option. BIOS set to UEFI, Safe mode Off. Always get stuck at the same IOconsoleUsers: GIOScreenLockState point. Tried -radvesa, -radoff, nv-disable=0 boot options (separately), and disabling BIOS virtualization (vt-d) -> NO luck. This from the top search result https://www.reddit.com/r/hackintosh/comments/b5a6ry/ioconsoleusersgioscreenlockstate_3_blackscreen/  
      Screen pics attached. Here are the last couple of lines that could be important:
      GTrace synchronization point 4
      Unsupported CPU
      Unsupported PCH
      Adding ADGP mode validate property
      hmm.. mismatch sizes 3100 vs 20
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOconsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
       
      Please give me some ideas what else might work. Thank you.


       
       
      Other details of Clover and Desktop PC below:
       
      Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: config.plist ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)  
    • By cixque
      CLOVER.zipCLOVER.zipDell Venue 11 Pro 7140
      ------------
      Specification
       
       
      Intel Core M 5Y71
       
      Intel HD Graphics 5300
       
      Intel Broadwell-U motherboard
       
      8GB Ram
       
      256GB SSD
       
      Dell DW1850e WWAN + GNSS GPS
       
      Intel Wireless 7265 + Intel Bluetooth
       
      NFC
       
       
      …..
       
       
       
       
       
      Mojave 10.14.6
       
      What works
      Native Power Manager (Generate Plugin type) Full Graphics with QE/CL Brightness (Add PNLF in Config.plist or DSDT Patch) — (Brightness slide bar) Touch Screen, and Pen (DSDT Patch + Voodoo I2C, I2CHID satellite KEXT) HDMI output with hot plug (Lilu + WhateverGreen) HDMI Audio with hot plug (Lilu + AppleALC) no Layout-id needed Front and Rear Cameras MicroSD slot - O2 Micro (I use Adding Arbitrary under Devices in Config file Method) Ref, Post #6 by Jake Jo https://osxlatitude.com/forums/topic/7346-applesdxc-driverdsdt-patch-for-o2-micro-sd-card-readers/ Battery Indicator (ACPIbattery by Rehabman) ——>To utilise both battery, SSDT (by Rehabman) is needed in order to combine 2 batteries as one.
      Travel Keyboard Dell K12a001 (USBinjectall KEXT) Native Keyboard keys (Brightness, volume keys) WWAN card Dell DW1850e (OOB) Bluetooth -------------------
       
      What doesn’t work
       
       
      Sleep Wake — I have no idea how to fix it as it is required DSDT patch I guess. GPS NFC Audio ---> Realtek I2S Audio (PG0.35 for DELL)
       
      In DSDT entries is HDAUDIO\\FUNC_01&VEN_10EC&DEV_0282&SUBSYS_00000000&REV_1000\ Which indicates ALC282
       
      Audio ALC3263 (As it shown in BIOS) - Broadwell rt286 - Card1/Codec#0 (Utilised in I2S Mode) there is nowhere in BIOS to change to HDA mode). Drop OEM HDA and Fix HDA don’t do anything, still show 3 HDMI Audio outputs. If there is a DSDT patch to force HDA Audio mode, Please do enlighten me.
      As a result Internal Speaker, Internal Mic, and Headphone Jack doesn’t work.
       
      Touchpad on Travel Keyboard Dell K12a001 (Should work with DSDT Patch with pin configuration) I have no idea how. Obviously, Intel Wireless 7265 AC. For experimental purpose. https://github.com/daliansky/XiaoMi-Pro-Hackintosh/issues/330 — Knock yourself out. I managed to get it work for awhile but the real problem is kernel panic so I gave up. Ordering compatible card instead. ------------------
       
      Config.plist got it from Rehabman laptop config.
       
       
      BIOS version A20
       
      Enable:
       
      - Legacy Boot Rom
       
      Disable:
       
      - Secure Boot
       
      - TPM 2.0
       
      - Vt-d
       
      ------------
       
      SMBIOS - I use MacBook8,1. —- MacBookAir7,1-7,2 (Min Freq is at 1.2 GHz) MacBookPro12,1 Min Freq is at 800 Mhz and it is the default this cpu should be. Again, there is a way to set it right somewhere in this forum.
       
      ------------
       
      -->> DSDT Windows 8 patch
       
      System sees only one I2C Controller which control Touch Screen.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      -->> DSDT Windows 8.1 Patch
       
      System sees two I2C Controllers which control Touch Screen and Accelerometer.
      Touch Screen registers as Magic Trackpad 2.
      Pen as Mouse
       
      OOO>>> With Windows 8.1 patch which it should run with this one because it can see more of HID devices and controllers.
       
      Problem is Accelerometer (SHUB).
      Device can automatically rotate screen as it should be BUT it flips the screen wildly even with slightly movement. It stops only when device stays completely still. Eventually it breaks internal screen graphic. It becomes grabble. I restored internal screen graphic by connecting it to external monitor and set rotation of external screen to 0 degree. Then it is back to normal. (I guess it conflict with rotation setting) I disable SHUB in DSDT.
       
      ---------------------
       
      During Installation process Full Graphic acceleration can be activated straight away by Lilu and Whatevergreen. AppStore, iMessage and, FaceTime activate by NullEthernet and SSDT by Rehabman USBInjectAll needed for keyboard and other usb peripherals. Use other tool to keep certain ports active as Rehabman mention this KEXT is not good for a long run. Please do Correct me if I did something worng. Or any suggestions to make this thing runs better.
      CLOVER.zip
      IOReg_SysReport.zip
    • By zee.malik2008
      Nvidia GT 640 3Gb not working in High sierra PC Dell Optiplex 9010. Spinning icon with mouse curser nothing else
    • By tlefko
      Description
      This esentially an ultra-simplistic version that is stable without the use of a deploy or complicated file installations and copies. Highly recommend using DW1560 wifi card, killer wifi isn't supported. This does include a copy of Clover, which of course I take no credit for. I am only responsible for minor changes in files and plists, as well as placement and instructions throughout the guide (as well as the work used from previous projects). Many files and ideas are sourced from @maz-1, @syscl, and my previous guides Granted, many files are similar or the same but there is significantly less of them and/or they are predeployed into spots where they will work just as well, even if not as efficient on bootup. Esentially, this guide is designed to provide a perfectly working setup with little knowledge of the topic and without optimization (because often they can break things). Most patches on the main plist use patches implemented by him as well. ****This guide does work excellently however and will provide you with a near perfect setup for Catalina for your XPS 9350, and is currently my daily driver as I struggled using the referenced users files as well.
      Styling
      This guide is designed to be literally as thorough as possible to appeal to those who really don't understand many of the things in @maz-1's guide or some of the other users as they assume you would already understand this information. It does not cover complex topics like undervolting etc etc Notes
      Never tested USB C except for charging, works great no issues with sleep, wakeup. power management is defaulted as I found with @maz-1 it had issues when on battery switching from AC USB devices eject on sleep (not really an issue) Haven't implemented a Bluetooth solution into this yet, as I don't really use it -- will be added ASAP (I believe KILLER WIFI will NOT work, must use one of the supported chipsets (DW1560 is excellent) BIOS Setup
      Set all SATA operation as AHCI Disable Secure Boot, Fast Boot For Coil Whine improvement disable C-States Enable UEFI Booting Recommended: Clean Install (Preinstall steps)
      Format a USB (16GB) as Journaled and then proceed to download the latest Catalina Installer Patcher Application Download the latest Catalina installer from within the Patcher App, and select to download a new copy and install to your USB device Download the clover configurator application and mount the EFI of the USB partition, then copy the contents of the Files linked above to the EFI Folder within the EFI partition. ** This is because the App Store installers will often not download a full installer, just an truncated version that downloads the installer files from the interent while installing. Thus, they're not bootable from a USB as they're not complete. That is why you should use this method to make sure the installer is usable for bootable media.
      Install Steps
      Simply use F12 to boot from the USB device, and select the USB Device and then boot from the Install mac OS partition. I have defaulted the installer to boot into verbose mode so I can easily see the errors you guys are seeing if you encounter them. If everything goes well, you can disable these from the boot arguments selection of Clover Configurator Boot into the USB Device, and follow the steps to format your SSD from the installer to install Mac OS Catalina. NOTE THE TRACKPAD WILL NOT FUNCTION AT THIS POINT, BUT THE TOUCHSCREEN WILL. This is caused by the way the installer handles Kext loading but because the touchscreen is being loaded via usb and the keyboard in a different method (which I can explain in detail if you'd like, the install will be possible. Do not be alarmed if the installer takes a long time to boot into, this is expected Once you have done this step, use F12 to select the USB and boot into the installer from the SSD in the options menu. (you cannot boot natively yet as the EFI isn't copied into the SSD yet. Setup computer as normal, touchpad, brightness, etc, should all be functioning at this point. Same with wifi. Then, you should using Clover configurator copy the contents of the USB EFI into the EFI folder of your SSD EFI partition (in the folder) Now we will add this as a native boot option. Setup computer as normal, touchpad, brightness, etc, should all be functioning at this point. Same with wifi. Then, you should using Clover configurator copy the contents of the USB EFI into the EFI folder of your SSD EFI partition (in the folder) Now will we add this as a boot entry so you can always boot from this natively without the USB. Boot Entry Setup
      Boot into the BIOS of the computer, then navigate to the Boot setup (or entries (not sure what it is called exactly, but it will be a list of the options your computer selects to boot) Click add new, and make sure the USB isn't plugged in. Select the only option that is avaiable, and in FS0 navigate to Boot/BOOTx64. Add this as an entry, then select this as whatever priority you would like. Credits
      Credit Hackintosher.com for basic patches (although @syscl) covered some Credit to @Rehabman Credit to @syscl Kexts, and his contributers (@maz-1) Messages and Facetime
      Using Clover Configuator generate your own Serials, Board Numbers, MLB There are various guides online to do this and as default they're set to essentially Null (Fakeserial) This is fairly straightforward and there is lots of documentation, just don't open these apps until you've done this properly. Finished!
      Congratulations, there really aren't any more steps that are required. Feel free to contact me with any questions. Files can be downloaded here, and issues and help requests can be said here or opened into the GitHub page. Please @ me for a faster response on this page, as I am not that attentive, also, feel free to PM me.  Github: https://github.com/tlefko/XPS13-9350-Catalina Thanks for reading! Files.zip
×