Jump to content
blackosx

Clover Theme Manager

581 posts in this topic

Recommended Posts

Hi guys!! Im have a issue when im boot theme...its apears icons together...like picture...any ideas? IM use CloverThemeManager...tks!!!

 

IMG_0689.thumb.jpeg.d5ec665d761a9ab9e50a3d73aed77ab9.jpegIMG_0688.thumb.jpeg.4b790d821f2a3831f88e395a289d7dfd.jpeg

Share this post


Link to post
Share on other sites
Advertisement

Since Clover r4830, the GUI uses a different way to detect the width of icons. Some themes are not affected by this change, but any themes that use the Layout -> TileXSpace setting are affected. Those affected themes have been updated in the Theme repo.

 

From the screenshot you've posted I guess you are using Badruzeus' Outlines theme. 

 

Please update the theme you are using to the latest version or alternatively edit the theme.plist to change the TileXSpace value to zero

 

            TileXSpace            0

 

 

EDIT:

If you are using a Clover revision pre 4830 then the simplest solution is to update Clover.

 

EDIT2:

If you are using a version of Clover before r4830 and with an updated theme then you will have to change the above TileXSpace in the theme.plist to a value larger than Zero.

 

Share this post


Link to post
Share on other sites
 

Hi guys!! Im have a issue when im boot theme...its apears icons together...like picture...any ideas? IM use CloverThemeManager...tks!!!

Last Clover release on SourceForge is r4813.

Since r4731++ is needed; you can try with this one (r4836)

Use CloverThemeManager.app to get latest Theme's version from repo as suggested by @blackosx above.

Edited by Badruzeus

Share this post


Link to post
Share on other sites

Hi guys, so many thanks for you help me!!! Sorry if im not saw un another forum...im really appreciate Badruzeus themes, and im think is very good think you created CloverThemeManager...very fun and beauty part of our Hack..!!! Im not know if hack will be the same without that...very awesome job for all of you guys!!!

 

God bless you are...im using Clover r4836 version, because 4813 not works even update all, like im used to do always...since now, the themes that im using is good screen 

 

Thanks!!!!

 

:thumbsup_anim:

Share this post


Link to post
Share on other sites

Thanks for the repot @xxperrimaryxx and for supplying the files. I've not seen this issue before.

 

The problem is that that your boot log file is being seen as a binary file and not a text file, so when grep is used to find your SelfDevicePath it simply returns 'Binary file /tmp/CloverThemeManager/boot.log matches'.


It's because of a NUL (well, two) in the following line of your boot log:
0:102  0:000  Clover started with option to boot ??p from Legacy HD1

 

Can you try this version please?

CloverThemeManager_v0.77.2b.zip

 

Share this post


Link to post
Share on other sites

Can anyone help me out with this issue please. EFI mounted and running latest Them manager version but still can't detect boot device. 

Boot device.png

Share this post


Link to post
Share on other sites

If you supply the log files then I can take a look.

 

From the first post:

Note: If you are reporting any problems then please supply a description of the problem, a screenshot and attach a .zip of the /tmp/CloverThemeManager directory (available only while the app is running).

 

So:

1 - Download and run CloverThemeManager_v0.77.2b.zip from the post above yours.

2 - When the app has got to the point in your screenshot above, leave it running and click on the Desktop.

3 - From the Finder press Command-Shift-G or select Go -> 'Go to Folder...' from the menu bar and enter /tmp

4 - Right click on the CloverThemeManager and select Compress 'CloverThemeManager'

5 - Upload that CloverThemeManager.zip here.

 

I'm going be out for most of today but will try to take a look this evening.

Share this post


Link to post
Share on other sites

Thanks for sending the log files.

 

From the SelfDevicePath

0:100  0:000  SelfDevicePath=PciRoot(0x0)\Pci(0x1,0x3)\Pci(0x0,0x2)\Pci(0x9,0x0)\Pci(0x0,0x0)\NVMe(0x1,00-00-00-00-00-00-00-00)\HD(1,GPT,31C70147-D0A2-4D43-B388-97EC0C91E631,0x28,0x64000) @D6E98D98

partutil fails to find your partition with UUID 31C70147-D0A2-4D43-B388-97EC0C91E631

 

@OnSale 

Can you show me the result of the following command in Terminal?

diskutil list -plist

 

Share this post


Link to post
Share on other sites
10 hours ago, blackosx said:

Thanks for sending the log files.

 

From the SelfDevicePath


0:100  0:000  SelfDevicePath=PciRoot(0x0)\Pci(0x1,0x3)\Pci(0x0,0x2)\Pci(0x9,0x0)\Pci(0x0,0x0)\NVMe(0x1,00-00-00-00-00-00-00-00)\HD(1,GPT,31C70147-D0A2-4D43-B388-97EC0C91E631,0x28,0x64000) @D6E98D98

partutil fails to find your partition with UUID 31C70147-D0A2-4D43-B388-97EC0C91E631

 

@OnSale 

Can you show me the result of the following command in Terminal?


diskutil list -plist

 

here is the result. 

 

Last login: Sun Jun  2 08:48:50 on console
macoss-imac:~ macos$ diskutil list -plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>AllDisks</key>
<array>
<string>disk0</string>
<string>disk0s1</string>
<string>disk0s2</string>
<string>disk1</string>
<string>disk1s1</string>
<string>disk2</string>
<string>disk2s1</string>
<string>disk2s2</string>
<string>disk2s3</string>
<string>disk2s4</string>
<string>disk3</string>
<string>disk3s1</string>
<string>disk4</string>
<string>disk4s1</string>
<string>disk4s2</string>
<string>disk4s3</string>
<string>disk4s4</string>
<string>disk5</string>
<string>disk5s1</string>
<string>disk5s2</string>
</array>
<key>AllDisksAndPartitions</key>
<array>
<dict>
<key>Content</key>
<string>GUID_partition_scheme</string>
<key>DeviceIdentifier</key>
<string>disk0</string>
<key>Partitions</key>
<array>
<dict>
<key>Content</key>
<string>EFI</string>
<key>DeviceIdentifier</key>
<string>disk0s1</string>
<key>DiskUUID</key>
<string>31C70147-D0A2-4D43-B388-97EC0C91E631</string>
<key>Size</key>
<integer>209715200</integer>
<key>VolumeName</key>
<string>EFI</string>
<key>VolumeUUID</key>
<string>0E239BC6-F960-3107-89CF-1C97F78BB46B</string>
</dict>
<dict>
<key>Content</key>
<string>Apple_APFS</string>
<key>DeviceIdentifier</key>
<string>disk0s2</string>
<key>DiskUUID</key>
<string>1FE429C5-C25D-4B82-A625-A5D43D6CCD24</string>
<key>Size</key>
<integer>999995129856</integer>
</dict>
</array>
<key>Size</key>
<integer>1000204886016</integer>
</dict>
<dict>
<key>Content</key>
<string>GUID_partition_scheme</string>
<key>DeviceIdentifier</key>
<string>disk1</string>
<key>Partitions</key>
<array>
<dict>
<key>Content</key>
<string>Microsoft Basic Data</string>
<key>DeviceIdentifier</key>
<string>disk1s1</string>
<key>DiskUUID</key>
<string>9FD0BAD7-1FFD-4D23-A49D-BA416789A514</string>
<key>Size</key>
<integer>2000397795328</integer>
<key>VolumeName</key>
<string>Storage</string>
<key>VolumeUUID</key>
<string>4AD69CF2-D507-45A7-AA4A-B5318C1DE3C3</string>
</dict>
</array>
<key>Size</key>
<integer>2000398934016</integer>
</dict>
<dict>
<key>Content</key>
<string>GUID_partition_scheme</string>
<key>DeviceIdentifier</key>
<string>disk2</string>
<key>Partitions</key>
<array>
<dict>
<key>Content</key>
<string>Windows Recovery</string>
<key>DeviceIdentifier</key>
<string>disk2s1</string>
<key>DiskUUID</key>
<string>8213A7F3-2AE7-4F41-AF32-4D51E93E6255</string>
<key>Size</key>
<integer>554696704</integer>
</dict>
<dict>
<key>Content</key>
<string>EFI</string>
<key>DeviceIdentifier</key>
<string>disk2s2</string>
<key>DiskUUID</key>
<string>BB8F49C5-0F82-4BF7-89DE-6264B6D9D742</string>
<key>Size</key>
<integer>103809024</integer>
<key>VolumeName</key>
<string>NO NAME</string>
<key>VolumeUUID</key>
<string>CEF8A417-D091-38BD-A2D7-39E5D4C3D1F1</string>
</dict>
<dict>
<key>Content</key>
<string>Microsoft Reserved</string>
<key>DeviceIdentifier</key>
<string>disk2s3</string>
<key>DiskUUID</key>
<string>B2870ED1-C16C-4523-83E9-7D8B27311F33</string>
<key>Size</key>
<integer>16777216</integer>
</dict>
<dict>
<key>Content</key>
<string>Microsoft Basic Data</string>
<key>DeviceIdentifier</key>
<string>disk2s4</string>
<key>DiskUUID</key>
<string>EE2765D6-4FF6-4B03-966F-A9712DD81B46</string>
<key>MountPoint</key>
<string>/Volumes/Windows</string>
<key>Size</key>
<integer>999527809024</integer>
<key>VolumeName</key>
<string>Windows</string>
<key>VolumeUUID</key>
<string>1A57A398-CC1E-4606-9C13-21BD688E7060</string>
</dict>
</array>
<key>Size</key>
<integer>1000204886016</integer>
</dict>
<dict>
<key>Content</key>
<string>GUID_partition_scheme</string>
<key>DeviceIdentifier</key>
<string>disk3</string>
<key>Partitions</key>
<array>
<dict>
<key>Content</key>
<string>Microsoft Basic Data</string>
<key>DeviceIdentifier</key>
<string>disk3s1</string>
<key>DiskUUID</key>
<string>4ED65521-6B74-44C4-BE92-25F0966AE0A6</string>
<key>MountPoint</key>
<string>/Volumes/InlandSSD</string>
<key>Size</key>
<integer>1024208142336</integer>
<key>VolumeName</key>
<string>InlandSSD</string>
<key>VolumeUUID</key>
<string>33E384E2-E116-4881-AEA5-EFB9DC911261</string>
</dict>
</array>
<key>Size</key>
<integer>1024209543168</integer>
</dict>
<dict>
<key>APFSVolumes</key>
<array>
<dict>
<key>DeviceIdentifier</key>
<string>disk4s1</string>
<key>DiskUUID</key>
<string>BDFA8944-8D7C-3340-BBCD-8E703A8B18C7</string>
<key>MountPoint</key>
<string>/</string>
<key>Size</key>
<integer>999995129856</integer>
<key>VolumeName</key>
<string>MacOSX</string>
<key>VolumeUUID</key>
<string>BDFA8944-8D7C-3340-BBCD-8E703A8B18C7</string>
</dict>
<dict>
<key>DeviceIdentifier</key>
<string>disk4s2</string>
<key>DiskUUID</key>
<string>DFB6681D-C01A-4D13-BE06-90EEC01FF3B4</string>
<key>Size</key>
<integer>999995129856</integer>
<key>VolumeName</key>
<string>Preboot</string>
<key>VolumeUUID</key>
<string>DFB6681D-C01A-4D13-BE06-90EEC01FF3B4</string>
</dict>
<dict>
<key>DeviceIdentifier</key>
<string>disk4s3</string>
<key>DiskUUID</key>
<string>C7762906-A862-452F-8346-F0D7D865BBDD</string>
<key>Size</key>
<integer>999995129856</integer>
<key>VolumeName</key>
<string>Recovery</string>
<key>VolumeUUID</key>
<string>C7762906-A862-452F-8346-F0D7D865BBDD</string>
</dict>
<dict>
<key>DeviceIdentifier</key>
<string>disk4s4</string>
<key>DiskUUID</key>
<string>C3C32701-EB6A-49F6-90A3-5FDC90C49786</string>
<key>Size</key>
<integer>999995129856</integer>
<key>VolumeName</key>
<string>VM</string>
<key>VolumeUUID</key>
<string>C3C32701-EB6A-49F6-90A3-5FDC90C49786</string>
</dict>
</array>
<key>Content</key>
<string>EF57347C-0000-11AA-AA11-00306543ECAC</string>
<key>DeviceIdentifier</key>
<string>disk4</string>
<key>Partitions</key>
<array/>
<key>Size</key>
<integer>999995129856</integer>
</dict>
<dict>
<key>Content</key>
<string>GUID_partition_scheme</string>
<key>DeviceIdentifier</key>
<string>disk5</string>
<key>Partitions</key>
<array>
<dict>
<key>Content</key>
<string>EFI</string>
<key>DeviceIdentifier</key>
<string>disk5s1</string>
<key>DiskUUID</key>
<string>16679AAC-CBD7-4E6D-A3C7-0485DB87C059</string>
<key>Size</key>
<integer>209715200</integer>
<key>VolumeName</key>
<string>EFI</string>
<key>VolumeUUID</key>
<string>0E239BC6-F960-3107-89CF-1C97F78BB46B</string>
</dict>
<dict>
<key>Content</key>
<string>Apple_HFS</string>
<key>DeviceIdentifier</key>
<string>disk5s2</string>
<key>DiskUUID</key>
<string>9D471552-9847-4760-9938-C4A58B74B509</string>
<key>MountPoint</key>
<string>/Volumes/Storage</string>
<key>Size</key>
<integer>319739797504</integer>
<key>VolumeName</key>
<string>Storage</string>
<key>VolumeUUID</key>
<string>E4C679C3-5EC4-3377-BA16-FEF7A1EEB35C</string>
</dict>
</array>
<key>Size</key>
<integer>320083771392</integer>
</dict>
</array>
<key>VolumesFromDisks</key>
<array>
<string>Windows</string>
<string>InlandSSD</string>
<string>MacOSX</string>
<string>Storage</string>
</array>
<key>WholeDisks</key>
<array>
<string>disk0</string>
<string>disk1</string>
<string>disk2</string>
<string>disk3</string>
<string>disk4</string>
<string>disk5</string>
</array>
</dict>
</plist>
macoss-imac:~ macos$ 

 

Edited by Slice
too long text

Share this post


Link to post
Share on other sites

Thanks.

 

I just wanted to double check the DiskUUID and I can see it's clearly matching disk0s1. Can you run partutil from Terminal to check the result?

 

So, load up Terminal and issue the following command, replacing PATH_TO with the path to where CloverThemeManager is.

 /PATH_TO/CloverThemeManager.app/Contents/Resources/public/tools/partutil --search-uuid 31C70147-D0A2-4D43-B388-97EC0C91E631

So for example:

 /Users/blackosx/Downloads/CloverThemeManager.app/Contents/Resources/public/tools/partutil --search-uuid 31C70147-D0A2-4D43-B388-97EC0C91E631

 

Can you show me the result?

 

Thanks

Share this post


Link to post
Share on other sites
52 minutes ago, blackosx said:

Thanks.

 

I just wanted to double check the DiskUUID and I can see it's clearly matching disk0s1. Can you run partutil from Terminal to check the result?

 

So, load up Terminal and issue the following command, replacing PATH_TO with the path to where CloverThemeManager is.


 /PATH_TO/CloverThemeManager.app/Contents/Resources/public/tools/partutil --search-uuid 31C70147-D0A2-4D43-B388-97EC0C91E631

So for example:

 /Users/blackosx/Downloads/CloverThemeManager.app/Contents/Resources/public/tools/partutil --search-uuid 31C70147-D0A2-4D43-B388-97EC0C91E631

 

Can you show me the result?

 

Thanks

 

macoss-imac:~ macos$ /Applications/CloverThemeManager.app/Contents/Resources/public/tools/partutil --search-uuid 31C70147-D0A2-4D43-B388-97EC0C91E631

Illegal instruction: 4

did i do something wrong?

Share this post


Link to post
Share on other sites

No. You did nothing wrong. You've just helped identify the reason why CloverThemeManager is not working for you.

 

Partutil is not working for you.

Checking your Clover boot log I see you have:

0:100  0:000  BrandString = AMD Ryzen 7 2700X Eight-Core Processor 

 

Partutil is compiled as 32-bit and I'm guessing your kernel does not have 32-bit support. I'll see if I can locate the partutil source and re-compile as 64-bit.

 

Share this post


Link to post
Share on other sites

@OnSale

Can you try the attached version of partutil?

 

First of all, unzip it and double-click the binary in the Finder to make sure the binary runs and you don't see Illegal Instruction.

 

If that works, can you replace the version of partutil in CloverThemeManager with the attached version? In case you're not sure how, right-click the CloverThemeManager app in the Finder, choose 'Show Package Contents' from the menu and drill down to CloverThemeManager.app/Contents/Resources/public/tools/

Then drag and drop the new version in to the tools dir, replacing the one that's there.

 

 

partutil.zip

Share this post


Link to post
Share on other sites

@blackosx

Thanks so much for helping me. it's working fined now. boot deviced recognized after replace the partutil. 

Screen Shot .png

Edited by OnSale

Share this post


Link to post
Share on other sites
On 6/2/2019 at 2:11 PM, blackosx said:

@OnSale

Can you try the attached version of partutil?

 

First of all, unzip it and double-click the binary in the Finder to make sure the binary runs and you don't see Illegal Instruction.

 

If that works, can you replace the version of partutil in CloverThemeManager with the attached version? In case you're not sure how, right-click the CloverThemeManager app in the Finder, choose 'Show Package Contents' from the menu and drill down to CloverThemeManager.app/Contents/Resources/public/tools/

Then drag and drop the new version in to the tools dir, replacing the one that's there.

 

 

partutil.zip

Tried this, still stuck on "Initialising"

 

CloverThemeManager.zip

Share this post


Link to post
Share on other sites

"git version detection failed."

 

From first page:

Please take note. To get themes from the new Clover theme repository you will need to have git installed.
You can install git either by itself by downloading the installer from http://git-scm.com or you can install the Xcode command line developer tools by loading up Terminal and typing xcode-select --install

Share this post


Link to post
Share on other sites

CloverThemeManager has now been updated to v0.77.2.

 

Changelog:

- Process bootlog as if it were a binary file to handle NULL in clover bootlog
- Update partutil with 64bit 

 

New version is available via app update, or directly from the Repo

https://sourceforge.net/p/cloverefiboot/themes/ci/master/tree/CloverThemeManagerApp/Updates/

 

 

Share this post


Link to post
Share on other sites

Hi @blackosx many thanks to you and the team for the great work!


However I just updated to latest official Clover r4961 and to CloverThemeManager at v0.77.2.

I am stuck in "Downloading updated git index" for quite some time now; I did try to rerun in a "clean" manner via the File menu, but to no avail.

Any ideas if this is coming from the app itself or Git?

Many thanks

 

P.S. A small UI fix for English menus that's there for quite some time: Menu File > Check for updates needs 3 dots, has 2 dots :)

Edited by MacKonsti

Share this post


Link to post
Share on other sites
On 6/19/2019 at 10:30 PM, blackosx said:

I need more to go on. Can you follow the steps outlined above (see my reply to OnSale) to send me the log file?
Thanks

 

Hi @blackosx thanks for your response. It could be a Git network problem. I had some time this morning and did a "Clean" process (via File menu) and I get now the list OK.

However, I did get partutil downloaded and it seems to report same version 0.17 with the one found in /Applications/CloverThemeManager.app/Contents/Resources/public/tools/

Even a diff showed they are the same binaries.

(sorry I may have checked the wrong message/reply of yours)

In any case, my issue was that it was stuck in the loading process where it was trying to get data from Git Index. Now I get all the themes listed OK.

Sorry for bothering you on this. Let me know how I can be of further help.

 

(and my kind reminder of a small UI fix for English menus that's there for quite some time: Menu File > Check for updates needs 3 dots, has 2 dots)

Edited by MacKonsti

Share this post


Link to post
Share on other sites
On 11/17/2014 at 5:50 AM, blackosx said:

Clover has many themes, some of which come included with the Clover installer but different themes, sometimes more up to date and better themes, have otherwise been listed in the Clover wiki with a download link to find the files. Not all themes can be included in the Clover installer as their many files make them large in file size and the installer would be unnecessarily bloated.


Because of this, it's been decided (soon) to move all themes from Clover's source repository and instead host them in a new specific theme repository at sourceforge, next to the Clover repository. This will result in a smaller Clover repository allowing for faster check out of the source and downloading of the Clover installer quicker. Clover with still have it's own very simple embedded theme so users installing without a theme will not be left in the dark.
 
Clover Theme Manager

4th June 2019 - Now at version 0.77.2 (Recent changelog)

If updating from a previous version fails then please download the new version from the bottom of this post.


Please take note. To get themes from the new Clover theme repository you will need to have git installed.
You can install git either by itself by downloading the installer from http://git-scm.com or you can install the Xcode command line developer tools by loading up Terminal and typing xcode-select --install

ELidvoS.jpg


It started out as a simple app which displayed a list of themes in the repository and gave you the option to download and install themes to your /EFI/Clover/Themes directories.

It's since grown with the aim of becoming more of a manager app by reading the Clover bootlog to determine what happened last boot and offering a set of options to change the theme for next boot depending on your system.


On launch, the app will attempt to read your boot device and use your boot device. If this device uses an MBR partition then the app will ask for your password so it can run fdisk to match the device. If your boot volume is an EFI system partition and it's currently unmounted then the app will ask for you password to mount it.

What happens if a theme designer updates their theme?
The theme manager can check for updates to themes and notify you giving you the option to update your installed version.

I no longer want to use a theme.
You can simply remove installed themes by clicking the UnInstall button.

I have created a theme. How do I add it to the repository?
Theme designers can have access to add and amend their themes for anyone else to install and try out. Step by step instructions can be found by clicking the 'How to add my theme' foot link in the app.

What does the Clover Theme Manager app install to my system?
A support directory is used for cloning the necessary repository files for the app to function. You will find that at:


~/Library/Application\ Support/CloverThemeManager

All application data gets saved to:


~/Library/Preferences/org.black.CloverThemeManager.plist

App runtime files, including a log are written to:


/tmp/CloverThemeManager

 
Where’s the source code for the app?
http://sourceforge.net/p/cloverefiboot/themes/ci/master/tree/CloverThemeManagerApp/CloverThemeManager/

Credits:
The app is based on the objective-c macgap (MIT license) with a couple of modifications by me. The web view presented by macgap is where I effectively run a web app which communicates back and forth with a bash script which is initially launched by macgap when it’s loaded.

The Clover git repo has been setup by apianti.
Thanks to apianti, dmazar, JrCs, SoThOr and Micky1979 for their help.
Thanks to alexq, arsradu, asusfreak, Badruzeus, chris1111, droplets, eMatoS, kyndder, mnfesq, oswaldini & SavageAUS for testing.

The application has been in development for a few months now and while I think it's pretty stable I can only test on my systems and respond to the feedback of others so there may well be bugs and issues yet to be squashed. If you wish to try out the application then please report any feedback, both positive and negative here.

Note: If you are reporting any problems then please supply a description of the problem, a screenshot and attach a .zip of the /tmp/CloverThemeManager directory (available only while the app is running).
 
Can I download themes without using the CloverThemeManager app?
Yes, you can manually manage your own /EFI/Clover/Themes directories yourself as you may currently do.
Dmazar suggests the following command in Terminal, replacing XXXXXXXX with the name of the theme. So cd to a directory of your choice and run this...


git archive --remote=git://git.code.sf.net/p/cloverefiboot/themes HEAD themes/XXXXXXXX | tar -x

Download v0.77.2:

Clover Repo at sourceforge

 

Hi blackosx I've made 2 clover themes I would like to add theme to the themes that can be downloaded with clover manager my user name on sourceforge is austcool

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
    • By IIIdefconIII
      This theme is original form Enzo:
       

       
      He build it for the chameleon boot loaders.
      http://forum.voodooprojects.org/index.php/topic,5918.0.html?PHPSESSID=8jgg62mu0el9hhaltncecthleffp942d
       
      I liked it so much that i asked his permission to convert it to a Clover theme.
      So glad he told me i can.
       
      Shout out for Enzo!
      mavs.zip
    • By IIIdefconIII
      This theme is original form Enzo:
       
      He build it for the chameleon boot loaders.
      http://forum.voodooprojects.org/index.php/topic,5918.0.html?PHPSESSID=8jgg62mu0el9hhaltncecthleffp942d
       
      I liked it so much that i asked his permission to convert it to a Clover theme.
      So glad he told me i can.

      So the Theme zip is included this post bellow.
       
      Shout out for Enzo!
×