Jump to content
blackosx

Clover Theme Manager

555 posts in this topic

Recommended Posts

blackosx not post here for long time

Thats not what I am talk ?

We're still able to reach him with PM though... not sure, I think it' s SF issue, IDK.

Share this post


Link to post
Share on other sites
Advertisement

Good news. SF have now fixed ssh access and I've been able to remove the index.lock file. The server-side hooks on the repo are now working again and user theme contributions/changes etc. should now be reflected in the CloverThemeManager.

Bad news, things server-side are not very fast. Hopefully things will improve in time.

If anyone has tried using CloverThemeManager during the period of downtime to access any of the recently added themes; 3DGREY,Chamelia,CUBE,EyeCandy,Luxury2.0,Neon,Smooth,SmoothDark,iCUBE and iOSX then they will fail to be installed by CloverThemeManager. The CloverThemeManager log may show something like this:

Installing theme Chamelia to /Volumes/EFI/EFI/Clover/themes
Bare git clone of Chamelia already exists. Will checkout from that.
        Checking out bare git clone of Chamelia.
        checkout .: error: pathspec '.' did not match any file(s) known to git.
        checkout HEAD --: fatal: invalid reference: HEAD
        hash=
        Chamelia : Install : Fail

To rectify the issue, please open ~/Library/Application Support/CloverThemeManager and manually delete the .git directory for the theme that's failing and retry from CloverThemeManager.

Edited by blackosx
update

Share this post


Link to post
Share on other sites
53 minutes ago, blackosx said:

If anyone has tried using CloverThemeManager during the period of downtime to access any of the recently added themes; 3DGREY,Chamelia,CUBE,EyeCandy,Luxury2.0,Neon,Smooth,SmoothDark,iCUBE and iOSX then they will fail to be installed by CloverThemeManager.

To rectify the issue, please open ~/Library/Application Support/CloverThemeManager and manually delete the .git directory for the theme that's failing and retry from CloverThemeManager.

Thanks for committing this, @blackosx :thumbsup_anim:

#EDIT: It works!

2rLdeaq.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites

Thanks for confirming it works Badruzeus.

I tried rebuilding the server-side bare git clones from the back end but they either weren’t correct or I didn’t spot the need to delete the local version from the Application Support/CloverThemeManager directory first so ended up forcing the scripts to rebuild the bare git clones by adding a file to each theme with that last commit. I forgot to delete those force.txt files from the themes so feel free to delete them. 

Share this post


Link to post
Share on other sites
6 minutes ago, blackosx said:

Thanks for confirming it works Badruzeus.

I tried rebuilding the server-side bare git clones from the back end but they either weren’t correct or I didn’t spot the need to delete the local version from the Application Support/CloverThemeManager directory first so ended up forcing the scripts to rebuild the bare git clones by adding a file to each theme with that last commit. I forgot to delete those force.txt files from the themes so feel free to delete them. 

I previously thought that I need to git rm then git add them (my uploaded themes when on SF issue) again to be indexed by CTM. Glad to know you've fixed this issue..

Edited by Badruzeus

Share this post


Link to post
Share on other sites

The app has been updated to v0.76.7 and it's available as an update. Please let me know of any issues.

 

Changes:
- Change check for theme repository.
- Add extra debug for installed git.
- Update Sparkle framework.

 

Download is now also available in first post.

Share this post


Link to post
Share on other sites

I can't install any theme in Mojave.... No error on setting up Theme Manager, but when I click Install on a certain theme, it just says downloading forever and ever... Could be my mistake, could be a bug, could be something specific with Mojave... I don't know. I was just wondering if I'm the only one with this issue.

Share this post


Link to post
Share on other sites
3 minutes ago, arsradu said:

I can't install any theme in Mojave.... No error on setting up Theme Manager, but when I click Install on a certain theme, it just says downloading forever and ever... Could be my mistake, could be a bug, could be something specific with Mojave... I don't know. I was just wondering if I'm the only one with this issue.

Is Git installed, or XCode CLT?

Share this post


Link to post
Share on other sites
7 minutes ago, Badruzeus said:

Is Git installed, or XCode CLT?

Not sure about Git.... But if it were a setup issue, shouldn't it throw an error on first launch...? I mean, for as far as I know, this is where git is configured. It passed everything with flying colours there. So...I'm not sure it's because of that.

Xcode CLT is installed, for sure, since I compiled Clover with it.

Edited by arsradu

Share this post


Link to post
Share on other sites
47 minutes ago, arsradu said:

Not sure about Git.... But if it were a setup issue, shouldn't it throw an error on first launch...? I mean, for as far as I know, this is where git is configured. It passed everything with flying colours there. So...I'm not sure it's because of that.

Xcode CLT is installed, for sure, since I compiled Clover with it.

I just did a test, glad to know that I have same issue as yours with CloverThemeManager.app v0.76.7 under 10.14 Beta.

Git v2.17.1 & Xcode Command Line Tools are installed, app running just fine, themes list loaded, but am unable to download any theme from repo. Same result if using VPN, ping sourceforge.net gives no issue with server.

CloverThemeManagerLog.zip

Screen Shot 2018-06-17 at 11.07.12.png

Screen Shot 2018-06-17 at 11.29.00.png

 

#EDIT: But I got a warning with app compatibility on it's 1st launch. The process is stuck at downloading and never finished.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
1 minute ago, Badruzeus said:

I just did a test, glad to know that I have same issue as yours with CloverThemeManager.app v0.76.7 under 10.14 Beta.

Git v2.17.1 & Xcode Command Line Tools are installed, app running just fine, themes list loaded, but am unable to download any theme from repo. Same result if using VPN, ping sourceforge.net gives no issue with server.

CloverThemeManagerLog.zip

Yeep. That's exactly what I'm talking about.

Now, as the warning says "software is not optimised and needs to be updated". :) Indeed it does.

 

Well, to be honest, many apps showed me this warning. And I'm sure it will disappear once they get updated.

What's weird is that it doesn't seem to throw any error when you're trying to download the theme. 

 

The only error I could find was this:

Error!. /Users/badruzeus/Library/Application Support/CloverThemeManager/theme.html not found

And I'm not sure it has anything to do with the actual issue.

Share this post


Link to post
Share on other sites
4 minutes ago, arsradu said:

 

The only error I could find was this:


Error!. /Users/badruzeus/Library/Application Support/CloverThemeManager/theme.html not found

And I'm not sure it has anything to do with the actual issue.

Uhmmb, is it actually an error? For me it looks like just warning. On 1st launch the app doesn't have this file, but created later.

Share this post


Link to post
Share on other sites
1 minute ago, Badruzeus said:

Uhmmb, is it actually an error? For me it looks like just warning. On 1st launch the app doesn't have this file, but created later.

Yeah, well it's labeled as an "error". :)) That's why I said it probably/most likely doesn't have anything to do with the actual issue.

 

But yeah, if this is an issue only with Mojave, as I think it is, there is plenty of time to fix it. After all, this is only the first Beta.

Share this post


Link to post
Share on other sites
6 hours ago, blackosx said:

I have not conducted thorough tests but CloverThemeManager seems to be working in Mojave Beta 2 (18A314h).

 

 

Still occurs for me. Only this time, after a while, I also get an error.

 

 

Screenshot 2018-06-20 at 07.26.35.png

Screenshot 2018-06-20 at 07.27.10.png

 

Installing theme BeautyDark to /Volumes/ctmTempMpcOR9142k3/EFI/Clover/themes
        Creating a bare git clone of BeautyDark
        Install git clone: Cloning into bare repository 'BeautyDark.git'...
remote: Counting objects: 121, done.        
error: RPC failed; curl 18 transfer closed with outstanding read data remaining
fatal: The remote end hung up unexpectedly
fatal: protocol error: bad pack header
        BeautyDark : Install : Fail
        Sending UI: Fail@Install@BeautyDark

UPDATE:

Did a Clean CloverThemeManager and now it works. :) 

 

Screenshot 2018-06-20 at 07.33.10.png

Edited by arsradu

Share this post


Link to post
Share on other sites

@blackosx, I'm still stuck at connecting to the repository...on the work build (10.13.6). I'm pretty sure it will work just fine at home. But still stuck here. Probably proxy issues. Probably something else... I have Xcode installed so I'm pretty sure this is not a matter of git etc etc etc

 

Also, does https://git.code.sf.net/p/cloverefiboot/themes work for anyone? Cause it's a blank page for me.

 

Log attached.

CloverThemeManagerLog.txt

Edited by arsradu

Share this post


Link to post
Share on other sites

The following command is failing at your end:

git ls-remote git://git.code.sf.net/p/cloverefiboot/themes

Works here:

$ git ls-remote git://git.code.sf.net/p/cloverefiboot/themes
7ff9d5d90db7319188e97343d915e42998852406	HEAD
7ff9d5d90db7319188e97343d915e42998852406	refs/heads/master

Maybe a network issue your end, but essentially, once you get this working in Terminal then the app will be fine.

 

BTW, here's a new build (0.76.8b) which now responds to Mojave's dark mode.

CloverThemeManager.zip

 

Edited by blackosx

Share this post


Link to post
Share on other sites
19 minutes ago, blackosx said:

The following command is failing at your end:


git ls-remote git://git.code.sf.net/p/cloverefiboot/themes

Works here:


$ git ls-remote git://git.code.sf.net/p/cloverefiboot/themes
7ff9d5d90db7319188e97343d915e42998852406	HEAD
7ff9d5d90db7319188e97343d915e42998852406	refs/heads/master

Maybe a network issue your end, but essentially, once you get this working in Terminal then the app will be fine.

 

BTW, here's a new build (0.76.8b) which now responds to Mojave's dark mode.

CloverThemeManager.zip

 

 

Yeah, I'm pretty sure the issue is related to my network here. I can test this at home, as well, same build, same everything, and I'm pretty sure it will work just fine. I was just thinking maybe there is a workaround for it.

 

The command above times out on my end:

git ls-remote git://git.code.sf.net/p/cloverefiboot/themes
fatal: unable to connect to git.code.sf.net:
git.code.sf.net[0: 216.105.38.16]: errno=Operation timed out

However, switching to https instead of git, seems to be working:

git ls-remote https://git.code.sf.net/p/cloverefiboot/themes
7ff9d5d90db7319188e97343d915e42998852406 HEAD
7ff9d5d90db7319188e97343d915e42998852406 refs/heads/master

Can I switch from the git URL to a HTTP URL? Where is this part set?

 

I'm pretty sure the git port is blocked. But the https one is not. So..this could be a valid workaround. Also...would it be possible to switch to https by default...? Or...attempt connecting via https if git fails at this point...? I don't know. I'm just saying.

Edited by arsradu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
    • By IIIdefconIII
      This theme is original form Enzo:
       

       
      He build it for the chameleon boot loaders.
      http://forum.voodooprojects.org/index.php/topic,5918.0.html?PHPSESSID=8jgg62mu0el9hhaltncecthleffp942d
       
      I liked it so much that i asked his permission to convert it to a Clover theme.
      So glad he told me i can.
       
      Shout out for Enzo!
      mavs.zip
    • By IIIdefconIII
      This theme is original form Enzo:
       
      He build it for the chameleon boot loaders.
      http://forum.voodooprojects.org/index.php/topic,5918.0.html?PHPSESSID=8jgg62mu0el9hhaltncecthleffp942d
       
      I liked it so much that i asked his permission to convert it to a Clover theme.
      So glad he told me i can.

      So the Theme zip is included this post bellow.
       
      Shout out for Enzo!
×