Jump to content

34 posts in this topic

Recommended Posts

Hello Guys,

App named BeamOff can repair Yosemite poor performance on VmWare products, like VmWare Workstation or ESXi vSphere hypervisor.

Also it enable more FPS, smoothly dragging windows

 

Direct link for download "BeamOff": https://www.sendspace.com/file/sm9sf7

Manual, how to make BeamOff autostart when Yosemite start: http://support.apple.com/en-us/ht2602

BeamOff github source code: https://github.com/JasF/beamoff.git

 

other methods

'Quartz Debug' utility direct download link: https://www.sendspace.com/file/g73nim

 
Known issue: Not working on El Capitan

Share this post


Link to post
Share on other sites
Advertisement

I'm a bit new to OS X  :blush: . Could you please detail on how to find / execute the 'Quartz Debug' utility and how to change the setting.

Share this post


Link to post
Share on other sites

Excellent find JasF!!!! Yosemite graphics scream like Mavericks now! Now just to figure out how to make it permanent without the program running...

 

Thank you!

 

For those looking for Quartz Debug, log in through developer section of apple and download the graphics tools for Xcode 6.1 on 10.10.

Share this post


Link to post
Share on other sites

Very good! I found out that you may start the beamoff binary from the command line by running 

sudo <path-to>/beamoff.app/Contents/MacOS/beamoff

...and it works! So, provided you put the beamoff program in /Applications/Utilities, you may have it automatically fixing your graphics at startup by creating the file beamoff.auto.plist inside /Library/LaunchDaemons with the following contents:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Label</key>
	<string>beamoff.auto</string>
	<key>ProgramArguments</key>
	<array>
		<string>/Applications/Utilities/beamoff.app/Contents/MacOS/beamoff</string>
	</array>
	<key>LaunchOnlyOnce</key>
	<true/>
	<key>RunAtLoad</key>
	<true/>
	<key>Disabled</key>
	<false/>
</dict>
</plist>

Upon restart, the graphics will just work.

Share this post


Link to post
Share on other sites

Just a question.

 

Animation on http://www.google.co.uk/chrome/

 

in Safari on Y 10.10 on Workstation 10.0.4

 

is beyond tragic (that is with beamoff disabled)

 

Is it only me?

 

No - graphics and sound are not great on virtualised OS X. There is no accelerated 3D driver for the VMware virtual video card.

Share this post


Link to post
Share on other sites

A new version of Fusion was released on 1st December 2014 (7.1.0), so should be an updated darwin.iso available soon on the CDS repository.

Share this post


Link to post
Share on other sites

A new version of Fusion was released on 1st December 2014 (7.1.0), so should be an updated darwin.iso available soon on the CDS repository.

 

I've installed the Fusion 7.1.0 tools from the darwin iso:

 

http://softwareupdate.vmware.com/cds/vmw-desktop/fusion/7.1.0/2314774/packages/com.vmware.fusion.tools.darwin.zip.tar

 

Result remains the same. The corner artifacts are still there.

Share this post


Link to post
Share on other sites

Thank you for the beamoff fix; this fixed my last issue with the VM running my TV and it now plays HTML5 videos very well.

 

Also if anyone has the issue of crackling output from digital audio (optical) out, for me it was solved in the BIOS. I disabled integrated graphics, the integrated SATA I wasn't using, the serial port, and everything else unnecessary. Now I have crystal clear digital audio again.

Share this post


Link to post
Share on other sites

Folks, thanks for raising your voice to let us know that this workaround works. We have implemented this workaround in the VMware Tools, that we will ship as part of an upcoming VMware Fusion release.

Share this post


Link to post
Share on other sites

Folks, thanks for raising your voice to let us know that this workaround works. We have implemented this workaround in the VMware Tools, that we will ship as part of an upcoming VMware Fusion release.

HPReg,

 

I have seen your recent post in VMware Fusion (for Mac) VMware Community, please let us know when the workaround has been added to the VMware Tools (darwin.iso) for Fusion.

Share this post


Link to post
Share on other sites

Hi Guys

 

My Yosemite on Workstation 11 VM is a dog.  beamoff and Quartz Debug both make a big difference - but not for long.  The VM freezes under either - typically when scrolling Safari. 

 

Any ideas what I might have done wrong?  The proc is a i7-5820K and I've given the VM 2 cores and 8GB of memory.

 

Thx

Share this post


Link to post
Share on other sites

Yeah, me too... 

 

My Yosemite on Workstation 11 VM is a dog.  beamoff and Quartz Debug both make a big difference - but not for long.  The VM freezes under either - typically when scrolling Safari. 

 

I'm not sure, but I suspect it is a display adapter problem. 

 

 

I had the same problem with guest 10.6 installed on VMware Workstation 7 on WinXP host, and could not boot either right after install. Your workaround did help on boot, thanks! but then I found I could not switch to the native resolution 1440 x 900 that my monitor supports due to the maximum 1280 x1024 restricted by VMware Display setting.

I thought it might be worth to try adding the two lines in vmx file even though my guestOS is configured as darwin10,

svga.enableScreenObject = "TRUE"

svga.enableTracesReg = "TRUE

With the default VMware Display setting, i.e. "Use host setting for monitors" and "Accelerate 3D graphics" under "3D Graphics", the two lines did the trick! I am able to boot again with native solution supported by the monitor!


forgot to mention, Preview "Take Screen Shot" still doesn't work for me after 1.2 installed. and Preview could not open either png or jpeg files, but opening pdf files is fine.

Share this post


Link to post
Share on other sites

Using beamoff, and making it start automatically as well, has greatly improved the visual performance on my Yosemite VM. On my VM during booting the screen sometimes looks a bit messed up until OS X loads to login, it's fine once it starts.

 

Here are some more beginner friendly instructions on how to set it up, particularly useful for those unfamiliar with how file operations work on Mac OSX (all clicks are left mouse button clicks, unless stated otherwise)

 

To install beamoff

  1. Download beamoff https://www.sendspace.com/file/sm9sf7 onto the VM you want to fix
  2. Click Downloads (the icon at the bottom of the screen towards the right, next to the Trash icon)
  3. Click beamoff.zip, which should unzip the file and open the Downloads window for you
  4. In the Downloads window right-click beamoff (not beamoff.zip) and select Copy "beamoff"
  5. Now in the left of the Downloads window, click Applications
  6. Move your mouse pointer to the right of the window over to a space between the Application icons (not over them)
  7. Right-click and select Paste Item
  8. If you don't want to run beamoff automatically, you can double-click to run it
  9. If you want it to run automatically read below

If you want beamoff (or any suitable program) to run automatically on OS X Yosemite 10.10.3

  1. Start your VM and Log in as an Admin (If your VM is running it will typically already be logged in as Admin, unless you have multiple users set up)
  2. Click the Apple menu (the little Apple logo at the top left corner of the screen), then choose System Preferences...
  3. The System Preferences window will open
  4. Choose the Users & Groups icon (it's at the bottom left of the window)
  5. The Users & Groups window will open
  6. Click the name of the Current User in the left column (typically your user name with the word Admin below it)
  7. Towards the top right of the window click Login Items (it's next Password)
  8. Near the bottom of the window click the black + (plus sign, not the greyed out one in the left column)
  9. An Applications window should open (if it doesn't say Applications for some reason, you can select it by clicking the little up ^ & down v arrows at the top centre of the window)
  10. Click the beamoff icon, then click the Add button at the bottom right of the window
  11. You should now have the beamoff Application listed under These items will open automatically when you log in:
  12. If you want to remove it, first click beamoff from the list and then click the black - (minus sign, not the greyed out one in the left column)

I hope this helps. :)

 

Obviously there are slightly quicker ways to do this, but if you are unfamiliar with OS X terminal, keyboard shortcuts & probably don't have a Mac Keyboard on the machine running the VM either, this is an easy way for beginners. It also helps familiarise yourself with how to navigate around the Mac desktop, which can be a little strange for people who have not used it before.

Share this post


Link to post
Share on other sites

Hello guys.  :)

I've just updated to VMWare Workstation 11. I'm running latest version of OSX 10.10 on Windows 7 64-bit, Intel i5-4690K, GTX970, 8GB.

Previously, even after update to Yosemite, "Fit Guest" feature worked like charm (and it's very useful, indeed!). But after update to VMWare 11 it's always grayed out now. I've tried re-installing VMWare Tools, re-installing latest VMsvga2 1.2.5, but no luck - it doesn't work anyway... Why so? I there a way to fix it? I would be very thankful for help!

Share this post


Link to post
Share on other sites

I have issues too with VMW11 and OSX 10.10 or 10.9, it's just not booting anymore, I analyzed log files and it seems config file have not the same name as in VMW10, perhaps a bad uninstall and registry errors... investigating. If I can't find the clue, I'll rollback to VMW10 + Maverick.

Share this post


Link to post
Share on other sites

Hi

I look for issue with El Capitan, and currently have no ideas for solution.

Standard application "Quartz Debug" from "Graphics Tools for Xcode" crashes on 10.11.

I think: this is time issue, because Apple must fix issue with "Quartz Debug". When they do it, maybe beamoff start working correctly

Otherwise updated "Quartz Debug" can be disassembled and patch applied too.

Stay tuned ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×