Jump to content
Mac_hack13

Need support for post installation on an hp laptop

5 posts in this topic

Recommended Posts

Hello

 

i managed to install yosemite on HP g6-2290sx using clover efi r2953 ...

 

i ve got the trackpad,keyboard,battery and audio working...

 

However i cant get the intel HD 4000 to work as it should, it has only 4 mb vram and graphics are slow and has artifacts.

also i need to get the ralink wifi and bluetooth and the realtek ethernet to work...

 

list of hardware:

Audio IDT working automatically

GPU intel HD 4000 not working preoperly

trackpad working

keyboard working

USB working

battery working

ralink wifi not working

ralink bluetooth not working

realtek ethernet not working properly

 

Thanks

Share this post


Link to post
Share on other sites
Advertisement

i looked up the page but it didnt work also there is a fake id thing which i cant figure out...

i tested 0x01660003 3 ports 1024 vram....same


update...

it now works with 0x016600003 and duallink 0

fakeis is 0x00000000

 

but the the brightness is reduced a little and the apple logo is washed out when booting

Share this post


Link to post
Share on other sites

how to make the HP webcam work?

are there any kexts for ralink/mediatek RT3290 wireless and bluetooth?

is there any guide to fix the brightness?

in the middle of the booting proccess the apple logo gets washed away in a way similar to incorrect edid injection,any fix for that?

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By k.panic
      Hi to all!

      I've installed Yosemite on:
      - i5 4690
      - ASRock H87M Pro4 (with intel ethernet I219-V) (IntelMausiEthernet, AppleIntelE1000 and RehabMan for I219V kexts)
      - 8gb ddr3 RAM
      - 1tb hard disk
       
      If I disable I219-V from BIOS, when I shutdown it, don't reboots (tested with all kexts)
      If I enable I219-V from BIOS, when I shutdown it, the system reboots.
       
      How can I fix this? Thanks!
    • By alpha.delta
      I installed macOS 10.15 Catalina on my Lappy.
      Everything work fine but only DW1510 BCM94322HM8L wont work.
      DW1510 BCM94322HM8L work OOB on 10.14.x but not on 10.15.
      I need help.
      --------------------------------------------------------------------------------------
       
      Solved By put IO80211Family.kext from macOs 10.14.5 to Clover/Kexts/10.15

    • By Gigamaxx
      Catalina seems to be a read only kext system so modifying kexts to make older hardware work doesn't seem to be possible at this point.   However we have had success using Mojave kexts to get hardware to function.
       
      For bluetooth on Broadcom WiFi cards using injectorkext and adding the Mojave bluetooth kexts to System/Library/Extensions folder seems to have solved the connectability issue.   Install Mojave kexts and use kext utility to repair permissions and caches before reboot.   The Zip contains the Catalina original kexts as a backup in case you want to revert.  
       
       
      Bluetooth kexts fix.zip

       
       
       
      For Atheros WiFi we are using Mojave modified with High Sierra kexts.   Install in System/Library/Extensions folder and use kext utility to repair.
       
       

    • By 그맆조닛
      Hi there
       
      can someone please compile AirportBrcmFixup.kext and other Broadcom kexts for macOS Catalina
×