Jump to content
InsanelyMac Forum
todesto

[SpeedStep] Can't load modified IOPlatformPluginFamily.kext

Recommended Posts

I am using MacPro 5,1 sambas and don't want to change it to other due to iCloud and iMessage log in issue.

 

I have been modifying IOPlatformPluginFamily.kext to use macmini5,1 speedstep for my i5-2500k and was working.

 

However, now with Yosemite, it won't boot with such kext.

I can load modified kext such as applertc, applehda, AGPM, etc but this kext won't load nor applied to kernel cache.

 

because of this, my system is stuck at 3.4GHz.

 

any idea?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Advertisement

Yes. I do have kext-dev-mode=1 in Boot flag. 

I just can't boot, it is stuck at reboot loop.

When I boot with backup partition, delete such kext, it will boot without it.

Then when I install vanilla kext and rebuild cache, reboot, then it won't boot. Stuck at reboot again.

 

Can't figure it out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By xXConcasXx
      Salve,
      Possiedo un Asus N552VW UHD con le seguenti specifiche:
      Intel Core i7 6700hq con display 15 pollici in 4K
      Grafica integrata Intel HD 530
      Grafica dedicata NVIDIA GeForce GTX 960m 4GB
      Chipset Intel HM 170
      16 GB RAM DDR4 2400 MHz
      1 SSD m.2 512 GB
      1 HDD SATA 1 TB
      1 HDD SATA 1 TB (ho rimosso il masterizzatore)
      WiFi Broadcom BCM94352Z M.2 NGFF con Handoff e AirPort
      con i seguenti OS gestiti da un'unica partizione EFI:
      macOS High Sierra 
      Windows 10
      Kali Linux
      Con tanta pazienza sono riuscito a fare funzionare tutto ad eccezione del lettore SD, Thunderbolt, forse HDMI (non l'ho testato), e FaceTime con iMessage.
      Ci tengo che sia iMessage che FaceTime funzionino (ho anche chiamato l'assistenza Apple per darli il codice errore e risolvere il problema, peraltro mi hanno fatto il controllo remoto con Apple Care, e con un po di fesserie inventate e la stupidità dell'operatore non si sono accorti che non era un MacBook, tuttavia il problema non è stato risolto)...
      Stavo pensando, se installassi El Capitan in un'altra partizione con Rt Variables e SMBIOS che uso su High Sierra potrei riuscire ad abilitare FaceTime e iMessage? Da quello che so la percentuale di successo su quella versione è più alta.
      Vi pongo questa domanda perchè non sono sicuro se sia fattibile e volevo sentire qualche parere in merito.
      PS: Nel caso sia possibile tutto ciò, quante probabilità ho di riuscire a installare El Capitan con questo hardware (non mi interessa che funzioni tutto, mi basta il minimo indispensabile per avviare l'OS con internet), poi, dove potrei trovare il link di download possibilmente a una build più vecchia possibile?.
      PSS: Ho già seguito diverse volte An iDiot's Guide To iMessage senza risultato.
       
      Grazie per l'attenzione.
    • By ammoune78
      Hey guys, I have problem of getting my iCloud account locked after each install of macOS, SMBios appear to be working on EveryMac and Apple, but I'm using MacBook Pro 9,2 and previously MacBook Pro 11,2 and same thing again AppleID locked for security reasons.
      Is there something to do, to change, thanks!
    • By giacomo.dessi2303
      Salve a tutti, ho un problema all'avvio di mac os che ho già provato a risolvere con foskvs ma senza risultati..
      Attualmente come smbios uso MacBookPro 12,1 (portatile in firma) mentre se uso imac 14,1 questo problema non si presenta.
      Dite che posso tenere iMac 14,1 magari rigenerando l'ssdt per il pm?
    • By Trung_Nguyen
      Hi guys,
      Today, I tried to switch the SMBIOS to the MBA5,2 from MBP9,2 to try the PowerNap.
      When I online, Apple Locked my iCloud password and I have to reset it.
      But, the thing is that a years ago, I start Hackintosh with 10.11.5 and use the MBA5,2 SMBIOS like from the tutorial by Jake Lo from OSXLatitude.
      I have to reset the password many times, almost after every minor/major update.
      But when I switch to the MBP9,2 like Herve, Everything went well, Apple seem to accept it.
      So, I thought maybe Apple have a list of SMBIOS model that shouldn't be fake and a list that contain fake-acceptable?
      I'm not sure about it because it may caused by the Fake serial number?
      Anyway, Have a good day!
×