Jump to content

[HELP] XFX ATI Radeon HD 5770 1 GB no display monitor active on OSX Mavericks and Yosemite


12 posts in this topic

Recommended Posts

Hello everyone.


I started a new config for my project from my PowerMac G4 400 AGP: 

- Gigabyte GA-B75M-D3H (rev. 1.2)

- Intel Pentium G620 (LGA 1155)

- XFX ATI Radeon HD 5770 1GB (HD577AZNFC)

- LG 22MT45D connected in HDMI


And I have a problem with the graphics card: kexts are loaded OOB but monitor are not detected and are not activated.


The monitor displays the verbose or logo of the gray apple, but the system works. 


I can enter the GUI by the VNC control (integrated natively in OSX).


I tried with Mavericks 10.9.0, 10.9.5 and 10.10.0 Yosemite: the result is the same each time

For Yosemite, I used Chameleon 2.2


I attach with this post, the more possible information :

- Yosemite-SysInfo.zip

- org.chameleon.Boot.plist

- Kext Wizard.txt


Note : GraphicsEnabler=No cause a Kernel Panic.


I'm sorry if what I say is bad writing (though I do not speak much English).


Could you give me advice to help me? 

Thank you very much.

Kext Wizard.txt



Link to comment
Share on other sites

No idea what the problem is, it should at least give you an output. Does it work while booting with -x? I can see you used Tonymac tools, do you enable some kind of graphics “fix” with it? I have no idea what it does to the system. Can you change the SMBIOS information to something newer, like MacMini5,1 or iMac12,1.


For now let’s try with a fixed DSDT and see what happens.



Link to comment
Share on other sites

I attached :

- Camera picture of Verbose mode with -x and without (Without your DSDT)

Camera picture of With your DSDT (Verbose mode with -x and without)

- Screenshot of Post-Installation option (for me there is no graphics fix but I could be wrong)


To install your DSDT, I renamed DSDT.dsl in DSDT.aml (I placed it in / Extra) then I said in org.chameleon.Boot.plist


I have not had time to change SMBIOS information, but I will.



Link to comment
Share on other sites

My bad, I should have uploaded the aml instead. And you can’t just rename it, you’ve gotta compile the binary.




And please don’t use those “beast” tools, you won’t get any help here if you do. To install the DSDT just place it into the Extra folder or in the root of the partition.

Link to comment
Share on other sites

No problem, I'll try again with your DSDT.aml in /Extra and I will say so in org.chameleon.Boot.plist 


Sorry for the capture of the tool, but it was in answer to your question : "do you enable some kind of graphics “fix” with it?"


Thank you very much for your help :)

Link to comment
Share on other sites

I used the new DSDT, but the result did not change:

- Kernel Panic when GraphicsEnabler=No

- Versobe displayed only on monitor and GUI available by VNC only when GraphicsEnabler=Yes


I am ready to resume my installation from scratch.


This page offers installation method to Clover, but I find it very complicated. 
Could you give me some advice?
Link to comment
Share on other sites

The Intel graphics is disabled in the BIOS and it has always been. 

But it's true that I can withdraw my 5770 and enable the Intel HD and re-install to see. 


For PCIRootUID I'm already doing tests with this setting, it gives it to remember: 

- With 0 it gives a Kernel Panic 

- With 1 it behaves as I already write 

But I can always try again to be sure of that. 


To patch the famebuffer, I do not quite understand what I should do. 


As for a clean installation, I tried several times to do a post-install with Clover. 

But my best result in the boot was a nice Kernel Panic. 

But I'm still going to experiment, I hope that if I can at least boot the system then we can go further. 


Thank you for your help.

Link to comment
Share on other sites

I found this post and I tried these settings but I have no change: no GUI display on my HDMI monitor : http://www.hackintoshosx.com/topic/16981-guide-xfx-hd5770-triple-monitor-1083/


Attached the org.chameleon.Boot.plist used the + /Extra/1002_68B8.rom 


Kernel Panic with the boot options manually typed: 

  • GraphicsEnabler=No + PCIRootUID=0
  • GraphicsEnabler=No + PCIRootUID=1
  • GraphicsEnabler=No 
  • GraphicsEnabler=Yes + PCIRootUID=1
Standing with verbose GUI available for VNC 

  • GraphicsEnabler=Yes 
  • GraphicsEnabler=Yes + PCIRootUID=0


I put instead of /Extra/1002_68B8.rom but it gives the same results.









Link to comment
Share on other sites


  • Create New...