Jump to content
KazWolfe

[REQ] Help for patching ALC668 on Asus Q550-LF

4 posts in this topic

Recommended Posts

Hello!

 

I have an Asus Q550LF running Mavericks 10.9.0, Niresh Edition.

 

Currently, I have most things working, but a priority is audio.

 

It is a Realtek ALC668. It has two inputs and three outputs:

 

- Combined Mic/Headphones port (1 in, 1 out)

- Built-in Microphone (in)

- 3 front laptop speakers (out)

- Subwoofer port (out) [priority=0]

 

I have read some basic guides on how to patch the AppleHDA, but I have no idea where to start as this is my first ever Hackintosh.

 

I have Windows 8, Ubuntu, and Clover all as available tools to help me fix this.

 

Can someone please try to walk me through how to create a KEXT for my PC?

 

Thanks!!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By JRevenge
      Ciao ragazzi,
      alla fine sono riuscito a risolvere il problema che riscontravo qualche mese fa, dopo l'ottima EFI sistemata da @gengik84 e l'ho risolto rimuovendo dart=0 che creava kernel panic e problemi quando la batteria scendeva sotto ad un livello di batteria basso. Adesso il sistema non crea più problemi di kernel panic, ma volevo chiedervi se allo stato attuale secondo voi c'è qualcos'altro da ottimizzare.
       
      Vi allego la EFI.
       
      Grazie anticipatamente.
      CLOVER.zip
    • By TheAngryYeti
      So after a gazillion tries with High Sierra, i gave up and decided to try Mojave. I had nothing to lose, afterall.
       
      I started from scratch. I reformatted my thumb drive. Made it bootable from the Mojave [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Booted with it. Selected my language. It installed a little bit. Rebooted. I Booted from the SSD. Installed a bit more. Rebooted. I Booted from the SSD again and it finished the installation.
       
      I went through the basic setup and got to the desktop. I ran [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and selected my options and "built" it.
       
      Thinking i was a-ok, i decided to reboot, just to make sure all was well.
       
      After about 1min, i lose display.
       
      I thought i had messed something up in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], so i decided to go back to my mac mini, redo the thumb drive all over again.
       
      I go to boot from the thumb drive and when i get to the language selection screen, i lose all USB usage, so i cant even get in to wipe the SSD and start over. So, Mojave is still on the SSD, but i cant get to it because i lose display.
       
      Im attaching a screenshot of Verbose mode right before i lose display.
       
      I would greatly appreciate any help to get back into it or at least help getting it re-installed!!
       
      -Sin

    • By TheAngryYeti
      First, my build:
       
      Asus ROG Strix H370-I mobo
      i5 8400 cpu
      32gb ddr 4 2133
      1tb samsung evo 860 ssd
       
      Ive finally gotten to the point where the installation of HS loads to the language selection screen, but then i lose all usage of every USB port.
       
      Im at a loss of what to do from here.
       
      According to others, i have the proper files in the kexts/other folder as well as the drivers64UEFI folder.
       
      Does anyone have any suggestions as to what i can do? Im getting kinda desperate as ive been at it for a week now and this is as far as ive gotten.
       
      -Sin
       
       
    • By TheAngryYeti
      So I FINALLY got my High Sierra thumb drive to boot and once I got to the language selection screen, I noticed I lost all connectivity to my keyboard and mouse.
       
      i tried plugging in both into all of my USB ports (2.0, 3.0, 3.1) to no avail.
       
      i made sure I had the latest USBInject kext and XHCI-Unsupported kext in the Other folder.
       
      i also noticed whilst troubleshooting, the thumb drive will ONLY boot using Verbose and plugged into one of the 2 3.1 ports.
       
      does anyone have ANY suggestions?? I’ve been struggling for a week now on this!!
       
      thanks in advance
       
      -Sin
       
      Build: Asus ROG Strix H370-I, i5 8400, 32Gb ddr 4 2133, 1Tb Samsung EVO 860 ssd
    • By grisno
      Hi people,
       
      Installer to activate the sound card REALTEK ALC282-v2 (10ec:0282) with LayoutID 1 or 3 in MacOS. This installer does not contain AppleHDA patched Kext. To work properly, it must be installed over vanilla AppleHDA.kext.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      Speakers : OK Headphones : OK HDMI Audio : OK (Intel HD4K Tested) LineIn : N/A (Model Without LineIn) MicInt : OK MicIntNoiseReduction : OK MicExt : N/A (Model Without MicExt) AutoDetectLineIn : N/A (Model Without LineIn) Sleep : OK WakeUp : OK AutoSleep : OK Hibernate : OK Siri : OK   Tested Laptops:
       
      - HP Pavillion 15-D002SS
       
      Coming Soon:
       
      - Unified installer for the different supported operating systems.
      - Support model with LineIn jack.
       
      Modified Verbs:
      01271C20 01271D00 01271EA0 01271F90 01471C10 01471D00 01471E17 01471F90 01871CF0 01871D00 01871E00 01871F40 01E71CF0 01E71D00 01E71E00 01E71F40 02171C30 02171D10 02171E21 02171F00 01470C02   DSDT:
       
      Patch to apply with MaciASL in your DSDT
      ######################################### HDEF v1.00######################################## into method label _DSM parent_label HDEF remove_entry;into device label HDEF insertbeginMethod (_DSM, 4, NotSerialized)\n{\n If (LEqual (Arg2, Zero)) { Return (Buffer() { 0x03 } ) }\n Return (Package()\n {\n "layout-id", Buffer() { 0x01, 0x00, 0x00, 0x00 },\n //"layout-id", Buffer() { 0x03, 0x00, 0x00, 0x00 },\n "hda-gfx", Buffer() { "onboard-1" },\n "PinConfigurations", Buffer() { },\n })\n}\nend;  
×