Jump to content
yehia2amer

[Help] Core i7-720QM Power Management & Speedstep

27 posts in this topic

Recommended Posts

the Problem: I am trying to enable Power Management & Speedstep in i7-720QM CPU

 

Speed stepping used to work in previous versions of OS X, using old ver of ssdtPRGen.sh but after Mavericks it don't work

 

 

i tried to use the newest ver of ssdtPRGen.sh but it don't support my processor, i even tried to contact with Piker but he confirmed that he don't support this CPU

 
 
 
 
I would greatly appreciate any help

Share this post


Link to post
Share on other sites
Advertisement

You don't need SSDT.

 

Just use Generate P e C states.

 

when i try to use only clover, the Multiplier became always "7" or 931MHZ which is the min Frequency 

but when i use the current SSDT it always use the highest Multiplier "12" or 1.2GHZ (Static) no change in Frequency and no Turbo boost !

 

using SSDT :

post-307642-0-32787900-1410086979_thumb.png

 
 
without SSDT (Clover only):
 

post-307642-0-04689700-1410087007_thumb.png

 

post-307642-0-15487200-1410087037_thumb.png

 

post-307642-0-73052700-1410087145_thumb.png

Share this post


Link to post
Share on other sites

hello

 

should use macbookpro6,2 smbios...

 

try this extract all ur bios tables with clover

 

Fn + F4

 

is gonna be saved in CLOVER/ACPI/Original

 

copy from there all ssdt tables to CLOVER/ACPI/patched folder..

 

then in clover set

 

DropOEMSSDT=True

 

Generate P-States=False

 

Generate C-States=False

 

is just a test

 

good hack

Share this post


Link to post
Share on other sites

What SMBios you use?

i tried macbookpro6,2 and macbook air but it don't change anything !

 

hello

 

should use macbookpro6,2 smbios...

 

try this extract all ur bios tables with clover

 

Fn + F4

 

is gonna be saved in CLOVER/ACPI/Original

 

copy from there all ssdt tables to CLOVER/ACPI/patched folder..

 

then in clover set

 

DropOEMSSDT=True

 

Generate P-States=False

 

Generate C-States=False

 

is just a test

 

good hack

The Same result the Multiplier is always "7" or 931MHZ which is the min Frequency !

so i reverted back to my edited SSDT.aml

 

but i noticed accedently that when my hackintinosh go to sleep and wake up again, speedstep works perfectly :)

 

so what could be the problem !!!

Share this post


Link to post
Share on other sites

using clover

works for up to yosemite(works in el capitan too but sleep and shutdown don't seem to be working)

use smbios macbookpro6,2

don't generate c-states

don't generate p-states

don't drop oemssdt

should only have DSDT in the patched folder(if patched)

Share this post


Link to post
Share on other sites

using clover

works for up to yosemite(works in el capitan too but sleep and shutdown don't seem to be working)

use smbios macbookpro6,2

don't generate c-states

don't generate p-states

don't drop oemssdt

should only have DSDT in the patched folder(if patched)

This wouldnt work always because the power management is done by BIOS and some laptops do not support bios pwm.

Share this post


Link to post
Share on other sites

Sorry to wake up this thread. I have same CPU and therefore unsupported by Piker.

So I have copied all 5 SSDTs generated using Clover into patched folder and then added them in the list in config.plist

I'm using MPB6.2

 

I've seen my CPU x multiplier in HWMonitor all over the place. From 7 to 15. So I think turbo working fine. I also see perceptible performance increase especially as soon as I login, screen renders much faster with tray icons.

 

My real issue is instant wake on sleep. Since the original poster here seems to have had the same issue, was wondering if he solved it.

Share this post


Link to post
Share on other sites

can you explain what you mean by this highlighted part, how you did this?

 

and then added them in the list in config.plist

Sorry to wake up this thread. I have same CPU and therefore unsupported by Piker.

So I have copied all 5 SSDTs generated using Clover into patched folder and then added them in the list in config.plist

I'm using MPB6.2

 

I've seen my CPU x multiplier in HWMonitor all over the place. From 7 to 15. So I think turbo working fine. I also see perceptible performance increase especially as soon as I login, screen renders much faster with tray icons.

 

My real issue is instant wake on sleep. Since the original poster here seems to have had the same issue, was wondering if he solved it.

Share this post


Link to post
Share on other sites

@macq, First and foremost, I'm not sure I'm supposed to do *this*

F2+F4 at Clover Boot screen will dump various aml files to Clover/ACPI/origin

Then in config.plist add them in sequence.

Sometimes you will get duplicate SSDTs. A clue is if two file sizes are the same.

 

BUT, once again, I don't think one is supposed to do this, while I dare say, my laptop is running much faster than it did before and also boots faster. For instance, previously after login, it took a while for all my tray app icons to load. Now it is instantaneous.

 

Needless to say, my quest is to try and solve my power issues causing instant wake. I know EHC2 is the culprit probably the WebCam preventing the sleep. Either I fix it or maybe figure out how to write script to disable it and enable it, so I can leave it disabled, get my sleep, and enable at will only when I need.

Share this post


Link to post
Share on other sites

First, you should not take any SSDTs which have names with a letter following a number. So I only needed to take ONE of them.

Second, just look at config.plist docs. There is a place in bottom right in the UI below where you specify DSDT where you can add your SSDTs.

Share this post


Link to post
Share on other sites

First, you should not take any SSDTs which have names with a letter following a number. So I only needed to take ONE of them.

Second, just look at config.plist docs. There is a place in bottom right in the UI below where you specify DSDT where you can add your SSDTs.

So if I have ssdt like SSDT-1x.aml to 4x and SSDT-0, I leave all the x ones and put yne 0 one in gui cloverconfigurator by drag and drop.

Is that it?

Share this post


Link to post
Share on other sites

@macq

I just go to finder, click on the ssdt pretending to rename it, then copy to  clipboard

Then go to clover configurator, hit +, then paste and type ".aml".

Can't get any simpler than that.

 

And oh by the way, don't take any SSDTs which have a letter after the number before ".aml". They don't help but I don't know if they hurt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By IOIIIO
      It took some messing around, but I have made a kext patch which can be used as a superior alternative for NullCPUPowerManagement.kext.

      Since it still allows AICPM to load, we can now load X86PlatformPlugin and by extension AGPM on a system where CPU PM doesn't work. This is useful on for example AMD systems, where CPU PM cannot be enabled properly.

      So far tested on Catalina and High Sierra, but should also work on other versions, and is reported to give very decent performance improvements when paired with an appropriate SSDT-PLUG SSDT and AGPM injector kext.
       
      Does not work in combination with NullCPUPowerManagement.kext
       
      From: D0 05 00 00 84 C0 74 46 E8 To: D0 05 00 00 84 C0 EB 46 E8 On: com.apple.driver.AppleIntelCPUPowerManagement  
    • By End3rPower50
      Hi, I want to install MacOS Catalina on my laptop.
      I was installed MacOS Mojave previously but i had a lot of problem, for example my wifi's card (Dell DW1820A) had a problem: My pc sometimes doesn't boot up or pc after some minutes crashed or slowed. 
      Now i want to try again to install macOS.
       
      this is my spec: 
      HP 15-AY034NL 
      CPU: i7 6500U  with HD520
      SSD: 500GB SSD Samsung
      Wifi & Bluetooth: Dell DW1820A (Bluetooth: BCM2045A0) (Wifi: BCM94350ZAE)
      USB 3.0 
      Ethernet: Realtek 8100
       
      Attached in this thread, my old clover configuration created by me (CLOVER OLD) and clover with Wifi driver (CLOVER) created by Hervè (I had asked help at insanelymac's community)
       
      P.S SORRY FOR MY BAD ENGLISH.
      Thanks in advance 
      -ANTONIO
      CLOVER OLD.zip
      CLOVER.zip
    • By ale003
      Boa noite galera!
       
      já a alguns anos que tenho hackintosh, é um I7 6700K em uma Asus Maximus Hero VIII Z170 com GPU RX480 8gb
      Porém desde sempre tenho congelamentos aleatórios, na maioria das vezes quando coloco um filme pra exportar no final cut. mas já aconteceu enquanto via videos ou escutava musicas no spotify e recentemente até ao ligar o computador, mal ligou congelou. ele congela todo não dá pra mexer em nada, só desligando segurando botão power que ele volta.
       
      Me disseram que era gerenciamento de energia, eu baixei a DSDT do meu processador, segui alguns outros tutoriais e ainda nada. não consigo de jeito nenhum resolver esse problema, já instalei varias versões desde o yosemite até o High sierra, e ainda nada. Só esse pequeno detalhe que me desanima do Hack. 
       
      Alguem pode ajudar?
       
      High Sierra 10.13.6
      Asus Maximus Hero VIII
      RX 480 Nitrous + 8GB
      Trident Z 16GB DDR4 3200MHZ
    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
    • By vin047
      Hi, have an old Asrock X58 Deluxe motherboard with an i7-920 Nehalem CPU (yes old board ) + AMD RX460 . As per the title, i've managed to get Mojave installed and running with Speed Step working too!
       
      Final issue i'm having is with sleep - it sleeps fine and even responds to keyboard/mouse event, but instead of waking up to the desktop it restarts and loads from BIOS boot screen. When finally booted into macos, it restores as if restored from unexpected shutdown (though no error is shown).
       
      I've tried for days to get it working, sometimes depending on clover config changes, I can get it to wake up without reboot, but it just remains at a black screen and is unresponsive. 
       
      I have no custom DSDT, i've tried writing one but don't know really know what i'm looking for? Currently relying on clover patches. I've uploaded my original DSDT (dumped from Clover, F4 option) + current config. Anyone have any ideas?
      dsdt original.zip
      config.plist.zip
×