Jump to content
tchospy

Vaio users black screen after boot

218 posts in this topic

Recommended Posts

Hello!

 

Can't get internal LCD to work on my Vaio-SZ770. There is no EDI* in DSDT or SSDT etc.

Have tried EDID injection via Clover - no luck.

 

Will attach ioreg, DSDT, clover boot log later today.

Share this post


Link to post
Share on other sites
Advertisement

Have a look into my vaio f11 dsdt (see signature), how I inject the nvidia device and adapt it for your device (changed device Id etc). Do it exactly the way I did.

 

Those vaios need some special nodes in that nvidia part to have a working internal scree , and the clover devs did not realize until now.

Share this post


Link to post
Share on other sites

Have a look into my vaio f11 dsdt (see signature), how I inject the nvidia device and adapt it for your device (changed device Id etc). Do it exactly the way I did.

 

Those vaios need some special nodes in that nvidia part to have a working internal scree , and the clover devs did not realize until now.

Unfortunately, in my DSDT there is no EDI data and in your DSDT there is EDI*, so I have no clue where to include edi patch in my case :/

My internal LCD EDID:

00 FF FF FF FF FF FF 00 3A C4 00 01 00 00 00 00 2D 0C 01 03 80 20 14 00 EA A8 E0 99 57 4B 92 25 1C 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 94 1B 00 AD 50 20 0A 30 40 40 42 00 42 C9 10 00 0A 30 40 40 42 00 42 C9 10 00 64 69 61 20 44 65 66 61 75 6C 00 00 00 FC 00 74 20 46 6C 61 74 20 50 61 6E 65 6C 00 00 00 00 FD 00 00 3D 1D 31 08 00 00 20 20 20 20 20 00 00 C8 

Original DSDT and patched by Clover:

 

Archive.zip

Share this post


Link to post
Share on other sites

So, the actual problem is not with the EDID in my case, as I've managed to wake-up internal display with "Inject Nvidia ON" in Clover and then after macOS boot going to System Preferences -> Displays - > Detect Displays. Then the internal LCD wakes up and works great, the second way to wake-up the internal LCD is to put the laptop to Sleep and then wake it up - internal display start to work. As soon as it's on then I can do sleep etc with no problems - it works till reboot.

Have no clue why it happens: tried fixing NGFX in DSDT to GFX0, IGPU - the same: internal LCD works on macOS boot (apple logo and the boot progress 50%) then it switches to my external LCD and to make it work again - Detect Displays or Sleep.

 

One suspect is the mac model - Clover suggested MacBookPro5,1 in my case (MBP5,1 has the internal GPU and discrete GPU) - probably can cause the issue with internal LCD - will change it to MacBookPro4,1 (with the same GPU and CPU as my laptop).

Share this post


Link to post
Share on other sites

AFAIK "GFX0" usually is AMD, "IGPU" is intel, "NGFX" or similar is nvidia. I guess no need to change that.

 

So do you have an intel GPU + nvidia?  I remember there was a problem with that and lot of people then only used the intel gpu... I don't know then :)

Share this post


Link to post
Share on other sites

AFAIK "GFX0" usually is AMD, "IGPU" is intel, "NGFX" or similar is nvidia. I guess no need to change that.

 

So do you have an intel GPU + nvidia?  I remember there was a problem with that and lot of people then only used the intel gpu... I don't know then :)

Yes, Intel GPU + Nvidia, but Intel GPU is old and is not supported after 10.8, so I use Nvidia GPU only.

Share this post


Link to post
Share on other sites

Anyone can help me guys to get my internal screen works!! I try to get it work for days :/ 

  1. Corrupted ioreg, please use IORegistryExplorer Version 2.1
  2. Extract the EDID from windows/linux and attach it here.

Share this post


Link to post
Share on other sites

 

  1. Corrupted ioreg, please use IORegistryExplorer Version 2.1
  2. Extract the EDID from windows/linux and attach it here.

 

 

Actually I don't have a duel boot on my device but I have a virtual Windows if this work :/ 

Archive.zip

Share this post


Link to post
Share on other sites

You can use Linux LiveUSB to extract the EDID.

 

I installed fedora LiveUSB and tried to get the EDID and that's what I got using the terminal..

 

 

[liveuser@localhost ~]$ xrandr --verbose

Screen 0: minimum 320 x 200, current 2624 x 900, maximum 8192 x 8192

XWAYLAND0 connected 1600x900+0+0 (0x24) normal (normal left inverted right x axis y axis) 360mm x 200mm

    Identifier: 0x21

    Timestamp:  41668

    Subpixel:   unknown

    Gamma:      1.0:1.0:1.0

    Brightness: 0.0

    Clones:    

    CRTC:       0

    CRTCs:      0

    Transform:  1.000000 0.000000 0.000000

                0.000000 1.000000 0.000000

                0.000000 0.000000 1.000000

               filter:

  1600x900 (0x24) 118.000MHz -HSync +VSync *current +preferred

        h: width  1600 start 1696 end 1856 total 2112 skew    0 clock  55.87KHz

        v: height  900 start  903 end  908 total  934           clock  59.82Hz

XWAYLAND1 connected 1024x768+1600+0 (0x25) normal (normal left inverted right x axis y axis) 0mm x 0mm

    Identifier: 0x23

    Timestamp:  41668

    Subpixel:   unknown

    Gamma:      1.0:1.0:1.0

    Brightness: 0.0

    Clones:    

    CRTC:       1

    CRTCs:      1

    Transform:  1.000000 0.000000 0.000000

                0.000000 1.000000 0.000000

                0.000000 0.000000 1.000000

               filter:

  1024x768 (0x25) 63.500MHz -HSync +VSync *current +preferred

        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock  47.82KHz

        v: height  768 start  771 end  775 total  798           clock  59.92Hz

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 18/8/2017 at 8:15 PM, jl4c said:

help me

hi jl4c

my dsdt e ioreg  for support me .i have screen only on monitor

on Sony vaio 13vpcs9e

thank

Archivio.zip

Edited by vrondena

Share this post


Link to post
Share on other sites

@vrondena,

You need to inject the internal display EDID in the ACPI tables through a SSDT. You can use the following example:

DefinitionBlock ("", "SSDT", 2, "Sony", "VAIO", 0)
{
    External (_SB_.PCI0.POP2.PEGP, DeviceObj)
    External (_SB_.PCI0.POP2.EDI3, PkgObj)
    Scope (_SB.PCI0.POP2.PEGP)
    {
        Method (_DSM, 4)
        {
            If (LEqual (Arg2, Zero))
            {
                Return (Buffer () { 3 })
            }
            Return (Package ()
            { "AAPL00,override-no-edid",  \_SB.PCI0.POP2.EDI3
            })
        }
    }
}

Use a Windows/Linux tool to extract the internal display EDID and compare it with your DSDT to find the correct value for EDIx, The above example use EDI3.

You can find more examples here

Buena suerte!

Share this post


Link to post
Share on other sites

sorry, but the EDID value extract only on win\linux   don't have installed on my vaio . I have create new ssdt with the example .insert on patches clover.

dsdt don't have edid and ssdt how create

 I'm  very confuse with this procedure 

support me, somos latinos

 

Share this post


Link to post
Share on other sites

resume. install and extract edid with win 8. install el capitan . compile SSDT-EDID5 (my dsdt show EID::no EDI::). number 5 is same. put on DSDT patches -reboot on hdmi monitor GE=YES - clover f4 - origin - dissamble DSDT.dsl - edid show on DSDT-SB.PCI0-POP2-PEGP (no able insert string). compile DSDT and put on patches clover. reboot ....black display on GE=YES. TV monitor is ok. create ioreg GE=Y e GE=no

need compile help.

Archivio.zip

Share this post


Link to post
Share on other sites

Try injecting additional values:

DefinitionBlock ("", "SSDT", 2, "Sony", "VAIO", 0)
{
    External (_SB_.PCI0.POP2.PEGP, DeviceObj)
    External (_SB_.PCI0.POP2.EID5, PkgObj)
    Scope (_SB.PCI0.POP2.PEGP)
    {
        Method (_DSM, 4)
        {
            If (LEqual (Arg2, Zero))
            {
                Return (Buffer () { 3 })
            }
            Return (Package ()
            {
                "AAPL, backlight-control", Buffer () { 1,0,0,0 }, 
                "@0,backlight-control", Buffer () { 1,0,0,0 }, 
                "@0,pwm-info", Buffer () { 1,20,0,100,168,97,0,0,8,82,0,0,1,0,0,0,0,4,0,0 }, 
                "AAPL00,override-no-edid", \_SB.PCI0.POP2.EID5
            })
        }
    }
}

Buena suerte!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By arsradu
      Hi guys,
       
      So, this little tutorial is meant to help people fix a new issue with Mojave: opening jpg files (looks like it happens with larger files, not so much with smaller ones) using Quick Look (on spacebar key pressed) or Preview app using the dedicated GPUs.
      The issue is that, when trying to open jpg files (for some reason, it doesn't occur with pngs), the pop-up window would remain in an endless loop. And from that point forward, any other app trying to open the same file, will either become unresponsive (in the case of the Preview app) or just stay in endless loop (in case of Quick Look)
       
      As a workaround, in case the tutorial below doesn't work for you, you can use Grab (built-in app in MacOS) to open said files.
       
      This issues DOES NOT occur using the iGPU. So...if you're comfortable using the iGPU, just switch to that and you should be good to go. You don't need this tutorial.
       
      This tutorial is based on @Cyberdevs' research and testing on this topic (especially useful if you're using an RX series AMD video card), and my own very limited time testing this on my rig. I just thought it would be useful to create a new thread for it so that people can discuss this particular issue here.
       
      The main thing we need to do is actually very simple: we need to enable the iGPU (integrated GPU) by default, in BIOS, while actually being connected to the dedicated GPU.

       
      With that being said, I'll just move on to the actual tutorial.
       
      New (probably better) method.
       
      Switch your SMBIOS in Clover config in regards to the dedicated GPU you're using. Take a look here and choose the corresponding SMBIOS closest to your hardware.
      Yeah, that's it.
       
      In case you lose CPU PM with this method, there are multiple ways to fix that, and they do not make the object of this thread.  It worked perfectly fine for me though and I didn't need to change anything else.
       
      In case you wanna try alternative medicine  ...
       
      For ATI GPUs (curtesy of @Cyberdevs' post here).
       
      The discreet GPU should be set as primary in BIOS and your displays should be connected to your discreet GPU
      The iGD/iGPU/iGFX must be enabled in BIOS/UEFI as the secondary GPU.
       
      I removed the DSDT Reconfigured the config.plist to and removed some flags which weren't needed because of the DSDT added the InjectATI + Ornioco Framebuffer (I removed the Orinoco framebuffer because of some weird glitches but it might be useful for other AMD GPUs if you inject the correct framebuffer according to your GPU. No need to inject anything for nVidia GPUs unless your GPU needs it) Added the InjectIntel + ig-platform-id for my intel HD530 (for intel HD 530 I use the 0x19120001 ig-platform-id) Removed com.apple.finder.plist Removed com.apple.QuickLookDaemon.plist rebuild the kextcache and reset the nvram  
      Steps 5 to 7 might not be necessary I just did them anyway, if anyone succeeded to get quicklook working without those steps let me know so I can exclude those steps.

           Also confirmed to work with AMD R9 270X on a SandyBridge rig (without an iGPU) using WhateverGreen + Lilu kexts, which also helped to solve the transparency issue along with the Quick Look problem, it also resolved the buggy Screen Capture (Command+Shift+5) issue as well. 
       
          Also, do:
      nvram cleanup kextcache & prelinked kernel rebuild reboot  More info on that here.
       
       
      For NVIDIA GPUs
       
      This is what I needed for my NVIDIA rig and the MSI motherboard in the signature. Your milage may vary, depending on your hardware. But, the idea should be the same regardless.
       
         For MSi motherboads (check out my motherboard details in the signature)
       
      Set your BIOS to use PEG (dedicated GPU) so you can boot.
      Since you're reading this, chances are that you're already connected to the dedicated GPU and the BIOS is set to PEG. So just go into BIOS and see if you're using the iGPU or the dedicated (PEG) graphics device by default.
      If you're already using this, skip to Step 3 (the part AFTER Reboot). Reboot (I think you don't necessarily need to boot into the OS...but you do need to reboot at least until Clover UI) Reboot back into BIOS and set it from PEG to IGD (integrated graphics) WITHOUT removing the cable. Save Reboot again.  
         The result should be that the OS is tricked into thinking you're booting with the IGPU when in fact you're using the dedicated GPU.
       
         For Gigabyte motherboards
       
         Set:
      Peripherals -> Initial Display Output -> iGFX Chipset -> Internal Graphics -> Enabled
           DVMT Pre-Allocation -> default 64M.
           DVMT Total Gfx Mem -> default 256M Save Reboot  
         You should do this with the cable connected to the dedicated GPU.
       
      You will also need to patch the iGPU from Clover config.
      1. Graphics -> Inject Intel (UNCHECK Inject Nvidia or ATI if it's checked).
      2. ig-platform-id (in my case for Intel HD 4600 Desktop) it was: 0x0d220003
       
      And use IntelGraphicsFixup.kext in Clover/kexts/Other. In my particular case, without the kext, I would get freezes in Safari.
       
      This might be a bug with Mojave and it could be fixed by Apple in the future. but in the meantime, feel free to use this if it helps you fix the issue.
       
      For HP motherboards (including laptops), so far no solution, unless the BIOS somehow allows to switch from eGPU to iGPU and vice-versa.
       
      Cheers!
    • By MaLd0n
      First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder   https://olarila.com/files/Clover.Folder/CLOVER.LGA775.zip   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.LGA775.zip     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Mojave Full DSDT patch http://olarila.com/forum/viewtopic.php?f=59&t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Install Clover UEFI in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace Folder CLOVER INSTALLATION.zip   --Install Sierra and boot into system!   --Install Clover UEFI and replace with my folder  CLOVER POST INSTALLATION.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edit... Run it RunMe.app   --DSDT My DSDT DSDT.ASUS H61M-A MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -EHCx -LPC -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -PNLF Clear NVRAM, Purge and Kextcache
          --FakeSMC http://www.hwsensors.com/releases --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
    • By IPN96
      Ciao mi scuso per il disturbo, io vorrei abilitare la mia scheda grafica Nvidia geforce gtx 950m per avere delle prestazioni migliori quando lavoro su after effect, la scheda Intel non è ha abbastanza memoria non so se sia possibile fare qualcosa, spero possiate aiutarmi, vi lascio delle info. 
      Sistema operativo Mac osx sierra 10.12.6 
      Modello laptop : Asus N551jx-cn043t
      Il resto è nella screen 
       
       

×