Jump to content
tchospy

Vaio users black screen after boot

221 posts in this topic

Recommended Posts

Hello!

 

Can't get internal LCD to work on my Vaio-SZ770. There is no EDI* in DSDT or SSDT etc.

Have tried EDID injection via Clover - no luck.

 

Will attach ioreg, DSDT, clover boot log later today.

Share this post


Link to post
Share on other sites
Advertisement

Have a look into my vaio f11 dsdt (see signature), how I inject the nvidia device and adapt it for your device (changed device Id etc). Do it exactly the way I did.

 

Those vaios need some special nodes in that nvidia part to have a working internal scree , and the clover devs did not realize until now.

Share this post


Link to post
Share on other sites

Have a look into my vaio f11 dsdt (see signature), how I inject the nvidia device and adapt it for your device (changed device Id etc). Do it exactly the way I did.

 

Those vaios need some special nodes in that nvidia part to have a working internal scree , and the clover devs did not realize until now.

Unfortunately, in my DSDT there is no EDI data and in your DSDT there is EDI*, so I have no clue where to include edi patch in my case :/

My internal LCD EDID:

00 FF FF FF FF FF FF 00 3A C4 00 01 00 00 00 00 2D 0C 01 03 80 20 14 00 EA A8 E0 99 57 4B 92 25 1C 50 54 00 00 00 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 94 1B 00 AD 50 20 0A 30 40 40 42 00 42 C9 10 00 0A 30 40 40 42 00 42 C9 10 00 64 69 61 20 44 65 66 61 75 6C 00 00 00 FC 00 74 20 46 6C 61 74 20 50 61 6E 65 6C 00 00 00 00 FD 00 00 3D 1D 31 08 00 00 20 20 20 20 20 00 00 C8 

Original DSDT and patched by Clover:

 

Archive.zip

Share this post


Link to post
Share on other sites

So, the actual problem is not with the EDID in my case, as I've managed to wake-up internal display with "Inject Nvidia ON" in Clover and then after macOS boot going to System Preferences -> Displays - > Detect Displays. Then the internal LCD wakes up and works great, the second way to wake-up the internal LCD is to put the laptop to Sleep and then wake it up - internal display start to work. As soon as it's on then I can do sleep etc with no problems - it works till reboot.

Have no clue why it happens: tried fixing NGFX in DSDT to GFX0, IGPU - the same: internal LCD works on macOS boot (apple logo and the boot progress 50%) then it switches to my external LCD and to make it work again - Detect Displays or Sleep.

 

One suspect is the mac model - Clover suggested MacBookPro5,1 in my case (MBP5,1 has the internal GPU and discrete GPU) - probably can cause the issue with internal LCD - will change it to MacBookPro4,1 (with the same GPU and CPU as my laptop).

Share this post


Link to post
Share on other sites

AFAIK "GFX0" usually is AMD, "IGPU" is intel, "NGFX" or similar is nvidia. I guess no need to change that.

 

So do you have an intel GPU + nvidia?  I remember there was a problem with that and lot of people then only used the intel gpu... I don't know then :)

Share this post


Link to post
Share on other sites

AFAIK "GFX0" usually is AMD, "IGPU" is intel, "NGFX" or similar is nvidia. I guess no need to change that.

 

So do you have an intel GPU + nvidia?  I remember there was a problem with that and lot of people then only used the intel gpu... I don't know then :)

Yes, Intel GPU + Nvidia, but Intel GPU is old and is not supported after 10.8, so I use Nvidia GPU only.

Share this post


Link to post
Share on other sites

Anyone can help me guys to get my internal screen works!! I try to get it work for days :/ 

  1. Corrupted ioreg, please use IORegistryExplorer Version 2.1
  2. Extract the EDID from windows/linux and attach it here.

Share this post


Link to post
Share on other sites

 

  1. Corrupted ioreg, please use IORegistryExplorer Version 2.1
  2. Extract the EDID from windows/linux and attach it here.

 

 

Actually I don't have a duel boot on my device but I have a virtual Windows if this work :/ 

Archive.zip

Share this post


Link to post
Share on other sites

You can use Linux LiveUSB to extract the EDID.

 

I installed fedora LiveUSB and tried to get the EDID and that's what I got using the terminal..

 

 

[liveuser@localhost ~]$ xrandr --verbose

Screen 0: minimum 320 x 200, current 2624 x 900, maximum 8192 x 8192

XWAYLAND0 connected 1600x900+0+0 (0x24) normal (normal left inverted right x axis y axis) 360mm x 200mm

    Identifier: 0x21

    Timestamp:  41668

    Subpixel:   unknown

    Gamma:      1.0:1.0:1.0

    Brightness: 0.0

    Clones:    

    CRTC:       0

    CRTCs:      0

    Transform:  1.000000 0.000000 0.000000

                0.000000 1.000000 0.000000

                0.000000 0.000000 1.000000

               filter:

  1600x900 (0x24) 118.000MHz -HSync +VSync *current +preferred

        h: width  1600 start 1696 end 1856 total 2112 skew    0 clock  55.87KHz

        v: height  900 start  903 end  908 total  934           clock  59.82Hz

XWAYLAND1 connected 1024x768+1600+0 (0x25) normal (normal left inverted right x axis y axis) 0mm x 0mm

    Identifier: 0x23

    Timestamp:  41668

    Subpixel:   unknown

    Gamma:      1.0:1.0:1.0

    Brightness: 0.0

    Clones:    

    CRTC:       1

    CRTCs:      1

    Transform:  1.000000 0.000000 0.000000

                0.000000 1.000000 0.000000

                0.000000 0.000000 1.000000

               filter:

  1024x768 (0x25) 63.500MHz -HSync +VSync *current +preferred

        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock  47.82KHz

        v: height  768 start  771 end  775 total  798           clock  59.92Hz

 

Share this post


Link to post
Share on other sites

@vrondena,

You need to inject the internal display EDID in the ACPI tables through a SSDT. You can use the following example:

DefinitionBlock ("", "SSDT", 2, "Sony", "VAIO", 0)
{
    External (_SB_.PCI0.POP2.PEGP, DeviceObj)
    External (_SB_.PCI0.POP2.EDI3, PkgObj)
    Scope (_SB.PCI0.POP2.PEGP)
    {
        Method (_DSM, 4)
        {
            If (LEqual (Arg2, Zero))
            {
                Return (Buffer () { 3 })
            }
            Return (Package ()
            { "AAPL00,override-no-edid",  \_SB.PCI0.POP2.EDI3
            })
        }
    }
}

Use a Windows/Linux tool to extract the internal display EDID and compare it with your DSDT to find the correct value for EDIx, The above example use EDI3.

You can find more examples here

Buena suerte!

Share this post


Link to post
Share on other sites

sorry, but the EDID value extract only on win\linux   don't have installed on my vaio . I have create new ssdt with the example .insert on patches clover.

dsdt don't have edid and ssdt how create

 I'm  very confuse with this procedure 

support me, somos latinos

 

Share this post


Link to post
Share on other sites

resume. install and extract edid with win 8. install el capitan . compile SSDT-EDID5 (my dsdt show EID::no EDI::). number 5 is same. put on DSDT patches -reboot on hdmi monitor GE=YES - clover f4 - origin - dissamble DSDT.dsl - edid show on DSDT-SB.PCI0-POP2-PEGP (no able insert string). compile DSDT and put on patches clover. reboot ....black display on GE=YES. TV monitor is ok. create ioreg GE=Y e GE=no

need compile help.

Archivio.zip

Share this post


Link to post
Share on other sites

Try injecting additional values:

DefinitionBlock ("", "SSDT", 2, "Sony", "VAIO", 0)
{
    External (_SB_.PCI0.POP2.PEGP, DeviceObj)
    External (_SB_.PCI0.POP2.EID5, PkgObj)
    Scope (_SB.PCI0.POP2.PEGP)
    {
        Method (_DSM, 4)
        {
            If (LEqual (Arg2, Zero))
            {
                Return (Buffer () { 3 })
            }
            Return (Package ()
            {
                "AAPL, backlight-control", Buffer () { 1,0,0,0 }, 
                "@0,backlight-control", Buffer () { 1,0,0,0 }, 
                "@0,pwm-info", Buffer () { 1,20,0,100,168,97,0,0,8,82,0,0,1,0,0,0,0,4,0,0 }, 
                "AAPL00,override-no-edid", \_SB.PCI0.POP2.EID5
            })
        }
    }
}

Buena suerte!

Share this post


Link to post
Share on other sites

I hope, someone can help me. I don't know, what I have to do. High Sierra work with the internal Monitor only with the flag nv_disable=1. If I start it without the flag, I can see via VNC viewer, that the GT330m work fine. 

 

Can someone help me, that the internal display work? My PC is a Sony Vaio VPCL14J9E (All-in-One) 24`Display: 1920x1080.

 

I upload my DSDT and the EDID (saved via Linux)

 

 

DUMP-EDID.txt

DSDT.aml

Share this post


Link to post
Share on other sites

Hi Guys, I can`t find the points in my dsdt which I have to change. My EDID is in, but it doesn't`t want to work

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Drovosek
      For my laptop Hp Pavilion 15-au028ur worked patch for HP 3165sf
      I also experimented with manual patching and assembled my own version:

      #Maintained by: RehabMan for: Laptop Patches #Battery_HP-DV6-1380ek.txt # created by RehabMan 2019-xx-xx # based on Battery_HP-DV6-1380ek.txt # additional patches for dv6-1380ek provided by chihab222, credit gsly # works for: #  HP Pavilion 15-au028ur, per Drovosek into method label B1B2 remove_entry; into definitionblock code_regex . insert begin Method (B1B2, 2, NotSerialized) { Return (Or (Arg0, ShiftLeft (Arg1, 8))) }\n end; # 16-bit EC0 registers #                BADC,   16, #                BFCC,   16, #                MCUR,   16, #                MBRM,   16, #                MBCV,   16, into device label EC0 code_regex BADC,\s+16, replace_matched begin ADC0,8,ADC1,8, end; into device label EC0 code_regex BFCC,\s+16, replace_matched begin FCC0,8,FCC1,8, end; into device label EC0 code_regex MCUR,\s+16, replace_matched begin CUR0,8,CUR1,8, end; into device label EC0 code_regex MBRM,\s+16, replace_matched begin BRM0,8,BRM1,8, end; into device label EC0 code_regex MBCV,\s+16, replace_matched begin BCV0,8,BCV1,8, end; # 16-bit method access into method label CLRI code_regex (\^.*)MBRM replaceall_matched begin B1B2\(%1BRM0,%1BRM1\) end; into method label UPBS code_regex (\^.*)MBRM replaceall_matched begin B1B2\(%1BRM0,%1BRM1\) end; into method label UPBI code_regex (\^.*)BFCC replaceall_matched begin B1B2\(%1FCC0,%1FCC1\) end; into method label UPBS code_regex (\^.*)MCUR replaceall_matched begin B1B2\(%1CUR0,%1CUR1\) end; into method label UPBS code_regex (\^.*)MBCV replaceall_matched begin B1B2\(%1BCV0,%1BCV1\) end;
      The only problem - when it reaches 100% charge, it no longer falls until you reset the CMOS (15-30 seconds hold down the power button on the laptop). In the rehabman guide there is a patch for ASUS in this case, there is a patch method FBST. There is no such method in my DSDT.
      Can someone help?
      Here's a patched and clean DSDT: https://vk.com/doc183234383_509697931
    • By Amit Meena
      This card is working OOB, but it has some graphical issues as per attachments.

      If someone has a solution please share.






    • By jamesxxx1997
      Hi everyone~
      Now using mojave 10.14.4 , I am patching my dsdt and ssdt but have four syntax error with my dsdt.dsl , and I don't know how to fix it.
       
      My specs:
      lenovo thinkpad x1 yoga 3rd
      CPU : i7-8550u
      graphics : uhd620
       
      The file of my dsdt and ssdt , ioreg , and my efi is in this link:https://drive.google.com/drive/folders/1T1nv1QgqDtczXrohdlQUJ_8O-kPpoSEf?usp=sharing
       
      thanks!
    • By bcuraboy3
      Good morning everyone. I have a HP Pavillion with the following specs
      I have managed to install MOjave on it, using Rehabman's config for Intel HD5500. 
      But I need some help with a DSDT for it.
      Would anyone be kind enough to have a look at the zip file, which contains the EFI folder, a IOREG, and some screenshots from DPCI Manager,
      and help me with a good DSDT patched and a correct config.plist for it?   
      Thank you very much.  Highly appreciated 
      I have also included a report from Aida64 in case anyone needs it 
       
      15-p200np
       
      Número do equipamento
      L5Z67EA
      Microprocessador
      Intel Core i7-5500U com placa gráfica Intel HD 5500 (2,4 GHz, 4 MB de cache, 2 núcleos);
      Memória
      SDRAM DDR3L de 4 GB a 1600 MHz (1 x 4 GB)
      Placa de vídeo
      NVIDIA GeForce 840M (DDR3 dedicada de 2 GB) >>  disabled already using the config.plist provided 
      Disco rígido
      SATA 1 TB 5400 rpm
      Unidade multimédia
      Gravador de DVD SuperMulti
      Visor
      HD BrightView com retroiluminação WLED de 39,6 cm (15,6 pol.) na diagonal (1366 x 768)
      Placa de rede
      Ethernet LAN Base-T 10/100 integrada
      Conectividade sem fio
      Combo 802.11b/g/n (1x1) e Bluetooth 4.0 (compatível com Miracast) >> It's not supported, but a DW1550 it's on it's way 
      Som
      BeatsAudio com 2 altifalantes >>  it's a ALC 290 
      Teclado
      Tamanho completo tipo ilha com teclado numérico
      Dispositivo
      HP Imagepad com suporte de gestos multi-toque
      Portas externas
      1 leitor de cartões multimédia SD multi-formato
      1 HDMI
      1 combinação auscultadores/microfone
      1 USB 2.0
      2 USB 3.0
      1 RJ-45
      Dimensões
      38,45 x 26,02 x 2,39 cm
      Peso
      2,27 kg
      Alimentação
      Transformador de alimentação CA de 65 W
      Polímero de iões de lítio 4 cél. 41 Wh
      Câmara
      Câmara Web HP TrueVision HD (frontal) com microfone digital de matriz dupla integrado
      Mac-Pro-Noi.zip
      Report.htm
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×