Jump to content
tchospy

Vaio users black screen after boot

220 posts in this topic

Recommended Posts

Test1

Thank you jl4c I will test as possible as soon I can. My pc have another issue right now. doesn't power on. thank you again.

Share this post


Link to post
Share on other sites
Advertisement

Hi j4c,

could not believe.

as i was reading this thread.

fixed black screen confusing me since weeks .

 

I was trrying a lot to fix Problems

About black screen on sony vaio VPC F11 Z 1 E 1. i have i7 749 quad with geforce 330.

i installed yosemite with uni and the the newest cuda driver.

without multi.

the vaio boot sssion told me first time that the boot configuration changed.

the internal monitor appeared. making the second boot.

the problem resists: black screen.

 

 

Also ethernet WLAN audio dont work actualy for main working tools.

I was wondering there is one Spanisch sspeaking Guy on the Internet

Installing it with iAtkos.

www.youtube.com/watch?v=0X914YhkRLA

 

same model as above

As far i can See the internal Monitor works with his method. why?

 

So i installed yosemite with newest Uni and Multi. and gave it a try.

 

 

My question should i take dsdt with Multi

Or should i take cover. What do you recommend me to do?

what is the difference between these two methods.

 

Possible to make a donation to you?

 

best regards

Thomas lianli

Share this post


Link to post
Share on other sites

Hi Tom

1. Download Yosemite from App store.

2. Make your usb with this guide http://cloverboot.weebly.com

3. Boot with your new Yosemite media and press F4 in Clover boot GUI, this will save all your ACPI tables in /EFI/Clover/ACPI/origin/ of usb.

4. Compress and attach the origin folder here.

post-1128367-0-75515900-1416968848_thumb.png

Share this post


Link to post
Share on other sites

hi jl4c,

 

thanks for your quick  reply,

Please be patient,

 

wait a moment a have to read a lot of clover installation manuals.

Cause I have to particually understand what im doing.

Clover its all new to me.

 

First i have to distinguish bios only from uefi.

Here we go. Ill sent to you attached file as soon as I come to the booting point.

 

Thomas lianli

Share this post


Link to post
Share on other sites

hi jl4c,

 

here we go,

black internal screen, hdmi works,

installation denied.

 

i clicked as less as possible in clover configurator.

heres my origin folder.

because im all new to clover what is the reason for stopping the install. process?

 

Thanks and gracias.

 

tom

 

origin.zip

Share this post


Link to post
Share on other sites

hi jl4c,

 

​here we go --- extracted with extron EDID manager.

its not the same as swiftresx shows i recognize.

installed windows and nvdia driver package 

Graphics Driver (NVIDIA) Suzaku_S6 - 8.16.11.8783

on win 7 ultimate 64 bit.

1920 x1080 60 HZ

 

thanks 

 

tom

MS_0025.bin.zip

Share this post


Link to post
Share on other sites

tchospy:
 
Regarding black screen problem:
1) use vanilla osx installation:#####
2) put FakeSMC.kext in /EFI/CLOVER/kext/10.10 or 10.9 depend on what system you are installing (yosemite works too), and may be VodooPS2Controller from rehabman to get keyboard and mice working
3) yosemite boots very slow without AppleACPI rollback, you can revert AppleACPI after installation.
4) to get working internal screen you need ONLY 1 DSDT PATCH! (look on next post)
5) in Clover you need to enable inject nvidia

SONY BLACK SCREEN PROBLEM FIX MANUAL
 
Example device: NVIDIA Corporation GT218M [GeForce 310M] [10de:0a75] (rev a2)
 
Internal LCD screen didn't work out from the box. Can be fixed with EDID injection.
 
Clover EFI EDID injector didn't work for some reason so we have to edit DSDT manually.
 
Save original (OEM) ACPI tables by pressing F4 to /EFI/CLOVER/ACPI/origin.
 
Use MaciASL to fix ACPI tables: https://github.com/RehabMan/OS-X-MaciASL-patchmatic
 
Boot from linux and run:

find /sys | grep -i edid

You will see:

/sys/devices/pci0000:00/0000:00:03.0/0000:01:00.0/drm/card0/card0-HDMI-A-1/edid
/sys/devices/pci0000:00/0000:00:03.0/0000:01:00.0/drm/card0/card0-VGA-1/edid
/sys/devices/pci0000:00/0000:00:03.0/0000:01:00.0/drm/card0/card0-LVDS-1/edid

We need only LVDS edid, save it and encode to hex array for usage in MaciASL:

xxd -c 8 -i edid-lvds.bin

It will show:

unsigned char edid_lvds_bin[] = {
 0x00, 0xff, 0xff, 0xff, 0xff, 0xff, 0xff, 0x00,
 0x4d, 0xd9, 0xfa, 0x06, 0x00, 0x00, 0x00, 0x00,
 0x2d, 0x0c, 0x01, 0x04, 0x90, 0x24, 0x14, 0x00,
 0xea, 0xa8, 0xe0, 0x99, 0x57, 0x4b, 0x92, 0x25,
 0x1c, 0x50, 0x54, 0x00, 0x00, 0x00, 0x01, 0x01,
 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01,
 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x30, 0x2a,
 0x40, 0x5e, 0x61, 0x84, 0x18, 0x30, 0x74, 0x74,
 0x88, 0x00, 0x68, 0xc8, 0x10, 0x00, 0x00, 0x18,
 0x30, 0x2a, 0x40, 0x90, 0x61, 0x84, 0xb4, 0x30,
 0x85, 0x85, 0xcc, 0x00, 0x68, 0xc8, 0x10, 0x00,
 0x00, 0x18, 0x00, 0x00, 0x00, 0xfc, 0x00, 0x4e,
 0x76, 0x69, 0x64, 0x69, 0x61, 0x20, 0x44, 0x65,
 0x66, 0x61, 0x75, 0x6c, 0x00, 0x00, 0x00, 0xfc,
 0x00, 0x74, 0x20, 0x46, 0x6c, 0x61, 0x74, 0x20,
 0x50, 0x61, 0x6e, 0x65, 0x6c, 0x00, 0x00, 0xa9
};

Open DSDT with MaciASL and look for Device (PEG3) and Names like EDI*.
Find one from EDI* names with the same hex values as your extracted EDID.
 
In my case it's EDI3:

    Name (EDI3, Buffer (0x80)
    {
        /* 0000 */  0x00, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0xFF, 0x00,  /* ........ */
        /* 0008 */  0x4D, 0xD9, 0xFA, 0x06, 0x00, 0x00, 0x00, 0x00,  /* M....... */
        /* 0010 */  0x2D, 0x0C, 0x01, 0x04, 0x90, 0x24, 0x14, 0x00,  /* -....$.. */
        /* 0018 */  0xEA, 0xA8, 0xE0, 0x99, 0x57, 0x4B, 0x92, 0x25,  /* ....WK.% */
        /* 0020 */  0x1C, 0x50, 0x54, 0x00, 0x00, 0x00, 0x01, 0x01,  /* .PT..... */
        /* 0028 */  0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x01,  /* ........ */
        /* 0030 */  0x01, 0x01, 0x01, 0x01, 0x01, 0x01, 0x30, 0x2A,  /* ......0* */
        /* 0038 */  0x40, 0x5E, 0x61, 0x84, 0x18, 0x30, 0x74, 0x74,  /* @^a..0tt */
        /* 0040 */  0x88, 0x00, 0x68, 0xC8, 0x10, 0x00, 0x00, 0x18,  /* ..h..... */
        /* 0048 */  0x30, 0x2A, 0x40, 0x90, 0x61, 0x84, 0xB4, 0x30,  /* 0*@.a..0 */
        /* 0050 */  0x85, 0x85, 0xCC, 0x00, 0x68, 0xC8, 0x10, 0x00,  /* ....h... */
        /* 0058 */  0x00, 0x18, 0x00, 0x00, 0x00, 0xFC, 0x00, 0x4E,  /* .......N */
        /* 0060 */  0x76, 0x69, 0x64, 0x69, 0x61, 0x20, 0x44, 0x65,  /* vidia De */
        /* 0068 */  0x66, 0x61, 0x75, 0x6C, 0x00, 0x00, 0x00, 0xFC,  /* faul.... */
        /* 0070 */  0x00, 0x74, 0x20, 0x46, 0x6C, 0x61, 0x74, 0x20,  /* .t Flat  */
        /* 0078 */  0x50, 0x61, 0x6E, 0x65, 0x6C, 0x00, 0x00, 0xA9   /* Panel... */
    })

Fill "AAPL00,override-no-edid" with EDID values via Name link "\_SB_.PCI0.PEG3.NGFX.EDI3"
 
Apply "Insert DTGP" patch in MaciASL.
 
Apply EDID override patch:

into device label NGFX parent_label PEG3 insert
begin
    Method (_DSM, 4, NotSerialized)\n
    {\n
        Local0 = Package (0x02)\n
            {\n
                "AAPL00,override-no-edid",\n
                \_SB_.PCI0.PEG3.NGFX.EDI3 // here is the full path to required EDID \n
            }\n
        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
        Return (Local0)\n
    }\n
end;

You can use "Buffer (0x80) { ... }" with EDID hex values instead of "\_SB_.PCI0.PEG3.NGFX.EDI3".
In my case it's easier to put link to EDID which already exists in DSDT.
 
This is the only DSDT patch required to get working internal screen.

Share this post


Link to post
Share on other sites

I tired this and I get two errors relating to

Local0 = Package (0x02)

syntax error, unexpected PARSEOP_LOCAL0
Invalid character (0x3D), expecting ASL keyword or name

Share this post


Link to post
Share on other sites

Gcenx, it seems like you didn't decode *.aml files well.

You need to install iasl (i do it with homebrew: brew install acpica).

Dump all acpi tables via clover or linux, put them in one directory and run: iasl -da DSDT.aml SSDT*.aml &> decode.log

It will give you more accurate *.dsl files, which can be edited and saved as *.aml (use ACPI 5 profile in MaciASL preferences).

Also my DSDT, for example, contains 1 error which I have to fix to be able to compile DSDT.dsl back to DSDT.aml.

Share this post


Link to post
Share on other sites

Hi art.sormy and jl4c

Can you help me patching my dsdt.

I did it and i saw that my EDID* is EDID4 and EDID5 have my Hex-EDID-string that i saw in linux.
I tried apply the patch but in my dsdt i don't have any AAPL00,override-no-edid

And not apply the patch.

Can you helpe ? i've attached my files:



 

edidt-hex.txt

Send me MacBook Pro de Respeito.zip

Share this post


Link to post
Share on other sites

I have a Toshiba Qosmio f60 which has the same problem with the gt 330m. Could you guys help get it fixed? Everything is working except for internal monitor. Only nv_disable=1 works.

Share this post


Link to post
Share on other sites

Gcenx, it seems like you didn't decode *.aml files well.

You need to install iasl (i do it with homebrew: brew install acpica).

Dump all acpi tables via clover or linux, put them in one directory and run: iasl -da DSDT.aml SSDT*.aml &> decode.log

It will give you more accurate *.dsl files, which can be edited and saved as *.aml (use ACPI 5 profile in MaciASL preferences).

Also my DSDT, for example, contains 1 error which I have to fix to be able to compile DSDT.dsl back to DSDT.aml.

 

Hello and thanks for the guide. But I'm sorry, I have the exact same error than Gcenx :(.

 

I dumped ACPI tables with both Linux & Clover and even with Windows using Aida64 v.3.20 and I still have these two errors. :blink::wacko::hammer:

 

I did "iasl -da DSDT.aml SSDT*.aml &> decode.log" on ACPI tables dumped by Clover and it went fine but still, I'm unable to patch the DSDT with your patch. :wallbash:

 

BTW, I also tried to use your DSDT (dsdt_art.sormy-v6.aml) "as it" since my EDI3 is the same according to my own EDID extract…

 

Attached is my ACPI dumps & EDID extracted from Clover & Windows.

 

Could you help ? If you need anything else, please ask :D !

 

Thx !

 

My specs :

 

VAIO vpcf13m0e - GeForce GTX 425m - Core i7 740QM @ 1.73 GHz / 2.93 GHz Turbo

 

For working Realtek ALC275 patched AppleHDA, see here and especially here ;). Works fine :D)

 

[EDIT] Your DSDT works with some removal in Clover fixes in config.plist but I'm stuck at 1024x768 with no QE/CI of course :P.

 

Attached IOReg & config.plist

EDID_ACPI_dump.zip

MacBook_Pro.zip

config.plist.zip

Edited by polyzargone

Share this post


Link to post
Share on other sites

Here's the Clover patch for ALC275 (update proof :D) :

		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>Expect 2 matches</string>
				<key>Find</key>
				<data>
				hAjsEA==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				AAAAAA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>Expect 2 matches</string>
				<key>Find</key>
				<data>
				hQjsEA==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				AAAAAA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>Expect 2 matches</string>
				<key>Find</key>
				<data>
				hBnUEQ==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				dQLsEA==
				</data>
			</dict>
		</array>
	</dict>

You'll need to install the attached dummy.kext in EFI/EFI/CLOVER/Kexts/10.10 and you're done !

 

NB : HDEF layout-id must be set to 3 :

            Device (HDEF)
            {
                Name (_ADR, 0x001B0000)
                Method (_PRW, 0, NotSerialized)
                {
                    Return (Package (0x02)
                    {
                        0x0D, 
                        0x05
                    })
                }

                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x04)
                        {
                            "layout-id", 
                            Buffer (0x04)
                            {
                                0x03, 0x00, 0x00, 0x00
                            }, 

                            "PinConfigurations", 
                            Buffer (Zero) {}
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }

All credits to Mirone for patched AppleHDA ALC275 which the dummy.kext is based on and Pokenguyen for his script to "Convert your patched AppleHDA to Clover patching-on-the-fly"

dummy.kext.zip

Share this post


Link to post
Share on other sites

polyzargone

 

here is your DSDT with 3 patches:

- 2 minor patches to able to compile it back.

- 1 to add DTGP method.

- 1 to fix SONY black screen problem.

 

Thanks, I really appreciate but unfortunately, it didn't work :(.

 

Actually, I got internal display just like with your own DSDT but no QE/CI. I suspect that the GeForce GT425 isn't working OOB cause there's no NVIDIA kext loaded at all (NVDAStartup.kext is no help for my issue) :

 

Apologies, I messed up with all my DSDT and didn't load the new one :P.

 

Good news is that I do have QE/CI. Bad news is now I've got this damn black screen again ! :wallbash:

I tried all EDI* to see if it can change anything but none of them works.

 

[uPDATE] HDMI audio works OOB via Clover DSDT fixes. HDMI/VGA works too with full QE/CI. But still no internal display. The screen is actually on but there's no display at all. I also tried several MacBookPro SMBios with no success so far.

 

In last resort, I tried Chameleon with GraphicsEnabler=Yes. Nothing changed.

 

What's wrong ! I don't get it :hammer: !

 

BTW, did you tried the ALC275 Clover patch ?

 

I may also have a DSDT edit to enable HDMI audio too but I can't test it since I also don't have no HDMI/VGA video output

Edited by polyzargone

Share this post


Link to post
Share on other sites

polyzargone, try this one

 

Actually there are 3 entry points for video card in DSDT: GFX0, PEG3, PEGP

PEG3 injection doesn't work, so we could try PEGP (this dsdt injects EDID into PEGP)

If it will not work then you could try to inject into GFX0, but I don't think that it will work (because it's native way of clover EDID injection and it doesn't work for Sony)

 

Could you please boot os x in as much vanilla state as you can and export ioreg. It will allow to see which DSDT device is used by default when you use HDMI (this will reveal GFX0, PEG3, PEGP or may be something else).

 

You have working VGA and it's strange =) In most cases VGA doesn't work.

DSDT_fixed.aml.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gorec
      Hi.
      I apologize in advance if I didn't post in the right category and if my title and description aren't specific enough :c
       
      My config in a nutshell:
      CPU: i7 5820k GPU: MSI GTX 1060 3GB RAM: 16 GB MOBO: MSI X99 SLI PLUS I attached RunMe output with all the details of my built.
       
      Some background:
      I have my Hackintosh for about half a year. That time I managed to make it works and fix major issues, but some of them left unresolved since then and I ignored them until now.
      I use my Hackintosh for Adobe projects (PR, AE, PS, IL, AU and a lot more) - most of them connected with video editing of course browsing with Chrome and other small tasks.
       
      Problems:
      Random restarts - this is the biggest one. I'm starting to work on bigger and bigger projects and at this time I think I can't allow this to happen that often. In the past, they happened like once a day or a couple of times a week. However, now it's just frustrating when it happens even 5 or more times a day. I've tried to observe and find out what can be the cause but I haven't managed to find any connections. I thought it happens when Premiere or another app is using GPU, but I haven't seen increased usage when it restarts. I think that it can be connected with GPU, memory or PSU or... meh, anything else. I don't have resources to check if it'll work with other components. There should be some fix for this. I will really appreciate any help with this :c Restart instead of shutdown & sleep doesn't work. I've tried to look through some Google results for this and tried many solutions (as you can see in attached Clover folder), but I think the right one for many of these issues is to make my own DSDT. Glitches, freezes and other things while encoding a video. It happens very often when I try to do this. Maybe it is an issue with GPU or (hopefully) only with GPU drivers which can be fixed with some patch. Today my headphones stopped working. I have a multi-output device configured in the Audio MIDI Setup app which includes my headphones (HyperX Cloud via USB) and Soundflowerbed virtual audio device for capturing system audio. Today while I was trying (like 15 times) to encode a video in Media Encoder in the background and watch video on YouTube I stopped hearing anything from my system. Of course, it restarted a couple of times as always, but even this didn't solve this. If I plug them directly with mini jack (not via USB Soundcard which was in the box and which I always used) in the front IO or the back I only hear some loud noise It takes EX-Fat formatted volumes a few minutes to mount after each restart. I found a workaround to format it with NTFS since I have Tuxera installed and I will reformat these volumes when I will find time for this, but maybe there is some fix for this. GPU is a little bit hot. HW Monitor shows it is only 45-55 degrees, but for my hand is a little bit hot, idk. Also related to GPU - glitch after POST but before entering Clover boot menu. It is a black screen with little white squared glitches for a few seconds. Maybe it indicates the GPU drivers are loading, but maybe it shouldn't be like this. And if I can ask about that - I can't make all applications hide on startup. I, obviously, have "Hide" checkbox checked on every login item in settings, but it doesn't work, none of the apps is hidden in the dock. Is there a way to fix this? Also a small but annoying problem - I can't turn off permanently Mojave update notification (since I tried to install it, and I had to reverse to High Sierra because I had a black screen and I didn't have time for repairing all of them. Tags are not working in Finder - every time I tag a file or folder and make a change in it (for example save a text file) the tag disappears.  
      So, with knowing all of that, is there a way to make a proper DSDT file for my Hackintosh? I tried to look through some guides on how to make it but I think I reached my abilities to understand how Mac OS works and what all of these things are, so I'm asking you guys politely, would someone like to help me? At least with these random restarts? :/
      I really begin to think that I'm a newbie in configuring all of that Clover things - even after what I managed to do with my PC. Help me, pleease... :c
       
      If you have any questions post it below, I will really appreciate any help <3
      Send me MBP-Gorec.home.zip
    • By arsradu
      Hi guys,
       
      So, this little tutorial is meant to help people fix a new issue with Mojave: opening jpg files (looks like it happens with larger files, not so much with smaller ones) using Quick Look (on spacebar key pressed) or Preview app, using the dedicated GPUs.
      The issue is that, when trying to open jpg files (for some reason, it doesn't occur with pngs), the pop-up window would remain in an endless loop. And from that point forward, any other app trying to open the same file will either become unresponsive (in the case of the Preview app) or just stay in endless loop (in case of Quick Look)
       
      As a workaround, in case the tutorial below doesn't work for you, you can use Grab (built-in app in MacOS) to open said files.
       
      This issue DOES NOT occur using the iGPU. So...if you're comfortable using the iGPU, just switch to that and you should be good to go. You don't need this tutorial.
       
      This tutorial is based on @Cyberdevs' research and testing on this topic (especially useful if you're using an RX series AMD video card), and my own very limited time testing this on my rig. I just thought it would be useful to create a new thread for it so that people can discuss this particular issue here.

       
      With that being said, I'll just move on to the actual tutorial.
       
      New (probably better) method.
       
      Switch your SMBIOS in Clover config in regards to the dedicated GPU you're using, instead of the CPU. Take a look here and choose the corresponding SMBIOS closest to your hardware.
      Yeah, that's it.
       
      In case you lose CPU PM with this method, there are multiple ways to fix that, and they do not make the object of this thread.  It worked perfectly fine for me though and I didn't need to change anything else.
       
      Alternatively, you can also try one of the MacPro SMBIOSes, such as MacPro5,1 or MacPro6,1. It was tested multiple times and it showed good results. 
      Keep in mind that choosing these will most likely not show you an iGPU in System Report, since those machines generally (probably all of them) use Xeon CPUs with no iGPUs either.
       
      A simple Lilu plugin
       
      Thanks to vulgo for the plugin and @Matgen84 for sharing and testing it, we now have yet another possible solution to this issue. It's a Lilu plugin (which means that it requires Lilu.kext in order to work) it's called NoVPAJpeg, and it can be downloaded from here.
      You use it as a regular kext, alongside Lilu. I prefer (and recommend) using it within the EFI folder, in Clover/kexts/Other. But if you want to use it in S/L/E, that should work just fine.
       
      More info can be found in this post here.
       
      In case you wanna try alternative medicine  ...
       
      The main thing we need to do is actually very simple: we need to enable the iGPU (integrated GPU) by default, in BIOS, while actually being connected to the dedicated GPU.
       
      For ATI GPUs (curtesy of @Cyberdevs' post here).
       
      The discreet GPU should be set as primary in BIOS and your displays should be connected to your discreet GPU
      The iGD/iGPU/iGFX must be enabled in BIOS/UEFI as the secondary GPU.
       
      I removed the DSDT Reconfigured the config.plist to and removed some flags which weren't needed because of the DSDT added the InjectATI + Ornioco Framebuffer (I removed the Orinoco framebuffer because of some weird glitches but it might be useful for other AMD GPUs if you inject the correct framebuffer according to your GPU. No need to inject anything for nVidia GPUs unless your GPU needs it) Added the InjectIntel + ig-platform-id for my intel HD530 (for intel HD 530 I use the 0x19120001 ig-platform-id)  
      Steps 5 to 7 might not be necessary I just did them anyway, if anyone succeeded to get quicklook working without those steps let me know so I can exclude those steps.

           Also confirmed to work with AMD R9 270X on a SandyBridge rig (without an iGPU) using WhateverGreen + Lilu kexts, which also helped to solve the transparency issue along with the Quick Look problem, it also resolved the buggy Screen Capture (Command+Shift+5) issue as well. 
       
          Also, do:
      nvram cleanup kextcache & prelinked kernel rebuild reboot  More info on that here.
       
       
      For NVIDIA GPUs
       
      This is what I needed for my NVIDIA rig and the MSI motherboard in the signature. Your milage may vary, depending on your hardware. But, the idea should be the same regardless.
       
         For MSi motherboads (check out my motherboard details in the signature)
       
      Set your BIOS to use PEG (dedicated GPU) so you can boot.
      Since you're reading this, chances are that you're already connected to the dedicated GPU and the BIOS is set to PEG. So just go into BIOS and see if you're using the iGPU or the dedicated (PEG) graphics device by default.
      If you're already using this, skip to Step 3 (the part AFTER Reboot). Reboot (I think you don't necessarily need to boot into the OS...but you do need to reboot at least until Clover UI) Reboot back into BIOS and set it from PEG to IGD (integrated graphics) WITHOUT removing the cable. Save Reboot again.  
         The result should be that the OS is tricked into thinking you're booting with the IGPU when in fact you're using the dedicated GPU.
       
         For Gigabyte motherboards
       
         Set:
      Peripherals -> Initial Display Output -> iGFX Chipset -> Internal Graphics -> Enabled
           DVMT Pre-Allocation -> default 64M.
           DVMT Total Gfx Mem -> default 256M Save Reboot  
         You should do this with the cable connected to the dedicated GPU.
       
      You will also need to patch the iGPU from Clover config.
      1. Graphics -> Inject Intel (UNCHECK Inject Nvidia or ATI if it's checked).
      2. ig-platform-id (in my case for Intel HD 4600 Desktop) it was: 0x0d220003
       
      And use IntelGraphicsFixup.kext (now included into WhateverGreen.kext) in Clover/kexts/Other. In my particular case, without the kext, I would get freezes in Safari.
       
      Another way to activate the iGPU while having the dGPU set as primary is by going into BIOS/SAG/Graphics Configuration/iGPU and setting Multi-Monitor to [Enabled], all the rest remains on [Auto], and set Inject/Intel to [True] in Clover config.*.
       
      Thanks to @gjw for the tip.
       
      *Motherboard dependent. But the multi-monitor option might be the same regardless of manufacturer.
       
       
      This might be a bug with Mojave and it could be fixed by Apple in the future. but in the meantime, feel free to use this if it helps you fix the issue.
       
      For HP motherboards (including laptops), so far no solution, unless the BIOS somehow allows to switch from dGPU to iGPU and vice-versa.
       
      Cheers!
    • By Bright Joe
      Hi there,
       
      I'm new to Hackintosh and I installed Mac OS High Sierra 10.13.6 (Build 17G65) on my PC.
       

       
      I have installed Mac OS using [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. Basically, I have installed the latest Nvidia Web Drivers for my build. But my GTX 950 is still not detected by the system. And it shows NVIDIA Chip Model 8 MB. However, using Inject Nvidia shows up my GPU but it's all glitchy as usual.
       
      I checked my config.plist and nv_disable=1 is enabled. I tried unchecking it and rebooting, but after the Mac OS loading screen, there's a black screen with pixelated codes which I can't see. And it stays stuck until I reboot. Every time I tried to boot, the same black screen until I checked nv_disable=1 again.
       
      Can you guys help me out with this? I'm new to Hackintosh builds and I have no idea how to fix this. 
       

       
       
      My system specs:
       
      Intel Core i7 3770  Zotac GTX 950 GDDR5 2 GB Samsung EVO 860 250 GB SSD (SATA III) Intel DB75EN Motherboard 16 GB DDR3 1600Mhz RAM.  
      I'm using a HDMI cable. Graphics settings in BIOS is set to PEG. 
       
      I'm also attaching my config.plist file for you guys to see.
      config.plist
    • By tom666
      osx10.14
      i5-4250u
      i have added "irq hdef hdau  mutex osys10" patch
      and install acpibettery on clover ,but the battery management still donot work

      my audio card is alc269vc ,i try to use applealc,and tried all the layoutid, all of those colud not work.
      2019-03-31 20:18:23.389590+0800  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to find IOHDACodecVendorID, retrying 0
      i have also use linux to find the codec
      i uploaded the clover , dsdt,codec.
      This problem has been bothering me for two days.
      thanks
       
       
      all.zip
      2019-03-31 20:18:17.997435+0800  localhost kernel[0]: calling mpo_policy_init for Lilu
      2019-03-31 20:18:18.003796+0800  localhost kernel[0]: Security policy loaded: Lilu Kernel Extension 1.3.5 (Lilu)
      2019-03-31 20:18:23.389590+0800  localhost kernel[0]: (kernel) AppleALC:     alc @ failed to find IOHDACodecVendorID, retrying 0
      2019-03-31 20:18:23.398483+0800  localhost kernel[0]: (kernel) Lilu: patcher @ lookup patching applied only 0 patches out of 1
    • By RamLalith
      I executed all my DSDT's and SSDTs with no errors 
      I can't patch the battery

      I need help
      I am attaching my ACPI folder
      ACPI.zip
×