Jump to content
tchospy

Vaio users black screen after boot

221 posts in this topic

Recommended Posts

Put the last DSDT on the extra folder of your OS X installation USB without delete any nvidia kext and boot with it, see if you reach the install screen with your internal display

Share this post


Link to post
Share on other sites
Advertisement

Put the last DSDT on the extra folder of your OS X installation USB without delete any nvidia kext and boot with it, see if you reach the install screen with your internal display

 

Well... I already did this... the dumper I sent you previously booted using what you said... the DSDT is already in Extra folder and the nvidia drivers is running... 100hal . Always using GraphicsEnabler=Yes

 

I think now it is reaching the internal display cause I can turn it on and off... but only black is shown. Nothing is showing on the screen... I can just control the brightness, but black brightness.

 

Also using swiftresx I can now extract the EDID from the internal monitor... and it is correct.. 

 

Do you think a need a modded nvidia driver or something ? This is weird .... Is there anything I could do here to help you ?

Share this post


Link to post
Share on other sites

We need to know if the internal display work without any change in the system, and yes the internal display is detected with the right EDID but for some reason you only get a black screen. Please boot with a clean OS X usb installation using the last DSDT and GraphicsEnabler=Yes flag.

Share this post


Link to post
Share on other sites

We need to know if the internal display work without any change in the system, and yes the internal display is detected with the right EDID but for some reason you only get a black screen. Please boot with a clean OS X usb installation using the last DSDT and GraphicsEnabler=Yes flag.

 

I have to put the DSDT inside the usb installation ? Or just boot with the usb installation, select the hard drive mac installation ?

Share this post


Link to post
Share on other sites

Yes, the DSDT must be on the Extra folder of your usb installation, see if the internal display work.

Share this post


Link to post
Share on other sites

Yes, the DSDT must be on the Extra folder of your usb installation, see if the internal display work.

So...I have to reinstall the system again, right ?

Share this post


Link to post
Share on other sites

No, i just want to know if the internal display works, i mean with QE/CI

I put the dsdt inside extra on usb installer and the same thing happened..

 

It's really detecting the internal monitor... It makes a big blink like it is transfering images from the geforce to the monitor...but then it fails in some way :/

Share this post


Link to post
Share on other sites

Try with this boot.plist

What is the native resolution of the internal display?

 

The same man.. the native resolution of the internal display is 1600x900 ... it is its max resolution.

new Extra folder :P

 

attachicon.gifExtra.zip

 

 

Thanks for helping me man!... Should I replace the actual Extra folder ?... also... should I use custom DSDT that jl4c sent me before ?

Share this post


Link to post
Share on other sites

yes, replace the Extra and test with no DSDT first, then reboot and and test with the DSDT too

 

 

 

 

I've tested both... NOT using DSDT the monitor turns off.. using DSDT from jlc4 the display turns on but shows only black screen :/

Share this post


Link to post
Share on other sites

try with clover and injectEDID, InjectNVDA, loadVBIOS,dualLink1,  you can install  clover first to a usb to see if this go better

Share this post


Link to post
Share on other sites

Try this...

 

 

Nope man... The same black screen... the display turned on this time.. but without any brightness control(the bar does not appear)

 

Attached ioreg.

 

thanks man..

ioreg.zip

Share this post


Link to post
Share on other sites

Do you think it could be something inside the nvidia driver ? Cause now that display is turned on... only the images aren`t being passed to the screen :/

Share this post


Link to post
Share on other sites

1.try  this kext NVEnabler64.kext, install with Kext Wizard/RepairPermissions/rebuildcaches/reboot

2. if no results, try install theses kexts from DP8Mav, backup yours NVDA kexts first

3. post result from this two comands

 

 ioreg -l | grep -15 "AppleACPIPCI" | grep "_UID"

 

sudo kextstat -l > ~/Desktop/kextloading.txt

 

 

NVDA.zip

 

Share this post


Link to post
Share on other sites

1.try  this kext NVEnabler64.kext, install with Kext Wizard/RepairPermissions/rebuildcaches/reboot

2. if no results, try install theses kexts from DP8Mav, backup yours NVDA kexts first

3. post result from this two comands

 

 ioreg -l | grep -15 "AppleACPIPCI" | grep "_UID"

 

sudo kextstat -l > ~/Desktop/kextloading.txt

 

 

attachicon.gifNVDA.zip

 

 

Hi guys, I did what you said..

 

First... using nvenabler64.kext the laptop restarts before completing the boot. I don`t know but seems that something went wrong..hehe..

 

Second... I installed the kexts that you told me...

 

Results:

 

ioreg -l | grep -15 "AppleACPIPCI" | grep "_UID"

    | | |   "_UID" = "0"

    | | |   "_UID" = "255"

 

 

The other result of kextstat is attached !... thanks man !

kextloading.txt

Share this post


Link to post
Share on other sites

OK, please dump your nvidia bios (vbios) using everest (windows) and upload here.

 

Ok... I'll dump the graphics card bios... I just need some time to do this cause I'm on the streets...

 

A while ago...I found this blog and the guy fixed this in linux... He had a vaio at that time and the same problem... seeing his configs maybe can help... I read and didn't understand what he did cause he used x11 configuration files and I find it is not possible in Mac os X.

 

http://www.jaredlog.com/?p=1148

 

 

Also...I found this on nvidia webpage about my graphics card.

 

  1. The following Sony VAIO notebooks are included in the Verde notebook program: Sony VAIO F Series with NVIDIA GeForce 310M, GeForce GT 330M, GeForce GT 425M, GeForce GT 520M or GeForce GT 540M. Other Sony VAIO notebooks are not included (please contact Sony for driver support).

 

Do you guys know if this "Verde" program is screwing our support on mac os x ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Duyhaicx
      Hi everybody. I am not a programmer and English is not my native language. So I'm very sorry if it bothers you.
      I want to use an EGPU but that requires editing the DSDT file. I have added the necessary lines of code. The other is to remove the Warning and Remark. It was really hard for me. So I look forward to getting help from a kind person.
      I use HP 8570w and this is my DSDT.dsl file.
      https://drive.google.com/open?id=1Th5DhYm7L08Ufj8AeQHFrLPSzrTaxFC6
      Thank you and have a nice day.
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/forum/viewtopic.php?f=28&t=8222   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder   https://olarila.com/files/Clover.Folder/CLOVER.LGA775.zip   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://olarila.com/forum/viewtopic.php?f=28&t=8222     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By kylon
      ACPI and Clover config for Acer Aspire v5-571PG
       
      Tested on Catalina 10.15.1 and Clover EFI 5098 (Should work on MacOS 10.9.x - 10.15.x)
       
      Not Working:
      - sd card reader
      - Atheros AR9462 (use a compatible USB wireless adapter, see below)
      - Touchscreen (MacOS 10.15 only)
       
       
      Notes:
      Disable Secure Boot and enable Legacy Boot. Legacy Mode is recommended.  
      **To reset your BIOS, power on the pc and hold the power button for about 30-40 seconds or you can short G2101 (RAM SLOT 1)**
       
       
      About the Atheros card:
      You can install ATH9KFixup (you will also need additional patches on 10.14+ to restore Atheros support) to enable this card, however,
      it will break sleep on MacOS 10.14+, it can freeze your OS at any time and it can freeze your network settings.
      Because of its instability it is highly recommended to buy a USB wireless adapter.
       
      You can find a list of working adapters, and the drivers, here.
       
       
      Additional things you will need:
      Latest Clover config (AcerAspireV5-571pg - CCE Bank) from here CloverEFI (download) or OpenCore (download - Untested) WhateverGreen (download) VoodooPS2 (download) VirtualSMC + SMCBatteryManager (download) AppleALC (download) Lilu (download) Mieze Realtek RTL8111 (download)  
      CloverEFI drivers you will need:
      ApfsDriverLoader EmuVariableUefi FSInject DataHubDxe VBoxHfs (if you have hfs partitions)  
      Remember to install BIOS drivers if you enable Legaby Boot.
       
       
       
      Feel free to ask for help.
      Please send me a PM if you have fixes or improvements, thanks.
    • By artaa5474
      Hello,
      hello I have a problem with mw laptop
      I installed Mojave 10.14.6
      on clover I use fix HPET on ACPI, but make my SSDT for processor multiplier didn't work
      If I Uncheck Fix HPET my audio can't work

      Spec:
      Acer E5-471
      intel core i3 4005U
      ram 6GB
      Intel HD 4400
      Send me SanKyuus-iMac.zip
×