Jump to content

74 posts in this topic

Recommended Posts

I found that I had mistake in path where should I extract files from post#1)) But even that - Clover not loading)).

Man, you're the best one! You typed so cool instruction - I'll try it tomorrow when I'll have access to Mac and be able to put this file!
I dunno could it helps me but...Man, thank you in advance!!!!!!))

Could you tell me, please, now I have win7, I've made partition for MacOS - after installing MacOS how can I make bootloader to be able to boot both OS?

Share this post


Link to post
Share on other sites
Advertisement

Once you boot into Clover it will already recognize Windows 7, even if you don't install OSX, as soon as you boot Clover you could boot directly in win7 because Clover "scans" your partitions to make our life easier ahah.

Basically in Clover you will have options as: boot Windows from HD, boot Mac OSX from your USB partition (the installation of OSX), Clover options, restart, shutdown....

 

One thing to keep in mind. When I decided to make my dual boot system I had some unexpected difficulties due to my ignorance in this matter   :lol:

 

Basically once you do it, it is not so difficult trust me, but it took days to me because I didn't know the following (mind you, maybe you already know and did right!):

 

The internal HDD can be formatted in MBR (Master Boot Record) or GPT (GUID Partition Table). It is not related to the partitions, it's referred to the entire disk, so either GPT or MBR, not both at the same time.

 

Now OSX wants a disk in GPT, for Windows it depends:

-If you install Windows in legacy mode it will use MBR

-If you install Windows in UEFI mode it will use GPT

 

By default on our Asus N53S (at least on my Asus N53SN) Windows is installed in NON UEFI mode, MBR, the wrong one. To have Windows in UEFI correctly (GPT) I had to boot in the EFI shell manually and start Windows installation the same way you should start Clover as I explained in the post above (insert Windows installation media, go in the EFI shell, look for it with "fsX:", find "bootx64.efi" and boot from it).

 

So the most natural way would be to have Windows in UEFI mode, so you can install OSX natively in the other partition, both Windows and OSX in GPT mode.

 

If you have Windows in legacy mode instead (MBR) you can decide to reinstall everything from scratch or to use a patch to convert OSX from GPT to MBR http://www.insanelymac.com/forum/files/file/426-el-capitan-mbr-patch/but unfortunately I reinstalled everything so I'm using GPT and I wouldn't be able to help you in using the patch.

 

This was the first "great" obstacle that I found while setting up the dual boot.

 

 

 

The second one is always related to the partitioning.

Basically from Windows I shrinked my disk to make space for a second partition for OSX, I rebooted and tried to install OSX in the partition created before, and I received the bad surprise that Disk Utility wasn't able to format the partition in Journaled. Searching the net I found out that it is a known problem and basically the way Windows initialize the HDD is not compatible with OSX which cannot "manipulate" the disk.

The solution that I found was using Gparted Live to format the entire disk and prepare the partitions already formatted in the correct way (NTFS for Windows and Journaled for OSX) as explained in this guide: https://www.reddit.com/r/hackintosh/comments/3nlzys/how_to_dual_boot_el_capitan_and_windows_10_on_a/

 

 

 

All this could maybe worry you, but trust me finding out later it's worse of course, so maybe it's better to have in mind what the dual boot involves. However after having done it I'm really happy because the two systems are really stable and perfect.

 

So my advice is to start preparing the disk with Gparted, install Windows in UEFI mode (GPT disk) and finally install OSX. Once you setup everything right with Anerik70's folder (for El Capitan posted in post #19, for Yosemite posted in post #1)  you should be good to go in a very short time; so I think that the preparation of the whole dual boot system is probably longer than the single installation of OSX. Of course all this is not needed if you use two different physical disks or if you install OSX on a USB drive...

Share this post


Link to post
Share on other sites

 

All this could maybe worry you, but trust me finding out later it's worse of course, so maybe it's better to have in mind what the dual boot involves. However after having done it I'm really happy because the two systems are really stable and perfect.

 

 

Man, I'm gonna go your way! I really appreciate you for your help!

 

In a while I'll try it!

Share this post


Link to post
Share on other sites

Oh man - I've gpted my hdd, I've installed Win7 with UEFI (It was sooooo hard man)!))

But when I enter command "cd \efi\boot" and then load bootx64.efi - I get black/blank screen and nothing else)))

 

My USB flash has indicator - after loading bootx64.efi nothing is happend.

UEFI in my BIOS is switched on.

Share this post


Link to post
Share on other sites

Oh man - I've gpted my hdd, I've installed Win7 with UEFI (It was sooooo hard man)!))

 

But when I enter command "cd \efi\boot" and then load bootx64.efi - I get black/blank screen and nothing else)))

 

My USB flash has indicator - after loading bootx64.efi nothing is happend.

 

UEFI in my BIOS is switched on.

It's very likely that "fs0" is your internal hdd. When you enter the EFI shell, or if you type "map" you should see beside "fs0" the "SATA" word somewhere on the same line; if I'm right you are booting the wrong disk. On my Asus fs0 is my internal hdd. As a matter of fact for me also fs1 is internal hdd but another partition.

However I'm saying that it is very lickely that fs0 is your hdd because also in your hdd there is the "EFI" folder in the so-called "EFI" partition that you created manually with Gparted or that Windows installation created for you. And also in the HDD's "EFI" folder there is a folder "BOOT" with inside "bootx64.efi". So basically when you connect the usb flash drive with Clover there are two drives that have the same path of folders "Efi\boot" and "bootx64.efi" file. You have to chose the correct drive. Only the USB's one will take you to Clover.

 

You can check what I'm saying in the following way: you create inside the "EFI" partition on your usb drive an empty dummy folder (you can do this from your mac mounting the EFI partition or directly from Win7). So you create a dummy folder, e.g. "Test" and you reboot and enter the EFI shell again. Now type "fs0:" and "ls" or "dir". If you do NOT see the folder you created, in the example "Test", you are in the wrong disk!

Another way to do the same is to check whether there is the file "shellx64.efi" when you type "ls" or "dir". If you did as I said in the post above and you copied my file "shellx64.efi" in the root of you usb's "EFI" partition you should see it. If you don't see it, again you are in the wrong disk.

 

However if I were you I would simply try others fsX because it is likely that you don't have more than 4 or 5. So for instance "fs1:", "cd \efi\boot", "bootx64.efi". If it doesn't work you do the same for "fs2", so "fs2:"....For my it was "fs4"!

 

One last thing. If after all the tests you are not able to access Clover I'd suggest you to change USB key (I had a problem with one of my USB flash drive that returned the message about the "EFI" folder not present, even though when I typed "ls" I could clearly see it; in that case I had to change USB drive. But don't worry, you can take a USB flash drive and "manually" create Clover. I don't know how you prepared you Clover usb, but when you are "satisfied" with it you can simply manually copy all the files inside your USB's "EFI" partition in another USB key. It doesn't matter the name of the USB drive, it only matters that the partition where you copy Clover and its "EFI" folder is formatted as FAT32. You don't necessarily need to re-create Clover with the Clover installer. In the end I decided not to install Clover on my hdd "properly", but to create another small partition on my internal hdd where I copied the content of my working USB Clover partition. I access it manually always from the EFI shell, this is to make you understand that once you have a working Clover configuration you can move it. You can also have Clover on an USB flash drive and the installation of OSX in another USB drive...

 

However as I said I'd try first with others fsX before changing USB drive. I hope this helps!

Share this post


Link to post
Share on other sites

I've attached two photos - one of them about command map (I have only two "fs"), and another one about "fl0:" (it consists of clover files).
 

The only thing - I'm trying to load from Usb Flash 3.0.

Maybe this point breaks everything?

post-1605468-0-81922500-1454759836_thumb.jpg

post-1605468-0-17513600-1454759844_thumb.jpg

Share this post


Link to post
Share on other sites

I don't think that if your usb drive is USB 3 there should be any problem, but however it is suggested to use the computer's usb 2.0 ports instead of the usb 3.0 port. My Asus N53SN has three usb 2.0 ports and one usb 3.0 port and I used the usb 2.0 port with a usb 2 flash drive.

 

The only thing I can say is that I had a problem with the EFI shell not finding the folder even though it was listed but I solved it changing the flash drive. But if you are able to launch the "bootx64.efi" I don't think that is the problem.

 

I have updated my bios to the last version (version 209 for Asus N53SN) but again I didn't try with the old bios, so I don't know whether that could be the problem.

At a first sight fs0 should be correct in your case, I had fs4, but maybe it is related to the boot priority list (but I don't know and don't think that is the problem).

 

I have attached my Clover folder. If you want you can try that...it is enough that you take a spare usb flash drive (also very small) formatted in fat32 (it is not important if there are other files and also the name of the drive doesn't matter) and copy the content of the zip (extracted) in the flash drive. And you try with that, without the installation of OSX, just to see if Clover boots.

 

Another option would be to use Clover legacy, I don't think it changes anything, and before being able to use UEFI with EFI shell I was using the legacy version that boots easily without the need of the shell.

Here is my Clover in a zip:

https://www.dropbox.com/s/o5lcbsvge0myjy2/Asus%20N53SN%20Clover.zip?dl=0

while in the attachment it is the same but in a rar.

 

If you want you can upload your version of the EFI folder and I can see if I'm able to boot with your files.

 

Asus N53SN Clover.rar

Share this post


Link to post
Share on other sites

jackal992, I've tried with your clover - and it works. Seems, everytime I make wrong clover.

First of all, I update my BIOS to the latest version (for Asus N53SM is 205).

Then I plug USB Flash with your clover - and clover works.

 

Last time I get the folder from post #1 (updated from 25 May), and then I replace root shellx64.efi with your's one).

 

That's my EFI folder. Maybe, you can try it repeatin' by my description?

 

 

P.S.: Maybe I'm not so lucky, but OK - I can try to install El Capitan. Could you help me with filling EFI partition?
I think, after Clover installing, I should put files from post #1, replace original clover files, then get files from post #19 and replace some files from the previous interaction? Or not?

 

P.P.S.: Load files from post #1 on another usb flash (fat32) - same reaction. Black (or blank) screen).

Share this post


Link to post
Share on other sites

I've attached the Clover version of post #1 with some modification without touching the files, only changing their positions. Now I'm able to boot from that Clover configuration too, the theme is different but it doesn't matter, you can download others later. If I were you I'd use that for Yosemite installation because it seems to be the more closer to your machine (you have an Asus n53sM like Anerik and not the n53sN like me I believe). 

 

However the basic key-files in a Clover configuration are 3:

-config.plist

-dsdt and ssdt (under ACPI/Patched)

-kext folder

 

 

Now if that Clover works I'd do:

 

0) Creation of OSX Yosemite installation drive. To do this I believe you read some guides online. Basically you have to have a mac where you download Yosemite and create the usb installation of OSX with terminal (the "createinstallmedia" method) or with the help of some tools. Yo can partition your usb drive one partition for clover and the other for OSX installation or you can use two different USB flash drives, there is no difference.

 

1) Attach both the USB drives (if you use two different drives for clover and OSX installation, otherwise the USB drive with OSX and Clover together), boot into Clover and start the installation. Sometime it can be "difficult" also only reaching the installation screen of OSX, but the files should have been adapted for your HW, so you shouldn't encounter any problems. So you install OSX in the partition dedicated to it. If during installation keyboard and mouse don't work use external ones, later you'll solve those problems. Once you complete the installation you should "tweak" a little the system to have everything working. I think that you'll need to tweak very little because Anerik had already found all the kexts for audio, wifi, bluetooth, keyboard, touchpad......

 

2) You install Clover to HDD. This has to be done after OSX installation. 

Installing to the HDD/SSD after installation is very similar to installing to the USB. You can use the installer of Clover http://sourceforge.net/projects/cloverefiboot/and "point" it to your internal HDD this time, not to USB. Once you install it you can copy the content of the Clover folder of your USB (the one already adapted and customized) to the Clover folder created in your internal HDD overwriting the files. Of course you will keep your edited "key-files" mentioned above deleting the "generic" ones just installed by Clover installer.

 

If you choose Yosemite you shouldn't encounter many problems, but if you choose El Capitan you should prefer starting from the files at post #19.

According to me the installation itself should be painless, the only thing that happened to me is that, since I have a different machine, at the beginning I had to re-patch by myself the dsdt and ssdt mentioned above because Anerik70's were unstable for me. But I cope with that problem after installation of OSX, to make the system more stable because every now and then I had some graphical problems and kernel panics. After having patched those files for my machine I've never had any problem.

Asus N53SM.zip

Share this post


Link to post
Share on other sites

Today made two flash drives - one with files from post#1 and Yosemite and second with El Capitan and files from post#19).

And no boot for Clover on both flash drives))).

I'm feelin' a lil' bit desperate with it))))

jackal992, could you make full instruction for making Clover boot loader? I think, I make one mistake that can not allow me to install Mac OS))).

Just, if it is possible - step by step. 

 

For today I made it such way:
1) Dowload Clover ( http://sourceforge.net/projects/cloverefiboot/ )
2) Open app and set location for installing to my flash and set install settings as it shown in video in post #1 ( https://youtu.be/HHx20DPyOFY).
But I matched that size in video is about 12 Mb, but mine - 11,2 or smth like that. Lower than in video.

3) Then I download files (post #1 or post #19) and copy files to partition.

And there is difference between #1 and #19 - #1 consists of folder EFI and two files, #19 - only folder.

When I make put files to partition Mac asks me - Replace files or Merge? Everytime I made replace, but maybe I was goin' wrong?
Or I should put files manually?
4) That is all) And it's not working)))).

 

 

P.S.: I haven't yet try with your files but I wonder - why it is only 8.9 Mb while files from post #1 near 50 Mb?

 

 

Sorry for annoying you, but I really can't understand, what is going wrong).

Share this post


Link to post
Share on other sites

I don't understand, I posted the working version of Clover in my previous post...can't you use it?

If you use that one it is enough to copy the content of the zip (extracted) on a fat32 usb flash drive and that's it, you can try to install OSX.

 

I don't know what you are doing wrong, in the end I didn't use Anerik70's guide, only just a couple of his kexts.

If I were you I'd try to install OSX and tweak, if necessary, some settings in Clover. If you use that folder you can jump that step of Clover installation!

 

If you still want to install Clover starting from 0 (the guide in the video) it is way more difficult because you have to manually setup the config.plist and use some kexts.

 

My file is smaller because I couldn't re-upload 50 mb of zip because the limit on this forum is just 10 Mb. I simply discarded some themes for Clover that you can easily download later.

 

With Clover from my files (that already contains the customized config.plist and the needed kexts) you should be able to start the installation of OSX.

 

The guide in the video is just the way you would install Clover from scratch, but it is pointless since you have to use the files provided. It's like saying "you install Clover and later you replace it with my files from post 1". You can just jump the installation and directly use Clover's file from the zip. My version in post 34 is the same in post 1 except that I deleted some themes to save space (it doesn't matter, later you can google "Clover themes" and find the one you like most) and I moved some files. Anerik had adapted the version in post 1 for his machine putting the files under "OEM" folder, I just moved them in a more "generic" position but they are the same, without the hassle of having to worry about having a slight different version of Asus N53Sx. I moved the content of the EFI\CLOVER\OEM\N53SM\UEFI into EFI. It is the same, just avoiding problems with the name. Indeed the more generic installation (the guide from the video, aka official Clover installer) puts the files the same way I do, so they are fine.

 

 

I'd say that you can try either:

1) Yosemite - you delete the EFI folder from your USB flash drive and put the files from post 34

or:

2) El Capitan: - you delete the EFI folder from your USB flash drive and put the files from post 32

this way you avoid any problem of Merge/Replace and you are sure of the files you are using. You don't want to have 2 versions of the config.plist, two versions of the kexts....because otherwise you are not able to understand which one you are using and if you need to tweak something you don't know which one is the one you need to "touch".

 

Anerik uses different positions for his files in post 1 and post 19. The conventional position of the Clover installer are in post 32 (El capitan) and 34 (Yosemite). I don't have any problem in using the versions from post 32 and 34.

 

Basically I'd suggest that you use one of the pre-built Clover configurations and go on from "Copy OS X to USB" section.

Share this post


Link to post
Share on other sites

jackal992, hooray! Clover boots very well! 
 

But another sad news - installing mac os stucked on first black screen with white apple in the middle.

 

Why does it happens?

 

P.S.: Thank you for your Clover!!! 

 

P.P.S.: Sorry, tried your Clover and El Capitan flash drive, tomorrow try El Capitan with files from post 32

Also, make flash with Yosemite and try with your files if there will be troubles with El Capitan

 

Am I right that black installation screen caused by lack of neccessary kext's?

Share this post


Link to post
Share on other sites

You should wait some minutes, it is not immediate the boot process...however to have a better understanding of what is happening you should try to boot in verbose mode. It is enough to press the space bar on the installation entry in Clover and choose "Boot in verbose mode". Otherwise you can do the same going in Clover's options and adding "-v" to the boot args.

In this way you can check where it hangs...

Share this post


Link to post
Share on other sites

Ok, I wait more time and installer shows this: 

 149901d1441466380t-guide-install-yosemit

 

Then I launched installer in verbose mode, and get such message - in attached.

 

It's El Capitan.

post-1605468-0-28929400-1454944109_thumb.jpg

Share this post


Link to post
Share on other sites

Well, I exchanged some files of your clover (DSDT & SSDT, config.plist, all the kext's - them I put in folder "Other", as your's one - and all the drivers in drivers64UEFI folder) and got that screen:

post-1605468-0-55404100-1454946919_thumb.jpg

Share this post


Link to post
Share on other sites

To be sincere I don't know what is the problem even because in the second picture I'm not able to read...usually that symbol comes up when the sytem has problems in reading from the usb or drive (on my desktop it was reated to AHCI not set)...

 

However it is quite strange because even though I have a different machine I was able to install the system without any problem with Anerik70's files, so it is strange that you are not even able to boot in the installer...you have an Asus N53SM right?

 

You can try changing usb port and/or flash drive, however:

-either there is something corrupt in the installation of OSX

-or there is something wrong with the settings of Clover (aka config.plist, kexts, dsdt)

 

For this reason you can try to use a very light version of Clover with few kexts, and once you install the system re-add them.

For instance I use very generic kexts in Clover and install the others directly in the system after the installation.

I have in EFI\Clover\Kexts\others just:

-fakeSMC (compulsory!!!)

-realtekRTL8111

-VoodooPS2Controller

during installation I used an usb keyboard.

Delete the numbered folders if you have any, eg 10.10 in EFI\kexts\, leave only Others.

 

However Anerik directly used all the kexts, so probably it is not the problem....

 

Also in EFI\Clover!drivers64UEFI I have just:

-FSInject-64.efi

-HFSPlus.efi

-OsxAptioFixDrv-64.efi (the source of your problem in the first picture), there are alternatives to this files online but I've never tried

-OsxFatBinaryDrv-64.efi

 

I tried both my config.plist and Anerik's one, and both of them make my system boot, so I don't think they are the problem, even though they are not the same.

 

Of course I'm also able to boot with both my dsdt and Anerik's one, but with Anerik's I have some instabilities, related to the different machine.

 

The best thing would be that you create your own DSDT patched for your machine, even though it is not an easy process, and I repeat that I was however able to install also with Anerik's files, so maybe the problem is in the installation of OSX corrupted...

 

Just as a comparison, I have in BIOS "USB legacy" enabled, and pretty much every feature enabled too...

 

I have sent you a pm with the link of the guide I used to create the installer, I don't know if you want to try with that. In that guide there is also the part where you have to configure Clover, again you can do that, but later use another usb drive to boot Clover or replace the files created by the installer; otherwise you can also avoid using our files and start from scratch...It took my at least 3 days to put up my current working system when I decided to start from scratch and not use Anerik's files, so is not the easiest thing in the word, but I'm not an expert in this field...So it's up to you, with that guide you can re-configue Clover from scratch, in fact you'll see that it uses just the 3 kexts i'm using. Wrt that configuration of Clover I added some modification to the config.plist and DSDT.

 

Let me repeat one last time that however I'm able to boot the installer with post 34 and 32, so I believe you could avoid losing time in the configuration of Clover and if needed patch the DSDT once you install the system if you notice some instabilities. I mean it is strange that you're not able to boot in the installation, even I with a different machine was able to using Anerik's files...that's why maybe is just the installation corrupted, but of course I'm not 100% sure...

 

Share this post


Link to post
Share on other sites

jackal, I'm so sorry for late answering but I wasn't able to do it.

 

First of all - thank you for your helping and patience! I almost finished installing Yosemite!)) Hooray)

 

After failed installing El Capitan, I changed some files from your Clover (jackal992-edition, ha-ha) - get from post #19 and changed files in your variant of Clover in post #34 - so I wanted to prepare for El Capitan, but then I tried with Yosemite and...It works))). Maybe it will affect in future, but now it works pretty well!

 

Now I stucked on formatting partition for Mac OS - Disk Utility shows me error "Media Kit reports not enough space on device for requested operation". I found that small EFI partition caused this - generally Windows makes only 150 Mb inspite MacOS need - near 300 MB (400 Mb - pretty enough). Also I found solution to make second EFI partition bigger previous one, copied files from previous to new one - and... I broke Windows Bootloader))). Unfortunatelly, I format my flash with Windows installer (and wrote MacOS Yosemite).

 

And the one more thing I want to tell. 

Asus N53Sm has 4 usb ports - two on the left side and two on the right side. I always use left ones, cause right ones used for powering cooler under my notebook)). And yesterday I plug my flash drives to the right side - and it works very well! Clover always boots (on the left side sometimes it is not boot - I don't know but that's it).

 

 

Today I'll try to repair my bootloader for windows and try to install MacOS with my big EFI partition. Hope, there will be more troubles.

 

 

And once again...Man, THANK YOU VERY MUCH for your Clover - I will save it to my cloud cause it's only one right bootloader for my notebook)))).

Whatever happens - I will write result here).

 

 

P.S.: Could you tell me, if I update my Yosemite to El Capitan - will it cause any problems? Kext or smth else? Or if it's installed and works, no problems could be encountered?)

Share this post


Link to post
Share on other sites

Hi micsha!

Yes, sorry I encountered the problem of the small EFI partition too, but I had forgotten about it. Theoretically if you prepare the disk with Gparted Live at the beginning with: Windows partition in NTFS and OSX partition already formatted in Journaled you shouldn't have problems, because yes Windows creates a small (unusable for OSX) EFI partition, but once you start installing OSX you shouldn't need to format anything because the MAC partition was already formatted in Journaled, then you "avoid" the problem with this trick .

 

However I have done a slight change to the upper method: in Gparted I prepared 3 partitions:

-EFI about 300 Mb ( I don't remember exactly)

-Windows partition formatted in NTFS

-OSX partition formatted in Journaled

 

Then I installed Windows UEFI in my NTFS partition and automatically Windows didn't recreate its small EFI partition, but used the bigger one I had previously prepared. Then I installed OSX, and I was able to:

-directly install on the previously prepared Journaled partition

-format the Journaled partition again from Disk Utility because this time I had a big-enough EFI partition. 

So basically this way you do whatever you want and you have all the "pros" of the different solutions, so in the future you can re-format also from Disk Utility etc..

 

 

After you install of course you still need Clover to boot inside OSX (pay attention to boot the installed system and not the installation again), you could find some "problems" maybe, but there is solution to them. I had those problems:

-wrong colors (pink-ish and green-ish colors) --> solvable changing display profile color

-bluetooth, wi-fi, touchpad, keyboard.....it is enough to properly install the kexts. I usually install them inside my system with KextWizard that is also able to repair permissions and rebuild kext cahces (important!). You can take them from Anerik's pack. Alternatively you can put them in Clover with the other kexts.

-Audio not working. For me it is the most difficult thing. If you're lucky it is also enough to use the proper kext, but I'm still struggling a bit with it...I managed to make it work in the end, but I'd like to be able to patch it in a more updated way...This time the kext has to be accompanied by a dsdt patch or by a config.plist setting. So don't worry, the audio could be a bit more tricky, but it is solvable too.

-Most important maybe: if you have graphical glitches and other instabilities (with Anerik's dsdt I was able to install the system, boot, but sometimes the system would freeze and reboot, sometimes during boot I had kernel panics, I had to boot like 3-4 times before being able to really boot into the system....) then you have to patch your own dsdt. It is not so difficult, I can help you. 

 

If you cope with the problems once at a time it will be almost "funny" being able to make it working part after part, so of course you could still need to invest a bit of your patience ahahah.

 

As a last thing, I prefer to have my Windows bootloader as the "main" bootloader, so if I turn on the pc it will boot Windows, because however it is the native system, so I didn't install Clover on the HDD with the scripts to make it automatically bootable, but I didn't even want to have the usb drive with Clover always attached or however with me...if you have to use your pc somewhere else and forget the Clover-usb at home? 

So I simply shrank the Windows partition by 300 Mb, obtaining a new small partition. I formatted it in fat32 and simply copied there my Clover files from the Clover-usb drive. In this way I don't replace or break Windows's bootloader in the "real" EFI partition, but I can access Clover as if it was on the usb drive from the EFI shell, without the need of the usb device always with me. I also removed the letter from that partition (in Windows' disk management) so that I don't even see it between the disks in Windows.

 

Hope this helps.

 

PS: for the question of the update from Yosemte to El Capitan I don't know. I installed El Capitan from scratch...You can try and see what happens, the kexts are almost all the same if I remember correctly (except the audio); before trying you can make a backup of your system with something like CCC (Carbon Copy Cloner) or SuperDuper...

Share this post


Link to post
Share on other sites

Hello, jackal992!

 

Type this message from my Yosemite)). 

 

I found that WiFI works very slow (can't download even Google Chrome). Every page loads about half minutes)).

 

Do you know what can be problem? Or which kext should resolve it?

 

I only installed Yosemite - and did nothing more.

 

P.S.: OMG, WIFI's fixed itself)). Nice speed. But no sound unfortunately. Could you help me with AudioHDA? What should I choose and how should I use this tool?

And taps on touchpad not working. But everything quite good!)))

 

P.P.S.: Next day I format all HDD and try to make your way - 400 Mb for EFI, some for Windows, some for Mac.

Share this post


Link to post
Share on other sites

For touchpad tap you must enable it in System preferences\Touchpad under "tap for click" or something like that.

Note that also the scrolling: to enable the scrolling with touchpad (two fingers) you have to change the "scrolling speed" at least once to enable it, otherwise it doesn't work. You can also come back to the default value later, but you have to move the slider at least once and try the scrolling.

 

For audio I had foretold it to you before....first of all it is always better to save the original AppleHDA.kext before tweaking with it. You can find it in System/library/extensions. To browse to that folder you can select in the Finder panel "View", and "Go to", or with the keyboard shortcut Command+Shift+G (=Alt+Shift+G) and type " /System/Library/Extensions" without quotes. You find the AppleHDA.kext and copy it somewhere else.

 

I'd suggest that you use Anerik's kext since you are on Yosemite, you can take it from post 1 or 34, you just need "AppleHDA.kext". To install it use "KextWizard" which can also automatically backup the original kext if you tick the option to backup it (the original will be placed on the desktop). Remember to always rebuild caches and permissions! Of course reboot after installation.

 

Besides...I lost which version of Clover you are using. In this case you should tell me which dsdt and config.plist you are using precisely. If you want you can also post them to be "sure". Basically you need to "inject" the use of a specific layout for audio by using dsdt, or config.plist, or another kext called "HDAenabler". I'm using config.plist, Anerik the dsdt if I remember correctly, at least for that old version.

 

So the AppleHDA works in pairs with the injector. If you only install the AppleHDA it is not enough.

 

So I need to understand if in your DSDT or config.plist there is the injection of the layout.

 

Moreover go in System Preferences\Audio and tick the option to view the volume in the sidebar (unless you already have the symbol...). Once you do that, which is the color of the symbol in the taskbar? Gray or black?

 

It is better to inject the audio only in one of the three ways, but you can also try the HDAenabler. It is another kext (injector) that you install as the other normal kexts and reboot. You can find it here:  http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=160172

Remember, you need the HDAenabler3!

 

 

Another option is to use the VoodooHDA, even though it usually offers a slightly worse quality of the audio, you can find it here: http://sourceforge.net/projects/voodoohda/ or you can use the one of the user in post 5.

Share this post


Link to post
Share on other sites

jackal992, I today I found the problem of failed loading Clover). 

It's the most stupidest cause really))).

 

Guys, I'm using cooler for notebook such as this - http://www.zalman.com/global/product/Product_Read.php?Idx=397 . It requires 2 usb for powering.

 

So...

 

******* ADVICE *******

 

UNPLUG EXTERNAL COOLER (AND OTHER USB DEVICES) FROM YOUR NOTEBOOK'S USB PORTS WHEN YOU TRY TO LOAD CLOVER FROM USB!!!

 

*************************

 

When I've done it - Clover boots from my flash drives with MacOS))). Today I wanna try to use anerik70's files (for El Capitan with El Capitan OS) - maybe I need no more to use custom Clover or smth like that. But it could be not))))

 

As for audio - today I broke my Yosemite by playing with kexts)))). 

 

Ok, I understand how to install (I only found AppleHDA269 in files from post#1) using KextWizard - nice tool. But what I should do with HDAWizard - I don't know)).

I guess that after installing kext I should patch it somehow.

Last time I used such Clover: https://www.dropbox.com/s/q2zx299sd8y8dkj/Clover_for_Yosemite.zip?dl=0

Today I want to try with files from post #19 (but there's only EFI folder - where is boot, cloverx64 and shellx64??? I think I should manually put them from post#1) and El Capitan OS (ah, I hate it Mission Control with hidden desktop thumbnails). Maybe without cooler it will loads very well))).

If it's load and install well, I will write here about it.

Share this post


Link to post
Share on other sites

Basically for "good quality" audio you have to use the AppleHDA method.

So you need to patch the AppleHDA (I guess Anerik already did this and it is posted in post 1, but that only works for Yosemite! You need a different AppleHDA for El Capitan because the AppleHDA changes with OSX versions!)

 

So once you have a patched AppleHDA you must choose between three options to make it work:

1) Patched AppleHDA + injection via DSDT

2) Patched AppleHDA + injection via config.plist

3) Patched AppleHDA + injection via HDAenabler3.kext

 

That's it.

 

Now there is also another way of patching, based always on the AppleHDA, but called aDummyHDA, but the principle is the same. In this case you don't touch the original AppleHDA, but install this new aDummyHDA kext.

This is what Anerik did in post 19. In fact you'll find the aDummyHDA between the kexts and not the AppleHDA. 

 

If you want think of this: post 1 or 34 have AppleHDA patched and injection for Yosemite, post 19 has aDummyHDA + injection (via config.plist) for El Capitan. So if you use Anerik's packs you are already good to go, you should have also audio working out of the box. 

 

 

 

If you don't want the "hassle" of all this audio thing and you accept a "lower quality" of the audio, you can use the VoodooHDA method, but I didn't try it, even though it should be way easier.

Share this post


Link to post
Share on other sites

Unfortunatelly, unpluging cooler from my notebook didn't help with loading anerik's EFI files)))).

Man, only your's one))). I thank you for your helping! Your assistance is really invaluable!!!

 

So, I try to make Clover for El Capitan using your base Clover and put kext and all the rest files into it. Result will be shown just a lil' bit later).

Share this post


Link to post
Share on other sites

I've installed pretty well El Capitan, but there's no sound - even if aDummyHDA was in kext's folder.

 

How should I do installing of this?

Via KextWizard?

Share this post


Link to post
Share on other sites

If you extract your own native acpi files I can try to patch it for you "suited" for your machine, it would be way better, whatever version of OSX you install.

 

To extract your native files:

0) CHECK: just to be sure, open the USB-Clover flash you are using, browse into the Clover EFI partition (mounting it in OSX or directly from Windows), go in the "EFI\CLOVER\ACPI\" and check that the "origin" folder is empty, now just to be sure remove my files from "patched" folder so that it is empty too  (if you want save my files somewhere just in case you need them later).

1) boot into Clover with the same flash drive of course.

2) once you are in clover press "f4" and wait some seconds. There is no feedback during or after the dump, just a slight delay as the files are written. You  can notice that for these seconds the machine is unresponsive, ie also left/right arrow don't work. When the arrow keys restart working, you can shut down your computer.

3) Remount the USB-Clover flash you are using, browse into the Clover EFI partition (mounting it in OSX or directly from Windows), go in the "EFI\CLOVER\ACPI\" and check that in the "origin" folder now there should be some files. If there are then compress the "origin" folder and post it here.

 

I warn you that in these days I have some exams at the university so it'll take some time for me to patch them. Maybe a couple of days.

 

Meanwhile you can reinsert my files in the "patched" folder and go on with them.

Moreover, which is the resolution of your screen? 1366x768 or 1920x1080?

 

PS: It would be better for you (it's in your interest...) that you also extract your own display EDID because I need it to patch the dsdt. If you don't want to do that I'll use my display's EDID, even though it's quite stupid because our machines are different (I told you, at the beginning I was using Anerik's files and everything seemed to be fine, until I started really using the system and noticed a lot of crashes and freezes).

 

So if you want to extract the EDID: too be fair I don't remember which software I used to extract mine, I only remember that I tried from uBuntu Live (get-edid and parse-edit) and wasn't able to extract probably for lack of drivers, so I tried from my Windows 10 and there too I had some problems. Finally I installed Win7 and extracted it from there. Our notebooks were "born" with Win7.... To extract the EDID you must have proper graphic drivers installed. Since you already have Win7 installed (at least I believe...) you should be already good to go. There are plenty of softwares out there which extract the EDID from Windows (from the registry...) like Monitor Asset, MonInfo, DumpEDID, Aida64 (at least i think...). If you extract it too you can post it here. For an example of what I need you can look here: https://sites.google.com/site/vquynh22/hackintosh/add-edid-to-identify-exactly-info-graphics-card-hackintosh you don't need to edit the edid with "find replace", you stop when you save the edid in the notepad, or however even if you use other softwares I need that sequence....It's up to you!

 

 

For the audio:

-which config.plist are you using? The one posted in post 32? Or Anerik's posted in post 19?

-which dsdt are you using? The one posted in post 32? Or Anerik's posted in post 19?

 

EDIT:

Have you installed the aDummyHDA.kext properly (you should take it from post 19)? You must use something like KextWizard, at least I prefer installing the kexts instead of leaving them in Clover's usb flash. So after installation with Kext Wizard (second tab, browse....install), always in Kext Wizard in the first tab there are the commands for rebuilt permissions and kext caches. Do them both. Reboot your computer. Which is the color of your volume icon in the top bar? Gray or black? If you don't have the icon of the volume enable it from SystemPreferences\Audio.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4542 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 14 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4542 for VMware.zip". Mount Clover-v2.4k-4542-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By MaLd0n
      First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
    • By MaLd0n
      --Install Follow my tutorial and use my Clover folder http://www.insanelymac.com/forum/topic/323052-guide-sierra-high-sierra-on-intel-5-6-7-8-and-9-chipset-series-nehalem-sandybridge-ivybridge-haswell-broadwell/ CLOVER Install.zip   --Post Install --Install Clover bootloader and replace with my folder CLOVER Post Install.zip   Bingo!   Now you need a fine tune! DSDT time!   If you need edited DSDT... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app     -DSDT bios F23 My DSDT  DSDT.MaLd0n GA X99-UD3P.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -sSATA -DMAC -SLPB -DARWIN -LPC -XHCI -EHCI -PLUGIN TYPE -ALZA to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -IMEI -SHUTDOWN -LAN -SPSR -EC -PNLF -HDMI


      e.g

       
      -Clover https://sourceforge.net/projects/cloverefiboot/files/Installer/ -FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, nmano and many, many, many others!   We're all here to have fun and learn from each other!  
    • By zebity
      Hi Hypervisors,
       
      EDITED - 9 JUNE 2018 - as all other issues resolved but am now stuck with QEMU Error: "PFLASH: Possible BUG - Write Block Confirm" details on testing lower in thread (to follow).
       
      I have been working to move my Late 2009 Xserve MacOS Server onto Ubuntu 18.04 LTS QEMU/KVM based virtual machine using OVMF and Clover.
       
      After much effort and testing based on the following information from: Kraxel's, Kholia, Gordon Turner and Clover site:
      https://www.kraxel.org/blog/2017/09/running-macos-as-guest-in-kvm/
      https://github.com/kholia/OSX-KVM
      https://gist.github.com/gordonturner/2a2e5ecde5e7860b52e2
      https://clover-wiki.zetam.org/Home
       
      I have now managed to get OVMF/Clover boot and install of MacOS Sierra.
       
      I started with Ubuntu 16.04 initially but this required download and compile of QEMU to get update of machines to: pc-q35-2.9 or better, so I moved to Ubuntu 18.04, which has pc-q35.2.11 available as standard.
       
      So I am now working with standard Ubuntu 18.04 LTS based systems with following packages: kvm/qemu/libvirt/bridge-utils/ovmf/virt-manager
       
      As I want to use PCIe Passthrough for a number of PCIe card currently installed in the server (SmallTree 10GbE & Areca ARC-1883 SAS RAID) I set up my machine with linux kernel boot configuration (/etc/default/grub) of: 
      GRUB_CMDLINE_LINUX_DEFAULT="iommu=1 intel_iommu=on" (as my machine is intel VT-d based HW virtualisation)
       
      This resulted in creation of a number of iommu groups (see /sys/kernel/iommu_group directory for this and this posting for information: https://forum.level1techs.com/t/ubuntu-17-04-vfio-pcie-passthrough-kernel-update-4-14-rc1/119639 , noting that Ubuntu 18.04 LTS has kernel version: 4.15.0-22-generic so there is no need to do kernel update for iommu to work).
       
      Using bare minimal Clover config.plist:
       
       
      And following Clover UEFI drivers:
       
      I can boot MacOS, but it is very very slow... it sits on the apple boot logo for over a minutes before finally moving onto the progress bar.
      The other problem I have is that no PCI or Network devices appear in the "About This Mac" System Information Report and I cannot get any network connectivity from bridged E1000 network device.
       
      Here is my virtlib.xml dump for the virtual machine:
       

      Can any one advise of whether I need to update the CLOVER config.plist to add extra items in to allow network and PCI Passthrough to work.
       
      Thank you.
       
      Regards,
       
      Zebity
       
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.13.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  selezionate OsxAptioFixDrv-64
                             *  :Se nel vostro sistema è presente una scheda grafica (discreta) della serie 9xx nVidia selezionate OsxAptioFix2Drv-64 al posto di  OsxAptioFixDrv-64 *
      ** OsxAptioFix2Drv :E' necessario per poter impostare CsrActiveConfig= 0x3 **
      ***OsxAptioFix3Drv oppure AptioMemory --> (consigliato) devono essere usati su hardware Skylake o successivi perché permettono alla nvram di lavorare correttamente
           (mi raccomando o uno o l'altro)
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
       
       
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      apfs.efi-10.13-NoLog.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      apfs.efi-10.13.1-No_LOG.zip
      apfs.efi-10.13.2_No_Log.zip
      apfs.efi-10.13.3-No_Log.zip
      apfs.efi-10.13.4-No_Log.zip
      apfs.efi-10.13.5_No_Log.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip
×