Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Agostino9446

Imessage and facetime Public Beta 2

126 posts in this topic

Recommended Posts

Hi arsradu,

 

It looks like Apple has tightened its server side checking procedures again!

 

At the moment, you need the MLB & ROM from a real Mac in your Clover Rt Variables/config.plist in order to activate iMessage/Facetime.  I posted about this here.  The "call Apple Support with error code" method doesn't seem to work anymore unless you have at least a genuine MLB value in your config.plist.  With both MLB/ROM genuine, you don't have to call support at all :).

 

Good luck!

 

 

Only Apple exactly knows the authentication algorithm. 

 

iMessage isn't part of iCloud authentication, it has it's own. As hardware identification has become a drastically important part of FaceTime and iMessage authentication, to make continuity work properly, Apple uses MLB value to identify your device. Self generated MLB's wouldn't work as those don't match with Apple's MLB's pattern. MLB is reversible as is Serial Number. 

 

Since the Hackintosh community started to call actively to Apple Support, they have updated their server side authentication, it seeks for proper pattern, if this is not found, you never get activated anymore. If you are able to generate by-self proper MLB, you probably pass the validation. Anyway, there is no any public knowledge available how to generate it. Thats why original ROM/MLB become useful. There is a light change to generate a valid 13 char length MLB, but it works on case when your comp is not the latest model. Since 2010 Apple changed the way how serials are made. Since this comps have 12char serial numbers instead of 11 char serials, and MLB's length is since this 17chars, instead of 13chars.

 

You can read more here -  MLB pattern.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hello MaLd0n,   Could you please make DSDT edits for my new Skylake desktop Lenovo M910t    RunMe files: https://www96.zippyshare.com/v/5bgqAiga/file.html
        Thank you very much in advance!
    • Have you tried adjusting the Khz in midi pref pane or editing the info plist to suit your needs. that sometimes corrects weird noise behavior.
    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/   My system:
      Gigabyte GA-X48-DQ6
      Core 2 Extreme QX9650 C0
      4 x Kingston DDR2 800ghz Ram
      Galaxy GTX460 1GB
      120GB SSD Leven JS500120C, high Sierra installed
      250GB seagate ST3250310AS
      250GB WDC WD2500JS-08NCB1
      File: https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing      
    •   Still garbled sound in earphone. The speaker is loud as previous. louder than 2.9.1   
    • Up for https://sourceforge.net/p/cloverefiboot/wiki,


×