Jump to content
themacmeister

ACER Aspire 4752 10.9.5 Guide with kextpack

72 posts in this topic

Recommended Posts

Here is the final kextpack - absolute necessity -> http://www.4shared.com/zip/L_N8E35Sba/Final_Acer_Aspire_4752_kextpac.html

 

Mac OS X Mavericks 10.9.5 on an Acer Aspire 4752 (MS2349)

 

EZAsfYx.jpg

 

Fgj1Rja.jpg

 

mHeGmhf.jpg

 

Cc2fS0w.jpg

 

7TQx6jd.jpg

 

 

 

vjdGFeK.jpg

 

7Hsxb16.jpg

 

REQUEST: If you have a fully unlocked BIOS (advanced/power) for this laptop, please contact me.

Luckily, AHCI is enabled by default. The BIOS I have WILL NOT BOOT from GPT formatted internal drives. I wish it were otherwise, as the computer would be more fluid, and extensible with GPT (easy resize/repartition), as well as the ability to install a recovery partition. You can retroactively convert MBT to GPT using open-source tools, but I am not sure how safe it will be?

 

UPDATE: I reverted to a different DSDT.aml without patches. I will need to re-run IRQ dsdt patch, as audio auto-sensing jack and HDMI audio not working at the moment. I had them working, as the screenshots show. This may also be why shutdown/restart was misbehaving... will try again and report back.

 

UPDATE: It WAS the IRQ patch. Fixed and Final and last kextpack uploaded above. ~75MB

 

REQUIREMENTS

 

MyHack for creating Mac OS X Mavericks boot USB (included in kextpack)

InstallESD.dmg or full "Install OS X Mavericks.app" for 10.9 or 10.9.4 UPDATE: 10.9.5 installer app now available via App Store!!!

OSXUpdCombo10.9.4.dmg  (download from Apple if required)

Download my kextpack above - this is ESSENTIAL.

Working Hackintosh or real Mac to create boot USB disk.

8GB+ USB disk/stick for boot media.

 

HARDWARE

 

Core i3 2350 @ 2.3GHz (2 cores - 4 threads). 4GB 1333MHz DDR3 SODIMM.

500GB HDD. Intel HD Graphics 3000. Incompatible WiFi card.

1366x768 backlit screen. 2 x USB 2.0, 1 x USB 3.0. Pioneer DVD-RW.

Broadcom SD-Card Reader, HDMI-video-out, VGA-out, Broadcom Gigabit Ethernet.

Broadcom 2070 USB HCI Bluetooth (optional).

UPDATE: Using Atheros AR9B195 Combo Card, I am of the opinion that I am using Bluetooth on the card, because I covered pin 51 with electrical tape, and I have bluetooth discovered and working again. I will double check this before going any further, but the combo card is Atheros AR9285(WIFI)/AR3011(Bluetooth), so Bluetooth3.0 +HS instead of 2.0 :-)

 

HARDWARE CHANGES

 

Replaced existing incompatible pcie wifi card with Atheros 9285 based card.

 

GUIDE

 

CREATE BOOT MEDIA

 

Use MyHack to create OSX boot USB disk. Remove the first two problematic kexts if it asks.

Keep AppleTyMCEDriver.kext

Extract MyHack_Extra_for_USB_Boot_creation.zip and copy and replace Extra folder on root of USB.

 

Copy my kextpack onto your boot USB media. This will make your install so much easier.

 

Run MyFix (FULL) on boot USB.

If the following install does not let you install to an MBR formatted drive, use one of the patches I provide (only for 10.9 and 10.9.4).

 

INSTALLATION

 

Shutdown your laptop. Make sure it is on the charger. Insert your USB boot disk into left-side port.

Start your laptop and quickly press F12 until the boot choice screen appears. 

I had some issues with initial USB detection, but removing, reinserting and restarting fixed all that.

Press F8 at the boot prompt and enter the following:

GraphicsEnabler=No IGPEnabler=Yes -f -v

Press Enter

At the main install screen, launch Disk Utility from the Utilities menu, and format your main HDD as Mac OS Extended (Journaled) as MBR (under Options... button).

Install as normal. At the end of the install, MyHack will prompt you to remove problematic extensions. Remove the first two, but keep AppleTyMCEDriver.kext.

 

UPDATE TO 10.9.4 UPDATE: Not needed when using newest 10.9.5 Install Mac OS X Mavericks.app

 

Boot with the USB stick again, select your laptop hard drive this time, but as before, type:

GraphicsEnabler=No IGPEnabler=Yes -f -v

Update to 10.9.4

 

INSTALL ESSENTIAL KEXTS

 

Reboot same as before with USB stick and GraphicsEnabler=No IGPEnabler=Yes -f -v

Install Chimera 3.0.1

Delete MyHack.kext from /System/Library/Extensions

Delete existing /Extra folder and replace with contents of supplied CURRENT WORKING EXTRA folder.zip

Delete existing /System/Library/Extensions/IONetworkingFamily.kext/Contents/Plugins/AppleBCM5701Ethernet.kext

Decompress Kext Utility 2.5.7 onto Desktop

Drag all kexts in KEXTS_YOU_NEED_THESE by dragging them all onto Kext Utility.

This should now have your laptop in a fully working state.

Run Kext Utility 2.5.7 to fix permissions and create kext cache.

Reboot, should start Mac OS X in GUI mode immediately.

 

All available software (App Store/iTunes Store/iCloud/Steam etc.) and networking working fine.

 

NOT WORKING AT THIS POINT

 

ONE ACPI Fn-Key is non-functional (Brightness-Down)but it is mirrored at fn-F12. This also means no caps-lock and scroll-lock. Might be fixable with raw keycodes.

Lid-Open Wake not working (lid-close sleep works).

Wake from Power Button only (almost identical under recent Linux, except keyboard also wakes). Trackpad and mouse do not wake computer.

No fan speeds reported, as BIOS controlled. A complex DSDT hack can fix this, but it is beyond me. The fan is quite audible, so you can almost guess the correct speed :)

 

UNTESTED

 

1/8-Inch Mic port (I don't own a microphone). I expect this will work as it is listed in System Report/Audio.

 

FULLY WORKING (& ACROSS SLEEP/WAKE) - TESTED

 

2 cores (4 threads) with AICPUPM natively, and all RAM.

Screen res/backlighting and Intel HD Graphics 3000 384MB+ all sweet. EDID RGB fix required for correct colour.

2 x USB 2.0 and one USB 3.0 all working perfectly.

SD-Card Reader.

HDMI video and audio, mirroring and extra monitor fine. Audio auto-switch back to analog when unplugged.

VGA Out working, but you would need to REALLY want it. It needs to be manually detected, and after unplugging, the computer is unaware it is not there until restart. I would recommend strongly against using VGA for a dual-monitor setup.

DVD-RW, read and burn, DVD playback all tested and working.

Gigabit ethernet.

Bluetooth 3.0

ALC269-based audio - 96k 24bit out and internal mic.

Keyboard/Trackpad - Tap, drag, 2 finger multitouch working.

Lid Sleep

Battery reporting/charging - fully automatic. Screen dim etc.

1/8-Inch stereo headphone port (auto-sensing)

 

NOTES

 

Sleep/Restart/Shutdown was causing serious issues until I replaced System.kext with one from an AMD 10.9.3 kernel package. This sounds bizarre, but it appears to be working :-|

For some inexplicable reason, the CPU was only going as low as 1.6GHz, not 800MHz. After replacing System.kext and rebuilding system and kernel caches, SpeedStep appears to be functioning correctly again...

Edited by themacmeister
update working download link

Share this post


Link to post
Share on other sites
Advertisement

Hmmm, this BIOS/Hardware does NOT like GPT formatted hard disks. I have had to format as MBR, and patch the installer for 10.9.0.

 

Everything has gone very smoothly since then, I have a DSDT file, which I am not sure is necessary for anything but HDMI output, although I believe it was successfully tested with HDMI out under 10.9.2.

 

I have updated to 10.9.4 with no ill effects. I have installed the latest HWMointor and FakeSMC, but I still get very rare lines through the screen, usually moving windows or scrolling. These are VERY rare, and only in certain programs. I wouldn't even call this an issue, as the artefacts are only temporary, and very slight.

 

I have not tested Sleep/Wake, but I have tested everything else. There is an issue with Shutdown/Reboot -- so I will apply the shutdown fix and see what happens. I have patched AICPM and no longer need NullCPUPM. I have also used RevoGirl's speedstep script to get all 16 power states functional with a new SDDT.aml file.

 

Here's a short list of what I have currently working:

 

CPU (detection, speed and power management working) - Core i3 2.3GHz 2-cores 4-threads

RAM (detected and working - showing 4 slots although there are only 2 in the machine)

Keyboard/Trackpad - both working well. Multitouch/gestures working on trackpad.

Intel HD Graphics 3000 - Working, showing correct 384MB RAM

USB 2.0 - both ports working well

USB 3.0 - port working with GenericUHCI.kext

Sensors (all working except Fans)

Wired Lan - Working with patched AppleBCM5701Ethernet.kext

Wireless Lan - Working with replacement Atheros AR92B95, and edited AirPortAtheros40.kext (inside io80211Family.kext plugins folder)

 

There are some remaining issues, like Bluetooth, but I am looking into those.

 

Also there are slowdowns, like Installer packages taking forever to load, and run (???). I may need a patched dynd?

 

I was hoping the laptop would be more responsive, but it could be a combination of MBR along with software issues. I will try a Mac Mini SMBIOS definition soon, and see if that helps (I have noticed differences in performance with my desktop Hackintosh with different SMBIOS configurations).

 

More news shortly, and possibly a kext download kit.

Share this post


Link to post
Share on other sites

Sleep tested and working - only resume with Power Button, but there may be a patch available for that. I know I screwed up the ApplePS2Nub kext thingy, so will need to reinstall that (or VoodooPS2) -- I am using a USB mouse, so it wasn't noticed for a while - They are in /Extra/Extensions, and I haven't merged them yet.

 

More news as it happens...

Share this post


Link to post
Share on other sites

Hooray, entire computer and all hardware functioning perfectly (except still occasional graphic corruption, this might be fixed with another version of FakeSMC).

 

I went through a horrible period last night -- trying to get the (non-existent) Bluetooth running, the computer would only start-up with -f -v flags. This was most annoying.

 

Also, I was getting an "Incorrect image size" error on startup too.

 

I manually replaced /boot with another one, and it got rid of that error.

 

I reinstalled the virgin IOBluetoothFamily.kext, and reinstalled Chimera 3.0.1, and the laptop is functioning really well again, with apple splash screen. Laptop is booting faster than it ever has!!

 

I tested HDMI port, and video mirroring/separate screens is perfect (up to 1080p), but I still have no audio over HDMI. This can be fixed with a DSDT patch and IntelFBkext edit, which I will try tonight.

 

I managed to get patched AppleHDA for ALC269 (actual card ALC271x) working nicely (with DSDT edit for Layout 28), now I have microphone input and auto-switching headphone jack.

 

Sleep/Wake/Shutdown/Reboot all working swiftly without a hitch.

 

Although I have the Broadcom BCM92070(?) Bluetooth sticker on the bottom of the laptop, the compatible kext edit to get it working failed miserably, and nothing remotely Bluetooth shows up with "lspci -vvv"

 

This was the cheap 2GB RAM model (since updated with 4GB DDR3 1600 RAM), and bluetooth was optional on this model... so no bluetooth hardware (never use it anyway).

 

There are no USB or network issues after sleep. Gigabit ethernet and wireless seem perfect -- full speeds for both, tested SMB and AFP connections, all fine.

 

Only problems at this point:

 

very slight screen corruption on a very rare basis (fixable?)

 

no HDMI audio (fixable)

 

cannot use keyboard/trackpad/mouse to come out of sleep. Not really a problem, but I would like to get wake on clamshell-open working (if it exists).

 

brightness up/down function keys are in a different position (normally fn-left & fn-right). These should be remappable, now I am using VoodooPS2 latest branch. Slider appears in Display preference panel for screen brightness.

 

kextcache rebuild fails most times... I wonder if I should use another tool besides Kext Utility?

 

Kext archive coming very soon (after I get HDMI audio working probably).

 

I have cloned my laptop HDD at the current point (bootable) in case disaster strikes :-)

 

more news soon...

Share this post


Link to post
Share on other sites

Kext archive is on the way tomorrow. Doing the HDMI audio fix tonight, and may experiment with DSDT fan settings/readings.

 

Looking at some Ubuntu posts, Acer (and others) are notorious for making laptops with no software fan control...

 

Going to try ACPIThermal.kext tonight, and see if that helps at all (it is a bit out of date tho).

 

From more reading, I can see the screen artefacts that appear sometimes are just a part of life, and I can only minimise them (which I have already done).

 

If everything works nicely, there should be a nice big zip file posted here tomorrow... wish me luck!

Share this post


Link to post
Share on other sites

hmmm, I had some dodgy RAM in that system (I thought it was the computer, so replaced the computer!! damn!) but I swapped it for the slightly slower 1333 DDR3 I had, and I am back on track.

 

I also switched back to a MacBookPro8,1 SMBIOS.plist, as I don't think it really matters (and I get the feeling that AGPM will work - maybe need a Chimera injection code).

 

I have put the DSDT edits for Fan reporting in the "too hard" basket, and will look into this at a future date. I must stress that rolling back to an older (10.8) AppleACPIPlatform.kext has made a marked difference with this laptop!

 

I don't know if this laptop has a clamshell-open switch, but I will also look into this later.

 

Will go now and install the HDMI fix, and if it works, will supply a "hackintosh in a box" archive here, along with a guide.

 

Cheers til tomorrow.

Share this post


Link to post
Share on other sites

Sorry for the delay... a friend's 13yo daughter committed suicide recently, and the funeral is tomorrow. I have had my mind on other things...

 

I will assemble the package tonight, and hopefully post it tomorrow night.

 

Remaining issues to fix:

 

No lid-open, keyboard or mouse wake from sleep (not a deal breaker)

No HDMI audio out (could be a deal breaker for those with HDMI screens)

No AGPM - unknown platform - (I will try to copy the MacMini5,1 settings in AGPM.kext)

No ACPI fan speed reporting (might be a difficult fix)

One ACPI fn-key button not working (brightness down - function-left-arrow) - I have remapped brightness/volume to F1/F2/F8/F9 with BetterTouchTool, so no biggie.

 

Anyone who has any of these working on their Acer Aspire 4xxx/5xxx laptop, please give me your DSDT.aml file, so I can compare it to mine...

I'm sure my Intel Framebuffer kext needs editing for HDMI out, but I need guidance! I do NOT have a HDAU device in my DSDT (is that only discrete graphics cards?).

 

With new Kext Utility 2.5.7, all is going really well. No stalls or hold-ups with installers/app launches. It is behaving exactly like an actual Apple laptop would work.

Share this post


Link to post
Share on other sites

Progress!!!

 

Bluetooth is now working!!! Had to launch into Linux, and press fn-F3 a lot of times, then studied the logs. Thankfully, the Vendor and Product ID was listed there. I followed other guides and inserted this info in decimal, into /S/L/E/IOBluetoothFamily.kext/Contents/Plugins/Broadcom....kext

 

I have been suffering from extended delays in reboot and shutdown, some so long that I had to do a hard-shutdown. In the logs, it looks like APSD is the main culprit. I didn't notice it at all before bluetooth was working, so it may be bluetooth related (waiting for push event?)

 

anyways, I'll check my settings again...

 

PS. kextpack is coming along, as is a draft of the guide. kextpack is 70+MB already... have a few helpful tools included.

 

More soon

Share this post


Link to post
Share on other sites

Funeral service was well done. I'm here at work, and the damn work proxy won't let me upload anything to anywhere -- sigh, a bad day for the WIFI to break down :( No kextpack until tonight.

Share this post


Link to post
Share on other sites

New install guide completed, but I am waiting to fully test restart/shutdown issue. I am pulling my hair out over this. I may need to "borrow" some DSDT code from another Acer laptop.

 

Same with lid-wake.

 

Back with all the goodies tomorrow...

Share this post


Link to post
Share on other sites

gdisk will not convert this single partition from MBR to GPT - it says there is a 32 block overlap between the two (???) partitions.

 

Anyways, I am relatively happy with MBR, I may start from scratch and see if I can reinstall from my backup... onto GPT.

Share this post


Link to post
Share on other sites

FINAL GUIDE AND KEXTPACK ABOVE

 

EVERYTHING WORKING, except ONE fn-FKEY (brightness down-remap to fix), no fan reporting (fans run fine based on CPU temps),  and lid-wake (use power button).

 

I can certainly live with that  :D

Share this post


Link to post
Share on other sites

Used the laptop all yesterday and all last night -- put it to sleep more than 20 times, woke perfectly. Went to restart -- infinite wait (with hard drive flashing rhythmically).

 

I have backed up the system, so might test USB backup, and then use the external USB HDD for launching OSX?

 

PS. Don't buy cheap slim toshiba 500GB USB HDD. They are IDE and use a bridge, and they DO NOT BEHAVE WITH MAC OS X !!!!

Share this post


Link to post
Share on other sites

I have bitten the bullet, and I am trying GPT formatted disk again. If it doesn't want to boot (due to legacy mode BIOS), then I will shrink the partition with GParted, and add a hidden FAT32 partition at the end of the drive, forcing a hybrid GPT table, which should boot on a legacy BIOS. I will still have the ability to use all the cool GPT features tho :-)

 

Also, when booting from my USB 10.9.0, there are extra ACPI power features showing up with pmset -g

 

I might experiment rolling back to 10.9 AppleACPIPlatform.kext to see if I can get lid-wake working?!

 

PS. I have already rolled-back to AppleACPIPlatform.kext from 10.8 anyways...

Share this post


Link to post
Share on other sites

GPT was a nightmare. I destroyed the entire partition. I now know of newer methods, but I have a seriously locked-down BIOS, so have no control over Legacy BIOS.

 

Also, audio jack sensing sometimes stops working after sleep. Annoying.

 

I have put enough time and effort into this. I am no longer working on improving this computer. I will keep Mac OS X 10.9.4 on here for a while longer, until little niggly issues make me give up and revert to Win7 64bit again.

 

PS. Upped the RAM to 8GB, made a huge difference.

Share this post


Link to post
Share on other sites

Not 100% sure what I did, but the little HackBook Pro is working very nicely.

 

Haven't seen screen artefacts in ages, and restart/shutdown seem to be working perfectly too (if a little slowly)

 

I will have more news in two days, after giving the laptop two full days at work.

 

Cheers.

Share this post


Link to post
Share on other sites

Working fine, been testing... sometimes takes longer than normal to load up, and sometimes freezes while loading Chimera bootloader (very rare, about 1 in 50).

 

Jack auto-sensing can sometimes get out of whack and stop working. Been working fine last two days... but keep that in mind. Actually, my other hackintosh with a custom AppleHDA patch is playing up too... almost like a recent Apple update has broken something. Might need to reinstall audio kexts again.

 

NO MORE FOR THIS. I WILL CALL THIS A FINAL GUIDE, AS I BELIEVE I CANNOT IMPROVE ANYTHING!!!

Share this post


Link to post
Share on other sites

I have updated to 10.9.5, needed to reinstate NullCPUPowerManagent.kext as the usual AICPMpatch no longer works (?!)

 

Some kind soul on this forum also patched my DSDT.aml with my AR9285 WiFi card details, and it isn't prone to dropouts under load anymore.

 

So, there will be a new KextPack soon, without IO80211Family.kext and with NullCPUPowerManagement.kext as well as new DSDT.aml

 

More soon with more testing...

 

I had issues with excess CPU, but it was just mds (metadata service) running amok. I disabled it on the main hard drive, and saved nearly 20 degrees Celsius on my CPU temps.

 

Search Google for how to permanently disable mds service.

 

I attempted using GenerateCStates and GeneratePStates, but it appears to be the same result as without... so I will clear that up before posting the next kextpack.

Share this post


Link to post
Share on other sites

Some very kind person gave me the Airport AR9285 injection into my DSDT. Apart from showing my locale as FRANCE, it works PERFECTLY, and no longer drops out permanently under load. Thoroughly tested and perfect. Also updated to very latest 10.9.5, and all other App Store updates.

 

I will post the DSDT shortly, and update the kextpack as well... pls be patient.

Share this post


Link to post
Share on other sites

I have also discovered a fix for zero Amp value/jack sensing on Wake - kext fix will be included in new kextpack upload (after testing), along with patched WiFi DSDT!

 

Should have this up and posted by Saturday at the latest... sorry about the wait, a lot of work here at the moment.

Share this post


Link to post
Share on other sites

Here is the updated kextpack with new DSDT for AR9285 wireless perfection.

 

http://www.4shared.com/zip/6O4kUaE_ba/Final_Acer_Aspire_4752_kextpac.html

 

Also, here is a possible solution for sound/jack-sensing not working after sleep

 

http://forum.osxlatitude.com/index.php?/topic/3084-eapdjack-sense-fix-no-audiojack-sense-issue-after-sleep/

 

EXPERIMENTAL - ONLY FOR THE BRAVEST - possible fix for ALC269 in DSDT -> need to extract from the following:

 

http://www.4shared.com/file/DdR-H8k8ba/DSDT__ALC269_.html

 

DO NOT USE THE WHOLE DSDT FILE!!!

Share this post


Link to post
Share on other sites

Now I know that my WIFI dropouts had absolutely NOTHING TO DO with my hardware or Mac OS X, I have gone back to latest Mavericks. I may experiment with Yosemite shortly, after backing up my entire hard drive to bootable USB.

Share this post


Link to post
Share on other sites

I have managed to get my laptop back to the way it was before. Most stuff working, I am avoiding using Sleep to be safe, although it appears to be working OK (it has slept automatically a few times, and came back to life OK.

Share this post


Link to post
Share on other sites

I can confirm the following is working on this laptop, even across multiple sleep/wake occurrences:

 

Mac OS X 10.9.5 with all updates...

 

Intel HD Graphics 3000 (512MB) with HDMI+AUDIO, headphone out

WIFI (replaced with AR9285). Working fine, also AirPlay showing in Display prefpane now.

AHCI Intel 6 Series SATA

Built-in 1.3mp camera/mic

Battery monitor, + all sensors except fans. Fan running fine on auto.

Trackpad (a bit too sensitive with myH*ck ApplePS2 stuff, works better with VoodooPS2/BTT, which I will try again soon)

Keyboard (all but two Fn keys working) - they can be remapped

USB 2.0 (perfect)

USB 3.0 (perfect)

Bluetooth 3.0 (full auto)

 

More news as it comes to hand.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×