Jump to content
PHV

Full Resolution at Clover

53 posts in this topic

Recommended Posts

Dude, no money please. You're in violation of forum rules!!

 

First, get everything back to vanilla state. Remove the EDID, flash the stock ROM, use only the PatchVBios option.

Second, make sure your connected via digital out (HDMI or DVI). NOT VGA

 

And lastly, check you monitor's scaling settings. It usually has 16:9 or auto, select 16:9.

 

Okay sorry, I didnt know that. 

 

So everything is back to vanilla. Only leaved the Things I need to boot up my Machine. You will find a boot.log and a config.plist below. 

 

I'm using a DVI Cable and my Monitor is set to "Aspect". I had two Options, "Aspect" and "Fullscreen".

 

 

What can we speak about without boot.log?

 

 

 

Sorry, below you'll find my boot.log. I looked inside and maybe the Solution is in those Lines:

 

"0:125  0:025  BiosVideoDriverBindingStart!

0:125  0:000  BiosVideoCheckForVbe
0:125  0:000  EdidOverride not found
2:989  2:863   Edid1-
5:852  2:863   Edid0-
5:894  0:041     0 640x480 attr=3BF - ok, 640x480, working, highest, pref=0
5:896  0:001     1 800x600 attr=3BF - ok, 800x600, working, highest, pref=1
5:897  0:001     2 1024x768 attr=3BF - ok, 1024x768, working, highest, pref=2
5:898  0:001     3 1920x1080 attr=3BF - ok
5:905  0:007     4 1280x800 attr=3BF - ok
5:907  0:001     5 1280x720 attr=3BF - ok
5:907  0:000  BV new mode: 2 1024x768
6:333  0:425   SetMode pref 2 (2) = Success"
 

 

This has to do with the CSM support module, just disable it.

 

I dont find this Option in my BIOS. I got a Asus P5Q Deluxe with EFI BIOS on it. 

 

Here is my boot.log and my config.plist:

 

bootlog-configplist.zip

Share this post


Link to post
Share on other sites
Advertisement

Well, according to your boot log, your monitor's EDID is missing.

 

Are you sure you were running the stock/untouched nvidia ROM when you got this log? Because I can see that 1920x1080 already exists which means you don't need to patch your ROM or even use PatchVBios !!

 

If you're sure, then boot into windows, get a clean EDID dump, put it in Clover's config.plist and remove the "PatchVBios" and "ScreenResolution" entries you have.

 

Have a look here: http://www.hackintoshosx.com/topic/20664-guide-edid-injection/

Share this post


Link to post
Share on other sites

Oh you mean the stock Nvidia BIOS? The 1920x1080 is there because I flashed it. I'm running this flashed BIOS right now, should I flash it with untouched VESA Tables and upload a new boot.log? 

 

I thought my EDID is already injected because "About my Mac" detects and matches my Monitor Model:

 

mo5jsls9.jpg

Share this post


Link to post
Share on other sites

Oh you mean the stock Nvidia BIOS? The 1920x1080 is there because I flashed it. I'm running this flashed BIOS right now, should I flash it with untouched VESA Tables and upload a new boot.log? 

 

I thought my EDID is already injected because "About my Mac" detects and matches my Monitor Model:

 

mo5jsls9.jpg

 

Yes, I mean the stock stock nvidia bios with untouched tables. Patching nvidia ROMs for custom VESA resolutions is very unreliable (and even dangerous sometimes).

 

The EDID in Mac is read by the NVIDIA driver. Clover can't see that EDID so we might need to add it manually to Clover's config.plist

 

Post another boot.log with the stock ROM. And have an EDID dump from Windows ready in case we need to add it to Clover.

Share this post


Link to post
Share on other sites

Did you have the PatchVBios option enabled with that last log?

 

I think its time to try adding your EDID to the config.plist. Check here: http://www.hackintoshosx.com/topic/20664-guide-edid-injection/

 

PS. Since you're using an older motherboard, install Clover using BiosBlockIO option instead of SATA to have it startup faster :)

Share this post


Link to post
Share on other sites

Yes, PatchVBios is enabled. Should I disable it? 

 

ViewSonic EDID Editor isn't working for me, "ActiveX could not create this object". So i ran RW-Enabler and got splitted HEX Number Block. Its this:

 

  00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

00 00 FF FF FF FF FF FF 00 04 72 CA 02 A2 60 30 20
10 03 16 01 03 80 3C 22 78 CA 7B 45 A4 55 4A A2 27
20 0B 50 54 BF EF 80 71 4F 81 40 81 80 81 C0 81 00
30 95 00 B3 00 D1 C0 02 3A 80 18 71 38 2D 40 58 2C
40 45 00 56 50 21 00 00 1E 00 00 00 FD 00 38 4C 1F
50 53 11 00 0A 20 20 20 20 20 20 00 00 00 FC 00 53
60 32 37 31 48 4C 0A 20 20 20 20 20 20 00 00 00 FF
70 00 4C 55 57 30 44 30 30 35 38 35 33 30 0A 00 E8
 
According to this Guide: http://www.hackintoshosx.com/topic/20664-guide-edid-injection/ I have to erase the first line and column. Is this the Block from "00" to "0F"? Dont want to make any mistake. Do I have to convert the large HEX Number into Base64 or is Clover that doing for me? 
 
Thank you for the SATA Tip, my Machine takes a long time to load up. I will try it! :)

Share this post


Link to post
Share on other sites
Add this to your config.plist
<key>CustomEDID</key>
<data>AP///////wAEcsoComAwIAMWAQOAPCJ4yntFpFVKoicLUFS/74BxT4FAgYCBwIEAlQCzANHAAjqAGHE4LUBYLEUAVlAhAAAeAAAA/QA4TB9TEQAKICAgICAgAAAA/ABTMjcxSEwKICAgICAgAAAA/wBMVVcwRDAwNTg1MzAKAOg=</data>

And keep PatchVBios enabled but remove the ScreenResolution entry from the config.plist

Share this post


Link to post
Share on other sites

JESUS 

 

I LOVE YOU

 

It works <333333333

 

Clover and Bootprocess now in unstretched, sharp 1920x1080 :)))))

 

You are my Hero man, but thanks to all Guys who wanted to help me! :)

 

Best community ever, I thought I would never get rid of that stretched Bootscreen. 

Share this post


Link to post
Share on other sites

Try changing Option ROM from forced bios to the other option (current I think)

 

Didn't know P5Q had a EFI BIOS. That's awesome to know though.

Share this post


Link to post
Share on other sites

Originally it came with a normal BIOS but theres a official EFI BIOS in Beta Stage :) But they didnt finalize it lol. But it runs very stable 

Share this post


Link to post
Share on other sites

 

Add this to your config.plist
<key>CustomEDID</key>
<data>AP///////wAEcsoComAwIAMWAQOAPCJ4yntFpFVKoicLUFS/74BxT4FAgYCBwIEAlQCzANHAAjqAGHE4LUBYLEUAVlAhAAAeAAAA/QA4TB9TEQAKICAgICAgAAAA/ABTMjcxSEwKICAgICAgAAAA/wBMVVcwRDAwNTg1MzAKAOg=</data>

And keep PatchVBios enabled but remove the ScreenResolution entry from the config.plist

 

I must be doing something wrong. Can someone take a screenshot of how this is entered or upload the section of your config.plist file? I keep getting errors that I'm using an invalid Hexadecimal entry.

 

cheers

 

Share this post


Link to post
Share on other sites

I must be doing something wrong. Can someone take a screenshot of how this is entered or upload the section of your config.plist file? I keep getting errors that I'm using an invalid Hexadecimal entry.

cheers

you're not trying to enter it into clover configurator are you? Because clover configurator needs it to be in hex, it automatically converts it into base64 in the confug.plist. if you enter it directly into the config.plist then you would use base64 format as shown above.

Share this post


Link to post
Share on other sites

Can somebody help me get full resolution on my Asus 5870? Currently i get maximum 1280x1024 at clover boot screen. Ive disabled CSM and am using Other OS for the UEFI option in BIOS.

 

I have a Dell U2713HM 2560x1440 display, and for starters would like to get 1080p to work. Manual VBIOS patching with hex editor hasn't worked. I tried to patch alll instances of 800x600 to 1920x1080.

 

I also tried screen resolution key in config.plist, but in preboot.log it says unable to select 1920x1080.

 

Edit

Made some progress and logs updated.

So boot.log shows it tried to patch 320x200 res to 2560x1440, but later it doesn't show up as a usable mode. Is it possible to auto-patch a mode like 1280x1024, one that does appear?

preboot.log.zip

boot.log.zip

config.plist.zip

Share this post


Link to post
Share on other sites

Reading this topic, I grabbed the necessary data to see how it would be to have Clover full res on boot.

 

It doesn't bother me to have just the center of the screen with BIOS/Clover. But I gave a try.

 

I didn't used Windows to get EDID data, I followed this instructions, using IORegExplorer: http://www.insanelymac.com/forum/topic/208410-fixing-scrambledstretched-or-wrong-resolution-laptop-display-problems/

 

So I got this:

 

<00 ff ff ff ff ff ff 00 4d d9 01 dc 01 01 01 01 01 14 01 03 08 a0 5a 78 0a 0d c9 a0 57 47 98 27 12 48 4c 21 08 00 81 c0 01 01 01 01 01 01 01 01 01 01 01 01 01 01 66 21 50 b0 51 00 1b 30 40 70 36 00 40 84 63 00 00 1e 0e 1f 00 80 51 00 1e 30 40 80 37 00 40 84 63 00 00 1c 00 00 00 fd 00 39 3f 1e 31 09 00 0a 20 20 20 20 20 20 00 00 00 fc 00 53 4f 4e 59 20 54 56 0a 20 20 20 20 20 00 4d>

 

Converted to this:

 

AP///////wBN2QHcAQEBAQEUAQMIoFp4Cg3JoFdHmCcSSEwhCACBwAEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAQIRjAAAeDh8AgFEAHjBAgDcAQIRjAAAcAAAA/QA5Px4xCQAKICAgICAgAAAA/ABTT05ZIFRWCiAgICAgAE0=

 

And added these lines to config.plist in Clover:

 

<key>InjectEDID</key>

<true/>

<key>CustomEDID</key>

<data>AP///////wBN2QHcAQEBAQEUAQMIoFp4Cg3JoFdHmCcSSEwhCACBwAEBAQEBAQEBAQEBAQEBZiFQsFEAGzBAcDYAQIRjAAAeDh8AgFEAHjBAgDcAQIRjAAAcAAAA/QA5Px4xCQAKICAgICAgAAAA/ABTT05ZIFRWCiAgICAgAE0=</data>

 

Also changed the PatchBios settings to </true>

 

When the boot reached Clover a message on the TV screen said: Incompatible Resolution, check input. But a few moments later the Apple logo appeared and system entered. As I boot verbose (-v) this part was with a resolution TV wasn't able to handle.

 

After the system booted I noticed this:

 

FXu4QhF.png

 

It says my TV has 71'' but it has only 32''

 

And here the data is correct about resolution:

 

Dwq3J01.png

 

EDID is wrong? Am I doing something wrong?

 

The only thing I remember not being able to use now was DVI>HDMI cable. TV and Hack are connected via VGA Cable.

 

The system is the one on the signature, using latest Clover (downloaded today) and 10.10 DP6.

Share this post


Link to post
Share on other sites

Like it was suggested before, try to add your monitor’s EDID (extracted from windows) in CustomEDID and enable InjectEDID too. Post a boot.log and config if it still fails. Beware though that there currently isn’t a definitive solution for this problem, it might just not work with your graphics/monitor. You can try as a workaround to boot in legacy mode, which uses a different method and sometimes succeeds where UEFI fails.

Share this post


Link to post
Share on other sites

does anyone know if a custom EDID is a solution to the resolution issue on virtualbox?  I have ML, Yosemite, EC all running flawlessly with clover on vbox except for the resolution issue.  My limited understanding is that in EFI mode on vbox you can choose different GPO modes.  Mode 4 is 1440x900 and Mode 5 is 1920x1200.  Is there a way to inject a custom EDID using clover to bypass/expand this so I can run fullscreen 1920x1080?  Sorry for my limited understanding of EFI, GPO, and how OSX gets its possible resolutions.

 

 

 

Share this post


Link to post
Share on other sites

Time to resurrect an old topic!

 

I am at my wits end. I got a new monitor (Dell U2715H) and graphics card (Nvidia GT 710) and now my Clover boot screen is stretched. It was perfect before. I was hoping to get the boot screen to be at the monitor's native resolution (2560x1440) but at this point I'd be happy to just get non scaled icons at boot! Once booted I get full native resolution so this is just a semi cosmetic thing but it drives me crazy.

 

I have done a dozen things to get it to work. I extracted EDID while booted into Windows and added that in the Custom EDID section. Checked and uncheck every combination of LoadVBios, PatchVBios, Inject EDID. Removed Screen Resolution and changed it to several options. Nothing works. I always get 1280x1024 (in Clover's information menu) and stretched icons.

 

Can anyone shed some light on this? The "Best Answer" above does not work for me.

 

Thanks!

Share this post


Link to post
Share on other sites

Time to resurrect an old topic!

 

I am at my wits end. I got a new monitor (Dell U2715H) and graphics card (Nvidia GT 710) and now my Clover boot screen is stretched. It was perfect before. I was hoping to get the boot screen to be at the monitor's native resolution (2560x1440) but at this point I'd be happy to just get non scaled icons at boot! Once booted I get full native resolution so this is just a semi cosmetic thing but it drives me crazy.

 

I have done a dozen things to get it to work. I extracted EDID while booted into Windows and added that in the Custom EDID section. Checked and uncheck every combination of LoadVBios, PatchVBios, Inject EDID. Removed Screen Resolution and changed it to several options. Nothing works. I always get 1280x1024 (in Clover's information menu) and stretched icons.

 

Can anyone shed some light on this? The "Best Answer" above does not work for me.

 

Thanks!

are you using uefi?

Share this post


Link to post
Share on other sites

I have been playing around with this issue for weeks and I have no solution. I have tried the solution in this forum but that did not work. I can't for the life of me figure out why I can't get full resolution at clover boot screen. I have tried a dozen different combinations of EDID, VBios, putting video cards ROM in EFI folder, etc. but nothing works. I also always get the "Graphics Output (UEFI) 1280x1024" message in Clover's info screen.

 
CsmVideoDxe-64 is used only for UEFI motherboards and I can see that you have a legacy board as I do.
 
Everything worked fine before I upgraded my video card and monitor (EVGA Nvidia Geforce GFX 750 TI SC and Dell 2715H).
 
I really hope SOMEONE out there has a solution.
 
FYI, this is in my log:
 
  BiosVideoDriverBindingStart!
  BiosVideoCheckForVbe
  EdidOverride not found
  Edid1-
  Edid0+
  found Detail Timing 2560x1440
  0 640x480 attr=3BF - ok, edid+, 640x480, working, highest, pref=0
  1 800x600 attr=3BF - ok, edid+, 800x600, working, highest, pref=1
  2 1024x768 attr=3BF - ok, edid+, 1024x768, working, highest, pref=2
  3 1280x1024 attr=3BF - ok, edid+, working, highest, pref=3
  BV new mode: 3 1280x1024
  SetMode pref 3 (3) = Success
 
And further down is:
 
  EdidDiscovered size=128
  00 | 00 FF FF FF FF FF FF 00 10 AC 67 D0 53 33 30 30
  16 | 05 1A 01 03 80 3C 22 78 EE 44 55 A9 55 4D 9D 26
  32 | 0F 50 54 A5 4B 00 B3 00 D1 00 71 4F A9 40 81 80
  48 | 77 80 01 01 01 01 56 5E 00 A0 A0 A0 29 50 30 20
  64 | 35 00 55 50 21 00 00 1A 00 00 00 FF 00 48 37 59
  80 | 43 43 36 32 33 30 30 33 53 0A 00 00 00 FC 00 44
  96 | 45 4C 4C 20 55 32 37 31 35 48 0A 20 00 00 00 FD
  112 | 00 38 56 1E 71 1E 00 0A 20 20 20 20 20 20 01 23
  NVidia GFX injection not set
  HDA Controller [8086:3A3E] :: PcieRoot(0x0)\Pci(0x1B,0x0) => setting specified layout-id=1 (0x1)
  RCBA access disabled; trying to enable
  stringlength = 552
  CurrentMode: Width=1280 Height=1024
I have a similar issue and I can't for the life of me figure out why I can't get full resolution at clover boot screen. I too have tried a dozen different combinations of EDID, VBios, putting video cards ROM in EFI folder, etc. but nothing works. I also always get the "Graphics Output (UEFI) 1280x1024" message in Clover's info screen.
 
CsmVideoDxe-64 is used only for UEFI motherboards and I can see that you have a legacy board as I do.
 
Everything worked fine before I upgraded my video card and monitor (EVGA Nvidia Geforce GFX 750 TI SC and Dell 2715H).
 
I really hope SOMEONE out there has a solution.
 
FYI, this is in my log:
 
  BiosVideoDriverBindingStart!
  BiosVideoCheckForVbe
  EdidOverride not found
  Edid1-
  Edid0+
  found Detail Timing 2560x1440
  0 640x480 attr=3BF - ok, edid+, 640x480, working, highest, pref=0
  1 800x600 attr=3BF - ok, edid+, 800x600, working, highest, pref=1
  2 1024x768 attr=3BF - ok, edid+, 1024x768, working, highest, pref=2
  3 1280x1024 attr=3BF - ok, edid+, working, highest, pref=3
  BV new mode: 3 1280x1024
  SetMode pref 3 (3) = Success
 
And further down is:
 
  EdidDiscovered size=128
  00 | 00 FF FF FF FF FF FF 00 10 AC 67 D0 53 33 30 30
  16 | 05 1A 01 03 80 3C 22 78 EE 44 55 A9 55 4D 9D 26
  32 | 0F 50 54 A5 4B 00 B3 00 D1 00 71 4F A9 40 81 80
  48 | 77 80 01 01 01 01 56 5E 00 A0 A0 A0 29 50 30 20
  64 | 35 00 55 50 21 00 00 1A 00 00 00 FF 00 48 37 59
  80 | 43 43 36 32 33 30 30 33 53 0A 00 00 00 FC 00 44
  96 | 45 4C 4C 20 55 32 37 31 35 48 0A 20 00 00 00 FD
  112 | 00 38 56 1E 71 1E 00 0A 20 20 20 20 20 20 01 23
  NVidia GFX injection not set
  HDA Controller [8086:3A3E] :: PcieRoot(0x0)\Pci(0x1B,0x0) => setting specified layout-id=1 (0x1)
  RCBA access disabled; trying to enable
  stringlength = 552
  CurrentMode: Width=1280 Height=1024

CsmVideoDxe-64 is used only for UEFI motherboards and I can see that you have a legacy board as I do.

Everything worked fine before I upgraded my video card and monitor (EVGA Nvidia Geforce GFX 750 TI SC and Dell 2715H).

I really hope SOMEONE out there has a solution.

FYI, this is in my log:

BiosVideoDriverBindingStart!
BiosVideoCheckForVbe
EdidOverride not found
Edid1-
Edid0+
found Detail Timing 2560x1440
0 640x480 attr=3BF - ok, edid+, 640x480, working, highest, pref=0
1 800x600 attr=3BF - ok, edid+, 800x600, working, highest, pref=1
2 1024x768 attr=3BF - ok, edid+, 1024x768, working, highest, pref=2
3 1280x1024 attr=3BF - ok, edid+, working, highest, pref=3
BV new mode: 3 1280x1024
SetMode pref 3 (3) = Success

And further down is:

EdidDiscovered size=128
00 | 00 FF FF FF FF FF FF 00 10 AC 67 D0 53 33 30 30
16 | 05 1A 01 03 80 3C 22 78 EE 44 55 A9 55 4D 9D 26
32 | 0F 50 54 A5 4B 00 B3 00 D1 00 71 4F A9 40 81 80
48 | 77 80 01 01 01 01 56 5E 00 A0 A0 A0 29 50 30 20
64 | 35 00 55 50 21 00 00 1A 00 00 00 FF 00 48 37 59
80 | 43 43 36 32 33 30 30 33 53 0A 00 00 00 FC 00 44
96 | 45 4C 4C 20 55 32 37 31 35 48 0A 20 00 00 00 FD
112 | 00 38 56 1E 71 1E 00 0A 20 20 20 20 20 20 01 23
NVidia GFX injection not set
HDA Controller [8086:3A3E] :: PcieRoot(0x0)\Pci(0x1B,0x0) => setting specified layout-id=1 (0x1)
RCBA access disabled; trying to enable
stringlength = 552
CurrentMode: Width=1280 Height=1024

Share this post


Link to post
Share on other sites

I tried one more thing as a last try.

 

1) Screen Resolution set to 2560x1440

2) Load VBios (placed VBios file for card with name 10DE_1380.rom in EFI>CLOVER>ROM. Downloaded correct ROM from techpowerup)

3) Patch VBios

4) Inject EDID (let clover inject)

 

Still no correct boot resolution but this is what I get in the boot log now:

 

1:784  0:000  Video bios patch requested or CustomEDID - forcing video reconnect
1:784  0:000  2 drivers needs connecting ...
1:784  0:000  PlatformDriverOverrideProtocol->GetDriver overriden
1:784  0:000  HFS+ driver loaded
1:784  0:000  Video driver loaded: disconnect Success
1:855  0:071  VideoBiosPatchNativeFromEdid:
1:855  0:000   Bios: nVidia, nv_data_table_offset: 0x28B, nv_data_table: 0xC028D, std_vesa: 0xC437E, nv_mode_table: 0xC4383, mode_table_size: 0x10
1:855  0:000   VideoBiosPatchInit(LegacyRegion = Not Found, LegacyRegion2 = Success) = Success
1:855  0:000   VideoBiosUnlock:  unlocked
1:855  0:000   Patching: BT_NVDA
1:855  0:000   Parse Edid: descriptor block 0 is timing descriptor (h_active: 2560, v_active: 1440, h_sync_offset: 48, h_sync_width: 32, h_blanking: 160, v_blanking: 41, pixel_clock: 24150, v_sync_offset: 3, v_sync_width: 5)
1:855  0:000  the patch is not ready for the desired resolution
1:855  0:000   VideoBiosLock: Success
1:860  0:004  BiosVideoDriverBindingStart!
1:860  0:000  BiosVideoCheckForVbe
1:860  0:000  EdidOverride not found
1:874  0:013   Edid1-
1:887  0:013   Edid0+
1:887  0:000   found Detail Timing 2560x1440
1:953  0:065     0 640x480 attr=3BF - ok, edid+, 640x480, working, highest, pref=0
1:955  0:002     1 800x600 attr=3BF - ok, edid+, 800x600, working, highest, pref=1
1:957  0:002     2 1024x768 attr=3BF - ok, edid+, 1024x768, working, highest, pref=2
1:960  0:002     3 1280x1024 attr=3BF - ok, edid+, working, highest, pref=3
1:970  0:010  BV new mode: 3 1280x1024
2:205  0:234   SetMode pref 3 (3) = Success

Share this post


Link to post
Share on other sites

Gouldn't find proper solution to make my Palit gf650ti Boost bootscreen with 1920x1080. Does anybody could lead me or link to where and how modify bios strings that will unlock 1920x1080?

Share this post


Link to post
Share on other sites

Gouldn't find proper solution to make my Palit gf650ti Boost bootscreen with 1920x1080. Does anybody could lead me or link to where and how modify bios strings that will unlock 1920x1080?

 

Native 1920x1080 (and above) resolution is only possible with UEFI GOP compliant GPUs. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×