Jump to content
VirusX

Wake reason: RTC (Alarm) - how to deactivate?

215 posts in this topic

Recommended Posts

Is it just me or did they go and remove com.apple.mDNSResponder.plist from the latest Beta today?

Looks like it has been removed.  That sucks.  Now I have to deal with my computer waking up every 2 hours and now I can't see my other networked computers.

Share this post


Link to post
Share on other sites
Advertisement

yup, I have to confirm: I had to load the discoveryhd.plist again to get internet back to work in DP8 :/

Fun fact: with Chrome I was able to surf the internet even when it was deactivated but no other app (spotify etc) was able to get internet connection.

 

I will test later if my computer wakes every 2 hours now.

 

edit: yes, computer wakes up every two hours again with DP8 :/

I just had tons of DNS errors in my system log - after a few restarts I just won back my internet by booting with discoveryhd unloaded and then load it after boot oO 

Share this post


Link to post
Share on other sites

My computer wakes every 2 hours now with beta 3.

Sep 17 03:23:33 mac kernel[0]: Wake reason: RTC0 (Alarm)
Sep 17 05:12:29 mac kernel[0]: Wake reason: RTC0 (Alarm)
Sep 17 07:01:25 mac kernel[0]: Wake reason: RTC0 (Alarm)
Sep 17 08:50:21 mac kernel[0]: Wake reason: RTC0 (Alarm)

A few minutes ago I decided to take mDNSResponder and mDNSResponderHelper from my mavericks install and disable discoveryd again.  So far it seems to be working well. Keep in mind I still have -DisableSleepProxyClient in the mDNSResponder.plist.

 

I copied /usr/sbin/mDNSResponder* from mavericks to /usr/sbin in yosemite.  I then copied com.apple.mDNSResponder*.plist from mavericks /System/Library/LaunchDaemons to /Library/LaunchDaemons on yosemite (I don't like modifying things in /System if I don't have to).  Make sure to copy all files using sudo.

sudo cp /Volumes/Mavericks/usr/sbin/mDNSResponder* /usr/sbin/
sudo cp /Volumes/Mavericks/System/Library/LaunchDaemons/com.apple.mDNSResponder*.plist /Library/LaunchDaemons/

Then I did:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist
sudo launchctl load -w /Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

Reboot after doing that.

Share this post


Link to post
Share on other sites

I tried to do that too. In order to  add -DisableSleepProxyClient I copied the responder.plist to the desktop, added the link and copied it back. I had to authenticate it my password. The problem is, that now the "path had bad ownership/permissions". So tried to fix the permissions with chmod/chown but I'm not successful :(

I just don't know all those little unix tricks :/

Could you please help me out here? 

 

Also, doing all your steps (excluding -DisableSleepProxyClient edit) resulted in DNS errors after restart. Even more restarts didn't help. Only restarting discoveryhd helped. It's just not my day today :/

Share this post


Link to post
Share on other sites

My computer wakes every 2 hours now with beta 3.

Sep 17 03:23:33 mac kernel[0]: Wake reason: RTC0 (Alarm)
Sep 17 05:12:29 mac kernel[0]: Wake reason: RTC0 (Alarm)
Sep 17 07:01:25 mac kernel[0]: Wake reason: RTC0 (Alarm)
Sep 17 08:50:21 mac kernel[0]: Wake reason: RTC0 (Alarm)

A few minutes ago I decided to take mDNSResponder and mDNSResponderHelper from my mavericks install and disable discoveryd again.  So far it seems to be working well. Keep in mind I still have -DisableSleepProxyClient in the mDNSResponder.plist.

 

I copied /usr/sbin/mDNSResponder* from mavericks to /usr/sbin in yosemite.  I then copied com.apple.mDNSResponder*.plist from mavericks /System/Library/LaunchDaemons to /Library/LaunchDaemons on yosemite (I don't like modifying things in /System if I don't have to).  Make sure to copy all files using sudo.

sudo cp /Volumes/Mavericks/usr/sbin/mDNSResponder* /usr/sbin/
sudo cp /Volumes/Mavericks/System/Library/LaunchDaemons/com.apple.mDNSResponder*.plist /Library/LaunchDaemons/

Then I did:

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist
sudo launchctl load -w /Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

Reboot after doing that.

 

I don't have a Mavs install.  Any way you can share that file?  I also had to revert this fix and now get wake ups every 2 hours again.  Would love to fix it as it is constantly ejecting my external HDD's (and slowly driving me insane).  

Share this post


Link to post
Share on other sites

I don't have a Mavs install.  Any way you can share that file?  I also had to revert this fix and now get wake ups every 2 hours again.  Would love to fix it as it is constantly ejecting my external HDD's (and slowly driving me insane).  

Here is a zip of the 2 binaries and the plists.  Binaries go in /usr/sbin and plists in /Library/LaunchDaemons

 

You'll need to manually set owner/group on the files once you copy them

sudo chown root:wheel /usr/sbin/mDNSResponder*
sudo chown root:staff /Library/LaunchDaemons/com.apple.mDNSResponder*.plist

EDIT: Forgot to mention that -DisableSleepProxyClient is already in the plist.

mDNSResponder.zip

Share this post


Link to post
Share on other sites

thanks for the commands mcdougal33. You do have a little typo (chwon instead of chown). I tried to give root:wheel to the launch daemons before - that's why it didn't work :/

 

but my main problem is now as follows:

9/18/14 12:21:35.901 PM mDNSResponder[491]: mDNSResponder mDNSResponder-522.92.1 (Jun  3 2014 12:57:56) starting OSXVers 14
9/18/14 12:21:35.901 PM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.domain.system) Service "com.apple.mDNSResponder" tried to hijack endpoint "com.apple.mDNSResponder.dnsproxy" from owner: com.apple.networking.mDNSResponder
9/18/14 12:21:35.901 PM mDNSResponder[491]: init_dnsproxy_service: XPCError: Connection invalid
9/18/14 12:21:35.903 PM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.domain.system) Service "com.apple.mDNSResponder" tried to hijack endpoint "com.apple.mDNSResponder" from owner: com.apple.networking.mDNSResponder
9/18/14 12:21:35.903 PM mDNSResponder[491]: RegisterMachService: 1100 44C unknown error code
9/18/14 12:21:35.903 PM mDNSResponder[491]: ! MACH PORT IS NULL ! bootstrap_checkin failed to give a mach port
9/18/14 12:21:35.904 PM com.apple.xpc.launchd[1]: (com.apple.mDNSResponder) Service only ran for 0 seconds. Pushing respawn out by 10 seconds.
9/18/14 12:21:43.020 PM apsd[53]: dnssd_clientstub set_waitlimit:_daemon timed out (60 secs) without any response: Socket 7
9/18/14 12:22:04.664 PM coreaudiod[270]: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
9/18/14 12:22:04.663 PM storeaccountd[360]: dnssd_clientstub ConnectToServer: connect()-> No of tries: 3
9/18/14 12:22:04.664 PM coreaudiod[270]: dnssd_clientstub ConnectToServer: connect()-> No of tries: 1
9/18/14 12:22:04.664 PM CalendarAgent[308]: [com.apple.calendar.store.log.caldav.queue] [Adding [<CalDAVAccountRefreshQueueableOperation: 0x7fc5cb87be50; Sequence: 0>] to failed operations.]
9/18/14 12:22:05.439 PM Google Chrome[262]: dnssd_clientstub set_waitlimit:_daemon timed out (60 secs) without any response: Socket 19

Even a few restarts didn't help. I only get internet back when I load the discoveryhd back :/

I also just tried your files - same problem. I don't know what's missing. It has worked before...

 

maybe it has something to do with that:

9/18/14 12:22:07.758 PM coreaudiod[270]: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mDNSResponder Socket:5 Err:-1 Errno:61 Connection refused
9/18/14 12:22:07.759 PM coreaudiod[270]: dnssd_clientstub ConnectToServer: connect() failed path:/var/run/mDNSResponder Socket:6 Err:-1 Errno:61 Connection refused

Share this post


Link to post
Share on other sites

Try unloading all related plists then load them again with launchctl.  Also, post the output of 'ls -l /Library/LaunchDaemons/com.apple.mDNS*.plist'

 

 

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist
sudo launchctl unload -w /Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl unload -w /Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist
sudo launchctl load -w /Library/LaunchDaemons/com.apple.mDNSResponder.plist
sudo launchctl load -w /Library/LaunchDaemons/com.apple.mDNSResponderHelper.plist

Share this post


Link to post
Share on other sites

Hi , i've resolved this issue editing com.apple.discoveryd.plist and com.apple.mDNSResponder.plist, just moving this parameter from one to other :

 

<key>Disabled</key>
    <false/>

 

and adding mDNSResponder binaries into /usr/sbin/

 

repairing rights, that's all, and thank you guys !

post-15471-0-82729600-1411883884_thumb.jpg

Share this post


Link to post
Share on other sites

Adding Disabled=YES to discoveryd will work.  Repair permissions and reboot.

 

You could also run 'sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.discoveryd.plist' to disable discoveryd.

Share this post


Link to post
Share on other sites

nexus77777, do you still have to use the com.apple.mDNSResponder.plist as well?

 

Do you mean the "disabled" com.apple.discoveryd.plist ? Yes, it still in "LaunchDeamons" folder

Share this post


Link to post
Share on other sites

Same issues on a real MacPro 3,1 here running beta 4 - haven't tried on the hackintosh yet. Applying the fix described above kills internet for me too.

 

I've been experiencing very poor network connectivity (wifi) under this beta regardless though. It won't load pages for ~10min after boot and then at random intervals afterwards, it's like a tap, on or off. Definitally related to the OS, northing to do with signal strength or local internet, am using hackintosh favourite TP-Link WDN-4800 which works great in real Mac's too.

 

Hope they sort all of this out before final GM...

Share this post


Link to post
Share on other sites

Can I please ask what is the exact method people are using for the most recent Yosemite releases to disable the 2 hour wake?

 

Does it require the addition of files from an older build or just en edit of the current file?

Share this post


Link to post
Share on other sites

I'm currently too busy to test things. I plan to wait for the final version of yosemite and then make a fresh install and go from there.

Currently, after all the fixes I tried, I don't get internet connection after boot so I have to unload and then load the discoveryhd.plist again to get it back to work. Without the discoveryhd.plist I only get DNS errors and no internet connection.

Share this post


Link to post
Share on other sites

All I'm doing is dropping the files from the post a couple pages back in their respective locations and repairing permissions and Internet works immediately, I don't even have to reboot. After each update I have to do this because the Internet breaks every time. Other than that, it seems to be working fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By SeePurple
      The display sleep does not work correctly. Starting with Mac 10.12.4, the display sometimes does not wake up. The backlight works, there is no image, a black screen. Currently installed 10.14.1. All the same. If the display is sent to sleep, then sometimes it can wake up in a black screen with a working backlight. From the description, it is not difficult to guess that the display sometimes wakes up correctly and sometimes wakes up in a black screen. In the course of the experiments, I also saw that the display sometimes woke up and showed the boot screen (the Apple logo and progress bar), a second after that the desktop appeared. This behavior occurs only when the display wakes up on a black screen and then I close and open the laptop cover again, after which the boot screen sometimes appears for a second, but sometimes nothing appears, the system just hangs.
      I hope I clearly described the symptoms of the problem.
       
       
      The screenshot was taken after the experiment. I sent the display to sleep, then woke it up. He woke up in a black image with burning lights. Then I closed and opened the laptop bucket, pressed the space bar and waited a few seconds. After a few seconds, the boot screen with the Apple logo appeared and then the desktop appeared. Immediately made a screenshot.
       
      Asus k501lb
      Intel HD 5500
      Core i-5 5200U ( Broadwell )
      Display: au optronics B156HTN03.8

       

    • By BrianWong11031
      Hi, my hackintosh won't sleep!
      It often sleeps for 3-5 seconds and auto wakes up.
      sometimes it can't enter the sleep mode even you click the sleep button.
      I have uploaded my DSDT file.
      but I don't know how to patch DSDT.
      If you know how to solve this issue, please help me!
       
      Cheers,
      Brian
      DSDT.aml
    • By BrianWong11031
      1, my hackintosh machine can sleep but just for a few seconds and the fans and HDD or some devices will start working.
      2, i have tried many ways to solve this issue, such as install DSDT.aml and Patch USB limit.
      Do you have any method to solve this issue?
      I really want some useful advice from you!
      Thanks for replying.
       
      Cheers,
      Brian
    • By ozy1ozy
      Resolved:
      After nearly going completely crazy trying to disable everything, it turned out to be the Common Unix Printing System (thanks to DGKApps.com).
       
      Turn off the CUPS from the command line:
       
      sudo launchctl unload -w /System/Library/LaunchDaemons/org.cups.cupsd.plist
       
       
      You can re-enable it with the following:
      sudo launchctl load -w /System/Library/LaunchDaemons/org.cups.cupsd.plist
       
       
      You can test to see if it’s running with the following command:
      sudo launchctl list | grep cupsd
×