Jump to content
InsanelyMac Forum
Mieze

Solution for Qualcomm Atheros AR816x, AR817x and Killer E220x

Recommended Posts

Advertisement

Just saw that, attached to the previous post. :)

 

Don't try it because it is just a debug built in order to track down an issue another user reported. The same applies to the attached kext.

 

@senoirchippy: the attached one is for you. Same procedure as last time.

 

Mieze

Share this post


Link to post
Share on other sites

Will redo with the attached kext. Going to take a bit, need to do other things on OSX too. (On windows currently)

 

Everybody should stay with stay with1.0.0d5, except senoirchippy because I made this "special"kext for him.

 

Mieze

Share this post


Link to post
Share on other sites

Using the attached kext. 

 

Go back to 1.0.0d5 from post number 1. I will post another official development build when it is ready.

 

Mieze

Share this post


Link to post
Share on other sites

I have posted a new development release, version 1.0.0d6, which is the first one including a release and debug build as the driver is already working stable for days on my machine. As always, the source code is included too.

 

Mieze

Share this post


Link to post
Share on other sites

Mieze... it's fantastic.

 

My Killer E2200 is now working on OsX in my office where it can play with dozens of AFP and SMB servers.

 

it's auto negotiating in 1000bast-T full-duplex, which the old driver i had couldn't do, and doesn't crash when transferring multiple large files in any way.

 

it's just working perfectly. I love you !

Share this post


Link to post
Share on other sites

Came here just to say thank you.  I have an AR8171, which the ALXEthernet driver is supposed to work with.  On my setup (Clover UEFI), I would get random reboots that didn't produce any logs or kernel panics.  My system would just reboot at what seemed like random.  I wouldn't have any indication in my logs as to what was happening, just that it SEEMED to happen more often when my network was under high load (VPN+Torrent).  I switched to your kext yesterday, and I torrented the {censored} out of the day without a single reboot.  Hats off to you, sir.

Share this post


Link to post
Share on other sites

hi i installed your driver and it seems to work fine,  thank you for updated driver!

 

Qualcomm Atheros AR8171 PCI Express Gigabit Ethernet:

 
  Name: ethernet
  Type: ethernet
  Bus: PCI
  Vendor ID: 0x1969
  Device ID: 0x10a1
  Subsystem Vendor ID: 0x1849
  Subsystem ID: 0x10a1
  Revision ID: 0x0010
  Link Width: x1
  BSD name: en0
  Kext name: AtherosE2200Ethernet.kext
  Location: /System/Library/Extensions/AtherosE2200Ethernet.kext
  Version: 1.0.0d7
 
i attach my log if you want to take a look :
 
the only error(?) i see is : kernel[0]: Ethernet [AtherosE2200]: replaceOrCopyPacket() failed.

net copy.txt

Share this post


Link to post
Share on other sites

Working well on the AR8161 here too...

Qualcomm Atheros AR8161 PCI Express Gigabit Ethernet:

  Name:	Atheros Ethernet Controller
  Type:	Ethernet Controller
  Bus:	PCI
  Slot:	Built In
  Vendor ID:	0x1969
  Device ID:	0x1091
  Subsystem Vendor ID:	0x1458
  Subsystem ID:	0xe000
  Revision ID:	0x0010
  Link Width:	x1
  BSD name:	en0

Share this post


Link to post
Share on other sites

Hey Mieze, would it be possible to enable Flow control with this driver ?

actually it's 1000Base-T, full duplex, no flow control.

 

Just asking ;-)

Share this post


Link to post
Share on other sites

I see this in the System.log...

Ethernet [AtherosE2200]: Link up on en0, 1-Gigabit, Full-duplex, Rx/Tx flow-control

Is that no good?

Share this post


Link to post
Share on other sites

Hey Mieze, would it be possible to enable Flow control with this driver ?

actually it's 1000Base-T, full duplex, no flow control.

 

Flow control is supported, the NIC is configured to advertise flow control support, but it doesn't force it. Well, I might add an option when I find some time but there is nothing wrong with it when auto-negotiation results in a connection without FC.

 

Mieze

Edited by Mieze

Share this post


Link to post
Share on other sites

@D-an-W: Sorry, but being in a hurry I missed the point that it was related to Excel233's post so that I was a little bit confused about the meaning.

 

Mieze

Share this post


Link to post
Share on other sites

Thanks Mieze,

 

working fine here in a GA H87N with the AR8161, even with WOL and WOD which Shailuas 1.0.2 driver did not manage!

 

Thank You for finally letting my File Server sleep and wake :)

 

Cheers

Share this post


Link to post
Share on other sites

D-an-W, sorry for the late reply, i'll check this asap.

 

AFAIK, i didn't seen any way to force FlowControl in advanced network prefs (like Mieze said obviously)

It does not seems to impact transfer performance at Gigabit speed.

My office made some tests with 10G+ ethernets (Pcie cards, not in this hackintosh) and no-flow control was responsible of bad performances while downloading.

 

Anyway, i'll paste here my system log asap like i said. Thanks !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×