Jump to content
casalgoese

Samsung RV420

47 posts in this topic

Recommended Posts

Boa noite pessoal.

Pimentel, Allan sou eu novamente.

Arrumei um Samsung para fazer uns testes, consegui instalar o Snow Rentail logo de cara com o ibxxt, mas é claro que não ia ser fácil.

Vou colocar as especificações e você me orientem por favor, qual OSX consigo instalar nesse, alem do Snow?

Não consigo tirar muita informação dele porque não consigo instalar o Ruindows de jeito nenhum, alias nem quero...rs

 

Processador: Intel® Core i5 2410M

Chipset:HM65

Audio: HD (High Definition) Audio

 

Com o Sistem info peguei essas informações:

 

Network controller  Ven ID: 14e4 Dev ID: 4727  (estou sem net nele)

VGA compatible: Ven ID: 8086 Dev ID: 0116 2nd Generation Core Processor Familiy Integrated Graphics Controller

 

 

Precisava colocar a net nele ai ficava mais fácil arrumar, quando ele tinha o Ruindows, o System info apareceu quase tudo verde e os outros com carinha  sorrindo..

Pessoal me ajuda mais uma vez?

 

 

 

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Advertisement

Olá

 

Dá e muito bem pra instalar o OSX 10.9 nesse...

 

Cara eu te passei uma solução para instalar o OSX, veja isso ai, é lago ótimo

 

E acerca da kext de ethernet eu te digo que isso você tem que "caçar" procura no google alguma compatível com teu controlador e testa.

Share this post


Link to post
Share on other sites

Boas Pimentel, não consigo iniciar a instalação.

Não da para instalar outras versões de dentro do Snow Leopard? como já tenho ela instalada (não esta funcionando varias coisas) poderiamos partir dai?

Li que precisa estar com ela atualizada, estou baixado a atualização.

O que acha?

Share this post


Link to post
Share on other sites

Olá

 

Cara esquece SL, nesse teu note com core i5 dá pra instalar o MV de boa.... Eu já te dei aquele método justamente pra isso, para você só criar teu usb installer e tentar subir o sistema....

 

Se você estiver tentando subir com o método que eu te dei. tenta subir com -x -v -f no Chameleon e no Clover tentar apertar [espaço] e selecionar boot without caches or boot in safe mode

Share this post


Link to post
Share on other sites

Fechou, vamos nessa.

Detectei um problema aqui, a memoria estava com problema, por isso o Ruindows não passava a instalação, não sei se esse problema afetava a instalação do OSX, vou fazer certo agora, vou tirar umas print do sistema e passar para iniciarmos nas claras ok?

Volto logo.

 

Valeu

Share this post


Link to post
Share on other sites

Bem, acredito que podemos começar.

O que acha Pimentel, metodoo Olaria via .raw ?

 

 

print_zpsbd438649.png?t=1405873498


Essa é a tela do systen info

 

printkext_zps89b7a647.png?t=1405874336


Ele só não tem LAN, mas a Wlan pegando esta bom demais..rs

Share this post


Link to post
Share on other sites

Primeira barreira

 

O boot reconhece o pen mas não inicia por ele de jeito nenhum, experimentei colocar o cd do ibxxt mas ele não apareceu, instalei a imagem .raw do olaria do SL e ela aparece, é algo na BIOS?

Configurável na BIOS eu tenho:

 

CPU Power Saving Mode

Hyperthreading

EDB (Execute DIsable Bit)

Legacy USB Support

UEFI Boot Support

AHCI Mode Control

Fan Silent Mode

Battery Silent Mode

Battery Life Cycle Extension

USB S3 Wake-up


Liguei o UEFI e entrou, vamos que vamos

Share this post


Link to post
Share on other sites

Olá

 

Cara eu te dei a imagem do Mavericks, não vejo o porque de continuar usando SL

 

Tenta dar boot com aquela imagem do Mavericks....

 

Se não der faça o que te falei

Se você estiver tentando subir com o método que eu te dei. tenta subir com -x -v -f no Chameleon e no Clover tentar apertar [espaço] e selecionar boot without caches or boot in safe mode

 

Se mesmo assim não subir, apaga as kexts da Intel, use transmac para isso.

Share this post


Link to post
Share on other sites

É mais ou menos isso...rsrs

É que você esta começando e o SL entra, você fica animado e não quer se esforçar mais....rsrs

Cara se vocês falam que dá então vou ate o fim.

Let´s go

Share this post


Link to post
Share on other sites

Olá

 

Com certeza dá, o problema é que se você colocar "Como fazer um hackintosh" ai no google os caras já vem falando de Snow Leopard+ib*****ot

 

Não sabem falar de outra coisa, e ainda afirmam algo muito sem noção que é "Se o PC não tiver como habilitar AHCI na Bios, esqueça de instalar o OSX" Isso ai não existe, pois existem muitas kexts que podem fazer essa função para diferentes chipsets.

 

É realmente uma lavagem cerebral e muitas informações que um leigo pega sem saber de nada e trata como verdade absoluta, eu era assim... ai um dia eu conheci o Insanelymac :thumbsup_anim:

Share this post


Link to post
Share on other sites

Legal

 

Pimentel terminou, esta instalado, show demais.

Agora vamos ao pós, não esta funcionando Wifi, Video, Som, Trackpad, Bateria, não reconhece Pendrive nem HD externo, Lan esse note não tem.

Continuo com o tuto de pós instação que você passou?


Vou ter que copiar os arquivos em um CD, se estiver funcionando.......rsr

Share this post


Link to post
Share on other sites

Allan

 

Obrigado pela dica e parabens pelo tuto, vou resolver quase todos ou todos os problemas com ele, mas eu não tenho como colocar nada no hackintosh, esta isolado, sem nenhum tipo de conexão, nada, zero, usb, dvd, blutooh....nada,   é agora?

Share this post


Link to post
Share on other sites

Olá

 

Eu recomendo, pois até mesmo é um guia do Chameleon e para essa maquina eu vejo chameleon como uma opção melhor.

 

Esse guia ai que o allan te passou tem muitos conselhos e pode trabalhar junto daquele guia que eu te dei.

 

Mas vem cá: Está subindo em safe mode é? Por que só em safe mode é que as coisas não costumam funcionar

Share this post


Link to post
Share on other sites

Bem como falta instalar algumas kexts, acredito que não instalou a kext de rede ainda.

 

Instala o Chameleon, coloca isso no boot.plist:

Screen Shot 2014-07-20 at 5.47.50 PM.png

Share this post


Link to post
Share on other sites

Pessoal,

A instalação esta beleza, eu começei a mexer agora e instalei o bootloader com o vietnam tool, bem legal ele, mas coloquei algo errado e deu kernel panic.

Pergunto, tenho que instalar tudo novamente ou tem algo que possa fazer agora, se precisar instalar de novo tudo bem, mas quando for instalar o bootloader e outras kexts, qual procedimento uso para não ter que começar do 0 novamente.

 

Valeu pessoal

Share this post


Link to post
Share on other sites

A primeira coisa é relatar como é o KP, há vários motivos para dar KP.

 

Faz assim, dê boot com -v, e quando der o KP, posta uma foto.

Share this post


Link to post
Share on other sites

Olá

 

O idela é remover a kext que dá erro, mas muitas vezes não se sabe nem qual é...

 

Eu não te acoselho usar o Hackintosh Vietnam para instalar o bootloader, instala o bootloader a parte.

 

Meu conselho é re-instalar.

Depois instala Chameleon:

pkg

 

Depois configura do jeito que deve ser configurado:

Crie a pasta Extra no HDD e dentro dela coloque: http://www.insanelymac.com/forum/files/file/59-chameleon-22-svn/

*org.chameleon

*SMBios

Guia para orientar eu já te dei anteriormente

 

Depois Baixe o Hackintosh Vietnam e faça o seguinte:

* Na seção SSDT, escolha a opção Custom, será criado um SSDT em seu desktop e você colocar esse SSDT na pasta EFI/Clover/ACPI/patched

* Na Seção Kext selecionar patch AICPUPM (algo como isso rsrsrs) para corrigir AICPUPM e fazer OSX funcionam bem para você ...

* Na seção Grafik selecionar uma opção ideal para a sua grafica intel ... depende de você configurar e ver na descrição o modelo e resolução de tela
* Depois de selecionar algumas configurações importantes, mas não selecionar  nada inútil ou vai atrapalhar todo seu trabalho duro
*Se não me engano na seção Kext tem a opção para instalar FakeSMC, instale esta kext porque é muito importante para OSX e é a única kext realmente necessária.

 

Só isso e nada mais. :)

Share this post


Link to post
Share on other sites

Show, até porque eu já tinha começado a instalar...kkk mas tudo bem, até que é rápido.

O em outros lugares falam muita bobagem mesmo, igual o Allan falou mesmo, mas ainda bem

que tem vocês aqui, é só ter paciência e perseverança.

ehehehe, olha que aqui a gente nem apanha..........na cara né......kkkk

 

Valeu pessoal pela força. Valeu Pimentel, Allan.


Ops, nem sei se pode colocar video aqui....agora já foi...rsrs

Share this post


Link to post
Share on other sites

Estamos a disposição, mas veja o seguinte. Reinstalar o OS X por qualquer erro, é desperdício de tempo, apenas tenha atenção.

Quando falar: "Deu KP aqui...", antes fala o que você fez, as vezes deixou passar algo simples. Que pode ser consertado, de maneira mais simples ainda.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By GiorgioHeins
      Hello everybody, it’s been a long long time since my last post here on this forum, I’m having a lot of issues trying to activate my graphic card, the system recognizes the graphic card but there’s not full acceleration, clearly shows up its name as Intel graphics HD 3000 with only 4 MB of video ram.
       
      I would like to know how I could fix this problem or a least any suggestion about it. The reason I came to this site one more time is because I have no clue how to edit or patch a DSDt.aml file, I have clover bootloader and still  (seems to be easy but not for me LOL) so I don’t want to ruin the system once again.
       
      My configuration is
      OS macOS High Sierra 10.13
      SAMSUNG series 3 NP300E5C-A0US
      INTEL CORE i3 - 2370M 2.4 GHz
      INTEL GRAPHICS HD 3000 
      WiFi ATHEROS AR5B95
      MEMORY 6 GB DDR3
       
       
      Wifi works *** Sound Works ***Ethernet Works*** 
       
      Battery indicators and trackpad gestures are not working yet.
       
      Thank you guys in advance, I’ll keep myself reading and searching for any kind of solution for my laptop..
       
      See attachment
       
      bootlog.txt
      CLOVER.zip
      DSDT.aml



    • By lukascaska
      Hello everyone, I just installed highsierra on my notebook with help by Maldon and Mirone.
      I have almost everything working, missing only a few details:
      - I think I have a lot of kexts i do not use
      - HDMI Audio not working
      - the screen turns black after sleep
      - boot takes more then a minute
      can anybody help me?
       
      folder with SendMe, Clover and IOREG: https://drive.google.com/drive/folders/1xPTVrHVL4Z_Dh3oeDMpQ7EQKHsigBWC2?usp=sharing
       
      hardware:
      i5-7200, hd620, 940mx, 8gb ram, 1TB
    • By midi-sama
      Sierra on Tab!
      [DISCONTINUED]
      MY TAB'S MOTHERBOARD FRIED!

       
      First of all, I would like to thanks everyone on the Tablets > Samsung section for making OS X on XE700T1C possible, first from Yosemite up to El Capitan. This thread, however, is for Sierra installation, thanks to this thread (and the users there for the help), we gathered some information about our device capabilities and limitation on Sierra:
      What works: Everything but: What's not working/issues: PS/2 buttons (volume/rotation/Home buttons) - driver problem, needs kext edits For some: WiFi disconnections Wacom Driver (as for now, drivers for Sierra not released yet) They have been released. Intel Wifi/BT (no need to ask why, check the old threads for this device) Battery level may (most of the time) be wrong, please check HWMonitor for the real values, somehow macOS reads it wrong, and at some point it may even show "Replace Soon" (LOL). Battery may be stuck at "Charging" icon if woken up from sleep while being charged and then unplugged, to fix that, replug and unplug the charger. Before starting, neither me nor insanelymac.com is held responsible if anything goes wrong to your computer, or your cat died because you didn't feed it or a nuclear war. We are here to show you how to do stuff, you do it and take full responsibility of it.

      Part 1:
      Prepare your Computer:
      Before doing anything stupid, BACKUP YOUR FREAKING DATA! Don't come crying at me because you've lost your work files, notes or the secret recipe of Krusty Krab, I'll point my finger at you and laugh to my heart's content (yes, but I warned you, and as they say in arabic: 9ad a3thara man anthar قد أعذر من أنذر) YOU HAVE BEEN WARNED! For that, you can use Samsung's tool (if you still have it), Microsoft Windows' tool (under windows 8/10 > File History, or under windows 10 using one of these) or using 3rd party tools like CCC or CloneZilla (open-source and totally free, recommended, backup partitions instead of disk, will help to restore single partitions instead of erasing the whole ssd), and if you're under OS X already, use Time Machine to backup, Linux users know what to do (CloneZilla, Aptik...). UPDATE your UEFI Firmware to the latest version, using Samsung Update, don't do anything stupid, let the updater do its thing and fulfill its requirements (full battery, no running program ..). May break your device if you do anything stupid here, don't be stupid then (I just solved world stupidity, praise me!). Prepare your tools: a OS X/macOS computer/VM (deal with it) one 8GB USB (or two, second may be small for clover only, recommended, external HDDs will work too) your ATIV (duh!) your brain, you can buy one if needed (mostly black markets, watch out: illegal) optionally, external USB mouse, as the internal one doesnt have scroll feature, blame ELAN for making the USB drivers not close to PS/2 ones Other than that, prepare yourself mentally, this will be tremendously long you'll pop your eyes out, so do this on a lit room and better in the morning when you're wide-awake, thank me later for that. Make some snakes while you're at it, you'll need them. Part 2:
      Prepare your install - Install!
      On your OS X/macOS computer Download (or build) Clover from here (or build from here) Download FakeSMC.kext (choose Binaries) toledaARPT.kext (only for AR9280/5 or compatible, optional) for BCM users, refer please to the older thread, must be the same for you, thought I've read that Sierra has some problems with some BCM cards, good luck then :3 Internet is NEEDED later, and AppleALC.kext and lastly HFSPlus.efi Download PlistEditor (google) Download macOS Sierra from the AppStore (by now the final release should be already published) Open Disk Utility and plug your USB stick. Select Erase > Name it whatever you want > Format: Mac OS Extended (Journaled) > Scheme : GUID Partition Table (GPT) > ERASE!!! You better have already saved what was there lol Select then Partition > hit + > Make a Clover partition of 500MB MS-DOS (FAT) partition and the rest Installer partition with Mac OS Extended (Journaled) Apply Note 1: for smartasses saying "Why GPT, why not MBR?", A: for some reason El Capitan/Sierra Disk Utility wouldn't let me partition it later on, I don't know what's going on, but only GPT partitioning was permitted, somebody please confirm/fix this. Thanks. Note 2: for smartasses saying "Why did you make a Clover partition instead of using the existing EFI partition from the GPT formatting", A: having a partition to automount is better than mounting a hidden one each time!  Thou art done with Disk Utility, Thou shalt close it! Install Clover on the CLOVER (well fat partitions are renamed with capital letters) partition LEAVE only these folders/files from CLOVER folder: ACPI drivers64UEFI kexts > Other misc ROM themes tools CLOVERX64.EFI Copy the kexts from 2. in Other folder under kexts. Copy HFSPlus.efi under driver64uefi and remove VBoxHFS.efi Download this config.plist (credits @rehabman, also, right click on the link > Save Link As ... > and make sure it ends with .plist NOT .txt, if it doesn't, change the Format under it to All Files, and remove .txt) Open it with PlistEditor (haha, aint spoilin') Save and rename it to config.plist then replace CLOVER > EFI > CLOVER > config.plist with this new one. Open Terminal (I use iTerm, better): run this  sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --applicationpath /Applications/Install\ macOS\ Sierra.app --volume /Volumes/Installer Sip some tea, or watch whatever you like (huhuhuuhhuuh), it will take a while (unless you're one of those plebs with ULTRA FAST WHATEVER WHATEVER usb keys) Once done, close terminal, you're ready to rock! On your ATIV! (the exciting part) Boot to your Firmware Setup (aka BIOS Setup, but the name before is the correct one), by using ONE of these methods: Power off > Press and hold Windows button under the screen > Power On > Once you see the SAMSUNG logo, release the Windows Button > TADAA! Power off > Press and hold Volume Down button > Power On > Choose "Enter Setup" > TADAA! Power off > Press repeatedly F2 > Power On [keep pressing] > TADAA! Power off > Press repeatedly F10 > Power On [keep pressing] > Choose "Enter Setup" > TADAA! If you're on windows already: Method 1 Plug a keyboard (dock or usb keyboard) Click on the power off icon (in the charm bar in win 8.x, in Start in win 10) Hover on Reboot Hold Shift while clicking on reboot You should see "Please Wait" Method 2 Open Settings Go to Updates and Recovery (win 8.x) or Update and Security (win 10) Go to Recovery Select Advanced Startup It should start the Advanced menu while showing "Please Wait" Once done, go to Troubleshoot > Advanced Options > UEFI Firmware Settings TADAA! If you have GRUB2 UEFI> Select System Setup > TADAA! Once in, do these changes: Advanced > Fast BIOS Mode OFF USB S3 Wake-up OFF (you can make it ON, but will drain battery as the dock will stay ON and may also be annoying and has an effect on sleep) AHCI Mode Control Auto Boot > BIOS Adaptive Brightness ON/OFF depending on choice (ON to help your eyes at night) Secure Boot OFF OS Mode Selection UEFI OS Plug your USB key, hit Save, and furiously keep pressing F10 Now you'll see your USB drive in the BOOT menu, select it, and Clover will start up Start up macOS Installer (eat a sandwich meanwhile, unless you have those SUPER ULTRA FAST WHATEVER usb keys!) Open Disk Utility At this point you can still back up and start saving up your files! LAST WARNING! Erase your WHOLE SSD (remember that I told you to save your stuff? Now you know why!) To this point, YOU. ARE. DONE. Close and Install macOS Note 1: You'll see it stuck at "One second left" for more than one second (lol), wait until it reboots. Note 2: If your tablet rebooted after the 1st phase but didnt start the USB key automatically, open the BOOT menu and run clover and start up the Installer, it will resume the Install as it should Note 3: I forgot to mention this, but you should have common sense without me telling that to you, PLUG YER CHARGER! Once done, we'll get to the next step. Part 3:
      Configure and Fix up your install
       
      Congratulations, you've successfully installed macOS Sierra on your Tab, you can clap now! For now, it's all about your IQ level (hope you have 3 digits, and you should if you made it up to here). Now, finish up your install and first boot, and make sure you're connected to the internet (Internal Wi-Fi, Bluetooth, USB Dongles... I dont care, deal with it, or you may just do Copy-Pasta from another computer, but that wont help for DSDT, for people experienced in OSx86, you know what you can do if you dont have internet).
       
      Once on your desktop, test the audio: Go to System Preferences Go to Sound Check if you see an Output device, if yes then proceed, if not, reboot again, if still not: Check your config.plist > Devices > Audio > Inject : 6 Check the kext AppleALC is under kexts > Other and no other folder under kexts but Other. Power off and boot the device up (cold boot) Select "Play feedback when volume is changed Change the volume using the keyboard keys, the buttons on the side wont work (lack of PS/2 drivers)
        Check TRIM: Hold Alt and click on the Apple menu > System Information Select SATA/SATA Express Select your drive Check TRIM Support : Yes in the description IF NOT: Open terminal Type  sudo trimforce enable Accept and confirm Wait until the computer reboots (it will take a while, no worries)
        SIP and add "Anywhere" to open any app Disabling SIP Reboot to recovery Open terminal Type in:  csrutil disable Reboot Enable "Anywhere" under Security and Privacy to allow foreign/unsigned apps Open terminal Type in:  sudo spctl  --master-disable Done Clover
      Open terminal and type: diskutil mount disk0s1 Copy the EFI folder in the USB to the EFI partition, so you'll get a EFI folder inside EFI partiton Make a folder named BOOT under folder EFI (so EFI > EFI > BOOT), copy CLOVERX64.EFI from CLOVER folder to it, rename it then (in BOOT folder) to BOOTX64.EFI  You'll be able to boot Clover from your SSD UPDD Rewind If you want to buy the UPDD software with the gestures and other stuff, head to http://touch-base.com/and order your software for $171.00 or 133.00 Euros (if you're a superrich pleb!). This software will then be updated and supervised by Touch-Base. If you're broke and want a free (but annoying alternative) follow this: If you want UPDD to control Wacom digitizer and you dont mind recalibrating it each time, download ONE of these: Digitizer ignores pen proximity (no hover) LINK Digitizer reacts to pen proximity (hover) LINK Q: Why do I have to recalibrate the pen after each reinstall? A: Because this driver was made initially for Samsung Slate 7 (the father of our Tab 7) and it had only HD screen (not like our FHD one) and so, when you move the pen over the screen it only reacts to the "HD" resolution portion of the screen. This is what I think, correct me if I'm wrong. if you only want touch with UPDD and want to wait until Wacom releases its driver LINK (this is the driver used by Surface 1 and possibly 2 too) - RECOMMENDED! Now either way, you have to use some of these tools (made by Automator, not some fancy coding or anything): Download this file containing the tools: RE:UPDD (huhuhuhuh) (thanks to @thanh for UPDDrewind) Extract them and throw them in Applications folder Mount the UPDD dmg, throw the installer under /Library/ Run re-updd and let it do its thing (confirm and type your password when asked) Notes: Please go to Part 4 > 7, below before running UPDDrewind After each reboot (under less than 24 hours from the time of the install) run UPDDrewind, you can add it to autorun at boot by adding it to the list in System Preferences > Users and groups > Your Username > Login items After each 24 hours of usage, run re-updd, it will reinstall and ask to run the driver program Reboot (now it should boot from your SSD) DSDT TIME On Clover menu, hit F4, then boot normally Once on the desktop, open MaciASL Copy patched folder from CLOVER > EFI > CLOVER > ACPI > patched to your Desktop Copy DSDT.aml and SSDT-0.aml (check that SSDT-0 is SataTabl, how? open it with MaciASL and look for OEM Table ID, id it's not, look into all your SSDTs and get the correct one) to a new directory on your desktop name it patched Open DSDT.aml Go to MaciASL > Preferences > Source > + Name: RehabMan repo URL:  http://raw.github.com/RehabMan/Laptop-DSDT-Patch/master Note: You may remove the others, you're free to choose. iASL > ACPI Specifications : 5.1 Close the Preferences and go to the Patch menu, apply these: [bat] Samsung Ativ Book 7 [igpu] Rename GFX0 to IGPU [syn] Fix _PLD Buffer/Package Error [syn] Fix *pnp/pnp lower case Error [usb] 7-series/8-series USB [usb] USB3 _PWR 0x0D (instant wake) For AR9285 only: [wifi] AR9285 WiFi RP02-PXSX : change RP02 in the 5th line to RP01 Download this patch file, click on Open in MaciASL's patch window, select Patch.txt and apply it. Save your DSDT Open terminal and copy this (everything):  curl -o ~/ssdtPRGen.sh https://raw.githubusercontent.com/Piker-Alpha/ssdtPRGen.sh/Beta/ssdtPRGen.sh && \ chmod +x ~/ssdtPRGen.sh && \ sh ~/ssdtPRGen.sh && \ diskutil mount /dev/disk0s1 && \ cp ~/Library/ssdtPRGen/ssdt.aml /Volumes/EFI/EFI/CLOVER/ACPI/patched/ && \ cp ~/Desktop/patched/* /Volumes/EFI/EFI/CLOVER/ACPI/patched/ && \ echo "All done." Hit enter and reboot Download these kexts (extract them if needed) and put them in Clover > kext > Other (mount your EFI volume using diskutil mount disk0s1): ACPIBacklight: https://bitbucket.org/RehabMan/os-x-acpi-backlight/downloads ACPIBatteryManager: https://bitbucket.org/RehabMan/os-x-acpi-battery-driver/downloads VoodooPS2Controller: https://bitbucket.org/RehabMan/os-x-voodoo-ps2-controller/downloads Reboot. Part 4:
      Extras and level up your macOStouch experience:
       
      Congrats again! Now you have a fully functional macOS tablet ... not yet! Why? Cuz it sux! like really! Just try it! Well then, to make it "suck less", we need to fix a number of things (HiDPI -cuz 1080p is ultra smoll-, LaunchPad size and UPDD Gestures fixes/enhancements, also wacom and 3G). ALL THESE ARE OPTIONAL, so:
      HiDPI Fix Open terminal and type: sudo defaults write /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled -bool true Install and go to Unknown Monitor > Custom Resolutions > + > Scaled Resolution (on top): Here you can add any "Scaled" resolution. I recommend 1366x768 HiDPI resolution, so I add a scaled resolution of 2732x1536 as in a retina display resolution (1366*2 and 768*2) If you want a HiDPI resolution, get the width and heigh, multiply each by two, add it to SwitchResX. Click on Display (on top bar) and hit Write System settings, then File > Save Settings.  Reboot
      LaunchPad 6x3 icons setting: Open terminal and type:  defaults write com.apple.dock springboard-rows -int 3; defaults write com.apple.dock springboard-columns -int 6; defaults write com.apple.dock ResetLaunchPad -bool TRUE;killall Dock Result: For UPDD Guestures: Get my configuration here: UPDD Settings You can still use yours, and open UPDD Gestures > Settings Note: Do not put it on full screen, you'll need to force quit it to use it again (then run UPDDrewind) Wacom: Go to Wacom Drivers webpage Select Bamboo under "All" and download its driver Install Reboot For 3G I didn't test/try, you can always check the Yosemite/El Capitan thread in #1 or #20 for instructions and STARTING from #258 onward to get the new drivers and stuff. WIP Annoying Firewire Update Open terminal and type:  softwareupdate --ignore ThunderboltFirmwareUpdate1.2 Configure re-UPDD and UPDDrewind re-UPDD: to run it without typing your password (may reveal your password explicitly to anyone knowing how to use Automator) Open Automator > Open > re-updd.app (or drag-n-drop re-updd on Automator) Go to "Run Applescript" part add 
        password *PUT_YER_PASSWORD_HERE* after  administrator privileges Hit the Hammer button above the box to check the syntax Save UPDDrewind: Open it with Script Editor Change INSERT_PASSWORD_HERE by your mac password (leave the quotes) Go to File > Export >   File Format: Application Check Run-only Save Now your password wont be explicitly shown for this application, because we made it to run only, no edition/viewing is permitted afterwards. Delete the source UPDDrewind (if you save it somewhere else) KeyUP: download and throw in Applications Brightness: Download: http://bergdesign.com/brightness/#download Throw it in Applications If you're using black theme in macOS, right click on the app > Show Contents > Contents > Resources Rename: display_icon.png > display_icon_black.png display_icon_white.png > display_icon.png Close and reopen the app. CodecCommander: Check the posts under this one You're done!! You can celebrate your intelligence now! What's still needs to work on:
       
       
      Though we did all that, there are still parts that wouldn't just work right:
      Make UPDDrewind run when it detects that UPDD Gestures is ran An app to combine both re-updd and UPDDrewind, as they are just scripts and still needs refining (or just one AppleScript for password reasons) 3G/SIM card driver (I just didnt test, still, I'm putting it here) Fix the battery percentage, as I found that HWMonitor gives a precise percentage, like I have 98% in HWmonitor while the OS reports 100%, 96% in HWmonitor while OS reports 98% (they align at 50% and they diverge again) 100click/24hours for UPDD Driver (meh! but it's annoying to reinstall each time) VoodooPS2 driver configuration Microphone may stop working in the middle of work. Workaround: use your headphone with microphone or do a sleep-wake cycle. These are not in any given order, and they all matter to the smooth work on our devices. 
       
      Credits:
       
      I would like to give to everyone who has done some work to get this device work:
      @Rehabman for drivers and DSDT patches
      @Apple for the SW
      @HWmonitor team for HWmonitor and FakeSMC and other drivers
      @everyone in Tablets Forum for every piece of information and work, especially in these threads: Yos/ElC 10.12 report First thread for XE700T1C
      @anyone I forgot to mention (PM me to add you here, you deserve it)
       
      Thank you all
       
      Guys, if anything is wrong, just report it, I'll fix it ASAP, thanks
       
×