Jump to content

iCloud/iMessage not Working (I've tried fixes)

3 posts in this topic

Recommended Posts

Good morning everyone,


I been trying to get my iCloud to work with little success. I tried all the fixes out there: EFI studio, Ethernet Built in, NVRAM module, etc. 


I also tried installing mountain lion but the same problem persists.


When I do try to login to iCloud I get "Unable to sign in because of a problem communicating with iCloud" message. 


I am able to login into the APP STORE (I downloaded apps) and iTunes without any issues.


When I do attempt to login into iMessage I input my credentials and it actually goes through, but two seconds after it logs me in iMessage goes "inactive" requiring me to input my password again. When I do input it again, it gives me trouble activating iMessage.



I am currently running 10.9 with just Audio, R9 270 Kext, and RealtekRTL81xx.kext version 0.0.90.

I made sure to update Chameleon and I can confirm my Ethernet is "en0" in system info 

I am using Chameleon pre made SMBIOS MacPro 3,1 and I randomized the Week of Manufacture and Unique Number


Besides the fact iCloud/iMessage is not working I have a fully functional system.


If I missed anything please do no hesitate to ask.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r5101 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
      1. Download and unzip "EFI_Clover_r5101 for VMware.zip". Mount Clover-v2.5k-5101-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By albcc
      I used OpenCore with this configuration:
      -b450i Aorus pro wifi
      - ryzen2700
      - rx5700
      - dw1560
      I followed the instruction and Catalina 10.5.2 works flawlessly. Usb power, bluetooth patched, iCloud,  airplay. audio, gpu.
      The only thinks that aren't working are iMessage, FaceTime and handoff.
      iMessage Error: a.cicala@logicsolution.com
      FaceTime Error: This account has not reachable addresses. Please signing to appleid.apple.com in order to add one.
      I think it could be related to ROM configuration in PlatformInfo-> Generic -> Rom 
      But even if I tries to change the value it doesn't seems to work.
      Steps I've done:
      - Change Rom Value
      - Change entirely the Generic settings
      - Used CloverConfigurator to create a new rom value
      - checked that en0 is stetted in Wifi
      - removed  [~/Library/Caches/com.apple, ... , networkPreferences.plist] files
      Is anything wrong I'm doing in the rom code creation? I attach my config.plist (without  smUUID) maybe in OpenCore I should use not data but string type?
    • By Shogun212
      I'm currently running MacOS Catalina 10.15.2
      Here's what i need help with: 
      1. Wifi (which previously worked on Mojave)  
      2. iMessage 
      3. FaceTime 
      4. AirDrop 
      Note: I can't do DSDT patching, tried it many times, and i failed. That's just beyond my capabilities. 
      I really hope someone can help me, i've been busting my head for days.  
      If possible, i would like to avoid bricking my os, because i need it for my job on the day after tomorrow. 
      My RunMe app file: https://mega.nz/#!yxlgiIwR!-XZsreXxNjxjQemXiQia2vcSfITWwr_AVciV2Kdb-ps  
      My specs: https://drive.google.com/file/d/1d47b7YXOAitKSYvA9Z6Ojv57ThqXzZxJ/view
    • By Hectorsky
      Hello InsanelyMac users,
      I'm constantly getting into troubles with iMessage & FaceTime on my Hackintosh.
      When I'm trying to activate iMessage on my hackintosh I'm getting message to contact apple with a customer code.
      Registration failed for <private> (Error: 31) My build is based on Lenovo ThinkCentre M83 MT which specifications is:
      CPU: Intel Core i7-4770
      MB: Lenovo SHARKBAY (Intel Q85)
      AD: Realtek 662v2
      LAN: Intel I217-LM
      BL: Clover 5070
      Native NVRAM
      My SMBIOS seems be properly generated for iMac14,2
      I've used macserial to generate serial numbers and MLB.
      For RTVariables I've use MacAddr0 of my LAN Card.
      Maybe someone else haves idea which thing can cause these errors?