Jump to content
heryts

How to Solve Imessage Login Problem

168 posts in this topic

Recommended Posts

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

I just did these:

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

 

After restarting the VM, iMessage started working again :).

Share this post


Link to post
Share on other sites
Advertisement

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

 

 

Thanks, it works to activated my iMessage.

and then the problem is i cannot send any messages, gave me this error "not registered with iMessage"

Share this post


Link to post
Share on other sites

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

How do i set these in clover, especially the ROM value ? thank you !

Share this post


Link to post
Share on other sites

set it static in config.plist, I recommend using cloverconfigurator : ) pretty easy to handle

 

attachicon.gifBildschirmfoto 2014-09-27 um 20.35.49.png

 

I understand that, but the ROM value is kind of strange "%77%77%77%77%77%77" should i just enter it like this in that field ?

Share this post


Link to post
Share on other sites

The 777 solution work great in clover. How to implement it with ozmosis defaults.plist?

 

same question for me but I suggest adding:

	<key>Defaults:4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14</key>
	<dict>
		<key>ROM</key>
		<string>wwwwww</string>
		<key>MLB</key>
		<string>7777777777777777</string>
  	</dict>

okay I tried that but the  ROM value gets changed, so better set ROM to wwwwww instead of %77%77%77%77%77%77

 

edit: it works

 

imessage.jpg

Share this post


Link to post
Share on other sites

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

Share this post


Link to post
Share on other sites

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=7777777777777777

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%77%77%77%77%77%77

 

heryts, not on ozmosis, if you don't set it in defaults.plist it gets cleared from nvram at boot, btw why are you repeating the command?

I don't see the difference

did someone try to set those command in /etc/rc.common ???

Share this post


Link to post
Share on other sites

I dont know, iam using uc browser on my phone, to follow this thread, and my post always double, sorry

 

Once I read on ozmosis thread, those command used to manipulate nvram value, because I dont have ozmosis, so I dont know if it get cleared on boot

I dont know, iam using uc browser on my phone, to follow this thread, and my post always double, sorry

 

Once I read on ozmosis thread, those command used to manipulate nvram value, because I dont have ozmosis, so I dont know if it get cleared on boot

Share this post


Link to post
Share on other sites

...getting this in debug....

 

2014-09-30 01:19:43.862 imessage_debug[1233:507] 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM: failed
2014-09-30 01:19:43.862 imessage_debug[1233:507] 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB: failed

 

...but messages is still working :smoke:

Share this post


Link to post
Share on other sites

as i said in early post you can activated iMessage in three ways

1. you have valid apple id, by adding cc and spend some money to buy apps, or itunes

2. call apple support to activated it

3. copy nvram value from real mac or working system

Share this post


Link to post
Share on other sites

Guys, what do you say to the support call agent ? my account has an cc attached, i got over 300euros of apps in the last year, i use the account on other 2 apple devices, what should i tell them after i call, because the upper instructions don't seam to activate FaceTime and imessage :( 

Share this post


Link to post
Share on other sites

If you're calling and Messages doesn't have any sort of activation code, you won't appear as temporarily "blocked," so there's nothing that they should be able to do.

Share this post


Link to post
Share on other sites

Got the popup telling me that "Your AppleID can't be used to set up iMessage at this time." along with the customer code. Haven't ran iMessage for a month and it said it was inactive. I did notice I received the latest synced messages from a few days ago when I got that message. Ran iMessage debug and under System-id were a string of zeros followed by my mac address. I'm running the latest Chameleon 2.2 r2399. Currently have 10.9.3 installed. Filenvram 1.1.2. iMac 12,2. Read about some System ID bug which would trigger that message. Thinking about switching to Clover with legacy boot, but scared it might make things worse (new serial numbers..etc). Been running Mavericks for several months without iMessage issues til now.

 

specs:

Gigabyte P55A-UD4P

PNY GeForce 660 Ti

Intel Core i7 860

Kingston 8GB ram

Share this post


Link to post
Share on other sites

I have Mavericks running 10.9.4 and 10.9.5... when I sign in to iMessage, it gives me error saying 'An error occurred during activation. Try again' is there an fix?

Share this post


Link to post
Share on other sites

Please change mlb rom and smuuid as first post, read the previous post, and youll understand how to use theese value

Please change mlb rom and smuuid as first post, read the previous post, and youll understand how to use theese value

Share this post


Link to post
Share on other sites

Please change mlb rom and smuuid as first post, read the previous post, and youll understand how to use theese value

Please change mlb rom and smuuid as first post, read the previous post, and youll understand how to use theese value

I tried the 111.. didn't seem to work. I should be fine if I use the other ones then? How do I back up the values/files for clean installs? Would switching to Clover be a better idea? I don't have UEFI. I already clean installed on an SSD drive, haven't activated iMessage, or anything onlne yet. Currently running on an secondary harddrive.

Share this post


Link to post
Share on other sites

same question for me but I suggest adding:

	<key>Defaults:4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14</key>
	<dict>
		<key>ROM</key>
		<string>wwwwww</string>
		<key>MLB</key>
		<string>7777777777777777</string>
  	</dict>

okay I tried that but the  ROM value gets changed, so better set ROM to wwwwww instead of %77%77%77%77%77%77

 

edit: it works

 

imessage.jpg

 

It worked for me too until I reinstalled fresh Yosemite GM

now I get again the infamous "Call Apple" :(

here are my plist and debug

can anyone help?

Archive.zip

Share this post


Link to post
Share on other sites

please don't use this MLB and ROM when installing (fresh install) or upgrading yosemite, it will get blocked,

if you want to use it on yosemite, please change to another MLB and ROM when installing (fresh install) or upgrading it,

then change it to this MLB and ROM when you have successfully booting into your yosemite

 

whatever the method, make sure that mlb and rom on iMessage_debug is

MLB 7777777777777777

ROM 777777777777

i did contact apple to activate this mlb and rom

 

and sorry i can't monitor these thread everyday, ill check when I'm online,

Share this post


Link to post
Share on other sites

as i said in early post you can activated iMessage in three ways

1. you have valid apple id, by adding cc and spend some money to buy apps, or itunes

2. call apple support to activated it

3. copy nvram value from real mac or working system

 

Fresh install of 10.9.5. Applied FileNVRam. I have a real Mac mlb and rom. I have been trying to determine how to correctly inject these values. Do all I need to worry about is:

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=XXXX

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=XXXX

 

I am not positive what format I should use for the values XXXX. When I go to iMessage_debug, should the values then match what I injected? If easier, please PM me. Would really like to get this resolved!

Share this post


Link to post
Share on other sites

well, I can log in with the 7777 MLB and ROM but I can't send/receive anything because the recipient's email/phone number "is not registered with iMessage" which is obviously not true. what now? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×