Jump to content
heryts

How to Solve Imessage Login Problem

168 posts in this topic

Recommended Posts

i didnt call apple, it hasnt get blocked yet by apple untill now, if you cant use it, remember to check with imessage_debug if thoose value inserted corectly, hihihihi

and i didnt know why my first value got blocket, i am not sure, if it got blocked because many people use it, as far as i know i can have many apple id on apple system, i mean i can login apps store or i message with any apple id

Whaaa?
I can access iM :cry:

post your imessage debug here, and bootloader type


sorry for late reply because i dont check my post everyday

Share this post


Link to post
Share on other sites
Advertisement

Thanks ALOT !@!!!!!!! :thumbsup_anim:  :lol:  :D

Works perfect for me , I reinstall Mavericks couple days a go and I lost message, two days trying to fix but 

OK now  :wink_anim:

Share this post


Link to post
Share on other sites

Thanks ALOT !@!!!!!!! :thumbsup_anim:  :lol:  :D

Works perfect for me , I reinstall Mavericks couple days a go and I lost message, two days trying to fix but 

OK now  :wink_anim:

 

Can you give me some lights on how you did it?

Share this post


Link to post
Share on other sites

Can you give me some lights on how you did it?

Verry simple, follow post 41 and see pics of clover configurator  ;)

Share this post


Link to post
Share on other sites

@Ru1Sous4,

 

You can actually keep your own unique SmUUID (instead of 11111111-1111-1111-1111-111111111111) and 12 character System Serial in the SMBIOS section by entering MLB (17 char) & ROM (12 char) values into the RTVariables section of your config.plist:

<key>MLB</key>
<string>11111111111111111</string>
<key>ROM</key>
<string>111111111111</string>

Note ROM is entered as a string value and not as a data value (otherwise you won't see the correct ROM after running imessage_debug).  If done correctly, the output from imessage_debug should be the same as what @iFire has posted in post#48 except you have your own SmUUID and System Serial.

Share this post


Link to post
Share on other sites

It indeed fix the problem of iMessenger, but the iCloud is still behaving weird, I mean it's sync but I can't acess it or even allow other apps to use it since it always ask me for the pw.

Someone had the same problem?

1) add a wrong pw to make sure is validating the pw

2) I put the right pw and don't do nothing

Share this post


Link to post
Share on other sites

Hey thanks for posting this fix. Been trying to fix the stupid "Your Apple ID can't be used to set up iMessage at this time. If this is a new Apple ID, you do not need to create another one. To use this Apple ID with iMessage, contact iMessage support with the code below:" error. 

 

Well if anyone wants to know how I fixed it, all I did was find a genuine serial number for the Mac your emulating on Google. Then in Clover Configurator add the genuine serial number and add heryt's fix to the following boxes:

 

Board Serial Number: 1111111111111111

SmUUID: 11111111-1111-1111-1111-111111111111

 

I restarted and bam it signed in perfectly!  :)

Share this post


Link to post
Share on other sites

i didnt call apple, it hasnt get blocked yet by apple untill now, if you cant use it, remember to check with imessage_debug if thoose value inserted corectly, hihihihi

and i didnt know why my first value got blocket, i am not sure, if it got blocked because many people use it, as far as i know i can have many apple id on apple system, i mean i can login apps store or i message with any apple id

post your imessage debug here, and bootloader type

sorry for late reply because i dont check my post everyday

 

Hmmm nevermind, I had many problems w/ my Hack actually, I remade the whole thing and will try again :D

 

EDIT:

nvm it's still working :D

Share this post


Link to post
Share on other sites

Can someone help me with this please I am really lost as to what to do.  I have followed various guides deleting certain things trying to generate new serials in chameleon and I can not get it working.  Please help

 

Thanks 

 

Matt

Share this post


Link to post
Share on other sites

as now for new MLB and SMUUID I registered by contact apple support is

 

MLB 1111111111111111

SMUUID 11111111-1111-1111-1111-111111111111

 

and you can use it to activated iMessage from it, just to put those value on smbios section as on picture

 

or if on chameleon

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%11%11%11%11%11%11

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=1111111111111111

 

Can someone help me with this please I am really lost as to what to do.  I have followed various guides deleting certain things trying to generate new serials in chameleon and I can not get it working.  Please help

 

Thanks 

 

Matt

 

Read THIS ^^^^ :D

Share this post


Link to post
Share on other sites

Hi hi hi, my old value can be used to activating iMessage, even though i didn't call apple, very interesting, and i still didn't understand how it get blocked, and how i reactivated again,  I'm editing first post for my old value

Share this post


Link to post
Share on other sites

Worked for me also. I was playing with different SMBIOS and as always that breaks iMessage for me. 

 

 

P.S. iMessage was working one evening and next day it stopped again. Strange thing was that I was still logged in, but I couldn't send any message. My contact names were in red.

After changing SmUUID, ROM and MLB to some different values for test I put back the values from the first post and again I was in and able to send. Lets see for how long this time.

 

 

Edit: Today on  7 of september it sopped working again. It says "An error occurred during activation. Try again.".

iMessage debug:

2014-09-07 11:16:36.129 imessage_debug[497:22138] Gq3489ugfi: <0ec0d946 f7103a2d 39285f7a 1f4d92be 40>
2014-09-07 11:16:36.130 imessage_debug[497:22138] Fyp98tpgj: <20b7512e 70cfe3d8 e5eced58 7cec2001 f2>
2014-09-07 11:16:36.130 imessage_debug[497:22138] kbjfrfpoJU: <57572eba fcd9912d 0056d928 b10d9b47 0d>
2014-09-07 11:16:36.130 imessage_debug[497:22138] IOPlatformSerialNumber: W88GG136XXXX
2014-09-07 11:16:36.130 imessage_debug[497:22138] IOPlatformUUID: 11111111-1111-1111-1111-111111111111
2014-09-07 11:16:36.130 imessage_debug[497:22138] board-id: Mac-942B59F58194171B
2014-09-07 11:16:36.131 imessage_debug[497:22138] product-name: iMac12,2
2014-09-07 11:16:36.131 imessage_debug[497:22138] 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM: <11111111 1111>
2014-09-07 11:16:36.131 imessage_debug[497:22138] 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB: 1111111111111111
2014-09-07 11:16:36.131 imessage_debug[497:22138] oycqAZloTNDm: <5ac6462e 0ce8756b 25cb4a46 08fe17d5 52>
2014-09-07 11:16:36.131 imessage_debug[497:22138] abKPld1EcMni: <49ca31ae 47f0b2bd 57ca66e2 91fbb1e0 ad>
Edited by Stefan Milev

Share this post


Link to post
Share on other sites

I installed iOS 8 on my phone. Messages no longer works on the Hackintosh. Can I copy/paste values from an actual machine I have to fix the issue? What would I put into clover?

 

Edit:

 

This solved my issue http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/page-5?do=findComment&comment=2040654

Share this post


Link to post
Share on other sites

This is a strange one, i cannot continue to send imessages from hack, but i can receive messages.

If u try and send something, it turns to green and probably tries to use continuity. i have no ios8 on my devices.

Share this post


Link to post
Share on other sites

Hi !

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=%11%11%11%11%11%11

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=1111111111111111

 

 

it's blocked no login or in inactive ( i have reinstall my mac yesterday and i had use this code)

 

And

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=C02K7438DRVCN1S5A
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=PF]6%99%a9

 

 

It worked but... iMessage active with no possibility to send an iMessage (+33xxxxxxxxx is not registered with iMessage)

 

 

Why have i reinstall my config !!!!???? F***

 

 

An other solution ?

Share this post


Link to post
Share on other sites

here my observation, when i didnt online with my imessage (approximately 2 weeks)  theese value will inactive, same for my first value, i didnt use it for some time and it get inactive, sorry, im busy with my windows machine lately, ill chek my message when i get home

Share this post


Link to post
Share on other sites

i tested it,and you can still use my first value,

 

MLB C02K7438DRVCN1S5A

ROM UEZdNpmp

SMUUID 9DFF0000-3C12-0539-FFFF-50465D3699A9

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=C02K7438DRVCN1S5A
sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=PF]6%99%a9

Share this post


Link to post
Share on other sites

I don't think it's a good idea to use these values posted online. They will eventually be inactive because everyone used them. At least that's how I understand it.

 

Then again I realize not everyone is lucky enough to have an actual Apple product to copy these values from :(

Share this post


Link to post
Share on other sites

i tested it,and you can still use my first value,

 

MLB C02K7438DRVCN1S5A

ROM UEZdNpmp

SMUUID 9DFF0000-3C12-0539-FFFF-50465D3699A9

 

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB=C02K7438DRVCN1S5A

sudo nvram 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM=PF]6%99%a9

 

thanks :)

 

heryts how can i find SMUUID on real mac?

Share this post


Link to post
Share on other sites

i guess not, 111 value become inactive because i switch to my original value, so i never login with 111 value, and i think that make 111 value become inactive

Share this post


Link to post
Share on other sites

I'm running into the same problem... I managed to login into imessage but i cannot send any messages  - "iMessage (+514xxxxxxxxx is not registered with iMessage)

 
This is how it looks like: 
 

2014-09-15 00:11:57.561 imessage_debug[2383:507] Gq3489ugfi: <f207cbdd 76e341ec c656a039 ebe6ff31 a6>

2014-09-15 00:11:57.564 imessage_debug[2383:507] Fyp98tpgj: <3219e3da f3ace052 30995677 7e4bf3a8 7f>

2014-09-15 00:11:57.565 imessage_debug[2383:507] kbjfrfpoJU: <67ede19a ca9867f2 71eeb0af 7efdac60 53>

2014-09-15 00:11:57.565 imessage_debug[2383:507] IOPlatformSerialNumber: G8845ZTS5J4

2014-09-15 00:11:57.565 imessage_debug[2383:507] IOPlatformUUID: 691EFE35-A163-5EE6-8C0B-EF5D6DAF8FB1

2014-09-15 00:11:57.565 imessage_debug[2383:507] board-id: Mac-F42C88C8

2014-09-15 00:11:57.566 imessage_debug[2383:507] product-name: MacPro3,1

2014-09-15 00:11:57.566 imessage_debug[2383:507] 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:ROM: <50465d36 99a9>

2014-09-15 00:11:57.566 imessage_debug[2383:507] 4D1EDE05-38C7-4A6A-9CC6-4BCCA8B38C14:MLB: C02K7438DRVCN1S5A

2014-09-15 00:11:57.567 imessage_debug[2383:507] oycqAZloTNDm: <f3340de6 c1d40b6b cecd0298 d6b1250a d0>

2014-09-15 00:11:57.567 imessage_debug[2383:507] abKPld1EcMni: <0c28c6f7 97449dfa 613575c3 6a4b27ed 09>

 

 

Any suggestions on how I can fix this? 

 

Cheers,

Dan. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×