Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

XFX Radeon 7850 recognized but everything still choppy and slow (Mavericks 10.9)

2 posts in this topic

Recommended Posts

So after installing Mavericks 10.9 using Niresh onto my desktop I couldn't seem to get the integrated Intel 4600 HD graphics to work. After spending hours upon hours on that I finally decided to get an XFX Radeon 7850 1gb card since it was pretty cheap and I wanted to get one anyway. 


I installed the 2 kexts required for the 7850 cards using ##### and then rebuilt the cache and repaired permissions using kext wizard. The graphics card is now being recognized in About This Mac as AMD Radeon HD 7850 1024 MB. The problem is that it is not being used because visually everything is still choppy and slow like how it was before I put the card in. I tried most of the stuff in the forums but none of it seemed to work, or maybe I am just stupid. Any help to get this thing working is greatly appreciated. Thanks!


Motherboard - Asus Z87-PRO



Graphics Card - XFX Core Edition 7850 1gb






Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.