Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By markilark
      So I have an HP Envy Notebook (15t-q400) which features two Band & Olufsen speakers (tweeters) and one subwoofer - the audio codec used is the ALC290 (aka the ALC 3241). I'm running on Mojave. So far I've tried AppleALC with Lilu and have no luck - the audio plays through the headphones - although very poorly - but not the external speakers at all, and I've tried everything short of writing my own XML file for it. So I've decided to go for using the VoodooHDA kext.  
       
      While VoodooHDA sees my devices immediately, they are strangely configured, and I cannot use the subwoofer or even see it listed as a device. This is my main problem.
       
      As I'm aware the proper configuration of the laptop is: 
      Three speakers - one left, one right, and one subwoofer module One 3.5mm headphone jack An internal microphone for the webcam (this is one I'm not sure about, I don't know if it is two separate microphones or one as there are two holes in the display chasis)   
       
      In my devices while using the default VoodooHDA kext, I have 
                Output:
      Speaker (Analogue) - Type= Apple speaker port <--- only tweeters work  Headphones (Back Right) - Type= Headphone Port <--- this seems to work well           Input:
      Microphone (Black Right) - Type: Microphone Port <---- this works a little, sounds like it's muffled, not from the webcam Microphone (ATAPI) - Type: Microphone Port  <--- this works well, is definitely the webcam microphone  
       

      Here is my Pin Config (with disabled devices not ignored as I think the subwoofer is one of those devices):

      Here is my Pin Config for the photo above (disabled devices NOT ignored, fix not applied).
      01371c00 01371d00 01371e00 01371f40 01871c10 01871d01 01871e17 01871f90 01a71c20 01a71d10 01a71ea1 01a71f04 01d71c2d 01d71d81 01d71e75 01d71f40 01271c30 01271d01 01271ea3 01271f99 01571c40 01571d10 01571e21 01571f04 01471cf0 01471d11 01471e11 01471f41 01671cf0 01671d11 01671e11 01671f41 01771cf0 01771d11 01771e11 01771f41 01971cf0 01971d11 01971e11 01971f41 01b71cf0 01b71d11 01b71e11 01b71f41 01e71cf0 01e71d11 01e71e11 01e71f41  
       
       
       

      Here is my Pin Config for the photo above (disabled devices ignored, fix not applied):
      01871c10 01871d01 01871e17 01871f90 01a71c20 01a71d10 01a71ea1 01a71f04 01271c30 01271d01 01271ea3 01271f99 01571c40 01571d10 01571e21 01571f04  
      I have been attempting to add the subwoofer as a node in the Info.plist of VoodooHDA but can't seem to get it to work (and frankly I'm not sure which device it is!) . I've tried adding both NID 19 and 20 into my Info.plist file for VoodooHDA but neither have done any good. Am I supposed to add the NID and PinDefault to the Info.plist AFTER Pin Configurator's fix? I was under the impression this only helped with a patched AppleHDA which VoodooHDA overwrites. 

      Thanks for all the help, I hope I conveyed this clearly! 
       
      I've attached my codec dump as well. 
      dumpcodec.rtf
    • By RogerDodger93
      Salve a tutti ragazzi,
      Mi sono appena iscritto e innanzi tutto vorrei esprimere la mia gratitudine per l'aiuto offerto. Il mio problema come da titolo riguarda il mio Pavilion Power 15 più precisamente il modello cb015nl. Ho notato che c'era un altro topic su un modello simile ma immagino che anche se i modelli sono simili non è detto che siano compatibili quindi ne ho creato uno per il mio modello. Per arrivare al dunque, sono riuscito ad installare con successo Mojave 10.14 ma ho riscontrato diversi problemi una volta avviato l'OS. Quello che non riesco a far funzionare è l'indicatore della batteria, il power managment (Stop non funziona e la luminosità), la porta ethernet e credo che la scheda wifi sia incompatibile, le gesture del trackpad, e l'audio che con una scheda audio esterna funziona a meraviglia e l'ultimo grosso problema è che non riesco a far partire clover senza la usb di installazione, ho installato clover bootoader sull'hd dove ho mojave ma niente senza la usb mi parte il bootloader di hp/windows. Premetto che sono partito con una copia di mojave scaricata dall'appstore. Vi allego il report di HackInfo sperando che possa essere d'aiuto per il troubleshooting
      HackInfo_Report.zip
    • By grisno
      This is a preliminary Mac OS driver installer for laptop HP Pavilion G6-2209SS with support for dual boot Bootloader. Maybe it can be installed on other HP Pavillion G6 series laptops, but in some cases additional fixes will have to be made.
       
      I want to thank the whole community for their efforts and content provided, because without these it would not be possible to create this installer.
       
      I would appreciate comments and suggestions!!
       
      Status:
      CPU : OK Intel Core i3-2370MAUDIO : OK IDT 92HD87B2/4 (111d:76d9) Layer 3 & 12 (Speakers+Hearphones+LineIn+MicInt w/NoiseFilter+MicExt+HDMI)VIDEO : OK Intel HD Graphics 3000 (8086:0116) (LVDS + HDMI A/V + VGA) (VGA MacOS < 10.8.2)MEMORY : OK Intel 2nd Generation Core Proccesor DRAM Controller (8086:0104) (Dual Channel DDR3 Up To 16GB)SATA : OK Intel 7 Series Chipset Family SATA Controller (8086:1e03) (ACHI Mode)DVD : OK (Read & Write)USB 2.0 : OK Intel 7/C216 Chipset Family USB Enhaced Host Controller (8086:1e26 & 8086:1e2d)USB 3.0 : OK Intel 7/C216 Chipset Family USB xHCI Host Controller (08086:1e31)WEBCAM : OK HP TrueVision HD (SuYin) (064e:e263) [USB 2.0]KEYBOARD : OK PS/2TRACKPAD : OK PS/2 SynapticsLAN : OK Realtek RTL8501E Fast/Gigabyte Ethernet Controller PCI Express (10ec:103c) *AIRPORT : KO MediaTek RT3290 PCI Express (1814:3290) (Not Supported)BLUETOOTH : KO MediaTek RT3290 PCI Express (1814:3298) (Not Supported)CREADER : OK Realtek RTS5229 PCI Express (10ec:5229) (10.12.5+) ***ACPI BAT : OK (Chameleon & Clover)ACPI PWR : OK (Chameleon & Clover)ACPI RST : OK (Chameleon & Clover)ACPI SLP : OK (Chameleon & Clover) **ACPI WAK : OK (Chameleon & Clover) **HIBERNATE : OK (Only Clover Bootloader w/Hibernatemode: 0, 21 & 29)IMESSAGE : OK (Chameleon & Clover)FACETIME : OK (Chameleon & Clover)ICLOUD : OK (Chameleon & Clover)APPSTORE : OK (Chameleon & Clover)ITUNES : OK (A/V DRM Content & Sync iPod/iPhone)SIRI : OKCMOS : OKRTC : OKLPC : OK Intel HM76 Express LPC Controller (8086:1e44)SMBUS : OK Intel 7/C216 Chipset Family SMBus Controller (8086:1e22)IMEI : OK Intel 7/C216 Chipset Family MEI Controller (8086:131a)GPT PART. : OK (Chameleon & Clover) (10.13+ APFS Not Tested)MBR PART. : Not Tested
      Known Issues:
       
      - AppleRTL8169Ethernet: phyWaitForAutoNegotiation TIMEOUT. *
      - AppleRTL8169Ethernet: only work to 10Mbits. *
      - You can't wake up the system when the laptop uses the battery and the system disk is a USB hard drive. **
      - You can't wake up the system from PS/2 Keyboard/Trackpad. **
      - The Wifi MediaTek RT3290 (1814:3290) device are not supported.
      - The Bluetooth MediaTek RT3290 (1814:3298) device are not supported.
      - The PCIe CardReader Realtek RTS5229 (10ec:5229) device are not supported. *** (10.12.5-)
      - Stop working when sleep with inserted card. *** (10.12.5+)
       
      Coming soon:
       
      - Create unified installer for all Mac OS versions
      - Manual: How To Install Wifi Card Blacklisted In HP UEFI BIOS
      - Manual: How To Install OSX Without Destroying Windows 8.x Partition
    • By Donw35
      I have a HP 840 G3 that was donated to me to Hackintosh, currently running High Sierra 10.13.6. This should work for the 840 G2 and you may even have more luck with the 840 G1 with the WiFi that PCIe.
       
      My method to install OS X on the SSD from a working real Mac via SSD to USB converter. I then install Clover and add my kexts ad set the config.plist
       
      Not working
      SD Card reader
       
      Working
      Video - screen looks better in OS X then it does in Windows 10
      VGA port
      WiFi and BlueTooth working OOO using the below hack
      Battery status with Rehabman's DSDT patch
      Brightness controls
      Sounds - using VoodooHDA
      Microphone - cannot turn it off or mute
      Keyboard backlight - controlled though BIOS anyways
      touchpad - using VoodooPS2Controller
      USB3 - this laptop has two on board only and I haven't test them using the docking station
      USB3.1 C
      Ethernet - using IntelMausiEthernet
      Sleep - kind of, closing the lid doesn't go to sleep but goes to sleep over time.
       
      Not tested
      This laptop does not have a Webcam - enterprise model.
      Display port
      Finger Print device
       
      For me what keeps this from being a day to day usable laptop (Mac Book) is the WiFi + Bluetooth, not having battery percentage could be an issue later though.
       
      Clover_folder for those that want to play along.
       
       

       
    • By twikoffin
      Hello. My hardware is:
      AMD Athlon X2 7750 dual-core
      Gigabyte NVIDIA 8400GS 512MB ( [VGA] ,HDMI,DVI)
      Motherboard Gigabyte based on NFORCE without AHCI support (only IDE)
      I have successfully installed Mac OS Yosemite, Mavericks and El Capitan with AppleNFORCEATA.kext
      But I can't use it with Mac OS 10.8, don't know why, it just gives error and my internal HDD's are not appearing in Disk Utility.

       
         
×