Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


iATKOS ML2 freezes on occasion, how can I find what's causing it?

11 posts in this topic

Recommended Posts

Hi, my Hackintosh with iATKOS ML2 began to freeze on occasion after I installed the 10.8.5 Combo update. At first I thought it was Chrome causing it because it kept happening when I clicked on text boxes, but then it began to start happening just by doing anything. So, I took a look at console and I'm still not sure what's causing it. 

Here's the log of it before I rebooted: http://pastebin.com/D3yWZGbN


My Build:

CPU: Intel Core i3 2100


MB: ASUS H61-M LX3 R2.0


Startup Flags: GraphicsEnabler=Yes -v

Share this post

Link to post
Share on other sites

Hello and Welcome.


Remove the Intel HD kexts:

fsck -fy
mount -uw /
mkdir /intelhd_backup
cd /System/Library/Extensions
mv AppleIntelHD* AppleIntelSNB* /intelhd_backup

and use this flag:

-f -v GraphicsEnabler=Yes

For Nvidia GPU, try this: http://www.osx86.net/files/file/767-geforce-460-gtx-ml-10-8-2-all-working/


After installing kext, run this commands in Terminal:

sudo touch /System/Library/Extensions

sudo nvram -c
Edited by Allan Oliveira

Share this post

Link to post
Share on other sites

I removed those kexts and it worked. Then I installed the NVIDIA kexts and now I am unable to boot. Here's a picture of where its stuck at post-1334676-14033026478644_thumb.jpg

I replaced the kext with the old one and it boots. However it won't let me past the login screen.

Share this post

Link to post
Share on other sites

The GPU, NVIDIA GeForce 460

I went into Safe Mode and reinstalled those kexts just to be sure and I used the PCIROOTUID stuff but I'm still stuck at the same startup like in the screenshot I posted

I also turned off GraphicsEnabler but it's still yielding the same results from the screenshot

Share this post

Link to post
Share on other sites

This is why retail installs are better. With distros you never know what you get, and if you don't try to find out, then you run into surprises like this.


Don't use two video injection methods at the same time! Remove Netkas' ATY_Init.kext, it's conflicting with GraphicsEnabler.


Boot in safe mode and install the nvidia web drivers for 10.8.5 so that you get rid of any iatkos modified nvidia driver files, looks like something is terribly wrong with NVDAGF100Hal.kext

Share this post

Link to post
Share on other sites

Well, I just went ahead and used the Mavericks Vanilla install since I'm in an impatient slob and well, Chrome hasn't been crashing yet. Maybe it will. But yeah, I'm not sure what was up with those NVIDIA Kexts Allan sent but I'm sure they work with other kinds of 460s. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.