Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Propellent

AMD desktop reboots when selecting Niresh ISO distro on boot menu

7 posts in this topic

Recommended Posts

This seems to be the only issue preventing me from hackintoshing my desktop. My build is


 


  • 990FXA-UD3 Rev3.0 FC
  • Phenom II X 4 965 BE
  • 2x Sapphire Radeon HD 7750
  • G.Skill 16 GB DDR3-1600

 


I've asked once and I'm trying again, does anyone have ANY insight?


 


One thing I've noticed in the Dual UEFI guides is a mention of "xHCI Mode", which I do not have, but I still have xHCI handoff and eHCI handoff,


I've also tried unplugged everything but the CD drive and HDD to be installed to. Also, I'm using Niresh's Mavericks iso distro on a bootable DVD using the guide here: http://www.macbreake...ith-niresh.html


Share this post


Link to post
Share on other sites

use kernel flag(Switch)

 

amd64 GraphicsEnabler=Yes -f -c

 

you do this by pressing any key when you see the niresh chameleon drive select.

when you get to options just type out what i typed above and hit enter.

once you have done your mac setup you going to need to edit your boot.chameleon.plist with chameleon wizard and add these flags(without the -f(ignore caches) and -v(verbose)) permanent so you don't have to type them on every boot.

 

(if GraphicsEnabler=Yes don't work replace Yes With No and also add additional IGPEnabler=Yes)

also you should boot niresh first time in safe mode, -x

 

PCIRootUID=0 maybe but likely 1.

 

i think you should pull out one of those sapphires for now.

Share this post


Link to post
Share on other sites

you need to set your target drive.(your installing along windows?)

 

boot your niresh installer, go to terminal, type:

 

sudo dd if=/usr/standalone/i386/boot1h of=/dev/disk0s2 (or whatever disk the os is on, In Disk Utility find the Disk Identifier, it is most likely what i told you to type.)

 

enter your password. reboot.

 

there is lots of info on this error.....

pull all your drives accept target and re-install, probably be simpler for you. yank one of those video cards to(for now). (its only 22 minutes for a re-install, for me)

i use a separate ssd for osx.

(i only say start over because you going to need a mbr patch if your windows is not guid. you probably can't boot windows anymore since you changed sata to achi (just go back to sata to boot back to windows))

set bios to achi and leave it (should be default anyway, come on gigabyte!, its just better.). reinstall os x first then reinstall windows beside it in that order. you don't need both handoffs (I got both on but i notice no problem leaving handoffs alone.), just the first, thats on by default.

 

your mb probably has "Secure Boot", that need turn off for achi.

Share this post


Link to post
Share on other sites

soooooo............

 

how did things work out for you?

 

oh well, you have probably given up eh?

 

are those sapphires discontinued? and i may have mis-understood your post, do you mean 2 of them or you got the 2gb version?

 

you should not worry about the dual-bios, you would never utilize it unless you core gamer.

Edited by Gigabard

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×