Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

My bootloader is screwed up

4 posts in this topic

Recommended Posts

EDIT: I apologize for posting in the wrong section i just read the rules, I guess i wrongly assumed you could ask questions here because everyone else seemed to be :(


A friend of mine pointed me in the direction of this site after i ran into some issues with my dual boot system. Im new to the hackintosh scene and this is my first go at an install


I have 

AMD FX 4130 

gtx 660 2gb



I have windows 7 installed on a SSD, I have maverick installed on a partition on my HDD 


When my bios trys to boot off of either of these drives it returns an error. I am able to boot into both OSs by forcing my bios to boot chameleon off a flash drive.


I have chameleon installed on the OSX "EFI"? partition (i have also tried installing it on the normal partition as well with no luck) , im not quite sure where to go from here. What do you guys suggest i do?


thanks in advanced

Share this post

Link to post
Share on other sites


hmm, i got windows to boot again, but i do not have internet access on the hackintosh side yet. I do not have a compatible wifi adapter and i can't run wired for atleast a week. (i was going to stick to windows till i was able too)


is there any other way to patch the mbr?


Edit: i just realised it was not downloading the patch my mistake, 

Share this post

Link to post
Share on other sites

Need a bit more information....


Did you install Windows 7 in UEFI mode on GPT/GUID disk or legacy mode on an MBR partitioned hard drive?  If it is legacy, you will have a "System Reserved" partition showing in the "Disk Management" window while it will show an "EFI" partition for UEFI windows.


Can you open terminal in OSX and post the output of

diskutil list

I also recommend you have a look at the dual booting section in @pokenguyen's AIO guides.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.