Jump to content
Raff7M

Intel HD Graphics 4600 Can't change brightness.

166 posts in this topic

Recommended Posts

Brightness adjustment will not work with a desktop framebuffer. Post your actual files if you want me to look again. For troubleshooting your boot process, use verbose.Also, try with DropOem=true *and* all SSDTs (patched ones and unpatched ones, eg. SSDT-1 through SSDT-8) in ACPI/patched. Generally, you need power management implemented properly to get QE/CI with laptop framebuffer. It is why I always implement power management first.

Which files ?

0x0a260006 this one worked and qe/ci is still there, brightness control under display is showing now, but not changing the brightness

Share this post


Link to post
Share on other sites
Advertisement

Which files ?

0x0a260006 this one worked and qe/ci is still there, brightness control under display is showing now, but not changing the brightness

Assuming you have the patched files in ACPI/patched, post ioreg (use IORegistryExplorer v2.1).

Share this post


Link to post
Share on other sites

Assuming you have the patched files in ACPI/patched, post ioreg (use IORegistryExplorer v2.1).

Unable to find this version there is 3.0.2 how abou it ?

And btw desktop frame buffer is better XD

Share this post


Link to post
Share on other sites

Unable to find this version there is 3.0.2 how abou it ?

And btw desktop frame buffer is better XD

No. Needs to be v2.1 (or 2.0). If you search, you'll find it.

Share this post


Link to post
Share on other sites

here is the file

 

 

And i switched to 0x0a260005 becuz 0x0a260006 is preventing me to boot sometimes

You have a PNLF in both DSDT and an SSDT. The one in DSDT takes priority and causes the SSDT to not be loaded. This is why your gfx device is not labeled as IGPU in ioreg.

 

You did not have PNLF in the DSDT you sent previously, so it here are the possibilities:

- you're using a different DSDT than the one you sent

- you're injecting PNLF via Clover AddPNLF option

- you're using an old version of Clover that automatically injects PNLF for all mobile (bug)

 

To fix:

- check that your DSDT in ACPI/patched does not contain PNLF

- check that you are not adding PNLF fix in config.plist

- check that your version of Clover is up-to-date

 

Finally, you do not have ACPIBacklight.kext installed.

 

Oh, also power management is still not implemented correctly. Since you have PlugInType in the pstate SSDT generated by Clover, I assume you have an incorrect AppleACPIPlatform.kext installed. Make sure you have vanilla AppleACPIPlatform for your version of OS X.

 

You can check the version of AppleACPIPlatform with:

kextstat|grep -y acpiplat
Yes, folks... there are many ways to screw up a laptop OS X install!

Share this post


Link to post
Share on other sites

You have a PNLF in both DSDT and an SSDT. The one in DSDT takes priority and causes the SSDT to not be loaded. This is why your gfx device is not labeled as IGPU in ioreg.You did not have PNLF in the DSDT you sent previously, so it here are the possibilities:- you're using a different DSDT than the one you sent- you're injecting PNLF via Clover AddPNLF option- you're using an old version of Clover that automatically injects PNLF for all mobile (bug)To fix:- check that your DSDT in ACPI/patched does not contain PNLF- check that you are not adding PNLF fix in config.plist- check that your version of Clover is up-to-dateFinally, you do not have ACPIBacklight.kext installed.Oh, also power management is still not implemented correctly. Since you have PlugInType in the pstate SSDT generated by Clover, I assume you have an incorrect AppleACPIPlatform.kext installed. Make sure you have vanilla AppleACPIPlatform for your version of OS X.You can check the version of AppleACPIPlatform with:

kextstat|grep -y acpiplat
Yes, folks... there are many ways to screw up a laptop OS X install!

There is no problem with anything

Except maybe the power management is the problem here is my version

Share this post


Link to post
Share on other sites

There is no problem with anything

Ummm.. I think detailed the problems in post #31. ioreg does not lie.

 

Except maybe the power management is the problem here is my version

??

Share this post


Link to post
Share on other sites

Ummm.. I think detailed the problems in post #31. ioreg does not lie.

 

 

??

sorry upload failed here is it

where to get that vanilla one can you link me somewhere ??

post-1358186-0-67884900-1402275638_thumb.jpg

Share this post


Link to post
Share on other sites

sorry upload failed here is it

As I suspected... Correct output for 10.9.3 is:

Speedy-ML:clover.git Admin$ kextstat|grep -y acpiplat
   12    1 0xffffff7f81e1e000 0x5f000    0x5f000    com.apple.driver.AppleACPIPlatform (2.0) <11 10 7 6 5 4 3 1>

Share this post


Link to post
Share on other sites

As I suspected... Correct output for 10.9.3 is:

Speedy-ML:clover.git Admin$ kextstat|grep -y acpiplat
   12    1 0xffffff7f81e1e000 0x5f000    0x5f000    com.apple.driver.AppleACPIPlatform (2.0) <11 10 7 6 5 4 3 1>

what does that mean now ?

Share this post


Link to post
Share on other sites

what does that mean now ?

If you don't understand how you have a bogus/patched AppleACPIPlatform of unknown origin/unknown version on your system, I recommend a fresh install.

 

And review all the other items I mention...

Share this post


Link to post
Share on other sites

If you don't understand how you have a bogus/patched AppleACPIPlatform of unknown origin/unknown version on your system, I recommend a fresh install.

 

And review all the other items I mention...

I guess I should have told you this before but did't thought about it,,, i have an iAtkos M Mavericks 10.9.1... I guess that mean I don't have a fresh Installer right ?

Share this post


Link to post
Share on other sites

I guess I should have told you this before but did't thought about it,,, i have an iAtkos M Mavericks 10.9.1... I guess that mean I don't have a fresh Installer right ?

It means who knows what you have... Start over with a vanilla install. That's my advice.

Share this post


Link to post
Share on other sites

It means who knows what you have... Start over with a vanilla install. That's my advice.

lol XD okay man I will do that and do everything we talked about and then will give you what happens.... thank you so much for your patience :)

Share this post


Link to post
Share on other sites

lol XD okay man I will do that and do everything we talked about and then will give you what happens.... thank you so much for your patience :)

I hope you didn't pay money for that garbage...

Share this post


Link to post
Share on other sites

Ouch!

:(

Hello again! I'm trying to install a fresh copy of OS X but I can't get to installer all i have is unlimted sppining wheel :/

(Using clover)

I got into verbose: it is getting stuck at BootCacheControl: unavle to open /var/db/bootcache.playlist: 2 no such file or directory

Share this post


Link to post
Share on other sites

:(

Hello again! I'm trying to install a fresh copy of OS X but I can't get to installer all i have is unlimted sppining wheel :/

(Using clover)

I got into verbose: it is getting stuck at BootCacheControl: unavle to open /var/db/bootcache.playlist: 2 no such file or directory

What is in your config.plist?

Share this post


Link to post
Share on other sites

I used my existing config, I attached it to u yesterday

You mean the one injecting a desktop framebuffer on a laptop?

Share this post


Link to post
Share on other sites

You mean the one injecting a desktop framebuffer on a laptop?

hehe no I fixed it, I set it to 0x0a260006

Share this post


Link to post
Share on other sites

hehe no I fixed it, I set it to 0x0a260006

Are you using Kernel flag: dart=0

 

Required if you can't disable VT-d in your BIOS.

 

May need also:

KernelAndKextPatches/KernelPm=true

KernelAndKextPatches/KernelLapic=true

SSDT/Generate/PStates=true

SSDT/Generate/CStates=true

SSDT/PluginType/=1

SSDT/DropOem=true

Share this post


Link to post
Share on other sites

Are you using Kernel flag: dart=0

 

Required if you can't disable VT-d in your BIOS.

I have it disabled already in BIOS! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×