Jump to content

167 posts in this topic

Recommended Posts

Advertisement

It seems your SSD is not recognized as such... Is SATA mode configured to AHCI in BIOS? I would bet money on it being set to ATA/IDE mode. SSD are only fully supported under AHCI mode.

 

You should see something like this with TRIM Support set to Yes or No:

post-851564-0-07687300-1434480779_thumb.jpg

 

Manual bin mod (patch) is fully detailed on p1 of this very thread. You may also use a hex editor (such as 0xED for instance) and edit the binary file found in MacOS subfolder of the IOAHCIBlocStorage kext, where you replace the 1st instance of "APPLE SSD" as follows:

replace

00 41 50 50 4C 45 20 53 53 44 00     -> = ". A P P L E   S S D ."

by

00 00 00 00 00 00 00 00 00 00 00     -> = ". . . . . . . . . . ."

 

Edit: I confirm my initial suspicion; I just set my laptop's SATA mode to ATA and I too get:

1) protocol set to ata

2) no SSD type reported

Share this post


Link to post
Share on other sites

Well, strange thing is according to MB manual as well as Windows on the same machine my controller is set in AHCI mode. AHCI works in Windows for me and some info apps for Windows recognized my disk as SSD. Is there any way to force AHCI mode during OSX boot?

Share this post


Link to post
Share on other sites

Well there you are, look no further... Your only hope would be to force SATA mode to AHCI through DSDT patching. Some have tried but very few (if not none) have actually succeeded. I myself have failed on my ICH7-M based Dell Latitude D620 laptop. Same with an ICH7-based Dell Optiplex 745 desktop. It just wouldn't work at all. Seems to be an Apple limitation. You can look it up on the web and search the topic(s) on this forum.

 

You might as well replace your SSD by a plain old HDD; it's kind of wasted with OS X here...

Share this post


Link to post
Share on other sites

Yeah thank you for your answers. At least I now know what is a problem. I'll continue to use SSD this way because it's much faster anyway than using a HDD. But at least I can start think about changing MB and CPU and keep everything else. 

 

regards

Share this post


Link to post
Share on other sites

Hopefully this isn't too much of a necro, but wanted to share that this is working on the ICH10 southbridge using the Samsung 850 EVO SSD.

I used the Clover on the fly patching method and I'm also running OS X 10.11.5

post-1312076-0-89875700-1467060424_thumb.png

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Exactly.

 

With sudo trimforce enable my two Samsung EVO works fine.

 

Share this post


Link to post
Share on other sites

Hi guys,

Today I have enabled trim in my ssd using sudo trimforce enable and had my first freeze playing a video in safari, how I disable the trim again?

Thanks in advance

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ivoryblade
      Hello! My internal SSD lifetime is running out so I'm thinking how to upgrade it. I don't want to replace it with slow Sata SSD so I want to buy OWCMercury Helios and install new nvme fast ssd, but I won't be able to boot from it using standard boot loader.... Is it possible to boot nvme ssd using Clover on real iMac?
    • By Angelo_
      I jusst bought a 500gb crucial mx500 to see wheter the slow response of my hackintosh was due to the old 2.5" 500gb wd black hdd that i savaged from a broken laptop at home to install osx the first time but i don't know how to transfer my datas, os, programs and bootloader on the new drive since crucial only shows how to clone the drive but doesn't (obiously) refer to the clover boot partition, how can i do that?
      and what filesystem should i use? apfs or hfs+?
      I can also use windows or linux programs since i'm on a triple boot setup
    • By LarryKu
      Hi everyone,
      I am new, I hope I am posting in the correct forum.
      My specs:
      Processor: Core i5 6500 Skylake 3.2ghz
      Mobo: Gigabyte h170-d3h
      M2SSD: WD Black 256gb PCIe (Mac OSx)
      SSD: Samsung 860 Evo (WIndows 10)
      HDD: WD Blue 1TB
      GPU: Radeon RX 480
      Monitor: BenQ RL2460 24"


      I was able to install High Sierra on a new m2 drive, that I added to the above configuration with windows 10 already installed.
      I had a few issues during install, including the monitor turning off at boot screen.

      Unfortunately, this persists even now. It turns off at about 60% of the progress bar, and to turn it on again I have to unplug/plug back my hdmi.
      Additionally, while all of the usb ports worked during install and while running it out of the clover I had on the usb stick, only the rear ones appear to work now.
      The audio doesn't work either, though I added the correct patch according to my mobo

      Lastly, my other drives are not recognized in the bios anymore. They run fine from boot override but they don't show up in the boot priority (while multiple entries of mac OS do, and they seem to increase in number at every reboot)

      Thanks in advance for the help
    • By Nov4tO
      Specs:
      Corei7 3.6ghz Motherboard: Ipmh61r1 / Gt 730 Nvidia
       
      Hello everybody! First of all I need to apologize for my english and say: this is my first try on hackintosh...
      If is possible every answer be clear and detailed was bee good.
      Lets go to the history, I try to install an hackintosh in my job computer, im a developer and my agency need to develope for IOS.
      Then i just enter in this history
      Im already install the hackintosh sierra on this computer, i be able to boot with -x mode and install everything, after that,
      i just start to install all the kexts was needed. internet, sound, usb and others... then when I install a kext very similar to IOahciFamily 
      and reestart thinking: OK now i will can boot without security mode... my system give this error:
      AppleAHCIport/IOahciFamily Kernel Panic
       
      Anyone can help me? IM REALLY NEED THIS HACKINTOSH FOR MY JOB!
       
      More facts: Already install fakesmc, Voodoo and others common kexts.
×