Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Realtek RTL8187(L)

105 posts in this topic

Recommended Posts

Just ran circles around not being able to save my profile. Ultimately, my solution was to add myself to the permissions for the "/Library/Preferences" folder with read/write access. Upon launch of the RealTek utility, I created a profile and it saved the settings. All was well. Not sure what changed between SL and Lion, but this works now.

Share this post

Link to post
Share on other sites

As anarkhos suggested, running a virtual machine to operate the device is a pretty good option.


It took me two days to figure out all the details (like setting up routing both from the VM, and from the mac itself for internet sharing), but I got there, and I've found two things:

  • No more booting in 32 bit, no more crashes, no more constant reboots and I can sleep my mac
  • I get a vastly stronger and more stable signal, and a faster throughput, to my great surprise

It turns out the Mac driver isn't just buggy, it actually doesn't seem to drive the device to its full potential. I'm getting great signal strength now, via the VM (using the Windows drivers via ndiswrapper - the native Linux drivers are awful too).


I wrote up step-by-step instructions on how to make it happen (using the free VirtualBox VM software, and the very small-form-factor Microcore Linux distribution) at http://atastypixel.com/blog/using-a-virtua...e-for-your-mac/ - I made a VM appliance you can download and boot straight away, and an easy-to-install OS X service to set up internet sharing for other computers on the network.


Dude, you are a ledge! Well done lar!

Share this post

Link to post
Share on other sites

First post here on insanelymac! Thanks for the tip about changing permissions on Library and Preferences, works great.


As Michael Tyson had said, the OSX driver doesn't use the full power of the RTL8187l. The reason why is a region-locking issue. In the US the TX power is limited to 27dB. In other regions, such as Bolivia, you can use the full 30dB power.


When I run Backtrack Linux (in Virtualbox) I've been able to change the region and TX power setting:



iw reg set BO

iwconfig wlan0 txpower30




I originally found this on this blog:




In Mac OSX there is no iwconfig command and ifconfig doesn't allow for the commands to change the region and power setting as far as I know. Anybody have any ideas?

Share this post

Link to post
Share on other sites



thanks for the instructive post and the good work on virtualbox support for rtl8187...

have been trying to get this running on two different systems, one running osx10.8 the other 10.7...



- took a bit of effort to get this running on 10.8 (tried a prev. vbox, only to figure out that some prefs were lost and needed reset when new vbox installed)...

- the vbox refuses when running wicd-curses with the traceback showing dbus_manager error filenotfound /var/run/dbus/system_bus_socket, which ofcourse is there...



- closer to getting it working, but wicd-curses is not showing a list of networks, most likely because the mac has some of the ralink wireless drivers still active in the background (will get them offloaded and disconnected for my next attempt)...


have you seen either one of the above?  any clues on the 10.8.x problem?



Share this post

Link to post
Share on other sites


- took a bit of effort to get this running on 10.8 


Can you please give me some detailed instructions on how you did this and how your method compares with/differs from Michael Tyson's that he posted at the external link "A Tasty Pixel".


I have a Netgear WG111v2 which I would like to use on my ML 10.8.2. I understand that it uses the Realtek RTL8187L driver (but is that driver 64-bit compatible??).


I have a little bit of experience of running a VM in Windows (that's actually how I installed my very first OS X) but have never tried a Vbox on ML or any other flavour of OS X.





Edit: Can you also upload (if you have it) the Microcore Router Virtual Appliance (Microcore-Router.ova - about 45MB) to this thread as the link in the original blog is dead (which is unsurprising as the original article is 2 years old). I have everything I need to try this method out......except that.


Edit 2: Got a new link direct from Michael: http://atastypixel.com/blog/wp-content/uploads/2011/09/Microcore-Router.ova

(File is too big to upload here)




Edit 3: Warning -  before you try this VBox method from the 'A Tasty Pixel' blog, check the following:

First, that your CPU supports virtualisation (Intel processor owners can go to the ARK site to find this out)
Second, that your BIOS allows you to turn this feature on.
That's why it didn't work for me as neither of my Intel processors support VT-x. Oh well, back to the drawing board.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.