Jump to content
Allan

[Guia] DSDT/SSDT - Conhecimentos Gerais

100 posts in this topic

Recommended Posts

Esse sim carregou show de bola, quero pedir um favor, quais foram os parches que vc utilizou?

 

Vc pode anexar eles em um arquivo para que eu deixe arquivado, para que quando sair o OSX 10.12 eu não tenha que ficar perturbando vc?

 

Sobre o desligamento eu vou colocar no post que criei da instalação vou efetuar as perguntas por lá

Share this post


Link to post
Share on other sites
Advertisement

Vc pode anexar eles em um arquivo para que eu deixe arquivado, para que quando sair o OSX 10.12 eu não tenha que ficar perturbando vc?

 

Não é necessario toda a vez que instalar o OS X, extrair de novo o DSDT e aplicar os patchs, fica com esse.

Só vai ser necessario se você atualizar ou fazer um downgrade do seu BIOS.

Share this post


Link to post
Share on other sites

Não é necessario toda a vez que instalar o OS X, extrair de novo o DSDT e aplicar os patchs, fica com esse.

Só vai ser necessario se você atualizar ou fazer um downgrade do seu BIOS.

 

O que quero é saber quais foram usadas pq nunca consegui fazer o meu

Share this post


Link to post
Share on other sites

Então terá de esperar o Artur mesmo.

 

O que poderá aprender é como consertar os erros.

 

Aiiiii agora sim, entendeu rsrsrsrs

Share this post


Link to post
Share on other sites

olá

 

dá por aqui uma boa leitura

 

http://www.insanelymac.com/forum/topic/196771-ga-ex58-and-ga-x58a-dsdt-native-power-management-modifications/

 

quanto ao file .. eu geralmente não edito dsdt dessa maneira .. 1º passo eliminar erros .. depois uso os patch especificos para a mobo .. no teu caso são os para ICH10 estão no olarila

 

bom hack 

Share this post


Link to post
Share on other sites

Olá a todos, tudo bacana?

Por gentileza, estou meio perdido aqui com a SSDT:
 

  • GereiSSDT através do script e copiei para a pasta EFI/ACPI/Patched do Clover
  • Desabilitei: P e C states do config.plist
  • Ativei: Drop All OEM SSDT na config.plist

Resultado: Simplesmente nao aparece nada depois que dou enter para o boot no Clover.



Sobe normalmente somente se eu ir em Options no boot do Clover e marcar a opção Drop SSDT.AML na seção ACPI.
Mas eu não consigo ativar essa opção dentro da config.plist, essa somente aparece como opcional na hora do boot( como mostra na imagem anexada).

Dei uma boa procurada no Google e aqui Fórum e juro que não encontrei nada. a respeito desse opcional do Clover.

 

 Muitíssimo obrigado.

 

       Hardware
Gigabyte B75M-D3H
    core i3 2130 sandy bridge
         Gtx 550 ti
   macOS Sierra 10.12


U64soiK.jpg

Share this post


Link to post
Share on other sites

No seu caso acho que nem vale a pena gerar um SSDT modificado.

 

Apenas use o que o Clover oferece, e será suficiente para sua performance.  ;)

Share this post


Link to post
Share on other sites

Olá!! Bom dia!! Allan e X-men Eu atualizei o meu sistema para o MacOS Sierra e notei que perdi os states de gerenciamento do processador e estou apenas tendo um multiplicador: o x23 como mostra na foto: post-177314-0-72735400-1477145668_thumb.png

 

No El capitan eu estava usando o gerenciamento de states do clover apenas marcando Gen C e P states mas agora no Sierra não consigo ter os states todos:

post-177314-0-16629200-1477145892_thumb.png

 

O clover reconhece no boot os states:

 

post-177314-0-62942000-1477150273_thumb.png

 

 

mas quando entra no sistema fica apenas em x12 e x23:

 

post-177314-0-14541700-1477150385_thumb.png

 

 

Estou achando que seja um problema do clover em si. Irei reinstalar o El capitan com as mesmas configs anteriores em outro hd para comprovar isso.

No mais alguém tem uma ideia? grato!!

Share this post


Link to post
Share on other sites

O macOS Sierra está com alguns problemas com o XCPM.

 

Acredito que se tentar usar um SSDT modificado, terá melhores resultados.

 

Off-topic: Você conseguiu ativar a Nvidia GTX 670M?

Share this post


Link to post
Share on other sites

O macOS Sierra está com alguns problemas com o XCPM.

 

Acredito que se tentar usar um SSDT modificado, terá melhores resultados.

 

Off-topic: Você conseguiu ativar a Nvidia GTX 670M?

 

Então, deve ser isso mesmo porque não mudei nada em minha config e só tenho x12 e x23 cravado e deixa muito limitado a máquina edição e afins.

O script do piker mudou e estou com umas dúvidas: antes era apenas usar o comando: ./ssdtPRGen.sh -w 3 e agora o que usar? deixo apenas o padrão e permita que ele reconheça o meu processador (coisa que ele faz com maestria). Pensei em usar esse comando: ./ssdtPRGen.sh -target 1 -c 3 -xcpm 0(já que o OS X está com problemas com o XCPM). A GTX 670M reconhece na install nativamente com o clover eu apenos instalo o webdriver pra evitar que ela tenha os antigos problemas de travamento. 

 

post-177314-0-55410600-1477158641_thumb.png

Share this post


Link to post
Share on other sites

Usando o comando antigo não têm problema.

 

Você precisa do XCPM, se não o gerenciamento não será completo, e indicar qual é o modelo do CPU não é necessário.

 

Apesar dos problemas, podemos fazer alguns testes.

Share this post


Link to post
Share on other sites

Usando o comando antigo não têm problema.

 

Você precisa do XCPM, se não o gerenciamento não será completo, e indicar qual é o modelo do CPU não é necessário.

 

Apesar dos problemas, podemos fazer alguns testes.

 

Entendo. Estou subindo com o XCPM mas não estou tendo todos os states como te disse; o clover está gerando o C e P states mas sem sucesso. Quais testes poderíamos fazer? 

Obrigado!

Share this post


Link to post
Share on other sites

Gere um SSDT com o XCPM em modo 1 (habilitado), coloque o mesmo no local correto.

 

Vá no seu config.plist e desabilite o C/P States, vamos deixar apenas o SSDT fazer o trabalho. Há e desmarque o DropOEM.

 

Pra saber se ela está sendo carregada, use a opção Debug, reinicie o Hack e dentro da pasta EFI/CLOVER/misc, verá um arquivo boot.log.

Abra o IOReg e veja como está seu gerenciamento de energia. 

Share this post


Link to post
Share on other sites

Gere um SSDT com o XCPM em modo 1 (habilitado), coloque o mesmo no local correto.

 

Vá no seu config.plist e desabilite o C/P States, vamos deixar apenas o SSDT fazer o trabalho. Há e desmarque o DropOEM.

 

Pra saber se ela está sendo carregada, use a opção Debug, reinicie o Hack e dentro da pasta EFI/CLOVER/misc, verá um arquivo boot.log.

Abra o IOReg e veja como está seu gerenciamento de energia. 

 

Olá, Allan! Tentei o procedimento ./ssdtPRGen.sh -xcpm 1 e me retornou isso:

 

post-177314-0-76011100-1477280570_thumb.png

 

E quando coloquei a ssdt e configurei o clover dessa forma eu não obtive sinal de vídeo:

 

post-177314-0-16854800-1477280750_thumb.png

 

post-177314-0-97678900-1477280772_thumb.png

 

 

Obrigadoo!!

Share this post


Link to post
Share on other sites

Bem de acordo com a 1º imagem, não têm como o script salvar o SSDT na pasta Extra, se está usando o Clover  :rolleyes:

 

Sobre o config.plist sem P/C States + video, têm coisa errada ai. Um não têm como afetar o outro. 

 

Deve está esquecendo algo ai....

Share this post


Link to post
Share on other sites

olá

 

não é isso que mostra teu snapshot do clover ..

 

dropoemssdt está desabilitado ..

 

bom hack

 

 

Obrigado Artur,

 

 

ta marcado é que a luz da foto tirada pelo celular não aparece o a seta marcando :) 

mas obrigado

No seu caso acho que nem vale a pena gerar um SSDT modificado.

 

Apenas use o que o Clover oferece, e será suficiente para sua performance.  ;)

Então Allan,

 

Sempre fico meio na dúvida, já li relativamente bastante sobre o assunto e a ultima compreensão que tive que no caso do meu hardware, é, que seria bom não ativar o P C States  e usar uma SSDT .... você acha desnecessário,? tenho medo do CPu não trabalhar corretamente e dar problema posteriormente.

 

Obrigado

Share this post


Link to post
Share on other sites

olá

 

 

The CPU not supported turbo

Turbo: 34/34/34/34

DSDT found in Clover volume OEM folder: EFI\CLOVER\ACPI\patched\DSDT.aml está patcheado ?

Patch table: SSDT SataTabl
6:134 0:000 SSDT len = 0x36D
6:135 0:000 Patch table: SSDT Cpu0Ist
6:135 0:000 SSDT len = 0x9AA
6:135 0:000 Patch table: SSDT CpuPm
6:135 0:000 SSDT len = 0xA92
6:135 0:000 Drop tables from Xsdt, SIGN=XXXX TableID= Length=0
6:135 0:000 Xsdt has tables count=8
6:135 0:000 corrected XSDT length=100
6:135 0:000 === [ ACPIPatchedAML ] ====================================
6:135 0:000 Start: Processing Patched AML(s): Unsorted
6:135 0:000 Inserting SSDT.AML from EFI\CLOVER\ACPI\patched ... Success
6:153 0:018 End: Processing Patched AML(s)
6:153 0:000 CPUBase=0 and ApicCPUBase=1 ApicCPUNum=4

 

isto não devia estar a ser carregado .. so devia carregar o ssdt.aml gerado pelo script com as configs para teu cpu

 

teu config.plist deve estar uma bosta .. faz o upload dele .. melhor faz up da pasta efi ..

 

para analisar .. não tens uefi nessa mobo ? porque estás a usar a emuvariable.efi ?

 

bom hack

Share this post


Link to post
Share on other sites

Bem de acordo com a 1º imagem, não têm como o script salvar o SSDT na pasta Extra, se está usando o Clover  :rolleyes:

 

Sobre o config.plist sem P/C States + video, têm coisa errada ai. Um não têm como afetar o outro. 

 

Deve está esquecendo algo ai....

 

Aqui está tudo certo... o problema ou é com o clover ou é com o Sierra. Eu acabei de usar as mesmas configurações no el capitan e tenho todos os states...

;). Há não ser que tenho mudado algo. Obrigado, Allan. Quando estiver mais tempo volto para testarmos.

 

post-177314-0-61289300-1477429208_thumb.png

 

Detalhe: eu não uso ssdt.

Share this post


Link to post
Share on other sites

olá

 

 

The CPU not supported turbo

Turbo: 34/34/34/34

DSDT found in Clover volume OEM folder: EFI\CLOVER\ACPI\patched\DSDT.aml está patcheado ?

Patch table: SSDT SataTabl

6:134 0:000 SSDT len = 0x36D

6:135 0:000 Patch table: SSDT Cpu0Ist

6:135 0:000 SSDT len = 0x9AA

6:135 0:000 Patch table: SSDT CpuPm

6:135 0:000 SSDT len = 0xA92

6:135 0:000 Drop tables from Xsdt, SIGN=XXXX TableID= Length=0

6:135 0:000 Xsdt has tables count=8

6:135 0:000 corrected XSDT length=100

6:135 0:000 === [ ACPIPatchedAML ] ====================================

6:135 0:000 Start: Processing Patched AML(s): Unsorted

6:135 0:000 Inserting SSDT.AML from EFI\CLOVER\ACPI\patched ... Success

6:153 0:018 End: Processing Patched AML(s)

6:153 0:000 CPUBase=0 and ApicCPUBase=1 ApicCPUNum=4

 

isto não devia estar a ser carregado .. so devia carregar o ssdt.aml gerado pelo script com as configs para teu cpu

 

teu config.plist deve estar uma bosta .. faz o upload dele .. melhor faz up da pasta efi ..

 

para analisar .. não tens uefi nessa modo ? porque estás a usar a emuvariable.efi ?

 

bom hack

 

uahSUAhsuahSUHAUSHAuhauhs :drool:

Nossa Artur, faz um tempão que não mexo no Clover, já fiz cada cagada tentando ajustar que depois que estabilizou não mexi mais...

 

Voce faria a gentileza de uma olhada na config?

A DSDT está patcheada..

 

Vou upar a pasta EFI então...

 

Muitíssimo obrigado e uma boa noite!

 

 

obs: unica coisa que mudei a vga hoje, agora é gtx 750 não sei se precisa saber....

 

https://www.dropbox.com/s/btx14wg30qg5ysi/EFI.zip?dl=0

 

 

Só pra complementar ( imagem anexa)

 

A gpu lá no HWMonitor..    a velocidade do GPU FAN e GPU PWM eles parecem estáticos.. é isso mesmo??

 

a temperatura,clock e memory tem alterações conforme uso mas esses outros componentes ficam em valores fixo...pode ser bug do programa?

 

https://www.dropbox.com/s/1w46kmlo3u0mkon/Captura%20de%20Tela%202016-10-26%20%C3%A0s%2001.11.49.png?dl=0

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

uahSUAhsuahSUHAUSHAuhauhs :drool:

Nossa Artur, faz um tempão que não mexo no Clover, já fiz cada cagada tentando ajustar que depois que estabilizou não mexi mais...

 

 

 

olá

 

testa este 

 

config.plist.zip

 

quanto aos sensores pode ter a ver com a fakesmc e plugins.. tenta com outra versão

 

http://www.hwsensors.com

 

bom hack

Share this post


Link to post
Share on other sites

olá

 

testa este 

 

attachicon.gifconfig.plist.zip

 

quanto aos sensores pode ter a ver com a fakesmc e plugins.. tenta com outra versão

 

http://www.hwsensors.com

 

bom hack

Vlw Artur,

 

Testei a config e tudo ok.. agora ficou assim o log de boot: https://www.dropbox.com/s/xr2w3nbm4dnynm8/bootlog.log.txt?dl=0

 

 

Tava muito ruim mesmo a config? e na pasta EFI, preciso apagar alguma coisa lá?

 

O DSDT e SSDT estão sendo carregados ? olhei lá me parece que sim não, mas não tenho certeza

 

 

Vlwwwwww

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By DoZe
      Hi :0)
       
      Hope As usual a perfect matching DSDT for this good Laptop.
       
      Regards, Ray
       
       
      SendMeStudiMac.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
×