Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
TechGuru

R9 290X Help for mavericks

472 posts in this topic

Recommended Posts

Was anybody brave enough to test the current patch on the 10.10.3 update? I'll wait :)

I am on 10.10.4 and everything working like it has been with the same patch

Share this post


Link to post
Share on other sites

Which patch? Just making sure I try the last working one here.

Find:

000400000403000000010300120403030004000004030000000101001102010100040000040300000001020021030202000400000403000000010400220504040004000004030000000105001000050500040000040300000001060020010606

 

Replace:

000800000402000000010200220502030004000004030000000101011204010100040000040300000001020021030202040000001402000000010300110203040004000004030000000105001000050500020000040200000001040110000406

Share this post


Link to post
Share on other sites

Which framebuffer? Baladi or Exmoor?

 

EDIT: No go for me with either one. Can you post your working config.plist?

Baladi and that is from my working config

Share this post


Link to post
Share on other sites

I get stuck with a black screen on my setup using the patches.

This is with one monitor connected via DL-DVI (One of those Korean 1440p IPS panels).

Anybody successfully get the patch working with dl-dvi?

Share this post


Link to post
Share on other sites

I get stuck with a black screen on my setup using the patches.

This is with one monitor connected via DL-DVI (One of those Korean 1440p IPS panels).

Anybody successfully get the patch working with dl-dvi?

I have 2 monitors connected as DVI and 1 monitor as HDMI and have no issues

Share this post


Link to post
Share on other sites

I get stuck with a black screen on my setup using the patches.

This is with one monitor connected via DL-DVI (One of those Korean 1440p IPS panels).

Anybody successfully get the patch working with dl-dvi?

This patch still works for me. I'm using a Korean 1440p IPS DVI-DL monitor too. Just make sure you follow it completely and make sure it's connected to the top DVI-DL port.

Share this post


Link to post
Share on other sites

Just FYI the graphics loading bar glitch happens on real mac also when there is an external HDMI monitor connected

Share this post


Link to post
Share on other sites

Just FYI the graphics loading bar glitch happens on real mac also when there is an external HDMI monitor connected

Is there any way to patch it to 'fix' it?

Share this post


Link to post
Share on other sites

This patch still works for me. I'm using a Korean 1440p IPS DVI-DL monitor too. Just make sure you follow it completely and make sure it's connected to the top DVI-DL port.

I have my config.plist set up exactly like that but the screen simply goes black after first stage boot.

Without any of the patches, I just get the flickering that can be cured by replugging the dvi connector (or hitting sleep).

Could it be an issue with my dsdt?

Share this post


Link to post
Share on other sites

It works fine for me.

 

I'm still unable to force the Baladi Framebuffer. As soon as I do it, black screen.
 
Dual monitor does not boot, but single one does and then I can plug my second monitor again to make it work.

Share this post


Link to post
Share on other sites

Anti-allasing was on on the test?

 

 

i dont use aa for any game unless i can inject smaa which is better and only 1fps drop

Share this post


Link to post
Share on other sites

Anybody tried to go to 10.11 as of today? :D

 

I currently have it planned for this weekend to make the jump and will report here if there needs a 'fix' that is fixable by me :).

 

If anybody else already made the transition, please tell everybody here how it worked out for you. You will help many owners of Rx90X graphics cards.

 

Thanks!

Share this post


Link to post
Share on other sites

Anybody tried to go to 10.11 as of today? :D

 

I currently have it planned for this weekend to make the jump and will report here if there needs a 'fix' that is fixable by me :).

 

If anybody else already made the transition, please tell everybody here how it worked out for you. You will help many owners of Rx90X graphics cards.

 

Thanks!

did it beta 1 lol now im on 10.11.1 and 10.11 both monitors working just not very good performance 

Share this post


Link to post
Share on other sites

I'm running 10.11 without a framebuffer patch since they don't work for me (surprise, surprise). Actually, I think the issue might lie in the DSDT being used. I might try booting without one and see if it'll work then.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×